Аннотация

КЛАССИФИКАЦИЯ
(системно-морфологический подход)

Кузнецов С.В., Титов В.В.

Ключевые слова: классификация, рубрикатор, логические операторы, деление, обобщение, законодательство, арбитраж.

Аннотация

Описаны основные принципы классификации объектов различной природы: предметов, явлений, понятий, законов, и т.д. Сформулированы общие правила разработки классификаторов, позволяющие получить системы, однозначно и недвусмысленно понимаемые пользователями любого уровня подготовки, вследствие чего навигация в подобных классификаторах становится существенно проще и надежнее как на этапе наполнения классификатора новыми объектами, так и на этапе поиска нужного объекта в классификации. Приведен обзор и беглый анализ наиболее широко используемых классификаторов, отмечены их основные достоинства и недостатки. В приложениях показан процесс разработки и переработки классификаторов на примере классификации правовой информации.

Resume

The fundamental principles of classifications of objects of different nature : subjects, phenomena, notions, laws, etc. are described The general rules of classification development are established, allowing to get systems, uniquely and nonambiguous understood by users of any level of competition. It seems that the navigation in similar classification becomes more simply and more reliable as in filling a classification with new objects, so and in the searching for necessary object in classification. The review and fluent analysis the most broadly used classifications are brought, marking their main features and defects. In appendixes the process of development and conversions of classification is shown on the example of classification of legal information.


Авторы

КЛАССИФИКАЦИЯ
(системно-морфологический подход)

Авторы

Мы приветствуем Вас и готовы к сотрудничеству
Кузнецов Сергей Валентинович
Титов Валентин Васильевич

Ваше имя:

Ваш E-mail:

Что бы Вы хотели сообщить:


введение

КЛАССИФИКАЦИЯ
(системно-морфологический подход)

Кузнецов С.В., Титов В.В.

"Три пути у человека, чтобы разумно поступать: первый, самый благородный, - размышление, второй, самый легкий, - подражание, третий, самый горький, - опыт."
Конфуций

1. Введение

Человеческий мозг устроен так, что одновременно он может манипулировать не более чем семью объектами (у кого-то предел - три объекта, у кого-то - восемь-десять, но таких индивидуумов - единицы). Жизнь же ежедневно предоставляет ему разбираться с куда большим количеством окружающих субъектов, объектов, действий или качеств. Но человек не был бы человеком, если бы не нашел способа уверенного поведения в этом множестве, намного превышающем “технические” возможности собственного мыслительного аппарата. В “донаучные” времена способ этот использовался интуитивно и специального названия не имел (за ненадобностью), сейчас же изучен достаточно детально и применяется вполне сознательно. Сводится же он к тому, что все море объектов, требующих осмысления или какой-либо обработки, организуется в виде упорядоченной системы. для которой разрабатываются определенные правила навигации и в которой каждому объекту отводится вполне определенное место, так что не возникает сомнений ни в том, куда поместить данный объект, ни в том, где его при надобности искать.

В таких случаях принято говорить, что эти объекты “расклассифицированы”, а самоё систему называют “классификацией”. Массивы, с которыми человеку приходится иметь дело, могут быть предметами (их можно пощупать, подвигать, и т.д.), графическими образами или фигурами (круг, конус, прямая, и т.д.), действиями или операциями (резание, выращивание, рисование, и т.д.), качествами (цвет, температура, твердость, и т.д.), могут быть звуками, символами, понятиями и много чем еще, и в каких-то ситуациях каждый из них может стать объектом классификации.

Но в любом случае процедуру классификации человек выполняет не непосредственно с объектами, а с понятиями, описывающими эти объекты на человеческом языке. И в этом случае весь инструментарий для проведения классификации ему предоставляет наука логика. К сожалению, эту науку уже давно не изучают ни в школах, ни в вузах (за редким исключением) и каждый вынужден постигать ее своим умом, что не всегда приводит к разумным результатам. Поэтому для начала придется вспомнить основные понятия логики, необходимые для изучения названной выше процедуры классификации.


Определение

КЛАССИФИКАЦИЯ
(системно-морфологический подход)

2. Логические операторы
2.1. Определение

Определение - это логический прием, имеющий целью раскрыть или уточнить содержание понятия. Основная задача определения (применительно к нашей проблеме) - отличить и отграничить определяемый объект от всех иных.
Формы определений очень многообразны. Для целей классификации наиболее подходящим является явное определение через род и видовое отличие, которое условно можно описать формулой

А = В и С

Здесь “А” -определяемое понятие, “В” - понятие, более общее по отношению к “А” (родовое понятие), “С” - такие признаки, которые выделяют объекты, обозначаемые “А”, среди всех объектов, обозначаемых “В” (видовое отличие). Типичные примеры - словарные определения или определение понятия “определение”, даннное в начале этого раздела.

Определение такого типа легко дать, когда имеешь дело с хорошо знакомым объектом. Если же пришлось столкнуться с “черным ящиком”, устройство которого не известно, то приходится ограничиться так называемым неявным определением, т.е. определением через набор известных его функций, свойств или фактов взаимодействия с окружающим миром (типичный пример - возбудитель какой-либо болезни на той стадии его изучения, когда его еще не выделили в чистом виде).

Правила явного определения:

1. Правило соразмерности определяющего и определяемого понятий. Примеры ошибок, нарушения этого правила:
а) слишком широкое определение: “Оптика - это раздел физики, в котором изучаются свойства и поведение электромагнитных волн”, но под это определение попадает и другой раздел физики - радиофизика;
б) слишком узкое определение: “Сверхпроводник - это металл с нулевым сопротивлением”, но в это определении не учтены керамические сверхпроводники.

2. Правило запрета порочного круга, когда понятие определяют через само себя либо непосредственно, либо через промежуточное понятие, определяемое, в свою очередь, через исходное понятие. Пример нарушения: “Закон есть закон”.

3. Правило ясности всех понятий определяющей части. Здесь очень важно, для кого дается определение, и в определяющей части допускается использовать только те понятия, которые хорошо известны и однозначно понимаются всем контингентом будущих пользователей (читателей. слушателей. и т.д.). Наиболее коварным нарушением этого правила является использование в определении терминов, допускающих многозначное толкование (омонимов), а также метафор и других образных средств языка, т.к. определяемое понятие может быть понято совсем не так, как того хотел дающий ему определение.

Прозрачный смысл приведенных выше правил отнюдь не означает легкости их исполнения, и в некоторых случаях для каких-то понятий просто невозможно дать объективное определение-описание, которое однозначно понималось бы всеми, кому оно предназначено. В этих случаях приходится давать определение-предписание, т.е. волевое назначение данному понятию определенного смыслового содержания. Такие определения-предписания можно встретить в большинстве законодательных актов, начинающихся, как правило, с раздела “Термины и определения”. Определение-предписание всегда имеет ограниченную сферу актуальности, как правило, оговариваемую его инициатором. В классификациях следует по возможности избегать определений-предписаний, а если уж без него никак не обойтись, то нужно при каждом упоминании такого понятия давать ссылку на его определение-предписание.


Вариантообразующие операторы

КЛАССИФИКАЦИЯ
(системно-морфологический подход)

2.2 Вариантообразующие операторы

Вариантообразующие (формообразующие) логические операторы основной своей целью имеют выявить и назвать все возможные варианты какого-либо объекта (предмета, действия, качества, и т.д.). К этой группе операторов относятся логическое деление, обобщение и классификация.

2.2.1. Деление

Логическое деление - это распределение на группы всех тех объектов, которые мыслятся в исходном или делимом понятии. Эти группы называются членами деления. Признак, по которому производится логическое деление, называют основанием деления. В каждом делении, таким образом, имеются делимое понятие, основание деления и члены деления.Делимое понятие является родом, а члены деления - видами по отношению к данному роду. Число членов деления всегда является конечным.
Логическое деление не следует смешивать с другой, очень похожей операцией - расчленением некоторого объекта на составные части. Формально каждый из этих логических операторов можно реализовать с помощью вспомогательных вопросов:

"Какие известны варианты данного объекта, различающиеся по данному признаку?” - для деления.
"Из каких частей состоит данный объект?” - для расчленения.

Можно различить и результаты действия этих операторов (ряды дочерних понятий), но уже не по вопросам, а по вспомогательным утверждениям:

"Любой из членов ряда дочерних понятий (т.е. членов деления) в то же время является делимым понятием” - деление.
"Ни одно из дочерних понятий (продуктов расчленения) не является расчленяемым понятием” - расчленение.

Основные правила логического деления:
Деление должно проводиться только по одному основанию. Пример нарушения: в любом обувном магазине есть отделы обуви: 1) мужской, 2) женской, 3) детской, 4) резиновой. В каком отделе Вы бы стали искать галошки для своей горячо любимой дамы трех лет отроду?
Деление должно быть соразмерным или исчерпывающим, т.е. сумма объемов членов деления должна быть в точности равна объему делимого понятия. Здесь также возможны два типа ошибок: неисчерпывающее деление (например, в бланке одной из переписей населения в графе “образование” стояло три варианта ответа: начальное, среднее и высшее; а куда же деть неграмотного младенца?) и избыточное (смотри выше пример с обувью).
Члены деления должны быть альтернативными или взаимно исключать друг друга. Это позволяет найти каждому конкретному объекту одно-единственное место в ряду членов деления. Нарушение - тот же пример с обувью.
Деление должно быть непрерывным, однопорядковым. Это означает, что нельзя часть родового понятия делить на виды, а другую часть - на подвиды таких видов (например, неверно деление наук на гуманитарные, естественные и математику).

Последнее правило имеет два важных исключения:

4а) Дихотомия - это деление объектов на две группы, в одну из которых входят разновидности, обладающие некоторым конкретным свойством, а в другую - все остальные, этим свойством не обладающие. Например, деление двигателей на электрические и неэлектрические, при котором во вторую группу войдут и лошадь, и реактивный двигатель, и двигатель внутреннего сгорания, и все остальные двигатели, не использующие электроэнергию.
4б) Деление, когда мы предполагаем, что, кроме известных вариантов реализации данного основания деления могут быть и иные, пока нам не известные, тогда для них в ряду членов деления отводится ячейка “прочие”.

А теперь в качестве упражнения ознакомьтесь с цитатой из “некоей китайской энциклопедии”, приведенной в книге [1], в которой говорится, что “животные подразделяются на: а) принадлежащих императору, б) бальзамированных, в) прирученных, г) молочных поросят, д) сирен, е) сказочных, ж) бродячих собак, з) включенных в настоящую классификацию, и) буйствующих как в безумии, к) неисчислимых, л) нарисованных очень тонкой кисточкой из верблюжьей шерсти, м) и прочих, н) только что разбивших кувшин, о) издалека кажущихся мухами”. Какие из правил деления здесь нарушены?

2.2.2. Классификация

Классификация как логический оператор - это просто многоступенчатое логическое деление, когда каждый из членов деления в свою очередь становится делимым понятием, но уже по иному основанию деления. Формально ограничений на глубину классификации, т.е. на число ступеней деления не существует, но реально в каждой конкретной классификации границы всегда есть и чуть позже мы с ними разберемся подробнее.

В простейшем случае классификация представляет собой древовидную или иерархическую структуру, это происходит, когда каждый из членов классификации подвергается делению только по одному основанию. На верхнем этаже этой пирамиды или дерева находится главное понятие, дающее название всей классификации и обобщенно охватывающее абсолютно все объекты, входящие в эту классификацию. Следующий, второй слой или этаж - результат логического деления главного понятия по наиболее существенному признаку или основанию деления, под ним располагается следующий слой, полученный логическим делением каждого из элементов второго этажа по своему основанию деления (тоже наиболее существенному), и т.д.

Однако во многих случаях объекты, входящие в объем какого-либо члена классификации, различаются по двум (или более) равносущественным основаниям, и тогда древовидная структура уступает место комбинативной или фасетной структуре: линейка альтернативных членов деления заменяется матрицей, размерность которой соответствует числу одновременно реализующихся оснований деления. Эта матрица занимает в структуре классификатора уже не один слой или этаж, а столько, сколько оснований деления задейст вовано в матрице.

2.2.3. Обобщение

При формировании какой-либо классификации иногда приходится двигаться не только вниз, в сторону деления понятий, но и вверх, для чего существует оператор, симметричный делению - обобщение. Это не простой оператор, его реализация невозможна без двух других операторов - сравнения и различения. Первый из них ставит своей целью выявить все то общее, что есть у сравниваемых объектов, а второй предназначен для нахождения того единственного атрибута или принципа, по которому различаются сравниваемые объекты. Таким образом, оператор сравнения позволяет сформулировать понятие обобщенного объекта (аналог делимого понятия), а оператор различения выявляет основание обобщения (аналог основания деления).

Однако в действительности при нескольких сравниваемых объектах такая ситуация является скорее исключением, чем правилом, чаще все объекты не имеют ни одного общего существенного атрибута, и различия у каждой пары - тоже свои. В таких случаях приходится констатировать, что одношаговое обобщение невозможно, массив надо разделить на несколько групп, в каждой из которых имеется и общее, и единственное существенное различие, провести для каждой из групп “локальное” обобщение, а затем уже пытаться реализовать обобщение этих групп (возможно, тоже не одношаговое).

До сих пор молчаливо предполагалось, что оператор обобщения применяется к группе понятий. Однако достаточно часто встречается задача обобщения одного-единственного понятия. Эта задача и проще, и сложнее. Проще потому, что ее можно осуществить одним действием - отбрасыванием одного из атрибутов исходного объекта. Сложнее потому, что выбрать из всего комплекса атрибутов объекта тот, который будет отброшен при обобщении, - отнюдь не просто. Формально, исходя из симметричности, противоположности операторов деления и обобщения, можно заключить, что, если для деления в качестве основания выбирается наиболее существенный атрибут объекта, то для обобщения нужно выбрать в качестве основания наименее существенный признак. Но перечень атрибутов любого объекта всегда ограничен со стороны наиболее значимых (или существенных) и ничем не ограничен со стороны менее значимых атрибутов. Конец этого перечня всегда определяется ситуацией, внешней по отношению к классифицируемому объекту, т.е. зависит от целей классификации и от окружения, с которым взаимодействует объект. А если вспомнить о том, что классификация предназначена для широкого круга пользователей, а классифицируемые объекты могут реально встречаться в самом разном окружении, то становится понятным, что задача обобщения одного-единственного объекта, во-первых, непроста, а во-вторых. неоднозначна. Неоднозначна прежде всего потому, что при разных вариантах обобщения последующее логическое деление получившегося обобщенного понятия (а оно при классификации совершенно обязательно, причем по тому же основанию) даст совершенно различные наборы членов деления

Следует особо подчеркнуть, что классификация (как логический оператор) является корректной тогда и только тогда, когда при ее создании использовались только логическое деление и логическое обобщение, причем для каждого перехода с этажа на этаж классификации четко и однозначно формулировалось основание логического деления (разумеется, при безусловном соблюдении всех правил логического деления).

Наконец, отметим, что в рамках классификации операция обобщения всегда сопровождается последующей операцией деления получившегося обобщенного понятия по тому же самому основанию.


Системообразующие операторы

КЛАССИФИКАЦИЯ
(системно-морфологический подход)

2.3. Системообразующие операторы

Один из них уже упоминался выше - это расчленение. Симметричный ему оператор - соединение - применяется гораздо реже (соотношение приблизительно такое же, как между анализом и синтезом). Но каждый из них в руках невнимательного аналитика может незаметно подменить похожий оператор совсем иного назначения (деление или обобщение), и тогда стройная конструкция классификации теряет большую часть своего эвристического потенциала. Но об этом дефекте речь пойдет позже, а сейчас, чтобы разобраться с системообразующими операторами, придется совершить небольшой экскурс в сторону основных понятий системного подхода.

"Система - это упорядоченное определенным образом множество элементов, взаимосвязанных между собой и образующих некоторое целостное единство"[2]. Система характеризуется составом элементов, структурой и выполняет определенную функцию.

Элементы - это относительно неделимые части целого, которые в совокупности образуют систему. Элемент считается неделимым в пределах сохранения определенного качества системы. Например, в компьютере блок питания является элементом, который можно рассматривать как неделимое целое, поскольку тот факт, что блок питания имеет сложное устройство и сам состоит из многих деталей, имеет для системы "компьютер" весьма несущественное значение.

Структура - это закономерные устойчивые связи между элементами системы, отражающие пространственное и временное расположение элементов и характер их взаимодействия. Именно структура, вид и конфигурация связей между элементами делают комплект элементов собственно системой.

Функция - это внешнее проявление свойств объекта (системы или ее элемента), определенный способ взаимодействия объекта с окружающей средой. Чаще всего функции проявляются в форме действий и отражают возможности системы. Среди всех функций обычно выделяют главную полезную функцию (ГПФ системы) как функцию, ради которой и создавалась система. (Хотя надо иметь в виду, что существуют не только искусственные, созданные человеком системы, но и естественные, природные, для которых понятие ГПФ в этой формулировке бессмысленно).

Элементы системы следует отличать от подсистем, также являющихся частями системы. Основное отличие состоит в том. что подсистемы формируются из элементов системы по функциональному признаку, т.е. для реализации определенной внутренней функции системы. Иногда подсистема содержит всего один элемент; с другой стороны, один и тот же элемент может входить в несколько подсистем.

Не вдаваясь в детали системного подхода (эту информацию можно почерпнуть, например, в [3]), отметим, что расчленение объекта как системы можно провести двояко: или на элементы, или на подсистемы. Разница при этом такая же, как между комплектом рабочих чертежей устройства и детальным описанием особенностей работы этого устройства и всех его частей.

Таким образом, подсистемы - это более общие и более информационно значимые единицы расчленения, чем элементы системы. Это сказывается и в названиях: название подсистемы обычно состоит из обобщенного слова типа “блок”, “система”, “устройство”, и т.п. плюс к нему существительное в родительном падеже, выражающее функцию или цель этого “блока”, например, блок электропитания, система наведения, устройство стыковки, и т.д. В то же время элементы системы, как правило, называют конкретным термином, принятым у конструкторов, а если и случается название с обобщающим словом, то это свидетельствует только о том, что этот элемент одновременно является подсистемой, т.е. единолично выполняет важную внутреннюю функцию системы.

Все системы, независимо от их природы, обладают рядом общих свойств.

Целостность системы означает, что комплекс объектов, рассматриваемый в качестве системы, обладает общими свойствами, функцией и поведением, причем свойства системы не сводимы к сумме свойств входящих в нее элементов.

Делимость системы отражает тот факт, что любой объект можно представить состоящим из элементов. В соответствии с этим в рамках системного подхода любой объект нужно рассматривать в трех аспектах: как нечто целое (систему), как часть более общей системы (надсистемы) и как совокупность более мелких частей (подсистем).

Теперь в свете этих понятий и определений можно более глубоко разобраться с содержанием и особенностями основных системообразующих логичеcких операторов.

2.3.1. Расчленение

Мы уже дважды начинали обсуждать этот оператор, но как его проводить, об этом пока не говорилось. С точки зрения познавательной значимости (или информационной содержательности) из двух вариантов расчленения системы (на элементы и на подсистемы) второй безусловно предпочтительнее, и выбрав именно этот вариант, можно сформировать и наиболее понятную и естественную процедуру его реализации. Основана она на том, что каждая из подсистем (будущих продуктов логического расчленения системы) характеризуется основным, наиболее практически значимым атрибутом - своей главной полезной функцией (ГПФ), которую она выполняет в нашей системе. По определению, эта ГПФ подсистемы является внутренней функцией системы и отражает динамику ее внутренних связей. Поэтому первым шагом при расчленении системы является определение перечня всех ее внутренних функций. Здесь нет единого “основания расчленения” (как при логическом делении), более того, внутренние функции, сравниваемые попарно, могут не иметь ничего общего, хотя все вместе они связаны, образуя функциональный облик системы.

После того, как перечень внутренних функций системы сформирован, процедура расчленения завершается механическим составлением пар понятий: для каждой внутренней функции (выраженной, например, отглагольным существительным) подбирается подходящее обобщающее слово (о них говорилось в предыдущем разделе) и составляется обобщенное название данной конкретной подсистемы.

Предлагаемый способ реализации процедуры расчленения - не единственный, но наиболее подходящий для целей классификации. Кстати, при таком способе практически исключается опасность незаметной подмены логического деления логическим расчленением, и наоборот.

2.3.2. Соединение

Этот логический оператор (симметричный расчленению) своим результатом имеет синтез надсистемы из имеющихся объектов или систем. С классификацией в чистом виде это практически не имеет непосредственной связи, хотя по эвристической мощи этот оператор несравним с остальными, так как он - единственный, с помощью которого можно создать, породить принципиально новую систему. Применение этого оператора, как правило, связано с творческим осмыслением ситуации, с озарением, с изобретением в самом широком смысле этого слова, а поэтому ни алгоритма, ни каких-либо закономерностей этого процесса (особенно с прицелом на компьютерное исполнение оператора) сейчас предложить не удается.


Свойства классификаций

КЛАССИФИКАЦИЯ
(системно-морфологический подход)

3. Свойства классификаций

Из приведенных выше определений и утверждений можно сделать достаточно важные выводы относительно свойств классификации и входящих в нее объектов.

3.1. Все объекты конкретной классификации выполняют одну и ту же функцию. Это следует из того, что вся древовидная или фасетная структура классификации сформирована из единственной вершины с применением единственного логического оператора - деления. А деление - это вариантообразующий оператор, в результате которого мы получаем какое-то количество вариантов делимого понятия, но все они - только варианты, и функция их (ГПФ) - та же, что и у делимого понятия. Поскольку это справедливо на всем протяжении классификации сверху донизу, то тем самым доказана идентичность функции всех объектов данной классификации.

3.2. Любой из членов классификации может стать основанием (или вершиной?) собственной классификации. Хотя последнее утверждение представляется сомнительным для самых нижних ячеек классификации (деление которых уже не производилось), но это лишь следствие того, что исчерпан перечень существенных оснований деления. Существенность же - понятие относительное, и если для задач, которые решались с помощью данной классификации, существенными являлись одни признаки, то для каких-то иных задач и существенные признаки могут быть иными, и тогда ветвление может быть продолжено.

3.3. Любой из объектов классификации является системой, а значит, состоит из подсистем, выполняющих различные внутренние функции в этой системе. Каждая из этих подсистем (со своей ГПФ) может стать основанием для самостоятельной классификации. Однако эти “дочерние” классификации нельзя считать элементами или частями основной классификации, т.к. при этом нарушается свойство 3.1 классификации.

3.4. В силу свойства 3.3 можно утверждать, что исследование вариантности объекта как системы может осуществляться либо через единственную классификацию, в которой рассматриваются варианты системы в целом, либо через “произведение” классификаций всех подсистем данной системы. Второй способ, как правило, дает значительно большее количество вариантов, поскольку заметную часть его составляют системы, не имеющие реального воплощения либо в силу несовместимости некоторых вариантов подсистем друг с другом, либо в силу того, что никто еще не додумался их совместить. Последнее приводит к выводу о том, что произведение подсистемных классификаций имеет большую эвристическую значимость, чем единая системная классификация.

3.5. Любая классификация является умозрительным построением, причем конкретные варианты объекта классификации могут находиться только на самых последних этажах классификации. Для разных ветвей классификационного дерева глубина классификации может быть различной, последним этажом считается результат последнего деления, ниже которого вариантность объектов уже не детализируется. На Рис.1 ячейки последних этажей классификации заштрихованы. Будем в дальнейшем называть объемом классификации полное число ячеек последнего этажа (на Рис. 1, например, объем классификации равен 13).

Рис.1. К расчету объема классификации.

3.6. Неоднозначность конечного результата операции на каждом шаге логического деления и логического обобщения, определяемая неоднозначностью ранжирования атрибутов классифицируемого объекта (которое проводится в соответствии с ГПФ этого объекта), приводит к естественному выводу, что классификация любых объектов (как итог многократного применения операций деления и обобщения) тесно связана с целями, для которых она производится. А это значит, что для многофункциональных объектов (т.е. объектов, ГПФ которых может меняться в зависимости от надсистемы, в которую входит этот объект) и классификаций - тоже много.

4. Как создается классификация

Напомним, что основная цель (и главная полезная функция) классификации - обеспечить однозначное и легко определимое место для каждого из классифицируемых объектов. Причем эта функция должна одинаково хорошо выполняться при двух основных видах использования классификации: размещении нового объекта в классифицируемом массиве и нахождении конкретного объекта в этом массиве. Это требует особой тщательности в выборе принципов, оснований логического деления, которые должны однозначно пониматься как человеком, наполняющим классификацию новыми объектами, так и тем, кто разыскивает нужный объект в расклассифицированном массиве. Задача отнюдь не простая, тем более что первая двусмысленность ожидает нас в самом начале пути.

Слово “классификация” выбрано крайне неудачно, поскольку грамматическая его форма и смысловое наполнение таково, что оно одновременно означает и процесс (подобно “стабилизации”, “унификации” и другим операциям), и результат этого процесса (подобно “декорации”, “ассоциации”, “экспликации” и другим модификациям), и состояние (подобно “прострации”, “медитации” и другим деформациям), и просто предметный объект (подобно “нации”, “акации”, “информации” и другим комбинациям). Чтобы исключить “многосмыс-ленность” этого термина в нашем изложении, дадим следующие определения- предписания (применимые только в дальнейшем тексте настоящей работы):

Классификатором будем называть ту систему ячеек и связей между ними, которая в совокупности является базовой для систематизации всех вариантов классифицируемых объектов, распределения их по этим ячейкам.

Классифицированием будем называть процесс наполнения классификатора содержимым, т.е. описаниями конкретных объектов.

Классификацией будем называть классификатор, наполненный описаниями конкретных объектов. Как правило, этот термин будет использоваться с обязательным вторым понятием - основанием классификации (например, “классифика-ция отраслей знания”, “классификация растений”, и т.д.).

Кроме этих основных терминов, предлагается использовать и некоторые дочерние понятия:
разработчик (классификатора) - человек, формирующий систему классификатора и кодирование его ячеек;
оператор (классифицирования) - человек, осуществляющий классифицирование и кодирование объектов;
пользователь (классификации) - человек, осуществляющий поиск объекта в классификации;
код (ячейки классификатора) - условное обозначение ячейки классификатора;
кодирование (или кодификация) - формирование системы условных обозначений ячеек классификатора;
упорядочение (списка) - размещение объектов в пределах одной ячейки классификации в линейный ряд в определенном порядке (например, по алфавиту или по возрастанию, и т.п.).

Вот теперь, договорившись об однозначном понимании терминологии, можно начать обсуждение важнейших вопросов о том, каким должен быть “идеальный” классификатор, как его создать и, наконец, насколько близки к этому “идеалу” реально существующие классификаторы.

Есть ли предел глубины классификатора, сколько ступеней или этапов логического деления должно быть реализовано в классификаторе? Вопрос этот отнюдь не из неуемного любопытства, он имеет глубокий практический смысл. Напомним, что количественный предел активного восприятия и анализа пользователем массива объектов (в частности, массива ячеек классификатора) - семь; при пяти объектах мозг работает комфортно, совершенно без напряжения (а значит, без усталости и ошибок); при трех объектах операция выбора происходит почти автоматически, т.е. без внутренних рассуждений. А поскольку навигация в классификаторе сводится как раз к операции выбора на каждом из этапов логического деления, то отсюда следует простое правило: на каждом этаже иерархического классификатора должно быть от трех до семи ячеек, т.е. каждая из операций деления должна “разложить” родовое понятие на 3-7 видовых. В таком классификаторе легко работать как оператору, так и пользователю.

Это количественное условие может показаться трудновыполнимым, однако, легко убедиться, что на практике массив любых объектов, число которых превышает 7-15, не составляет никакого труда разделить на две-три группы по легко определимым общим признакам, т.е реализовать оператор логического деления этого массива “в чистом виде”.

Как выбирать основания логического деления при создании классификатора? Выше мы описали один из способов как наиболее естественный и удобопонятный. Но этот способ применим только для классификаций предметных систем, где функции подсистем определяются без особого труда. Если же объектом классификации являются не предметы, а иные объекты (операции, качества, понятия, явления, информационные объекты, и т.д.), то формальные понятия системного подхода (подсистемы, функции) здесь становятся сомнительными и требуют иного словесного оформления. Повидимому, можно воспользоваться понятием “атрибут” (англ. “attribute” имеет два перевода: “приписывать” и “свойство”), приписав ему тот смысл, что перечень атрибутов объекта дает достаточно полное обобщенное его описание (т.е. косвенное определение). В качестве атрибутов для объектов разной природы могут быть самые разные понятия (например, если для предметной системы определяющим атрибутом является его ГПФ, то для функциональной системы этим атрибутом может оказаться или объект обработки, или принцип действия, или временной фактор; для классификации качеств атрибутом может оказаться или пригодность для определенного использования, или какой-либо количественный фактор, или другое качество, следующего порядка детализации, и т.д.). Поэтому вопрос о выборе основания логического деления при создании классификатора в общем случае не имеет конкретного ответа (как для предметных систем). Единственная рекомендация - на каждом этапе логического деления выбирать в качестве основания наиболее существенный атрибут. Возможно, полезным для этой процедуры выбора основания деления окажется вспомогательный вопрос с некоторой эмоциональной окраской: “Чем прежде всего различаются объекты данной группы?" Из содержания этого вопроса ясно, что ответы на него будут обязательно с оттенком субъективности, а это значит, что объективизация (а значит, и общее признание) создаваемого классификатора возможна только при коллективном исполнении работы, когда и составление, и экспертная оценка элементов классификатора выполняются в режиме всестороннего обсуждения и усреднения.

Строить классификатор можно двумя путями: дедуктивным и индуктивным. Дедуктивный способ в качестве отправной точки имеет единственный объект - основание классификации, и формирование классификатора ведется с применением единственного оператора - логического деления. Индуктивный способ применяют, имея в наличии несистематизированный набор вариантов реализации этого объекта; при формировании классификатора приходится использовать оба вариантообразующих оператора: деление и обобщение, поэтому алгоритм работы гораздо сложнее и труднее поддается формализации, чем при дедуктивном методе.

При дедуктивном методе разработки классификатора следует на каждом этапе логического деления предусмотреть ячейку “прочие” на тот случай, если атрибут - основание деления будет когда-нибудь реализован вариантом, еще не встречавшимся оператору классификации. Вначале эта ячейка не подвергается дальнейшему делению (делить-то нечего!), но по мере наполнения достигается ситуация, когда число объектов в ней возрастает и начинает значительно превышать предел комфортной работы по сравнительному анализу и выбору вариантов из массива. Можно условно обозначить два числа: 9=32 и 49=72, первое из них означает, что массив с таким числом объектов уже можно попытаться разделить (логически) на три массива по три элемента в каждом; второе число означает, что при таком количестве объектов логическое деление массива совершенно необходимо (причем скорее всего оно окажется уже не одноэтапным на 7 блоков по 7 элементов, а более сложным).

Другой тонкий момент при проведении логического деления в классификаторе - ячейка “нет” или “отсутствует”. Она соответствует варианту объекта, в котором данный атрибут (основание деления) вообще не реализован. Далеко не всегда такое в принципе возможно, поэтому здесь нет требования обязательно вводить эту ячейку, но проверить, продумать, имеет ли она смысл на данном конкретном шаге, - обязательно. И если этот вариант возможен, то он включается в классификатор на общих основаниях (т.е. он занимает определенное место на соответствующем этаже классификатора и может быть подвергнут дальнейшему логическому делению так же, как и любой другой вариант.

Индуктивный метод разработки классификатора в чистом виде практически не встречается. Более того, прибегать к этому методу, как правило, приходится в условиях сильных помех в виде уже существующих многочисленных не совсем корректных попыток классификации данного массива объектов. Поэтому первая рекомендация в таком случае состоит в том, что, приступая к этой работе, следует либо полностью отрешиться от уже существующих классификаций данного массива и начинать все “с нуля”, с исходного массива объектов, либо наоборот, вначале тщательно проанализировать существующий классификатор на предмет выявления всех использовавшихся оснований деления и всех замеченных ошибок логического деления, а затем попытаться “отре-монтировать” существующий классификатор (что чаще всего невозможно) или использовать его исправные фрагменты в качестве элементов своего будущего классификатора.

В большинстве случаев исходной позицией при создании классификатора является наличие массива несистематизированных вариантов некоего объекта (членов нижнего этажа будущей классификации) и осознание обобщенного названия объекта классификации (т.е. вершинной ячейки классификатора). Иначе говоря, имеется вершина классификатора и неорганизованная масса вариантов классифицируемого объекта. Впрочем, часто эта неорганизованная масса содержит еще и массу постороннего для данной классификации материала. Посторонним в данном случае может оказаться не вариант классифицируемой системы, а вариант какой-либо из ее подсистем (согласно свойству 3.3 любая подсистема является членом совсем другой классификации). В последнем случае фильтрующим вопросом для каждого из конкретных вариантов является : “Является ли <вариант> <системой> или это что-то другое?”. Отсеяв все объекты, не относящиеся к данной классификации, оставшееся множество можно использовать для построения классификации “сверху вниз”, для чего можно использовать уже упоминавшийся вопрос: “Чем прежде всего различаются объекты данной группы?”. Альтернативный путь (снизу вверх) значительно труднее, поскольку он требует попарного сравнения всех вариантов (а их количество, как правило, значительно превышает тот предел комфортных условий работы, о которых уже говорилось) и их группировки по принципу (основанию), которое еще требуется найти.


Анализ классификаторов

КЛАССИФИКАЦИЯ
(системно-морфологический подход)

5. Анализ некоторых классификаторов

Практически в каждой отрасли человеческой деятельности используются те или иные классификаторы. Систематические библиотечные классификации, многочисленные классификации товаров, классификации отраслей знания, классификации объектов интеллектуальной собственности, классификации изделий промышленности (станков, приборов, деталей, инструмента, и т.д.), классификации должностей и званий, классификации нормативных актов, классификация химических соединений, классификация животных, и так далее, перечень можно продолжать бесконечно.

Что общего у всех этих классификаций? Прежде всего то, что почти все они формировались стихийно, без жесткого алгоритма процедуры развития. Многие из классификаций имеют уже очень солидный возраст (например, классификация животного мира, созданная Линнеем, живет уже несколько веков), а количество любых классифицируемых объектов имеет тенденцию со временем только увеличиваться, разнообразие их - тоже. Поэтому классификатор - развивающаяся система, и это развитие совершается усилиями самых разных людей, отнюдь не всегда обращающих внимание на такие “мелочи”, как правила логического деления.

Результатом этого является наличие ошибок логического деления и, как следствие, основной дефект многих классификаторов - перекрытие ячеек классификатора и неизбежная неоднозначность выбора ячейки для очередных классифицируемых объектов. Финалом же этой цепочки следствий является то, что пользователь не сможет найти интересующий его объект иногда просто из-за того, что он лежит не там, где его ищут.

Рассмотрим конкретные классификаторы, наиболее часто используемые в человеческой деятельности.

5.1. Классификаторы отраслей знания

Если взять любой вузовский учебник по конкретной науке. то его оглавление почти всегда может служить классификатором областей знания в данной науке. Например, есть учебник “Общая физика”, но есть и учебник “Оптика”, а есть и учебное пособие “Волновая оптика”. На примере этих трех книг можно продемонстрировать вложенность классификаций: в учебнике общей физики есть раздел “Оптика”, в учебнике оптики есть раздел “Волновая оптика” (а по некоторым аспектам волновой оптики есть монографии, в которых также имеются свои оглавления, еще более углубляющие классификацию знаний).

Знания интересуют людей по разному. И классификаторы отраслей знания могут служить разным целям. Чаще всего, конечно, справочным, поисковым: знать все невозможно, но знать, где лежат нужные в данный момент знания, можно и нужно. Поэтому в научных библиотеках, например всегда есть не только алфавитный каталог (как уже говорилось раньше, алфавитный принцип - самый искусственный при классификации), но и - обязательно! - систематический, упорядоченный именно по темам, по отраслям знаний. Существует довольно много классификаций отраслей знаний, начнем обзор с самой главной - Универсальной десятичной классификации.

5.1.1. Классификатор УДК

Хотя эту аббревиатуру из трех букв УДК каждый встречал десятки и сотни раз (поскольку каждая статья и каждая книга снабжаются кодом УДК), мало кто знает, на каких принципах основана эта классификация. Существует она более 90 лет (первое сводное издание вышло в 1905 году), работало и работает над ее модификацией практически все мировое сообщество, в результате получилась мощная всеобъемлющая система, описать которую лучше, чем это сделано в самом классификаторе [4], невозможно. поэтому мы просто приведем оттуда развернутую цитату.

“... Универсальная десятичная классификация в целом характеризуется несколькими основными свойствами. Само название говорит о двух из них: универсальности и десятичности. Кроме того, следует отметить многоаспектность, как заложенную в структуре основной таблицы, так и возникающую при применении вспомогательных таблиц и приемов образования индексов, несущих в себе элементы стандартизации.

В многочисленных разделах этой системы упорядочено множество понятий по всем отраслям знаний или деятельности. Иными словами, УДК охватывает весь универсум знаний. При этом УДК не является конгломератом отдельных отраслевых классификаций. Хотя разделы классификации, соответствующие отдельным отраслям, отличаются по своей внутренней структуре, определяемой спецификой отрасли, система воспринимается как единое целое, благодаря существованию единого иерархического кода, общих правил построения индексов и непременному показу взаимосвязей данного раздела и его зависимости от других с помощью методического аппарата (“смежные области”, “ссылки”). УДК универсальна и в применении. Благодаря обилию средств и приемов индексирования, легко сокращаемой дробности, она успешно применяется для систематизации и последующего поиска самых разнообразных источников информации в различных по объему и по назначению фондах - от небольших узкотематических собраний специальной документации до крупных отраслевых и многоотраслевых справочно-информационных фондов

Универсальная десятичная классификация построена по систематическому принципу.

В УДК один и тот же предмет встречается в разных местах в зависимости от отрасли знания и от аспекта, в котором он рассматривается. Например, “нефть” встречается в нескольких разделах. В разделе 547 Органическая химия мы находим понятие “Химия нефти”; в 553 Месторождения полезных ископаемых - “Месторождения нефти”; в 622 Горное дело - “Добыча нефти”; в 662 Взрывчатые вещества. Топлива - “Нефть в качестве топлива” и т.д.

Такое явление, называемое множественной локализацией понятий, отражает многоаспектность УДК как свойство, заложенное в самой структуре схемы классификации. Это свойство всегда нужно иметь в виду при индексировании по УДК.

Многоаспектное индексирование содержания документов и запросов обеспечивается, кроме самой структуры УДК, использованием общих и специальных определителей, отражающих время, место, язык, параметры, оборудование, процессы и т.д., а также применением некоторых правил комбинирования индексов.

Одной из главных отличительных особенностей УДК является иерархическое построение большинства разделов основной и вспомогательных таблиц по принципу деления от общего к частному с использованием цифрового десятичного кода. Универсум знаний делится по аналогии с десятичными дробями.

Каждый класс (первая ступень деления) содержит группу более или менее близких наук, например, класс 5 - математику и естественные науки, класс 6 - прикладные науки; технику, сельское хозяйство. медицину.

Последующая детализация идет за счет удлинения индексов.

Индексы УДК построены так, что каждая последующая присоединяемая цифра не меняет значения предыдущих, а лишь уточняет, обозначая более частное понятие. Например, индекс понятия “Химическая коррозия” 620.193.4 складывается следующим образом:

6 Прикладные науки
62 Инженерное дело. Техника в целом
620 Испытания материалов. Товароведение
620.1 Испытания материалов. Дефекты материалов. Защита материалов
620.19 Дефекты материалов и их выявление. Коррозия
620.193 Коррозия. Коррозионная стойкость
620.193.4 Химическая коррозия. Воздействие различных агрессивных сред

Как уже было сказано, по иерархии от общего к частному построены не только основная, но и вспомогательные таблицы общих и специальных определителей, например,

Специальные определители
62-6 Регулирование и управление машинами и процессами
62-55 Регуляторы
62-555 Регуляторы. приводимые в действие посредством физических процессов
62-555.5 посредством излучения
62-555.56 селеновых фотоэлементов
Общие определители точки зрения
.004 Аспект применения, эксплуатации, употребления
.004.6 Изменения при применении, эксплуатации, употреблении. Восстановление
.004.67 Восстановление. Исправление. Улучшение. Ремонт

В настоящее время при детализации разделов цифра 0, как правило, не используется ввиду возможной путаницы со специальным определителем .0; цифра 9 обычно отводится для понятия “другие”, “прочие”. Таким образом, активно используются восемь цифр. В том случае, когда количество классифицируемых понятий превышает восемь мест в ряду, девятый раздел может дробиться дальше, а получаемые сотые (если нужно и тысячные) доли-индексы приравниваются по своему значению к десятым долям (так называемый октавный принцип).”

Описание общей методики работы с УДК занимает объем более 1,1 учетно-издат. листа плюс многочисленные таблицы общих и специальных определителей, но в сумме все это позволяет кодифицировать практически любой текст (от монографии до частного письма или багажной квитанции включительно), причем кодифицировать (при желании) настолько детально, что в некоторых случаях даже и читать-то такой текст уже нет необходимости, так как вся содержащаяся в нем информация полностью находится в коде.

Поскольку УДК сформирована с неукоснительным соблюдением правил классификации, перечисленных выше, то ей присуще и еще одно очень ценное свойство: эту классификацию легко усечь как сверху, так и снизу, т.е. либо напрямую использовать ее часть. посвященную конкретной области знания (с “отрезанием” левой части кода, выводящей за пределы нашей области знаний), либо ограничиться определенным уровнем детализации знаний и аспектов их представления (с игнорированием большей части дополнительной информации, кодируемой общими и специальными определителями), либо и то, и другое. Иными словами, УДК может служить в качестве “заготовки” для формирования любого не столь универсального классификатора.

Очень важным достоинством УДК является элегантное решение проблемы фасетной классификации с помощью системы определителей, этот принцип мог бы существенно упростить многие иные классификации, о чем еще будет речь дальше.

Однако не самым удачным воспринимается выбор условных обозначений для некоторых определителей (“.00” - для точек зрения, “-03” - материалы, “-05” - личные характристики, “(0...)” - форма документа, а также некоторые другие). Минимизация длины кода делает предпочтительной однознаковую индикацию служебных характристик кода, и таких знаков (например, букв латинского алфавита) вполне достаточно было бы для всего набора общих и специальных определителей УДК. Но традиция - великая сила (90 лет все-таки...), в результате эти многоместные индикаторы сохранились до сих пор.

5.1.2. Классификатор РФФИ

Крайне интересно в этом смысле проанализировать классификатор Российского фонда фундаментальных исследований [5], который по идее должнен бы представлять из себя усеченный снизу Универсальный десятичный классификатор (разделы 1 Философия. Психология, 3 Общественные науки, 5 Математика. Естественные науки, 9 География. Биографии. История).

Первое, что бросается в глаза при обозрении классификатора РФФИ, - это резкий крен в сторону естественных наук за счет общественных и в рамках естественных наук - столь же резкий крен в сторону наук о Земле. Вот структура классификатора РФФИ:

1. Математика, информатика, механика (3 раздела 2-го уровня, 46 разделов 3-го уровня).
2. Физика и астрономия (8 разделов 2-го уровня, 38 разделов 3-го уровня).
3. Химия (5 разделов 2-го уровня, 28 разделов 3-го уровня).
4. Биология и медицинская наука (3 раздела 2-го уровня, 23 раздела 3-го уровня).
5. Науки о Земле (7 разделов 2-го уровня, 96 разделов 3-го уровня).
6. Науки о человеке и обществе (9 разделов 2-го уровня без дальнейшей детализации).
7. Создание и развитие информационных, вычислительных и телекоммуникационных ресурсов для проведения фундаментальных исследований (4 раздела 2-го уровня, 23 раздела 3-го уровня).

Этот классификатор имеет не столько теоретическое значение, сколько сугубо практическое: именно в таком соотношении распределяются скудные средства на поддержку умирающей фундаментальной науки России. И печальный вывод о том, что общественные науки в нашем научном и властном сообществе обречены, влечет не менее печальный вывод о том, сколько времени нам еще придется блуждать в потемках экономических и политических экспериментов без понимания, что и зачем делать.

Да и в естественных науках ситуация не менее странна: базовые для высоких технологий фундаментальные науки (физика, химия, биология) в сумме не дотягивают до наук о земле - базовых для добывающих отраслей. Так что все это заставляет поставить очень неприятный вопрос: какую же глобальную цель преследуют те руководители Фонда, кто утвердил столь своеобразную селективность поддержки фундаментальной науки?

Таблица 1 .

Наименование раздела верхнего уровня классификатора | Печатный объем перечня рубрик раздела УДК, страниц | Число рубрик нижнего уровня классификатора РФФИ | Нормированное соотношение объемов
Математика (+Механика) | 4,55(+5,1) | — |
Математика, информатика, механика | — | 46 | 4,3
Астрономия. Геодезия + Физика (—Механика) | 4,15+2,8+16,2(—5,1) | — | 1,9
Физика и астрономия | — | 32+6 |
Химия | — | 28 |
Химия. (Кристаллография. Минералогия) | 25,2(+1+1,6) | — | 1
Биология и медицинская наука | — | 15+8 |
Биологические науки + Ботаника + Зоология | 4,6+4,45+8,7 | — | 1,17
Геология. Геологические и геофизические науки | 10,15 | — | 8,6
Науки о Земле | — | 96 |

Если принять в качестве исходного положения то, что пропорции развития разных отраслей фундаментальной науки должны приблизительно соответствовать количеству рубрик этих отраслей в УДК (ведь фундаментальные науки от конъюнктуры и местных условий практически мало зависят), то можно оценить, насколько классификатор РФФИ искажает реальное положение дел в науке. В таблице 1 показаны “объемные” пропорции разных наук в классификаторах УДК и РФФИ.

Отсутствие идентичности наименований рубрик в этих двух классификаторах не дает возможности назвать точные соотношения, в таблице это осуществляется добавлением или вычитанием объемов соответствующих подразделов. Тем не менее, очевидно, что РФФИ из всех естественных наук отдает явное предпочтение геологам и в меньшей степени - математикам, химики и биологи - в совершенном загоне, чуть лучше положение физиков.

С формальной точки зрения классификатор РФФИ тоже довольно ущербен. Попробуйте решить задачу: как сформулировать единственное основание деления, в результате которого получились бы семь разделов классификатора РФФИ первого уровня? Едва ли это удастся. Формально классификатор РФФИ представлен как чисто иерархический, хотя в нем невооруженным глазом просматривается неоднозначность (например, разделы 01-326 Динамика атмосферы и океана перекликаются с разделами 05-513 и 05-514 в океанологии и с разделами 05-610 и 05-612 в физике атмосферы), причем очевидно, что эта неоднозначность напрямую связана с насильственной попыткой фасетную классификацию втиснуть в прокрустово ложе иерархической. Подобных ошибок в классификаторе РФФИ достаточно.

Очевидная некорректность классификатора РФФИ (и по форме, и по сути) вынуждает поставить вопрос: а как мог бы выглядеть корректный классификатор фундаментальных наук? Не вдаваясь в детали конкретных рубрик нижнего уровня, можно сказать, что число рубрик нижнего уровня каждого из основных разделов классификатора РФФИ все-таки должно соответствовать объему соответствующих разделов УДК (еще лучше, если бы соответствовали и названия). Очевидно, что это будут в какой-то степени обобщающие рубрики, поэтому для каждой из них придется дать расшифровку объема.


Патентная классификация

КЛАССИФИКАЦИЯ
(системно-морфологический подход)

5.1.3. Международная патентная классификация (МПК)

В принципе МПК можно было бы получить из УДК простым усечением ее, ограничившись большей частью раздела 6 (Прикладные науки. Медицина. Техника), а также мелкими фрагментами еще двух-трех разделов, в которых могут появляться технические решения. Однако при более пристальном рассмотрении между МПК и УДК выявляются очень существенные различия.

Различие прежде всего связано с целевыми функциями обеих классификаций. УДК родилась в недрах библиографических проблем (первое французское издание 1905 года называлось “Manuel du repertoire bibliografique universel” - “Руководство к универсальному библиографическому репертуару”), и дальнейшее развитие не изменило ее основной целевой функции - упорядочения информационных материалов в библиотечных (и иных) каталогах. Экономическая значимость ошибок или недоработок в УДК была не столь велика и в худшем случае удлиняла процедуру поиска нужной статьи или книги, поэтому переиздание УДК (точнее, выпуск очередной новой редакции) повторялось нерегулярно, да и полномасштабное использование УДК сейчас едва ли можно где встретить.

Другое дело - МПК. Патент - это объект интеллектуальной собственности (потенциально - очень дорогостоящий), и чтобы не выдать патент на объект, уже защищенный кем-то ранее заявителя, эксперт-патентовед должен во всем мировом фонде патентов просмотреть все близкие технические решения и ни в коем случае не ошибиться, не пропустить аналогичное решение, родное ли российское, или зимбабвийское, или еще чье. А для этого вся патентная (и близкая к ней) информация должна быть расклассифицирована очень строго, подробно, единообразно и недвусмысленно. Иначе говоря, первое отличие - колоссальная цена ошибок и неточностей классификации, а значит, величайшая тщательность определения и различения рубрик классификатора МПК.

Второе отличие связано с тем, что проблема обновления в МПК стоит гораздо острее, чем в УДК. Новые отрасли знания появляются гораздо реже, чем новые направления в технике, а те, в свою очередь, гораздо реже, чем принципиально новые продукты и изделия. В результате скорость заполнения ячеек “Прочие” в МПК настолько велика, что ВОИС (World International Property Organization) каждые 5 лет вынуждена выпускать новую редакцию МПК. Шестая редакция вступила в силу с 1 января 1995 года.

Предисловие к русскому переводу МПК6 (именно так принято обозначать эту редакцию МПК) начинается с точного описания назначения МПК [ ]:

“1. Страсбургское соглашение 1971 года о Международной патентной классификации, вступившее в силу 7 октября 1975 года, предусматривает создание единой системы классификации, охватывающей патенты на изобретения, включая опубликованные патентные заявки, авторские свидетельства, полезные модели и свидетельства о полезности (далее именуемые общим термином “патентные документы”). Международная патентная классификация в дальнейшем обозначается сокращенно “МПК”.

2. МПК, являясь средством для единообразного в международном масштабе классифицирования патентных документов, представляет собой эффективный инструмент для патентных ведомств и других потребителей, осуществляющих поиск патентных документов с целью установления новизны и оценки вклада изобретателя в заявленное техническое решение (включая оценку технической прогрессивности и полезного результата или полезности).

3. Важным назначением МПК, кроме того, является:

а) служить инструментом для упорядоченного хранения патентных документов, что облегчает доступ к содержащейся в них технической и правовой информации;
б) быть основой для избирательного распределения информации среди потребителей патентной информации;
в) быть основой для определения уровня техники в отдельных областях;
г) быть основой для получения статистических данных в области промышленной собственности, что в свою очередь позволит определить уровень развития различных отраслей техники.”

Объем информации, подведомственной МПК, перекрывается с объемом УДК лишь частично, т.к., с одной стороны, по широте охвата УДК больше МПК (все гуманитарные и описательные знания подведомственны только УДК), но по глубине классификации МПК больше УДК. Более того, если в УДК большая часть рубрик приводится без комментариев, то в МПК очень многие рубрики (не самых нижних уровней) снабжены подробными описаниями, т.е. определениями, с максимально возможной степенью точности задающими смысловой объем данной рубрики. Не менее подробные определения-предписания (толкования) даны и многим часто употребляемым общим словам и словосочетаниям (типа “прочие”, “например”, “предусмотренный”, “и т.п.”, ...).

МПК использует цифро-буквенную индексацию рубрик и строгое иерархическое строение основного классификатора. Но, как и в УДК, неизбежная множественность оснований деления заставляет решать проблему фасетности классификации. Одно из главных оснований деления всех технических решений в МПК: “объект сам по себе” и “объект по назначению” напоминает предметный и функциональный аспект в системном анализе (см. раздел 2.3.1 настоящей работы). В МПК деление по этому принципу в явном виде не имеет места, рубрики рассыпаны по всем отраслям техники, но - перевязаны ссылочным механизмом и обязательным присовокуплением к основному классификационному индексу дополнительной информации, представляемой либо в той же форме, что и основной индекс, либо в несколько измененной форме кода (в МПК понятия “классифицирование” и “кодирование” не совпадают по смыслу: кодированием называют сопровождение основного классификационного индекса объекта другими индексами, которые носят чисто служебный, поисковый характер и определяются по формальному. терминологическому принципу).

Таблица 2.
Ступень иерархии | Классификационный индекс | Наименование рубрики
Раздел | В | РАЗЛИЧНЫЕ ТЕХНОЛОГИЧЕСКИЕ ПРОЦЕССЫ; ТРАНСПОРТИРОВАНИЕ
Класс | В 64 | ВОЗДУХОПЛАВАНИЕ; АВИАЦИЯ; КОСМОНАВТИКА
Подкласс | В 64 С | ЛЕТАТЕЛЬНЫЕ АППАРАТЫ ТЯЖЕЛЕЕ ВОЗДУХА
Основная группа | В 64 С 25/00 | Посадочные устройства
Подгруппа с 1 точкой | В 64 С 25/02 | .шасси
Подгруппа с 2 точками | В 64 С 25/08 | ..подвижно закрепляемые, например, сбрасываемые
Подгруппа с 3 точками | В 64 С 25/10 | ...убирающиеся, складывающиеся, и т.п.
Подгруппа с 4 точками | В 64 С 25/18 | ....приводы
Подгруппа с 5 точками | В 64 С 25/26 | .....контрольные или блокирующие устройства
Подгруппа с 6 точками | В 64 С 25/30 | ......аварийные

Многолетняя практика использования и корректирования МПК показала, что единого для всех разделов принципа организации и расположения информации не должно быть, и хотя костяк структуры МПК достатончо прочен, основным принципом внутреннего структурирования рубрик промежуточных уровней является является масксимальное удобство пользования. В частности, основная структура классификационного индекса представлена на рисунке 2.

Но в некоторых разделах последовательность родственных классов, кроме того, объединяется общим заголовком, а в конце этой последовательности ставится жирная горизонтальная линия. Все это означает в неявной форме появление дополнительного этажа классификации, создано исключительно для удобства пользования бумажным изданием классификатора, но никак не отражается на классификационных индексах.

Есть и еще одна форма дополнительного изображения иерархического подчинения рубрик, представленная на примере таблицы 2: Рубрика В 64 С 25/30 практически читается как “Аварийные контрольные или блокирующие устройства приводов убирающихся или складывающихся подвижно закрепленных шасси, используемых в посадочных устройствах летательных аппаратов тяжелее воздуха”. Как видите, шесть ступеней иерархии, обозначенные точками, на форме классификационного индекса никак не отразились. Правда, эта “скрытая” иерархия чревата неудобствами другого плана: если надо вклинить новую рубрику между имеющимися, а для нее уже нет места в целочисленном ряду последнего знакоместа рубрики, то придется прибегнуть к добавлению следующего знака в индекс, как, например, в таблице 3, и оказывается, что иерархическое положение некоторых рубрик уже не только не определяется числом знаков в “хвосте” классификационного индекса, но просто противоположно этому принципу.

Таблица 3.
С 08 С 1/06 | ..консервирование латекса
С 08 С 1/065 | ..увеличение размера частиц диспергированного каучука
С 08 С 1/07 | ...с использованием агломерирующих агентов
С 08 С 1/075 | ..концентрирование
С 08 С 1/08 | ...с помощью средств, способствующих отстаиванию

Таким образом, МПК по детальности проработки близка к УДК и, хотя и лишена ее “десятичного” единообразия (в подклассах используется иногда почти весь алфавит, в обозначениях подгрупп - от двух до четырех знакомест, так что об октавном принципе здесь нет и речи), но имеет и свои методические находки.
В заключение отметим, что в США имеется своя патентная классификация, не менее проработанная в глубину, чем МПК, но основанная исключительно на цифровом индексировании.


Классификаторы ВНИИКИ

КЛАССИФИКАЦИЯ
(системно-морфологический подход)

5.2. Классификаторы ВНИИКИ

В России большинство задач классификации статистической информации Правительством возложено на Всероссийский научно-исследовательский институт классификации, терминологии и информации по стандартизации и качеству (ВНИИКИ) Госстандарта. Цель этого мероприятия очевидна: обеспечить оперативную компьютерную обработку всей текущей технико-экономической и социальной информации о стране. Перечень классификаторов общероссийского значения [7] содержит 25 наименований иерархических классификаторов (из них 12 ведет ВНИИКИ) плюс 20 общесоюзных классификаторов, сохранивших силу до настоящего времени; кроме того, имеются два громадных фасетных классификатора: профессий и информации о населении.

Все классификаторы ВНИИКИ однотипны: они заявлены как иерархические структуры с 3-4 уровнями деления и цифровым кодированием; кроме информативных цифр код содержит еще контрольную цифру, предназначенную для защиты кодовой информации от сбоев считывания. Условие “от трех до семи” практически не используется, на верхних уровнях классификаторов иногда оказывается по нескольку десятков позиций.br> При поверхностном анализе кажется, что при формировании рубрик классификаторов ВНИИКИ, предназначенных в первую очередь для компьютеризованного статистического анализа информации, нарушение принципа “от трех до семи” не столь существенно, так как компьютер не страдает ограниченностью числа одновременно анализируемых объектов. Однако это справедливо лишь на этапе обработки уже расклассифицированной информации. А первой стадией является как раз определение места этой информации в классификации, и его можно выполнить или вручную (и тогда вступает в игру фактор “от трех до семи”), или с помощью компьютерной программы, но тогда в программу надо заложить алгоритм распознавания ключевых признаков информации и сопоставления этих признаков с соответствующими признаками всех ячеек классификатора. Риторический вопрос: “Если нужно сделать выбор среди ряда альтернатив, то в каком случае это сделать легче: когда число вариантов три или тридцать?” однозначно приводит к выводу, что принцип “от трех до семи” удобен не только для “ручного” выбора, но гораздо важнее он для компьютерного: если при формировании классификатора на каждом этапе четко формулировать основание логического деления, то все проблемы с компьютерным размещением объектов в классификацию решаются элементарно, причем особенно просто это реализуется в диалоговом режиме, когда процесс выбора предлагает компьютер, а реализует человек, оператор.

Впрочем, и для полностью “безлюдного” размещения новой информации в классификацию проблема решается, если методами смыслового анализа полнотекстовой информации весь классификатор будет “прошит” соответствующими запросами автоматического поиска. В настоящее время эта проблема в принципе решена, на рынке существует несколько программ распознавания смысла русскоязычной полнотекстовой информации, дело только за составлением соответствующих запросов (правда, это довольно тонкая и кропотливая работа).

Перекраивание всей системы классификации - процесс очень болезненный и непростой, тем более, что основное человеческое свойство - привычка - безусловно вызовет массовое неприятие принципиально нового способа классификации. Однако есть сравнительно несложный способ “плавного” перехода к новой структуре классификаторов. Дело в том, что все наименования ячеек существующих классификаторов легко опознаваемы, соответствуют реальным объектам и отказываться от большинства этих устоявшихся наименований нет никакого смысла. Поэтому новый классификатор можно строить из старого так же, как новый дом - из кирпичей разобранного старого. Новым здесь является только принцип навигации в классификаторе: вместо того, чтобы ломать голову над очередным неохватным пасьянсом рубрик, оператору ведь менее утомительно ответить на простые вопросы, появляющиеся на экране компьютера (и даже не ответить, а просто выбрать из трех - семи уже готовых ответов). А то, что наряду со старым хорошо знакомым классификатором где-то в недрах компьютера заложен новый, то об этом оператор может и не знать.

Такой способ мог бы путем незначительного “косметического” ремонта наименований рубрик старых классификаторов полностью исключить основные их болезни - неоднозначность выбора ячеек и консервативность (трудность расширения и введения новых рубрик), одновременно и сохранив все уже наработанное (т.е. наполнение существующей классификации), и переведя “на новые рельсы” всю работу по классификации.


ОКП, МКТУ и ТН ВЭД

КЛАССИФИКАЦИЯ
(системно-морфологический подход)

5.3. Классификаторы материальных объектов и услуг

И услуги, и материальные объекты предназначены для потребностей человека, а значит, определяющими их атрибутами являются именно целевые функции предназначения объекта или услуги. В таком случае следует ожидать, что именно этот фактор станет первым основанием деления в классификаторах подобного типа. Посмотрим, как в действительности обстоит дело в трех наиболее развитых классификаторах этого типа.

5.3.1. Общероссийский классификатор продукции (ОКП)

Во введении к этому классификатору [8] поясняется его структура и организация:

“Каждая позиция ОКП содержит шестизначный цифровой код, однозначное контрольное число и наименование группировки продукции, которые записывают по следующей форме:

Код | КЧ | Наименование
Например:
57 1193 | 1 | Пески из природного камня, прочие

В ОКП предусмотрена пятиступенчатая иерархическая классификация с цифровой десятичной системой кодирования. На каждой ступени классификации деление осуществлено по наиболее значимым экономическим и техническим классификационным признакам. На первой ступени классификации располагаются классы продукции (XX 000), на второй - подклассы (XX X000), на третьей - группы (XX XX00), на четвертой - подгруппы (XX XXX0) и на пятой - виды продукции (XX XXXX). Коды 2 - 5-разрядных группировок продукции дополнены нулями до 6 разрядов и записываются с интервалом между вторым и третьим разрядами.

Классификация продукции в ОКП может быть завершена на третьей, четвертой или пятой ступенях классификационного деления. При записи отдельных наименований классификационных группировок используют сокращенную форму записи с заменой лексических элементов графическими, при этом:
- опускают начальную часть полного наименования, вместо которой ставят тире, когда она повторяет предшествующее наименование,
- предшествующее наименование или его часть, соответствующая опускаемой части сокращенного наименования, отделяют косой чертой.

Например:
57 1430 9 Плиты облицовочные пиленые / из природного камня
57 1431 4 - из гранита, диорита, сиенита, лабрадорита, габбро, базальта, диабаза, андезита;
57 1432 0 - из белого мрамора;
57 1433 5 - из цветного мрамора.”

Из этой цитаты видно, что, во-первых, структура классификатора декларируется как чисто иерархическая, во-вторых, что при написании наименований объектов используется тот же принцип МПК (замена предшествующей части наименования знаком “-”).

Классификатор ОКП предназначен для специалистов, постоянно с ним работающих, а поэтому раньше или позже запоминающих расположение разделов, описывающих ту отрасль или ту сферу деятельности, по которой они и работают. Для постороннего же взгляда порядок разделов представляется довольно странным. Уже то, что на верхнем этаже иерархии находится 82 позиции, весьма прихотливо разбросанные по смыслу (например, класс 40 Вычислительная техника внедрен между классами 39 Инструмент, технологическая оснастка, абразивные материалы и 41 Продукция общемашиностроительного применения, еще “удачнее” расположен класс 50 Программное обеспечение - между замочными и скобяными изделиями и бытовыми приборами). Разумеется, это не злая воля и не безграмотность разработчиков классификатора, а его генетическое свойство - слишком малая этажность (глубина классификации) и ограниченные возможности развития. Ситуация усугубляется еще и тем, что десятичный принцип и жестко фиксированное число знаков кода, используемые в классификаторе, в сочетании с чрезвычайным разнообразием объектов очень часто приводят к переполнению этажа, когда для очередного объекта данного уровня уже нет свободной цифры.

5.3.2. Международная классификация товаров и услуг (МКТУ)

Эта классификация [9] предназначена в основном для определения, регистрации и защиты товарных знаков и знаков обслуживания (фирменных знаков), при этом навигационные цели здесь фактически имеют несущественное значение: работают по этой классификации исключительно специалисты - патентоведы. Классификация в действительности не соответствует своему названию, т.к. она - одноуровневая, содержит 34 класса товаров и 8 классов услуг; внутри классов объекты просто упорядочены по серийным номерам, состоящим из одной буквы (первая буква первого слова, описывающего объект) и четырехзначного порядкового номера.

Однако проблемы с классификацией существуют и у патентных служб: новые товары и услуги появляются ежедневно и повсеместно, предусмотреть для них место в МКТУ непросто. Ситуация усложняется еще и тем, что серийные номера объектов идут с шагом 1, так что для нового объекта встроить его номер в эту неразрывную цепочку невозможно (например, объекту “Архиватор” места между “А0288. Арфы” и “А0299. Архитектурные макеты” нет). Еще одна вынужденная неуклюжесть выбранного способа кодирования МКТУ состоит в том, что объект, описываемый несколькими словами, частенько имеет два, а то и три кода в соответствии с тем, какое из слов его описания поставить на первое место.

Все это заставило авторов МКТУ снабдить издание классификатора [9] пояснениями, откровенно признающими его несовершенство и подсказывающими, как в этих условиях все же определить, к какому классу отнести тот или иной объект, если классификатор в этом помочь не сможет. Много ценного в этих пояснениях можно найти и для других классификаторов, поэтому стоит привести перечень рекомендаций МКТУ целиком:

“Указания товаров и услуг, содержащиеся в Перечне классов, представляют собой общие указания, отражающие принадлежность товаров или услуг к той или иной области. Поэтому для уточнения классификационного индекса при классифицировании конкретного товара или вида услуг следует обращаться к алфавитному перечню. Если не удается отнести товар к какому-либо классу с помощью Перечня классов или алфавитного перечня, рекомендуется учитывать следующие критерии:

(а) Готовые изделия классифицируются в основном в соответствии с их функцией или назначением; если этот критерий не предусмотрен в перечне классов, то такие изделия следует классифицировать по аналогии с другими подобными изделиями, представленными в алфавитном перечне. Если такие изделия в нем не предусмотрены, следует исходить из вспомогательных критериев, таких как материал, из которого изготовлены изделия, или принцип действия.

(b) Готовые изделия, имеющие составные элементы многоцелевого назначения (например, часы со встроенным радиоприемником) могут быть отнесены ко всем классам, соответствующим каждой из выполняемых ими функций или тем целям, для которых они предназначены. В случае, если этот критерий не представлен в Перечне классов, то применяется критерий, сформулированный в подпункте (а).

(с) Сырье, необработанное или частично обработанное, следует классифицировать по материалу.

(d) Изделие, предназначенное для того, чтобы стать составной частью другого изделия, классифицируется в основном в том же классе, что и изделие в целом, при условии, что оно не используется обычно для иных целей. Во всех других случаях при отнесении таких изделий к соответствующим классам следует руководствоваться рекомендациями, изложенными в п. (а) данных замечаний.

(е) Если товары (готовые изделия или полуфабрикаты) классифицируются по материалу, из которого они изготовлены, и если при этом они изготовлены из различных материалов, их следует классифицировать по преобладающему в их составе материалу.

(f) Емкости (контейнеры, футляры, чехлы и т.д.), предназначенные для упаковки и хранения товаров, классифицируются в том же классе, что и эти товары.”

После этих общих замечаний идет более подробное описание содержания каждого из классов (“Перечень классов...”), в котором имеются два не совсем обычных раздела : “К классу относятся в частности ...” и “К классу не относятся ...”, в этих разделах содержатся так называемые сомнительные объекты, которые по смыслу можно было бы поместить не только в этот класс, но и в какие-либо другие.

Все это очень напоминает попытку стандартными средствами логики хоть как то смягчить несовершенство классификатора: с одной стороны, дается прямое и косвенное номинальное определение каждому классу МКТУ, с другой стороны, подсказывается иерархия оснований деления для тех нередких ситуаций, когда МКТУ бессильна. Но, честно говоря, трудно позавидовать эксперту, стоящему перед задачей определить класс и код, ннапример, пластмассовых фишек-медвежат с магнитиком, предназначенных для временной фиксации каких-либо памятных бумажек на металличесой стенке.

Несовершенство русскоязычной МКТУ можно продемонстрировать на одном фрагменте, взятом из [9] (см. таблицу 4).

Из позитивных черт в Перечне классов МКТУ следует отметить обилие “спасательных” формулировок вроде “изделия из металлов, не относящиеся к другим классам” (аналог ячейки “Прочие”). Но общий вывод о качестве данной классификации все же такой, что примером для подражания она служить не может, т.к. ставит задач перед пользователем гораздо больше, чем их решает.

Таблица 4.

Класс | Номера рубрик | Название товаров | Номера рубрик | Название товаров на английском и французском языке
16 | Д0280 | Документы (папки для-) | E F0362 E J0004 F C0655 | Folders for papers Jackets for papers Chemises pour documents
16 | Д0281 | Документы (папки для хранения [канцелярские принадлежности] для-) | E D0194 F D0252 | Document files (stationary) dossiers (papeterie)
16 | Д0282 | Документы (пластины [тканевые] для нанесения краски машин для репродуцирования -) | E I0083 F T0323 | Inking sheets for document reproducing machines toiles d’encrage de machines pour la reproduction de documents
16 | Д0283 | Документы (портфели для -) | E B0656 F P0745 F S0233 | Briefcases porte-documents serviettes (maroquinerie)
18 | Д0284 | Документы (чемоданы плоские для -) | E A0458 F M0055 | Attache cases maliettes pour documents

Замечание к последней строке таблицы: пятая редакция МКТУ принята в 1985 году, официальный перевод в России - в 1990 году, однако, ни “дипломат”, ни “кейс”, обозначающие в обиходе объект Д0284, в классификации не присутствуют, а понятие “чемодан документов” Руцкой ввел в обиход, кажется, только в 1995 году.

5.3.3. Товарная номенклатура внешнеэкономической деятельности (ТН ВЭД).

ТН ВЭД [10] регулирует практически ту же область, что и два предыдущих классификатора, и, казалось бы, должна иметь ту же или близкую структуру. Однако в действительности различие между этими классификациями довольно значительно. Обусловлено оно и генетическими причинами, и целевыми функциями этих классификаторов.

Во-первых, ТН ВЭД создана на базе Гармонизированной системы описания и кодирования товаров (ГС) и комбинированной тарифно-статистической номенклатуры Европейского экономического сообщества (КН ЕЭС) и вследствие этого меньше подвержена волюнтаризму отечественных разработчиков. Другая особенность ТН ВЭД связана с ее целевой функцией - четко и однозначно определять принадлежность любого конкретного товара тому или иному классу при внешнеэкономических операциях. Поскольку это связано с серьезными финансовыми вопросами (тарифное регулирование, лицензирование, и т.д.) и вопросы эти - сиюминутные (а не отложенные, как в МКТУ), то вопрос об однозначности понимания классификационных группировок становится одним из важнейших для данного классификатора.

Структура классификатора и его кодов такова: 21 раздел содержит в общей сложности 97 групп товаров, при десятичной кодификации групп для них используются два знакоместа, разделы никак в коде не проявляются. Следующие два знакоместа отведены для второго этажа классификации, но на этом этаже число альтернатив редко превышает 10. Два знакоместа отведены и для следующего этажа, и здесь впервые цифре 9 отведена роль идентификатора “Прочих” объектов. Четвертому этажу классификации в коде отведена одна цифра, так же, как и пятому. Общее число знаков в коде фиксировано и равно 9, последний знак (в настоящее время - нуль во всех кодах) предназначен для отражения в будущем российской специфики.

Написание наименований позиций в ТН ВЭД производится, как и в МПК, с заменой родовых понятий черточками, так что иерархия позиций просматривается не только (и не столько) по кодам, но и по виду наименований. Но, как и в МПК, не всегда число значащих цифр кода соответствует этажу классификатора.

Как и остальные классификаторы этой группы, ТН ВЭД не обладает навигационными свойствами. Разумеется, говорить о правиле “от 3 до 7” здесь вообще нельзя, 21 раздел (верхний этаж) и 97 групп (второй этаж) классификатора делают фактически малозначащим дальнейшее дробление, поэтому остальные этажи в подавляющем большинстве случаев обходятся 3-5 альтернативами.

Высокая экономическая значимость результата классификации заставила разработчиков (и переводчиков) добавить к классификатору громадное количество словесных уточнений, примечаний и замечаний [1], что фактически обнажает низкое качество классификатора прежде всего в смысле определенности, однозначности классифицирования.


Классификаторы документации

КЛАССИФИКАЦИЯ
(системно-морфологический подход)

5.4. Классификаторы документации

5.4.1. Общеправовой классификатор отраслей законодательства (ОКОЗ)

Классификатор [11] содержит около 470 ячеек, сгруппированных в трехэтажную структуру. Собственно говоря, отраслями законодательства (формально именно это является объектом классификации, т.е. вершиной классификатора) можно назвать только ячейки верхнего этажа, да и то не все. Этих ячеек ровно 50, они никак не структурированы и на одном уровне оказались и “020.000.000. Гражданское законодательство”, и “320.000.000. Законодательство о гидрометеорологии”, и “660.000.000. Решения по вопросам помилования”.

Ни одну из ячеек следующего уровня (например, “010.040.000. Государственный язык”, или “020.060.105. Прокат”) нельзя назвать отраслью законодательства, поэтому формально ОКОЗ (точнее, та его часть, которая содержит именно отрасли законодательства, а это разделы с 010.000.000 по 420.000.000) является не классификатором, а простым перечнем отраслей законодательства, никак не структурированным (хотя провести логическое деление этого небольшого массива очень просто).

Совсем иначе смотрится ситуация, если бы ОКОЗ назывался несколько иначе, например: “Классификатор нормативных правовых актов (федерального уровня)”. В этом случае структура и формальные связи между ячейками больше похожи на то, что характерно для классификации. Тем не менее, остаются другие ошибки.

Разделы (ячейки) верхнего уровня ОКОЗ содержат обязательное слово “законодательство” и это - правильно. Формально при смене названия классификатора следовало бы в каждый раздел (любого уровня) включить обязательное понятие “нормативный правовой акт”. Экономия на словах приводит к тому, что по названию раздела далеко не всегда можно сказать, к какой части классификатора он относится (например, раздел под названием “Компетенция” встречается шесть раз без упоминания, о чьей компетенции идет речь). Это вынуждает для понимания сути раздела проследить всю иерархическую цепочку, которая в ОКОЗ выглядит сравнительно короткой (всего три этажа иерархии), но в реальном классификаторе (при соблюдении условия “от трех до семи” на каждом этаже классификации) может быть более протяженной. В частности, для массива разделов, присутствующих в ОКОЗ, при их корректной классификации среднее число этажей (из расчета среднего коэффициента деления, равного 4) будет равно 1+log4450»5,5, причем при строчной записи классификатора эти 5-6 строк будут разнесены в тексте на солидные расстояния и практически недоступны для одновременного обозрения. Поэтому с точки зрения удобства пользования классификатором каждая его строка (при строчной записи) должна содержать информацию обо всей иерархической надстройке.

Альтернативный вариант - изображение классификатора в виде блок-схемы (подобной Рис.1) - позволяет не разворачивать текст ячеек полностью, но у него свой недостаток - необозримость всего поля классификации. Впрочем, организация записей в форме, подобной представленной на Рис.1, помогает сравнительно просто обойти эту трудность и при ошибочном выходе не на ту ячейку быстро вернуться к этажу, на котором был сделан неверный выбор, и пойти по другой ветви.

Возвращаясь к конкретному ОКОЗ, можно сделать вывод, что это не классификатор в строгом смысле этого слова, поисковые возможности его весьма слабы, а многозначность рубрик или разделов делает весьма субъективной и неоднозначной работу как по размещению нормативных актов, так и по поиску их.

Тем не менее, содержание этого классификатора безусловно можно использовать для создания корректного классификатора нормативных правовых актов при соблюдении всех основных правил классификации. В Приложениях 1 и 2 показано, как могли бы выглядеть некоторые фрагменты такого классификатора.

5.4.2. Общероссийский классификатор управленческой документации (ОКУД)

Этот классификатор [12] является плодом работы семи “нянек”- учреждений, не считая головного ВНИИКИ. В соответствии с постановлением о введении в действие ОКУД целями его создания и использования провозглашены:

- регистрация форм документов;
- упорядочение информационных потоков в народном хозяйстве;
- сокращение количества применяемых форм;
- исключение из обращения неунифицированных форм документов;
- обеспечение учета и систематизации унифицированных форм документов на основе их регистрации;
- контроль за составом форм документов и исключение дублирования информации, применяемой в сфере управления;
- рациональная организация контроля за применением унифицированных форм документов.

Далее приведем описание ОКУД, как оно дано в самом документе:

“В ОКУД принята иерархическая классификация с тремя ступенями. Каждая позиция классификатора состоит из двух блоков: блока идентификации и блока наименований объекта классификации.

Структура кодового обозначения унифицированной формы документа по ОКУД:

Пример кодового обозначения унифицированной формы документа по ОКУД:

09010046 Расчетная ведомость по страховым взносам в Пенсионный фонд

В кодовом обозначении унифицированной формы документа отражены следующие признаки классификации: первый и второй знаки (класс форм) - принадлежность унифицированной формы документа к соответствующей унифицированной системе документации; третий и четвертый знаки (подкласс форм) - общность содержания множества форм документов и направленность их использования; пятый, шестой и седьмой знаки - регистрационный номер унифицированной формы документа внутри подкласса; восьмой знак - контрольное число.”

Хотя в описании классификатора декларирована иерархическая его структура, в действительности массив информации этой классификации таков, что в некоторых участках фасетная организация просматривается невооруженным глазом. Например, в приведенном ниже фрагменте классификатора видно, что многие формы документов повторяются “один к одному” в разных подклассах (например, формы 0211151, 0212151 и 0213151), о чем свидетельствует идентичность трех последних цифр кода в приведенном примере. Таких примеров можно привести много, особенно по последним трем значащим цифрам кода. Ведь ясно, что на одном уровне иерархической структуры не может находиться тысяча элементов (три десятичных знака), так что явно или неявно, но массив этого “нижнего” этажа отнюдь не одноэтажный.

Фрагмент классификатора ОКУД

КОД | КЧ | Наименование формы
0200000 | 2 | УНИФИЦИРОВАННАЯ СИСТЕМА ОРГАНИЗАЦИОННО-РАСПОРЯДИТЕЛЬНОЙ ДОКУМЕНТАЦИИ
0211000 | 0 | Документация по созданию организации, предприятия
0211031 | 3 | Договор об аренде
0211071 | 5 | Заявление на государственную регистрацию
0211072 | 1 | Заявление в финансовые органы об открытии расчетного счета
0211073 | 8 | Заявление об исключении из состава членов колхоза (совхоза)
0211101 | 1 | Письмо об изготовлении печати, штампа
0211111 | 7 | Положение о структурном подразделении
0211151 | 9 | Приказ о создании предприятия
0211152 | 5 | Приказ о выходе из совхоза
0211161 | 4 | Протокол общего собрания (конференции) трудового коллектива о создании предприятия
0211162 | 0 | Протокол общего собрания членов кооператива об утверждении устава
0211163 | 7 | Протокол заседания правления колхоза
0211171 | 3 | Распоряжение главы администрации территории о предоставлении земельного участка
0211191 | 0 | Свидетельство о регистрации
0211231 | 2 | Устав
0211241 | 8 | Учредительный договор
0212000 | 4 | Документация по реорганизации организации, предприятия
0212151 | 2 | Приказ о реорганизации
0212161 | 8 | Протокол общего собрания (конференции) трудового коллектива о реорганизации
0212181 | 9 | Решение совета директоров (правления) о реорганизации
0213000 | 8 | Документация по ликвидации организации, предприятия
0213011 | 4 | Акт о ликвидации
0213101 | 9 | Письмо с сообщением о ликвидации
0213102 | 5 | Письмо участника о выходе из совместного предприятия
0213151 | 6 | Приказ о ликвидации и создании ликвидационной комиссии
0213181 | 2 | Решение совета директоров (правления) о ликвидации
0213161 | 1 | Протокол общего собрания (конференции) трудового коллектива о ликвидации

Кстати, семь обязательных десятичных знаков кода означают, что можно закодировать 10000000 форм, тогда как в классификаторе их наличествует всего около 2000. В этом смысле принцип “от трех до семи” гораздо более экономичен и логичен (несмотря на то, что некоторые из кодов могут содержать даже больше семи знаков).

5.4.3. Особенности классификации регламентной информации.

Регламентная информация в отличие от информации о предметах или о процедурах сообщает сведения о правилах, определяющих и состав, и связи, и функционирование элементов той или иной системы. Это создает специфические трудности при классификации такой информации, что достаточно наглядно продемонстрировано в двух предыдущих разделах.

Суровые законы классификации, несоблюдение которых чревато резким ухудшением навигационных возможностей классификатора, требуют, в частности, однородности всех объектов, содержащихся в классификации. В то же время объекты такой классификации - это документы, регламентирующие отнюдь не однородные объекты регулирования, которые мы (для выхода из этого положения) назвали общим названием “атрибуты системы” (это и подсистемы, и функции, и связи, и объекты воздействия, и т.д.). Собственно говоря, сложность состоит в том, что нужно либо использовать полное наименование каждой рубрики (типа “регламентный документ, регулирующий то-то и то-то”, и так абсолютно в каждой рубрике), что резко ослабляет внимание оператора и увеличивает вероятность ошибок, либо использовать сокращенное наименование рубрик (опуская названные выше слова “преамбулы” рубрики), что потребует особой тщательности именно при разработке классификатора и при выборе оснований деления. Конечно, второй путь предпочтительнее, поскольку он проходится усилиями специалистов и только один раз, а работу с готовым классификатором предстоит вести пользователям, не обремененным специальными познаниями, и многократно.


Классификация: системно-морфологический подход

КЛАССИФИКАЦИЯ
(системно-морфологический подход)

Оглавление

1. | Введение
2. | Логические операторы
2.1. | Определение
2.2. | Вариантообразующие операторы
2.2.1. | Логическое деление
2.2.2. | Классификация
2.2.3. | Обобщение
2.3. | Системообразующие операторы
2.3.1. | Основные положения системного подхода
2.3.2. | Расчленение
2.3.3. | Соединение
3. | Общие свойства классификаций
4. | Как создается классификация
5. | Анализ некоторых классификаторов
5.1. | Классификаторы отраслей знания
5.1.1. | Универсальная десятичная классификация
5.1.2. | Классификатор РФФИ
5.1.3. | Международная классификация изобретений
5.2. | Классификаторы ВНИИКИ
5.3. | Классификаторы материальных объектов и услуг
5.3.1. | Общероссийский классификатор продукции (ОКП)
5.3.2. | Международная классификация товаров и услуг (МКТУ)
5.3.3. | Товарная номенклатура внешнеэкономической деятельности (ТН ВЭД)
5.4. | Классификаторы документации
5.4.1. | Общероссийский классификатор отраслей законодательства (ОКОЗ)
5.4.2. | Общероссийский классификатор управленческой документации (ОКУД)
5.4.3. | Особенности классификации регламентной информации.
 | Заключение
 | Приложение 1. О принципах организации классификатора нормативных правовых актов
 | Приложение 2. Пример составления классификатора правовой информации

Введение


Предложение о разработке

Деловое предложение

Итак, у Вас есть проблемы с классификацией. По этой книге Вы могли убедиться, что в действительности задача создания грамотной классификации не так проста, как кажется неосведомленному человеку. Разбор существующих классификаторов показал, что солидные (по возрасту, а не только по значению) классификаторы грешат не только возрастными недостатками, но и более элементарными несообразностями. И, безусловно, они непригодны для автоматического рубрицирования больших потоков входящей информации.

Каждый должен делать то, что он делает лучше других, эту истину цивилизация внедряет в мозги очень болезненными экономическими средствами. Поэтому, если Вы не собираетесь стать специалистом по разработке классификаций, а потребность навести порядок в собственном хозяйстве ну очень даже животрепещет, то мы готовы Вам помочь:

  • если у Вас уже есть самодельный или позаимствованный классификатор, мы можем его улучшить, сделать более логичным и однозначным;
  • если у Вас нет классификатора и вся информация находится в беспорядке, то мы можем разработать для Вас уникальный (только для Вас предназначенный) классификатор;
  • если Ваш классификатор достаточно хорош с точки зрения автоматической рубрикации входных потоков информации, то мы можем разработать программный продукт, который в дальнейшем без Вашего участия будет идентифицировать и раскладывать всю информацию по рубрикам этого классификатора;
  • если у Вас уже есть и классификатор, и система автоматической или ручной классификации, то мы можем разработать для Вас интерактивную систему автоматического поиска нужной информации в классификаторе. Что это такое, Вы можете узнать, просмотрев презентационный материал.

Ну а если у Вас особой необходимости в классификаторе и классификации нет или если за это страшно даже браться, то вернитесь на главную страницу, там есть другие интересные предложения.

Оглавление


Приложение 1

КЛАССИФИКАЦИЯ
(системно-морфологический подход)

Приложение 1.
О принципах организации классификатора нормативных правовых актов

Первое, что следует сказать, - это то, что по правилам классификации любые конкретные классифицируемые объекты могут располагаться только в ячейках нижнего этажа классификатора, все промежуточные этажи (уровни) классификатора предназначены только для выполнения единственной и основной его функции - навигации. Но большинство нормативных правовых актов (НПА) регулирует не отдельные правоотношения, а целые группы их, а это значит, что такой НПА по смыслу охватывает целую ветвь классификации и вследствие этого должен быть размещен “у корня” этой ветви. Выйти из этого положения можно двояко: или отказаться от принципа классификации, названного выше, или сохранить “принцип нижнего этажа” и при каждом логическом делении предусмотреть ячейку “Не уточняется” или “Все варианты”
Второе - на каждом этапе создания классификатора обязательно формулируется основание логического деления. Не всегда это удается выполнить в удобопонятных любому пользователю терминах, но обязательное требование состоит в том, чтобы любой пользователь мог легко сделать на каждом этапе однозначный выбор при любом вопросе, приведшем его к работе с классификатором. Иначе говоря, все четыре правила логического деления должны выполняться абсолютно четко.

Ниже приводится ряд фрагментов классификатора НПА, при этом прослеживается структура верхних уровней и по одной из ветвей - цепочка уровней до самого низа (т.е. до конкретных документов). Там, где наименования рубрик совпадают с ОКОЗ, приводятся соответствующие цифровые коды ОКОЗ.

схема 1-1
Схема П1-1. 1-й и 2-й уровни классификатора НПА.

схема 1-2
Схема П1-2. Фрагмент 2-го и 3-го уровней классификатора НПА.

Схема П1-3. Фрагмент 2-го и 3-го уровней классификатора НПА.

Схема П1-4. Логическое деление блока 21 классификатора НПА.

Схема П1-5. Логическое деление рубрики 22.

Схема П1-6. Логическое деление рубрики 23.

Обратите внимание - на схемах появились ячейки типа “Прочие”, это на будущее, для тех видов членов деления, о которых нам пока ничего не известно. В принципе все ячейки “общего назначения”, о которых говорилось в начале этого раздела, можно обозначить на всех подобных схемах, но можно (пока их нечем заполнять) и оставить их “в уме”. Впрочем, в некоторых случаях желательно эти ячейки ввести сразу (например, когда уже есть единичные НПА, для которых неочевидно сродство к одной из альтернатив ряда).

На следующей схеме мы впервые сталкиваемся с фасетной структурой.

 | 24. Стабильность (защита) государственной системы 350.000.000
Объект защиты | 1. Территория и статус | 2. Экономика (хозяйство) | 3. Граждане | 4. Иные объекты
Территория защиты |
1. Внутри государства | 2411. Внутренняя военная безопасность 370.080.000 | 2421. Внутренняя экономическая безопасность | 2431. Защита правопорядка 370.000.000 | 2441.
2. На границе | 2412. НПА об охране границы | 2422. Таможенное законодательство 360.000.000 | 2432. Регламент поведения в приграничной зоне | 2442.
3. Вне государства | 2413. Внешняя военная безопасность 340.000.000 | 2423. НПА о хоз. деятельности вне территории государства | 2433. Защита граждан за рубежом 440.045.000 | 2443.
Схема П1-7. Логическое деление раздела 24 классификатора НПА по двум основаниям деления.

На схеме П1-7 применены другие обозначения: крупным жирным шрифтом выделено делимое понятие, мелким жирным прямым шрифтом - два основания деления, жирным курсивом - альтернативные члены деления (по соответствующим основаниям). Надо сказать, что хотя в некоторых ячейках и проставлены девятизначные индексы ОКОЗ, но в большинстве случаев совпадение содержания ячеек лишь частичное, а формулировки иногда вовсе не идентичны.

Заметим еще, что на схеме П1-7 “без объявления” использован позиционный принцип кодирования фасетного участка (первой цифрой двузначного кода всегда идет кодовая цифра по основанию “объект защиты”, второй - “территория защиты”.

Для дальнейшего движения вниз по дереву классификатора выберем рубрику 224. Культурное развитие человека.

Схема П1-8. Логическое деление раздела 224.

Если теперь выбрать для дальнейшего деления раздел 2241. Образование, то мы столкнемся с комбинативным (фасетным) участком классификатора при числе независимых оснований деления больше двух, а именно: 1) виды образования, 2) организационно-правовые формы образовательных учреждений, 3) атрибуты организации процесса обучения. Изобразить такую структуру на плоскости уже почти невозможно, а поскольку в будущем не исключена возможность, что число оснований деления будет больше трех, то следует выбрать способ кодирования, записи и распознавания кода для общего случая фасетной классификации. В свое время революцией в математике был переход от римской системы написания чисел к арабской, позиционной. Можно попробовать использовать этот принцип и здесь (как это сделано на схеме П1-7).

Пусть по каждому из оснований деления фасетного участка кодирование попрежнему ведется цифрами: для конкретных альтернатив - цифрами от 1 до 7, для ячейки “Прочие” используется 9, а для ячейки “не уточняется” (или “все возможные значения”) используем 8. Пусть также задан конкретный порядок расположения кодирующих цифр фасета, например, вначале идет код по параметру “виды образования”, за ним - код по параметру “организационно-правовые формы образовательных учреждений”, а за ним - код по параметру “атрибуты организации процесса обучения”. Если все эти коды - однозначные, то сказанного достаточно. Но в данном случае при делении по основанию “виды образования” одним этажом не обойтись, придется задействовать два знакоместа (две цифры).

Перечень альтернатив по каждому из оснований деления рубрики 2241 тогда будет выглядеть следующим образом:

2241 Виды образования.
1. Дошкольное образование. (190.030.000)
2. Общее образование (190.030.020)

21. Начальное общее образование.
22. Среднее общее образование.
23. Общее (и специальное) образование для детей с отклонениями развития. (190.030.030)
24. Общее образование для детей-сирот и лишенных попечения родителей. (190.030.040)
28. Не уточняется.
29. Иные варианты общего образования.
3. Профессиональное образование.
31. Начальное профессиональное образование. (190.030.050)
32. Среднее профессиональное образование. (190.030.055)
33. Высшее профессиональное образование. (190.030.060)
38. Не уточняется.
39. Иные варианты профессионального образования. (190.030.080?)
4. Послевузовское образование.
41. Вторая специальность. (190.030.080?)
42. Аспирантура, ординатура. (190.030.070)
48. Не уточняется.
49. Иные варианты послевузовского образования. (190.030.080?)
8. Не уточняется.
9. Прочие виды образования. (190.030.080?)

Организационно-правовые формы образовательных учреждений. (190.040.000)
1. Государственные образовательные учреждения. (190.040.010)
2. Муниципальные образовательные учреждения. (190.040.020)
3. Частные образовательные учреждения. (190.040.030?)
4. Образовательные учреждения общественных объединений или религиозных организаций. (190.040.030?)
5. Самообразование, экстернат, соискательство. (190.035.000)
9. Прочие формы образовательных учреждений. (190.030.080?)
8. Не уточняется.

Атрибуты организации процесса обучения.
1. Учебники и учебные пособия. (190.050.020)
2. Учебные программы, регламент аудиторных и домашних занятий.
3. Каникулы, летний отдых. (190.050.030)
4. Практика, стажировка. (190.050.040)
5. Стипендии, льготы. (190.050.010)
6. Права и социальная защита обучающихся. (190.050.000)
7. Особенности обучения иностранцев. Направление российских граждан на учебу за границу. (190.070.000)
8. Не уточняется.
9. Иные атрибуты учебного процесса.

Пользуясь этим списком обозначений кодов, можно закодировать любой конкретный нормативный документ, относящийся к образованию. Например:
- Код 22413834 соответствует нормативному документу, регламентирующему вопросы практики или стажировки в частных образовательных учреждениях всех видов.
- Код 22412883 соответствует документу, регламентирующему порядок каникулярного и летнего отдыха учащихся в общеобразовательных учебных заведениях всех уровней и организационно-правовых форм.

При данном способе кодирования фасетные участки в каждом конкретном месте классификатора снабжены заранее оговоренным порядком расположения фасетов. Если фасет представляет собой одно-двухуровневое дерево, то это не сильно удлиняет код, но если фасет разветвляется на 4-5 этажей и таких фасетов не два и не три, то код становится неоправданно длинным, причем в силу жесткости позиционирования фасетов - даже в тех случаях, когда какие-либо ветви фасетов не задействованы (ячейки “Не уточняется” в приведенном выше списке). Повидимому, более компактными коды могут стать при использовании нецифровых индикаторов фасета (аналогично общим и специальным определителям УДК). Например, если в разделе “Образование” ввести определитель вида образования “А”, определитель организационно-правовых форм “Б” и определитель атрибутов образовательного процесса “В”, то коды примеров, приведенных выше, запишутся как 2241Б3В4 и 2241В3. При этом ячейку “Не уточняется” можно из поискового запроса исключить (так как можно отсутствие обозначения фасета в запросе понимать именно в смысле “Все значения”). Какой из вариантов выбрать для классификатора НПА, пока не решено, но не вредно проанализировать список определителей УДК и по возможности его использовать в той или иной степени.

На этом примере видно, что нижние этажи корректного классификатора НПА включают практически все рубрики ОКОЗ, имеющие отношение к данному разделу, но кроме того, содержат и рубрики, отсутствующие в ОКОЗ, но явно необходимые по смыслу. Более того, некоторые из этих новых рубрик в настоящее время пусты, т.е вопрос требует правового регулирования, а его на сегодняшний день - нет! Иначе говоря, корректный классификатор может играть и не совсем обычную роль постановщика задачи для нормотворчества.


Приложение 2

КЛАССИФИКАЦИЯ
(системно-морфологический подход)

Приложение 2.
Пример составления классификатора правовой информации

В этом приложении подробно рассматривается процесс составления самостоятельного классификатора правовой информации по сравнительно узкому аспекту правоотношений - арбитражному процессу.

Арбитражное законодательство - система, регулирующая защиту прав и интересов в сфере предпринимательской и экономической деятельности. Эта система, как и всякая другая система, характеризуется составом элементов, структурой и выполняет определенную функцию. Весь массив информации, связанной с системой под названием “Арбитражный процесс”, необходимо систематизировать так, чтобы потенциальный пользователь мог легко найти нужный документ.

Основной принцип этой систематизации зависит от цели, для которой она производится, и от того, кому предназначена информация названного массива. Официальный “Общеправовой классификатор областей законодательства”, не мудрствуя лукаво, определил по этому разделу восемь подрубрик одного уровня, оставив за пределами внимания детальную градацию многочисленных вопросов, связанных с арбитражем. Впрочем, для юристов, специализирующихся на обслуживании арбитражного процесса, ни этот, ни какой другой классификатор не являются предметом первой необходимости. Другое дело - предприниматель, сталкивающийся с необходимостью разобраться в тонкостях арбитражного судопроизводста далеко не ежедневно, да и вообще имеющий образование, отличное от высшего юридического. Но именно для его бизнеса эти тонкости приобретают время от времени гамлетовскую остроту, поэтому естественно при систематизации информации об арбитражном процессе ориентироваться именно на предпринимателя - неподготовленного пользователя.

Исходные положения для выбора стратегии систематизации правовой информации таковы:
В любой конкретной ситуации, требующей решения спорных экономических вопросов, наличествуют: субъекты права (не менее двух), объект спора (имущество, неимущественный объект), вид правоотношения (имущест-венные и неимущественные права, право на действие), место и время проявления правоотношения. Если эта конкретная ситуация требует арбитражного разрешения, т.е. имеет место конфликт интересов в области предпринимательской или экономической деятельности, то предметом (объектом) рассмотрения является конкретная ситуация со всеми ее атрибутами, перечисленными выше. Но сама система арбитража - это уже другая система, которая включает собственно арбитражный суд (точнее, всю иерархию арбитражных судов и вспомогательных учреждений) и участников спора (истцов, третьих лиц, ответчиков и свидетелей, причем каждый из участников может быть не в единственном числе). Именно арбитражным законодательством регламентируются структура этой системы и взаимодействие ее элементов.

Фактически пользователю (например, предпринимателю) может понадобиться знать, куда и к кому обратиться со своей проблемой (т.е. получить сведения о структуре, иерархии связей и функции органов и сотрудников арбитража), знать всю процедуру арбитажного судопроизводства, права и действия участников арбитражного процесса на разных его стадиях. Не менее важно бывает предвидеть результат арбитражного процесса (по результатам прецедентов по аналогичным делам).

Поэтому первый выбор, который должен сделать пользователь, входя в классификатор базы “Арбитражный процесс”, - это ответить на вопрос, что его прежде всего интересует (см. Табл. П2-1):

Таблица П2-1.
Код | Вопрос | Рубрика первого уровня классификатора
1 | Кто должен решать мой спор? | Структура арбитража
2 | Как будет решаться мой спор? | Арбитражное производство
3 | Как были решены аналогичные споры? | Арбитражная практика

Поэтому в соответствии с правилами логического деления исходного понятия (основание классификатора) “Арбитражный процесс” первое дробление классификатора следует произвести, используя в качестве основания суть потребности пользователя.

Рис.П2-1. Схема первого этапа создания классификатора по теме “Арбитражный процесс”.

Можно подойти к этому же вопросу с другой стороны, с чисто формальных позиций системного подхода. Арбитраж как предметная социальная система состоит из неких структурных элементов, находящихся в определенной взаимосвязи, выполняет определенную функцию (разрешает экономические споры) с помощью ряда определенных процедур или внутренних функций, а также имеет некоторую историю выполнения своей функции. Иначе говоря, три раздела верхнего уровня соответствуют трем аспектам системного анализа арбитражной системы: элементный и структурный анализ (рубрика 1), внутренний функциональный анализ (рубрика 2) и внешний функциональный анализ (рубрика 3).

Все сказанное можно изобразить в виде двух схем, показанных на Рис.П2-1 (одна - на языке обычного потребителя, другая - на языке системного анализа).

Теперь вспомним, что речь идет о классификаторе правовой информации, в котором должны быть и нормативные акты, и практика арбитражного процесса. Руководствуясь основным законом классификации (она должна быть образована только оператором логического деления), нетрудно убедиться, что наш классификатор в действительности состоит из двух самостоятельных классификаторов: 1) нормативных актов арбитражного законодательства (левые два раздела) и 2) прецедентов арбитражной практики (крайний правый раздел). Это снимает, кстати, вопрос о некорректности выражения “Классификатор арбитражного процесса”, нет такого классификатора. И на языке, который не будет оскорблять ухо ученого юриста, верхние этажы рубрикатора “Арбитражный процесс” будут выглядеть, как показано на Рис.П2-2.

Рис.П2-2. Структура и полные формулировки рубрик верхних этажей рубрикатора "Арбитражный процесс"

Заметим, что из основного правила классификации следует, что полное название каждой рубрики классификатора нормативных правовых актов (НПА) должно начинаться со слова “НПА”, рубрики прецедентов - со слова “Прецедент”. С точки зрения литературной корректности такое многократное повторение одних и тех же слов и словосочетаний не является благозвучным и, главное, рассеивает внимание и создает некий дискомфорт в работе, вызывая быстрое “отупение” и, как следствие, возникновение ошибок.

Поэтому мы будем использовать не только полные, но и краткие наименования рубрик. В данном случае, сделав еще одно упрощение и убрав промежуточную рубрику “НПА, регулирующие арбитражный процесс”, получим окончательный вариант верхнего участка рубрикатора с краткими наименованиями рубрик (см. Рис.П2-3).

Рис. П2-3. Краткие наименования рубрик верхнего этажа рубрикатора "Арбитражный процесс"

Подчеркнем, что применение кратких наименований рубрик сделано только из соображений литературной грамотности и комфортности работы, но в процессе создания и использования рубрикатора надо постоянно иметь в виду и полные наименования рубрик, и основания логического деления, так как это обеспечивает соблюдение правил классификации и исключает сомнения в адресации тех или иных документов.

Для кодирования рубрик будем использовать цифры, не забывая о необходимости соблюдения трех правил классификации нормативной информации: 1) на каждом этапе логического деления число членов деления не должно превышать семи (а лучше всего - от трех до пяти) и 2) с учетом возможности развития классификатора во многих случаях следует при логическом делении понятий включать “запасную” рубрику под условным названием “Иные” или “Прочие”, 3) для документов обобщающего плана ввести рубрику “Не уточняется” (или “Все варианты”). Итого мы получаем, что для всего процесса кодирования достаточно девяти кодирующих цифр. И, конечно, позиционный принцип: код рубрики следующего (вниз) уровня пристраивается справа к коду верхней рубрики.

Договорившись таким образом о правилах кодирования, приступим к дальнейшей детализации рубрик. В классификаторе НПА (левые две рубрики на Рис.П2-3) все сравнительно просто (см. Табл. П2-2):

Таблица П2-2.

Рубрика
Основание логического деления
1. Строение и полномочия арбитражных органов.
11. Высший Арбитражный Суд (строение и полномочия).
12. Федеральные окружные арбитражные суды (строение и полномочия).
13. Арбитражные суды субъектов РФ (строение и полномочия).
Уровень иерархии арбитражных судов
2. Процедура арбитражного производства.
21. Атрибуты арбитражного производства (сроки, формы документов, расходы).
22. Последовательность арбитражного производства.
Процессуальные характеристики арбитражного производства

Сложнее обстоит дело с третьей рубрикой. Дело в том, что в прецеденте существенными атрибутами являются: 1) субъекты спора, 2) объект спора, 3) вид оспариваемого правоотношения, 4) место и время спора, 5) уровень арбитражного суда, принявшего решение по спору, 6) суть решения по спору. И каждый из этих атрибутов не зависит от других и может принимать разные значения, причем число вариантов в некоторых случаях намного превышает “нормативные” 7, т.е. для каждого из перечисленных атрибутов можно строить свою классификацию. А итоговый классификатор прецедентов представляет собой уже не иерархическую (древовидную) конструкцию, а многомерную фасетную (матричную) систему, причем размерность матрицы равна числу независимых атрибутов прецедента.

В Универсальной десятичной классификации отраслей знания, принятой во всем мире, проблема кодификации фасетной структуры решена с помощью так называемых определителей, когда для кода каждой из независимых характеристик вводится определенный знаковый индикатор (определитель): .0 (точка-ноль), .00 (точка-два нуля), = (знак равенства), : (двоеточие), (0 (скобка-ноль), и т.д. Число таких определителей, сконструированных из знаков препинания, свободных цифр и букв, безгранично, так что мы в данной ситуации можем выбрать такие, которые при минимальном количестве знаков обеспечат однозначное прочтение кодов. Пусть наши атрибуты прецедента будут перечислены в следующем порядке и снабжены следующими определителями:

А - уровень и суть судебного решения,
Б - объект спора,
В - вид оспариваемого правоотношения,
Г- субъект спора,
Д - место спора,
“ “ - время спора (заключается в кавычки).

Здесь для удобства сделаны следующие изменения: 1) уровень решения (три варианта) и его суть (от двух до четырех вариантов) объединены в один параметр с целью сокращения размерности классификатора; 2) порядок записи кодов избран таким, чтобы они располагались слева направо по мере убывания значимости атрибута прецедента для потенциального пользователя. Наконец, можно сделать и еще одно упрощение (только для данного случая!): ограничимся здесь рассмотрением только внутрироссийских экономических споров, тогда единство правового пространства страны позволит исключить из кодификации атрибут места. И, наконец, прецедент имеет информационную ценность для пользователя независимо от времени его происхождения (в пределах времени существования понятия “арбитраж”), т.е. и эту характеристику тоже можно исключить из кода. Остаются четыре атрибута из вышеприведенного перечня. И третья рубрика дробится следующим образом (см. Табл. П2-3):

Таблица П2-3.

Рубрика
Основание деления
3. Прецеденты арбитражной практики. .
А. Уровень и суть судебного решения.
А1. Решение суда первой инстанции.
А9 Обжалование и его результаты.
кратность рассмотрения спора
Б. Объект спора.
Б1. Имущество.
Б9. Иные объекты спора.
вид объекта спора (имущественный или неимущественный)
В. Вид оспариваемого правоотношения.
В1. Собственность, владение, пользование.
В9. Иные правоотношения.
характеристики правоотношения (право на действие,право обладания)
Г. Субъект спора.
Г1. Государственный орган.
Г2. Негосударственная организация.
Г3. Гражданин.
статус субъекта спора

Итак, в результате этих действий получен следующий рубрикатор:

Арбитражный процесс.
1. Строение и полномочия арбитражных органов.
11. Высший Арбитражный Суд (строение и полномочия).
12. Федеральные окружные арбитражные суды (строение и полномочия).
13. Арбитражные суды субъектов РФ (строение и полномочия).
2. Процедура арбитражного производства.
21. Атрибуты арбитражного производства (сроки, формы документов, расходы)
22. Последовательность арбитражного производства.
3. Прецеденты арбитражной практики.
А. Уровень и суть судебного решения.
А1. Решение суда первой инстанции.
А9. Обжалование и его результаты.
Б. Объект спора.
Б1. Имущество.
Б9. Иные объекты спора.
В. Вид оспариваемого правоотношения.
В1. Собственность, владение, пользование.
В9. Иные правоотношения.
Г. Субъект спора.
Г1. Государственный орган.
Г2. Негосударственная организация.
Г3. Гражданин.

Это уже можно рассматривать как рабочий вариант кодификатора, хотя в зависимости от сферы особых интересов пользователя отдельные рубрики его можно либо свернуть, либо, наоборот, детализировать.

Проведем еще один этап детализации кодификатора (см. Табл.П2-4).

Таблица П2-4.

Рубрика
Основание деления
1. Строение и полномочия арбитражных органов.
11. Высший Арбитражный Суд.
111. Строение Высшего Арбитражного Суда.
112. Функции Высшего Арбитражного Суда.
основные атрибуты системы
12. Федеральные окружные арбитражные суды.
121. Строение федерального окружного арбитражного суда.
122. Функции федерального окружного арбитражного суда.
основные атрибуты системы
13. Арбитражные суды субъектов РФ.
131. Строение арбитражного суда субъекта РФ.
132. Функции арбитражного суда субъекта РФ.
основные атрибуты системы

2. Процедура арбитражного производства.

21. Атрибуты арбитражного производства.
211. Процессуальные сроки. Сроки исковой давности.
212. Формы документов арбитражного производства.
213. Финансовые аспекты арбитражного производства
виды атрибутов арбитражного производства
22. Последовательность арбитражного производства.
221. Досудебные процедуры.
222. Производство в арбитражном суде первой инстанции.
223. Обжалование решения арбитражного суда.
224. Исполнение судебных решений.
этапы арбитражного процесса
3. Прецеденты арбитражной практики.
А. Уровень и суть судебного решения.
А1. Решение суда первой инстанции.
А2. Постановление апелляционной инстанции.
А3. Постановление кассационной инстанции.
А4. Решение по протесту надзорных органов.
А5. Пересмотр по вновь открывшимся обстоятельствам.
уровень судебного решения
Б. Объект спора.
Б1. Имущество.
Б2. Договорные отношения.
Б3. Действия властных структур.
Б9. Иные объекты спора.
виды объектов спора
В. Вид оспариваемого правоотношения.
В1. Собственность.
В2. Владение и пользование.
В3. Право на перемещение объекта спора.
В9. Право на иные действия.
разновидности экономически значимых правоотношений
Г. Субъект спора.
Г1. Государственный орган.
Г2. Некоммерческая организация.
статус субъекта спора
Г3. Коммерческая организация.
Г31. Производственное предприятие.
Г32. Торговое предприятие.
Г33. Транспортное предприятие.
Г34. Предприятие сферы обслуживания (быт, отдых).
сферы коммерческой деятельности предприятия
Г4. Гражданин.
Г41 Предприниматель без образования юридического лица.
Г42 Гражданин, не занимающийся коммерцией.
отношение гражданина к коммерческой деятельности

Далеко не всегда удается сразу сформулировать точное и однозначное понятие основания деления для конкретной рубрики, но результатом этого действия (если оно удалось) является прозрачность и общепонятность (независимо от уровня подготовки пользователя) классификации, т.е. в конечном счете удобство и безошибочность работы как при заполнении классификации новыми документами, так и при поиске документов в расклассифицированном массиве.

В последнем рубрикаторе к разным рубрикам было проявлено разное внимание, это сделано в соответствии с авторским пониманием сравнительной необходимости детализации рубрик для конечного пользователя. Поэтому не стоит принимать этот вариант рубрикатора как абсолютный и придираться к тому или иному решению. Просто можно принять этот вариант как один из возможных. “В чистом виде” он выглядит так:

Арбитражный процесс
1 Строение и полномочия арбитражных органов.
11. Высший Арбитражный Суд.
111. Строение Высшего Арбитражного Суда.
112. Функции Высшего Арбитражного Суда.
12. Федеральные окружные арбитражные суды.
121. Строение федерального окружного арбитражного суда.
122. Функции федерального окружного арбитражного суда.
13. Арбитражные суды субъектов РФ.
131. Строение арбитражного суда субъекта РФ.
132. Функции арбитражного суда субъекта РФ.
2. Процедура арбитражного производства.
21. Атрибуты арбитражного производства.
211. Процессуальные сроки. Сроки исковой давности.
212. Формы документов арбитражного производства.
213. Финансовые аспекты арбитражного производства.
22. Последовательность арбитражного производства.
221. Досудебные процедуры.
222. Производство в арбитражном суде первой инстанции.
223. Обжалование решения арбитражного суда.
224. Исполнение судебных решений.
3. Прецеденты арбитражной практики.
А. Уровень и суть судебного решения.
А1. Решение суда первой инстанции.
А2. Постановление апелляционной инстанции.
А3. Постановление кассационной инстанции.
А4. Решение по протесту надзорных органов.
А5. Пересмотр по вновь открывшимся обстоятельствам.
Б. Объект спора.
Б1. Имущество.
Б2. Договорные отношения.
Б3. Действия властных структур.
Б9. Иные объекты спора.
В. Вид оспариваемого правоотношения.
В1. Собственность
В2. Владение и пользование.
В3. Право на перемещение объекта спора.
В9. Право на иные действия.
Г. Субъект спора.
Г1. Государственный орган.
Г2. Некоммерческая организация.
Г3. Коммерческая организация.
Г31. Производственное предприятие.
Г32. Торговое предприятие.
Г33. Транспортное предприятие.
Г34. Предприятие сферы обслуживания (быт, отдых).
Г4. Гражданин.
Г41. Предприниматель без образования юридического лица.
Г42. Гражданин, не занимающийся коммерцией.

Наконец, сделаем еще один шаг детализации этого рубрикатора (см. Табл.П2-5).

Таблица П2-5

Рубрика | Основание деления
1. Строение и полномочия арбитражных органов. | Уровень арбитражного органа
11. Высший Арбитражный Суд. | Основные системные атрибуты
111 Строение Высшего Арбитражного Суда. | Органы Высшего Арбитражного Суда.
1111. Пленум Высшего Арбитражного Суда (состав, порядок образования и полномочия). |
1112. Президиум Высшего Арбитражного Суда (состав, порядок образования и полномочия). |
1113. Председатель Высшего Арбитражного Суда. Заместители председателя. |
1114. Судебные коллегии. | Специализация коллегий
11141. Судебные коллегии по рассмотрению споров, возникающих из гражданских и иных правоотношений. |
11142. Судебные коллегии по рассмотрению споров, возникающих из административных правоотношений. |
1115. Судебные составы. |
1116. Совет председателей арбитражных судов. |
1117. Научно-консультативный совет при Высшем Арбитражном Суде. |
112. Функции Высшего Арбитражного Суда. | Сферы деятельности В.А.С.
1121. Полномочия Высшего Арбитражного Суда как суда первой инстанции. |
1122. Надзорные функции Высшего Арбитражного Суда. |
1123. Регламентные функции Высшего Арбитражного Суда. |
1124. Деятельность Высшего Арбитражного Суда в области законодательной инициативы и охраны Конституции Российской Федерации. |
1129. Прочие функции Высшего Арбитражного Суда. |
12. Федеральные окружные арбитражные суды. | Основные системные атрибуты
121. Строение федерального окружного арбитражного суда. | Органы Федерального Окружного Арбитражного Суда.
1211. Президиум федерального арбитражного суда округа. |
1212. Председатель федерального арбитражного суда округа. Заместители председателя. |
1213. Судебные коллегии. | Специализация коллегий
12131. Судебные коллегии по рассмотрению споров, возникающих из гражданских и иных правоотношений. |
12132. Судебные коллегии по рассмотрению споров, возникающих из административных правоотношений. |
1214. Судебные составы. |
122. Функции федерального окружного арбитражного суда. | Сферы деятельности федерального окружного арбитражного суда
1221. Кассационные функции федерального окружного арбитражного суда. |
1229. Прочие функции федерального окружного арбитражного суда. |
13. Арбитражные суды субъектов РФ (порядок образования и полномочия). | Основные системные атрибуты
131. Строение арбитражного суда субъекта РФ. | Органы арбитражного суда субъекта РФ
1311. Президиум арбитражного суда (состав, порядок образования и полномочия). Председатель арбитражного суда. Заместители председателя. |
1312. Судебные коллегии. | Специализация коллегий
13121. Судебные коллегии по рассмотрению споров, возникающих из гражданских и иных правоотношений. |
13122. Судебные коллегии по рассмотрению споров, возникающих из административных правоотношений. |
1313. Состав и полномочия членов, осуществляющих судебный процесс. | Исполнители арбитражной процедуры
13131. Судья. Судебный состав. |
13132. Аппарат суда. |
13133. Прокурор. |
13134. Эксперт. |
13135. Судебный исполнитель. |
1314. Участники арбитражного процесса и их права. | Участники спора
13141. Истец. |
13142. Ответчик. |
13143. Третьи лица. |
13144. Свидетель. |
13145. Представительство в арбитражном суде. |
13146. Иностранные участники арбитражного процесса. |
132. Функции арбитражного суда субъекта РФ. | Функции арбитражного суда субъекта РФ
1321. Функции арбитражного суда субъекта РФ как суда первой инстанции. Подведомственность и подсудность. |
1322. Апелляционные функции арбитражного суда субъекта РФ. |
1329. Прочие функции арбитражного суда субъекта РФ. |
2. Процедура арбитражного производства. |
21. Атрибуты арбитражного производства. | Виды атрибутов арбитражного производства
211 Процессуальные сроки. Сроки исковой давности. | Временные атрибуты
2111. Правила исчисления процессуальных сроков. |
2112. Регламент назначения процессуальных сроков. |
2113. Сроки исковой давности. |
212. Формы документов арбитражного производства. |
213. Финансовые аспекты арбитражного производства. | Виды финансовых потоков
2131. Судебные пошлины. |
2132. Судебные штрафы. |
2133. Текущие расходы арбитражного процесса (оплата экспертизы, и т.д.). |
22. Последовательность арбитражного производства. | Этапы арбитражного процесса
221. Досудебные процедуры. | Досудебные этапы
2211. Претензионное рассмотрение спора. |
2212. Предъявление иска. |
2213. Подготовка дела к судебному разбирательству. |
222. Производство в арбитражном суде первой инстанции. | Атрибуты арбитражного судопроизводства
2221. Порядок заседания суда. |
2222. Доказательства. |
2223. Обеспечение иска. |
2224. Изменение хода производства. | Варианты изменения хода рассмотрения спора
22241. Приостановление производства. |
22242. Прекращение производства. | Варианты прекращения рассмотрения спора
222421. Мировое соглашение. |
222429. Прекращение производства по иным основаниям. |
22243. Оставление иска без рассмотрения. |
2225. Решение арбитражного суда. Определение арбитражного суда. |
223. Обжалование решения арбитражного суда. | Этапы обжалования решения
2231. Апелляционный процесс. |
2232. Кассационный процесс. |
2233. Производство в порядке надзора. |
2234. Пересмотр судебных актов по вновь открывшимся обстоятельствам. |
224. Исполнение судебных решений. | Атрибуты процедуры исполнения решения по спору
2241. Исполнительный лист (порядок выдачи и предъявления). |
2242. Отсрочка, рассрочка, изменение способа или порядка исполнения судебного акта. |
2243. Поворот исполнения судебного акта. |
3. Прецеденты арбитражной практики. |
А. Уровень и суть судебного решения. | Уровень решения
А1. Решение суда первой инстанции. | Суть решения
А11. Удовлетворение иска. |
А12. Отказ в иске. |
А19. Иные варианты решения. |
А2. Постановление апелляционной инстанции. | Суть решения
А21. Подтверждение решения суда первой инстанции. |
А22. Отмена решения суда первой инстанции (полностью или частично). |
А23. Изменение решения. |
А29. Иные варианты решения. |
А3. Постановление кассационной инстанции. | Суть решения
А31. Подтверждение обжалуемого решения или постановления. |
А32. Отмена решения или постановления (полное или частичное). |
А321. Возврат на повторное рассмотрение. |
А39. Иные варианты решения. |
А4. Решение по протесту надзорных органов. | Суть решения
А41. Оставление опротестовываемого решения без изменений. |
А42. Отмена или изменение решения или постановления арбитражного суда. |
А421. Возврат на повторное рассмотрение. |
А49. Иные варианты решения по протесту. |
А5. Пересмотр по вновь открывшимся обстоятельствам. | Суть решения
Б. Объект спора. |
Б1. Имущество. | Виды имущества
Б11. Недвижимое имущество. | Виды недвижимости
Б111. Жилое строение. |
Б112. Производственное строение. |
Б113. Земля. |
Б114. Недра. |
Б119. Иное недвижимое имущество. |
Б12. Движимое имущество. | Виды движимого имущ.
Б121. Транспортное средство. |
Б122. Предметы быта. |
Б123. Производственное оборудование. |
Б124. Расходные материалы, комплектующие изделия. |
Б129. Другое движимое имущество. |
Б13. Финансовые ценности. | Виды финансовых ценностей
Б131. Деньги (рубли). |
Б132. Валютные ценности. |
Б133. Ценные бумаги. |
Б139. Иные ценности. |
Б2. Договорные отношения. | Виды оспариваемых действий по договору.
Б21. Разногласия по договору. |
Б22. Изменение условий или расторжение договора. |
Б23. Неисполнение или ненадлежащее исполнение обязательств. |
Б3. Действия властных структур. | Виды властных структур
Б31. Действия законодательных органов. |
Б32. Действия административных органов. |
Б39. Действия иных властных структур. |
Б9. Иные объекты спора. |
В. Вид оспариваемого правоотношения. | Виды правоотношений
В1. Собственность | Динамика права собственности
В11. Право собственности. |
В12. Переход права собственности. |
В2. Владение и пользование. | Варианты владения и пользования
В21. Аренда. |
В22. Лизинг. |
В29. Другие варианты владения и пользования. |
В3. Право на перемещение объекта спора. |
В4. Неимущественное право | Виды неимущественных прав
В41. Право на информацию |
В42. Деловая репутация |
В43. Право на имя, товарный знак и т.п. |
В49. Иные неимущественные права |
В9. Иные правоотношения. |
Г. Субъект спора. | Статус субъекта
Г1. Государственный орган. | Виды государственных органов
Г11. Законодательный орган. |
Г12. Административныйй орган. |
Г13. Силовой орган. |
Г14. Финансовый орган. |
Г19. Иные органы власти. |
Г2. Некоммерческая организация. | Виды некоммерческих организаций
Г21. Фонд. |
Г22. Ассоциация. |
Г23. Образовательная структура. |
Г24. Культурно-просветительная организация. |
Г25. Религиозная структура. |
Г26. Общественная организация. |
Г29. Иные некоммерческие организации. |
Г3. Коммерческая организация. | Виды коммерческих предприятий
Г31. Производственное предприятие. | Сферы производства
Г311. Промышленное предприятие. |
Г312. Сельскохозяйственное предприятие. |
Г313. Предприятие добывающей промышленности. |
Г319. Производственное предприятие иного типа. |
Г32. Торговое предприятие. |
Г33. Транспортное предприятие. |
Г34. Предприятие сферы обслуживания. | Виды обслуживания
Г341. Предприятие бытового обслуживаиия. |
Г342. Предприятие развлечения, отдыха. | Виды услуг для отдыха
Г3421. Предприятие туризма. |
Г3422. Предприятие игорного бизнеса. |
Г3429. Иные предприятия развлечения и отдыха. |
Г4. Гражданин. | Статус гражданина
Г41. Предприниматель без образования юридического лица. |
Г42. Гражданин, не занимающийся коммерцией. |

В этой таблице информация организована несколько иначе, а именно: в правом столбце основания деления расположены в ячейке, соответствующей делимому понятию. Кроме того, не во всех случаях формулировка основания деления является удачной даже по мнению авторов. Наконец, следует иметь в виду, что полное наименование рубрик существенно длиннее и по сути отличается от того, что показано в таблице (например, рубрика 223 Обжалование решения арбитражного суда в действительности должна восприниматься как 223 Нормативные правовые акты, регламентирующие процедуру обжалования арбитражного решения, или: элемент рубрики Г2 Некоммерческая организация (точнее, это только часть кода рубрики) в действительности означает Г2 Прецедент, в котором одним из участников спора является некоммерческая организация). Поэтому тавтология в таблице между делимым понятием и основанием деления в действительности является мнимой; ну а поскольку представленная таблица служит всего лишь промежуточным, рабочим этапом формирования рубрикатора, то эту литературную неприятность можно пережить.

Итак, последний вариант рубрикатора “Арбитражный процесс” выглядит следующим образом:

Арбитражный процесс
1 Строение и полномочия арбитражных органов.
11 Высший Арбитражный Суд.
111 Строение Высшего Арбитражного Суда.
1111 Пленум Высшего Арбитражного Суда (состав, порядок образования и полномочия).
1112 Президиум Высшего Арбитражного Суда (состав, порядок образования и полномочия).
1113 Председатель Высшего Арбитражного Суда. Заместители председателя.
1114 Судебные коллегии (порядок образования и полномочия).
11141 Судебные коллегии по рассмотрению споров, возникающих из гражданских и иных правоотношений.
11142 Судебные коллегии по рассмотрению споров, возникающих из административных правоотношений.
1115 Судебные составы.
1116 Совет председателей арбитражных судов.
1117 Научно-консультативный совет при Высшем Арбитражном Суде.
112 Функции Высшего Арбитражного Суда.
1121 Полномочия Высшего Арбитражного Суда как суда первой инстанции.
1122 Надзорные функции Высшего Арбитражного Суда.
1123 Регламентные функции Высшего Арб. Суда.
1124 Деятельность Высшего Арб. Суда в области законодательной инициативы и охраны Конституции РФ.
1129 Прочие функции Высшего Арбитражного Суда.
12 Федеральные окружные арбитражные суды.
121 Строение федерального окружного арб. суда.
1211 Президиум федерального арб. суда округа.
1212 Председатель федерального арбитражного суда округа. Заместители председателя.
1213 Судебные коллегии (порядок образования и полномочия).
12131 Судебные коллегии по рассмотрению споров, возникающих из гражданских и иных правоотношений.
12132 Судебные коллегии по рассмотрению споров, возникающих из административных правоотношений.
1214 Судебные составы.
122 Функции федерального окружного арб. суда.
1221 Кассационные функции федерального окружного арбитражного суда.
1229 Прочие функции федерального окружного арбитражного суда.
13 Арбитражные суды субъектов РФ (порядок образования и полномочия).
131 Строение арбитражного суда субъекта РФ.
1311 Президиум арбитражного суда (состав, порядок образования и полномочия). Председатель арбитражного суда. Заместители председателя.
1312 Судебные коллегии (порядок образования и полномочия).
13121 Судебные коллегии по рассмотрению споров, возникающих из гражданских и иных правоотношений.
13122 Судебные коллегии по рассмотрению споров, возникающих из административных правоотношений.
1313 Состав и полномочия членов, осуществляющих судебный процесс.
13131 Судья. Судебный состав.
13132 Аппарат суда.
13133 Прокурор.
13134 Эксперт.
13135 Судебный исполнитель.
1314 Участники арбитражного процесса и их права.
13141 Истец.
13142 Ответчик.
13143 Третьи лица.
13144 Свидетель.
13145 Представительство в арбитражном суде.
13146 Иностранные участники арбитражного процесса.
132 Функции арбитражного суда субъекта РФ.
1321 Функции арбитражного суда субъекта РФ как суда первой инстанции. Подведомственность и подсудность.
1322 Апелляционные функции арб. суда субъекта РФ.
1329 Прочие функции арбитражного суда субъекта РФ.
2 Процедура арбитражного производства.
21 Атрибуты арбитражного производства.
211 Процессуальные сроки. Сроки исковой давности.
2111 Правила исчисления процессуальных сроков.
2112 Регламент назначения процессуальных сроков.
2113. Сроки исковой давности.
212 Формы документов арбитражного производства.
213 Финансовые аспекты арбитражного производства.
2131 Судебные пошлины.
2132 Судебные штрафы.
2133 Текущие расходы арбитражного процесса (оплата экспертизы, и т.д.).
22 Последовательность арбитражного производства.
221 Досудебные процедуры.
2211 Претензионное рассмотрение спора.
2212 Предъявление иска.
2213 Подготовка дела к судебному разбирательству.
222 Производство в арбитражном суде первой инстанции.
2221 Порядок заседания суда.
2222 Доказательства.
2223 Обеспечение иска.
2224 Изменение хода производства.
22241 Приостановление производства.
22242 Прекращение производства.
222421 Мировое соглашение.
222429 Прекращение производства по иным основаниям.
22243 Оставление иска без рассмотрения.
2225 Решение арбитражного суда. Определение арбитражного суда.
223 Обжалование решения арбитражного суда.
2231 Апелляционный процесс.
2232 Кассационный процесс.
2233 Производство в порядке надзора.
2234 Пересмотр судебных актов по вновь открывшимся обстоятельствам.
224 Исполнение судебных решений.
2241 Исполнит. лист (порядок выдачи и предъявления).
2242 Отсрочка, рассрочка, изменение способа или порядка исполнения судебного акта.
2243 Поворот исполнения судебного акта.

3 Прецеденты арбитражной практики.
А Уровень и суть судебного решения.
А1 Решение суда первой инстанции.
А11 Удовлетворение иска.
А12 Отказ в иске.
А19 Иные варианты решения.
А2 Постановление апелляционной инстанции.
А21 Подтверждение решения суда первой инстанции.
А22 Отмена решения суда первой инстанции (полностью или частично).
А23 Изменение решения.
А29 Иные варианты решения.
А3 Постановление кассационной инстанции.
А31 Подтверждение обжалуемого решения или постановления.
А32 Отмена решения или постановления (полное или частичное).
А321 Возврат на повторное рассмотрение.
А39 Иные варианты решения.
А4 Решение по протесту надзорных органов.
А41 Оставление опротестовываемого решения без изменений.
А42 Отмена или изменение решения или постановления арбитражного суда.
А421 Возврат на повторное рассмотрение.
А49 Иные варианты решения по протесту.
А5 Пересмотр по вновь открывшимся обстоятельствам.
Б Объект спора.
Б1 Имущество.
Б11 Недвижимое имущество.
Б111 Жилое строение.
Б112 Производственное строение.
Б113 Земля.
Б114 Недра.
Б119 Иное недвижимое имущество.
Б12 Движимое имущество.
Б121 Транспортное средство.
Б122 Предметы быта.
Б123 Производственное оборудование.
Б124 Расходные материалы, комплектующие изделия.
Б129 Другое движимое имущество.
Б13 Финансовые ценности.
Б131 Деньги (рубли).
Б132 Валютные ценности.
Б133 Ценные бумаги.
Б139 Иные ценности.
Б2 Договорные отношения.
Б21 Разногласия по договору.
Б22 Изменение условий или расторжение договора.
Б23 Неисполнение или ненадлежащее исполнение обязательств.
Б3 Действия властных структур.
Б31 Действия законодательных органов.
Б32 Действия административных органов.
Б39 Действия иных властных структур.
Б9 Иные объекты спора.
В Вид оспариваемого правоотношения.
В1 Собственность
В11 Право собственности.
В12 Передача права собственности.
В2 Владение и пользование.
В21 Аренда.
В22 Лизинг.
В29 Другие варианты владения и пользования.
В3 Право на перемещение объекта спора.
В4 Неимущественное право
В41 Право на информацию
В42 Деловая репутация
В43 Право на имя, товарный знак, и т.п.
В49 Иные неимущественные права
В9 Иные правоотношения.
Г Субъект спора.
Г1 Государственный орган.
Г11 Законодательный орган.
Г12 Административный орган.
Г13 Силовой орган.
Г14 Финансовый орган.
Г19 Иные органы власти.
Г2 Некоммерческая организация.
Г21 Фонд.
Г22 Ассоциация.
Г23 Образовательная структура.
Г24 Культурно-просветительная организация.
Г25 Религиозная структура.
Г26 Общественная организация.
Г29 Иные некоммерческие организации.
Г3 Коммерческая организация.
Г31 Производственное предприятие.
Г311 Промышленное предприятие.
Г312 Сельскохозяйственное предприятие.
Г313 Предприятие добывающей промышленности.
Г319 Производственное предприятие иного типа.
Г32 Торговое предприятие.
Г33 Транспортное предприятие.
Г34 Предприятие сферы обслуживания.
Г341 Предприятие бытового обслуживаиия.
Г342 Предприятие развлечения, отдыха.
Г3421 Предприятие туризма.
Г3422 Предприятие игорного бизнеса.
Г3429 Иные предприятия развлечения и отдыха.
Г4 Гражданин.
Г41 Предприниматель без образования юридического лица.
Г42 Гражданин, не занимающийся коммерцией.

Разумеется, столь подробный классификатор в полном своем воплощении (а в действительности он еще больше, т.к. мы не включили в него многочисленные ячейки “Прочие” и “Не уточняется”) скорее всего не найдет потребителя. Это и не является целью данного примера. Но любой корпоративный потребитель сможет на базе этого классификатора сформировать свой, соответствующий именно его сфере деятельности и интересам. Можно нарастить его рубриками о международном арбитражном процессе, можно урезать рубрики структуры арбитража или иные не интересные данному пользователю рубрики. Но если вся документация в базе-источнике информации закодирована по полномасштабному классификатору, то перенос этой информации в собственную более компактную классификацию реализуется чрезвычайно просто.

В заключение этого приложения приведем несколько примеров кодирования информации. Подчеркиванием в текстах выделены участки, формирующие код документа.

1. Закон РФ "О защите прав потребителей" (в ред. Федерального закона от 9 января 1996 г. N 2-ФЗ) (извлечения)
Статья 43. ...
1. Федеральный антимонопольный орган (его территориальные органы) вправе налагать штраф на изготовителя (исполнителя, продавца) за уклонение от исполнения или за несвоевременное исполнение его законных предписаний о прекращении нарушений прав потребителей в размере до пяти тысяч минимальных размеров оплаты труда, установленных федеральным законом...
3. ... Штрафы, предусмотренные пунктом 1 и абзацами вторым и третьим пункта 2 настоящей статьи, наложенные на индивидуальных предпринимателей, уплачиваются ими в тридцатидневный срок со дня получения соответствующих решений о наложении штрафов. При уклонении индивидуальных предпринимателей от уплаты штрафов в установленный срок или при неуплате штрафа в полном размере органы, указанные в пунктах 1 и 2 настоящей статьи, вправе обратиться в арбитражный суд с заявлениями о взыскании с индивидуальных предпринимателей соответствующих сумм штрафов, а также пени в размере одного процента налагаемой суммы штрафа или его неуплаченной части за каждый день просрочки.
Штрафы, предусмотренные абзацами четвертым и пятым пункта 2 настоящей статьи и налагаемые на индивидуальных предпринимателей, взыскиваются в соответствии с административным законодательством.

Данный фрагмент кодируется рубрикой 11321, этот код означает, что данная норма права несет информацию о функциях арбитражного суда субъекта РФ, поведомственности и подсудности спорного правоотношения. Весь документ кроме этого кода будет иметь (через знак +) еще и другие коды в соответствии с содержанием других статей.

2.Письмо Госарбитража СССР от 4 сентября 1990 г. N С-13/ОП-107
"О предъявлении и рассмотрении претензий и исков в иностранной валюте"
В целях обеспечения единства практики применения законодательства при предъявлении и рассмотрении претензий и исков в иностранной валюте Государственный арбитраж СССР считает необходимым сообщить следующее.
1. При предъявлении предприятием, учреждением, организацией претензии и иска в иностранной валюте сумма претензии и цена иска определяются в той валюте, в которой производились или должны были быть произведены расчеты между сторонами.
2. В исковом заявлении, подаваемой в государственный арбитраж, указывается цена иска в иностранной валюте и рублевый эквивалент по официальному курсу Госбанка СССР, действующему на день предъявления иска.
В этом случае подведомственность спора определяется исходя из цены иска в рублевом эквиваленте.
3. Государственная пошлина по делам, рассматриваемым государственным арбитражем, уплачивается в советских рублях исходя из цены иска в рублевом эквиваленте на общих основаниях.
4. В решениях государственного арбитража об удовлетворении предъявленных в иностранной валюте исков и в выданных согласно этим решениям приказах арбитража предусматривается взыскание соответствующей суммы в иностранной валюте и государственной пошлины в советских рублях. Приказы на взыскание сумм в иностранной валюте и государственной пошлины в советских рублях выдаются отдельно.

Данный документ имеет код 11321+2131+2241, что свидетельствует о том, что в данном нормативном документе изложена информация о функциях арбитражного суда субъекта РФ, подведомственности и подсудности, судебных пошлинах и исполнительном документе.

3. Постановление Президиума Высшего Арбитражного Суда РФ от 11 марта 1997 г. N 5136/96
Президиум Высшего Арбитражного Суда Российской Федерации рассмотрел протест заместителя Генерального прокурора Российской Федерации на решение Арбитражного суда Волгоградской области от 31.07.95 по делу N 210/6.
Заслушав и обсудив доклад судьи и заключение заместителя Генерального прокурора Российской Федерации, поддержавшего протест, Президиум установил следующее.
Акционерное общество открытого типа "Каустик" обратилось в Арбитражный суд Волгоградской области с иском о взыскании с индивидуального предприятия "Сиинт" 1 230 000 рублей стоимости невыполненных работ.
Решением от 31.07.95 иск удовлетворен в полной сумме.
В апелляционном и кассационном порядке законность и обоснованность решения не проверялись.
В протесте заместителя Генерального прокурора Российской Федерации предлагается состоявшееся решение отменить и направить дело на новое рассмотрение.
Президиум считает, что протест подлежит удовлетворению по следующим основаниям.
В соответствии со статьей 8 Гражданского кодекса Российской Федерации гражданские права и обязанности возникают из договоров и иных сделок, предусмотренных законом.
Договором признается соглашение двух или нескольких лиц об установлении, изменении или прекращении гражданских прав и обязанностей (статья 420 Гражданского кодекса Российской Федерации).
Принимая решение об удовлетворении исковых требований, суд сослался на письмо от 15.02.95 N 06, тем самым признав его за договор, состоявшийся между АООТ "Каустик" и ИП "Сиинт".
Однако из содержания копии этого документа, приобщенной к материалам дела, невозможно установить юридическое лицо, направившее оферту ответчику, полномочия должностного лица, подписавшего письмо на заключение сделок от имени юридического лица. В письме не указана стоимость работ за исполнение заказа. В материалах дела отсутствуют доказательства принятия предложения заключить договор на указанных в письме условиях.
При таких обстоятельствах вывод суда о состоявшемся между сторонами договоре от 15.02.95 и нарушении ответчиком принятых по нему обязательств является неправомерным.
В платежных поручениях N 894, 898, 920, представленных истцом в качестве доказательства предоплаты за выполнение работ, назначением платежа указана оплата по договорам от 02.01.94 и от 02.01.95 б/н. Сведений об оплате работ, перечисленных в письме от 15.02.95, в названных документах не содержится. Данное обстоятельство судом не исследовано.
Кроме того, при рассмотрении дела судом допущены нарушения норм процессуального права, в частности, к производству принято исковое заявление, подписанное заместителем руководителя предприятия без подтверждения его полномочий, что противоречит статье 102 Арбитражного процессуального кодекса Российской Федерации.
Не были истребованы документы, подтверждающие наличие у сторон статуса юридического лица и возможность их участия в арбитражном процессе.
В качестве представителя ответчика к участию в деле допущена вдова учредителя индивидуального предприятия Зинченко А.В. - Зинченко Ю.С. без надлежащего подтверждения ее полномочий, что противоречит статье 50 Арбитражного процессуального кодекса Российской Федерации.
В нарушение статьи 123 Арбитражного процессуального кодекса Российской Федерации в деле отсутствует протокол судебного заседания, что является безусловным основанием для отмены решения.
Таким образом, судом при рассмотрении спора не исследованы фактические обстоятельства дела и нарушены нормы процессуального права.
Учитывая изложенное и руководствуясь статьями 187 - 189 Арбитражного процессуального кодекса Российской Федерации, Президиум Высшего Арбитражного Суда Российской Федерации постановил:
решение Арбитражного суда Волгоградской области от 31.07.95 по делу N 210/6 отменить.
Дело направить на новое рассмотрение в тот же арбитражный суд.

И.о. Председателя Высшего Арбитражного Суда Российской Федерации М.К.Юков

Код этого документа 113145+3А41Б13В12Г3 несет информацию, что в документе излагается прецедент, где в результате удовлетворения протеста надзорного органа возвращен для повторного рассмотрения иск о взыскании денег, причем и истец, и ответчик являются коммерческими организациями; в документе также имеется информация о представительстве в арбитражном суде.

4. Постановление Президиума Высшего Арбитражного Суда РФ от 16 января 1996 г. N 7749/95
Президиум Высшего Арбитражного Суда Российской Федерации в составе председательствующего и.о. Председателя Высшего Арбитражного Суда Российской Федерации М.К.Юкова, заместителей Председателя А.А.Арифулина, О.В.Бойкова, В.В.Витрянского, судей Н.Г.Вышняк, Н.П.Иванниковой, Ю.А.Киреева, О.А.Козловой, А.С.Козловой, С.Ф.Савкина, Г.И.Суховой, М.Ф.Юхнея, Г.Л.Танкилевича рассмотрел протест заместителя Председателя Высшего Арбитражного Суда Российской Федерации В.В.Витрянского на решение от 17.06.95 и постановление от 19.09.95 Арбитражного суда Свердловской области по делу N КЭ/418.
Заслушав и обсудив доклад судьи, Президиум установил следующее.
Акционерное общество "Тюменьлес" предъявило иск к Свердловскому кустовому информационно-вычислительному центру, акционерному обществу "Свердлеспром", производственному объединению "Свердловскагропроминформ" и акционерному обществу "Электроноргтехника" о взыскании 22 026 600 рублей - эквивалент перечисленных на счет ВВО "Электроноргтехника" платежным поручением от 28.08.91 N 21 5 400 долларов США для закупки по импорту запчастей к персональным компьютерам.
До вынесения решения по делу истец увеличил свои исковые требования до суммы 27 572 400 рублей в связи с изменением курса доллара.
Решением от 17.06.95 исковые требования удовлетворены полностью за счет АО "Электроноргтехника".
Постановлением апелляционной инстанции от 19.09.95 указанное решение оставлено без изменений.
В протесте заместителя Председателя Высшего Арбитражного Суда Российской Федерации предлагается состоявшиеся решение и постановление отменить и в иске АО "Тюменьлес" отказать, так как истцом пропущен срок исковой давности и доказательств наличия уважительных причин его пропуска истец не представил.
Президиум считает, что протест подлежит удовлетворению, решение и постановление арбитражного суда - отмене, а дело - передаче на новое рассмотрение по следующим основаниям.
В своих отзывах по делу и в заседании ответчики обращали внимание арбитражного суда на пропуск истцом срока исковой давности и истец в исковом заявлении ходатайствовал о его восстановлении. Однако арбитражный суд в нарушение статьи 43 Основ гражданского законодательства не применил исковую давность, не проверил соблюдение истцом срока давности и наличие уважительных причин для его восстановления.
АО "Тюменьлес" платежным поручением от 28.08.91 N 21 перечислило ВВО "Электроноргтехника" 5 400 долларов США для закупки по импорту запчастей к персональным компьютерам, и течение трехгодичного срока исковой давности на взыскание рублевого эквивалента этой суммы начинается не со дня ее перечисления, а с того момента, когда эти импортные запчасти должны были быть поставлены.
Истец перечислил деньги ВВО "Электроноргтехника" на основании заключенного со Свердловским кустовым информационно-вычислительным центром договора на техническое обслуживание персональных компьютеров и закупку запчастей для их ремонта от 16.07.91 и телеграммы этого центра от 09.08.91, но в договоре и телеграмме отсутствуют данные о том, когда должны были закупаться по импорту и поставляться указанные запчасти.
Поэтому для определения начального момента течения срока исковой давности необходимо истребовать у кустового информационно-вычислительного центра заключенный им с ВВО "Электроноргтехника" договор комиссии на закупку импортных запчастей, а от ВВО "Электроноргтехника" - контракт с инофирмой на поставку этих запчастей.
При новом рассмотрении дела следует иметь в виду, что ссылка в постановлении апелляционной инстанции на то, что в связи с замораживанием валютных средств предприятий во Внешэкономбанке СССР течение срока исковой давности было приостановлено, является необоснованной, так как приостановление использования валютных средств предприятий не распространялось на платежи по сделкам, заключенным ими до 31.12.91, а в платежном поручении истц

И.о. Председателя Высшего Арбитражного Суда Российской Федерации М.К.Юков

Код этого документа 2113+3А41Б131В12Г3 означает, что в документе излагается прецедент, где в результате удовлетворения протеста надзорного органа возвращен для повторного рассмотрения иск о взыскании денег, причем участниками спора являются коммерческие организации (если бы участники имели разный статус, то код Г пришлось бы повторить столько раз, сколько типов участников задействовано в прецеденте); в документе есть информация о сроках исковой давности.

Как видно из данных примеров, код документа может дать очень подробную информацию о его содержании. Подробность напрямую зависит от глубины классификатора.


Заказ классификации

КЛАССИФИКАЦИЯ
(системно-морфологический подход)

Заказ классификации

Пожалуйста, обратитесь к любому из авторов этой работы.


Заключение. Литература

КЛАССИФИКАЦИЯ
(системно-морфологический подход)

Заключение

Анализ множества классификаторов, существующих в обозримом информационном поле, позволяет сделать следующие выводы:

  1. Основные принципы классификации, изложенные в разделе 3 (единство основания деления, наличие ячейки “Прочие”, вложенность классификаторов), ни в одном из рассмотренных классификаторов в явном виде не декларированы.
  2. Принцип “от трех до семи” в неявной форме реализован в десятичных классификаторах, точнее, в той их части, где каждому разряду или этажу классификации отведено одно знакоместо в коде. Чаще всего этот принцип используется в наиболее “пожилом” классификаторе УДК.
  3. Во всех классификаторах разработчики предпочитают строить иерархическую структуру, смиряясь с фасетной только в уж совсем безвыходных положениях.
  4. Фасетные участки классификаторов организованы у разных разработчиков по разному. ВНИИКИ, например, просто преобразует фасетную часть (если она появляется) в иерархическую. В УДК введена система определителей, т.е. фактически независимых ветвей, довольно часто представляющих собой самостоятельные классификаторы солидного объема и значительной глубины. Разработчики системы ДИМОЛ [ 13 ] пошли по пути создания совершенно изолированных классификаторов вместо фасетного их объединения.
  5. Большинство классификаторов, утвержденных Госстандартом, имеют одно общее свойство: необозримое множество элементов на самом верхнем этаже деления. Как правило, верхний этаж кодируется двумя десятичными знаками, и не всегда этого набора хватает.
  6. Другое печальное общее свойство многих классификаторов связано с тем, что не соблюдено единство основания деления. В сочетании с чрезвычайно большим числом рубрик на конкретном этаже классификатора, бессистемным расположением объектов в перечне этих рубрик и необходимостью развития классификатора (т.е. добавления новых рубрик) это приводит иногда к таким несуразицам, как, например, размещение раздела Программное обеспечение между разделами Замочные и скобяные изделия и Бытовые приборы (классификатор ОКП).

Большинство классификаторов при их создании предназначалось для постоянной ручной работы с ними сравнительно узких специалистов, которые раньше или позже доводили до полного автоматизма нахождение тех немногих рубрик, с которыми они работали, вне зависимости от того, какие у этих рубрик “соседи по этажу”. Это позволяло мириться с неудобствами типа слишком большого количества рубрик на этаже, огрехами в выборе оснований деления (и соблюдения правила единственности основания) и бессистемностью в расположении рубрик.

Однако к настоящему времени ситуация существенно изменилась. Объем классифицируемой информации во многих случаях стал настолько велик, что ручная классификация становится очень дорогостоящей, т.к. требует большого количества занятых ею специалистов высокой квалификации, а цена ошибки в рыночных условиях стала реальным и очень важным фактором. С другой стороны, развитие информационных технологий достигло такого уровня, что рутинную работу по классификации можно было бы поручить машине. Но для этого существующие классификаторы практически непригодны, прежде всего из-за невозможности сформулировать запрос, отличающий например, объект, относящийся к классу упомянутого выше Программного обеспечения, от каждого из 93 остальных классов этого уровня (так как именно столько классов находится на верхнем этаже ОКП).

Таким образом, правило “от трех до семи” здесь приобретает совсем иное звучание: надо для каждого из членов деления данной группы сформировать уникальный перечень признаков, однозначно опознаваемых компьютером даже при условии, что объекты описываются обычным русским (или иным человеческим) языком с его синонимами, омонимами и эпитетами.

Алгоритмы распознавания текстов по смыслу уже существуют (на выставке Softool’87 демонстрировалась даже программа, автоматически составляющая реферат текстового файла), а задача различения объектов без подобного алгоритма нереализуема. Но без правила “от 3 до 7” она тем более нереализуема.

Поэтому на очереди стоит задача преобразования практически всех общероссийских классификаторов в тех областях, где текущее состояние дел требует надежной статистической обработки множества разнообразных данных. Как решать эту задачу и в какой последовательности модифицировать классификаторы, эти вопросы частично затрагивались в настоящей работе, но, конечно, они требуют более глубокой проработки, так как проблема по масштабу и ответственности сравнима с проблемой перехода Европы на единую валюту.

Другой аспект проблемы связан с узкой, но очень важной отраслью - правом. Проблема правовой реформы в России характризуется двумя ключевыми моментами: 1) приведение всего законодательства в самосогласованную непротиворечивую систему и 2) обеспечение свободного доступа граждан ко всей правовой информации. И то, и другое требует в первую очередь классификации всей уже имеющейся правовой информации, причем классификации однозначной и понятной не только юристам-жилищникам, например, но любому гражданину, не обремененному никаким юридическим образованием (в надежде, что в такой классификации разберется и юрист, специализирующийся по любой из многочисленных отраслей права). И здесь, безусловно, важным навигационным компасом может служить основание деления, в явной форме предложенное пользователю при каждом его шаге выбора среди 3-7 альтернатив. Поэтому в Приложениях к настоящей работе рассмотрена именно эта задача.

Литература.
1. А.А.Ивин. Искусство правильно мыслить. М., Просвещение, 1986.
2. В.Н.Садовский. Методологические проблемы исследования объектов, представляющих собой системы. В кн. "Социология в СССР". М., Наука. 1965.
3. В.В.Титов. Системный подход. М., ВНИИПИ, 1990.
4. Универсальная десятичная классификация. 1986.
5. См. газету "Поиск" № , 1986, с. 6-7.
6. Международная патентная классификация. ВНИИПИ, 1995.
7. Общероссийский классификатор общероссийских классификаторов (ОКОК). Утвержден Постановлением Госстандарта РФ 30.12.1995.
8. Общероссийский классификатор продукции (ОК 005-93) Введен в действие Постановлением Госстандарта РФ №301 от 30.12.1993.
9. Международная классификация товаров и услуг.
10. Товарная номенклатура внешнеэкономической деятельности. Второе издание (официальное). М., ГТК РФ, 1992.
11. Общероссийский классификатор отраслей законодательства (ОКОЗ). Введен в действие Указом Президента
12. Общероссийский классификатор управленческой документации (ОК 011-93). Утвержден Постановлением Госстандарта РФ №299 от 30.12.1993.
13. Отчет РНЦ "Курчатовский институт" по программе ДИМОЛ, 1998.