Литература

Системно-морфологический подход
в технике, науке, социальной сфере.
Титов В.В.

Литература.

1. Bertalanffy L. von. An Outline of General System Theory.- The British J. for the Philosophy of Science. 1950, N2, p.134.
2. Zwicky F. Discovery, Invention, Research through the Morphological Approach. Toronto,1969.
3. Вайнерман М.И. и др. Комплексный метод поиска новых технических решений. Горький, 1980, части 1-4.
4. Голдовский Б.И., Вайнерман М.И. Рациональное творчество. М., “Речной транспорт” 1990.
5. Одрин В.М., Картавов С.С. Морфологический анализ систем. Киев, “Наукова Думка”, 1977.
6. Одрин В.М. Морфологический анализ систем: постановка задачи, классификация методов, морфологические методы “конструирования”. Препринт ИК АН УССР, 86-3,1986.
7. Одрин В.М. Морфологический синтез систем: морфологические методы поиска. Препринт ИК АН УССР, 86-5, 1986.
8. Koller R. Konstruktionsmethode fur den Maschinen-, Gerate- und Apparatenbau. Berichtiger Nachdruck. Berlin, Springer Verlag, 1979.
9. Зарипов М.Ф. и др. Элементы теории информационных моделей преобразователей с распределенными параметрами. Уфа, 1983.
10. Zwicky F. Morphological Astronomy. Springer Verlag, 1957.
11. Zwicky F. The Morphological Approach to Discovery, Invention, Research and Construction.- New Methods of Thought and Procedure. Pasadena, 1967, p. 273.
12. Лапатухин М.С. и др. Школьный толковый словарь русского языка. М., “Просвещение”, 1981.
13. Ивин А.А. Искусство правильно мыслить. М.,”Просвещение”, 1986
14. Садовский В.Н. Методологические проблемы исследования объектов, представляющих собой системы.- Социология в СССР, М., “Наука”, 1965, т.1, с.164.
15. Леках В.А., Баринов Э.Ф. Использование системного подхода при создании изобретений.- Вопросы изобретательства, 1986, №8, с.59.
16. Хубка В. Теория технических систем. М., “Мир”, 1987.
17. Моисеева Н.К. Функционально-стоимостной анализ в машиностроении. М., "Машиностроение",1987.


Оглавление

Системно-морфологический подход
в технике, науке, социальной сфере.
Титов В.В.

Оглавление

 | Аннотация
 | Введение
1. | Немного истории
 | 1.1. Метод отрицания и конструирования
 | 1.2. Метод систематического покрытия поля
 | 1.3. Метод морфологического ящика
 | 1.4. Морфологический подход в науке (история сверхпроводимости)
2. | Немного логики
 | 2.1. Определение
 | 2.2. Классификация
3. | Системный подход: основные положения
 | 3.1. Основные определения
 | 3.2. Системное представление объекта
4. | Системное исследование объекта
 | 4.1. Пример 1. Пылесос
 | 4.2. Пример 2. Распределение квартальной премии
 | 4.3. Пример 3. Закон "О подоходном налоге с физических лиц"
5. | Законы построения систем
 | 5.1. Закон функциональной полноты
 | 5.2. Закон проводимости
 | 5.2.1. Пример 1. Пылесос
 | 5.2.2. Пример 2. Издание бюллетеня
 | 5.3. Закон динамичности
 | 5.4. Закон параметрического порога
6. | Законы развития систем
 | 6.1. Закон повышения идеальности системы
 | 6.2. А что же дальше?
 | 7. Заключение
 | Литература

Введение


Немного истории

Системно-морфологический подход
в технике, науке, социальной сфере.
Титов В.В.

1. Немного истории

Хотя в учебниках утверждается, что основателем системного анализа как метода является Людвиг фон Берталанфи [1], более пристальное рассмотрение приводит к другому выводу. В 1969 году швейцарский астрофизик Ф. Цвикки опубликовал работу "Discovery, Invention, Research through the Morphological Approach" [2], где подводились итоги его многолетней работы над собственным методом, который он назвал морфологическим подходом (morphological approach) и который он успешно применял в изучении самых различных систем, получив при этом и открытия (в частности, открытие нейтронных звезд и "черных дыр"), и изобретения (в частности, серию изобретений в области ракетных двигателей), и впечатляющие результаты исследований в разных областях науки (от способов послевоенного восстановления научных библиотек до классификации многогранников и... юриспруденции в космическом пространстве).

Цвикки не употреблял словосочетаний "системный анализ" или "системный подход", однако, те семь методов исследования проблем, которые изложены и рекомендованы в [2], при ближайшем рассмотрении оказываются весьма похожи на то, что сейчас умно именуется системным подходом. У Цвикки все это выглядит даже более фундаментально, и вот как он сам в предисловии к [2] оценивает метод:

"Цель морфологического исследования - увидеть перспективу полного "поля знаний" о предмете. Это может быть поле материальных объектов, поле явлений или поле отношений, концепций, идей или теорий. Чтобы получить желаемую общую перспективу такого поля, морфолог ("morphologist" по Цвикки) должен иметь внутреннюю мотивацию к исследованию без предубеждений. Одни обладают такими способностями, другие - нет, и почему это так, до сих пор остается тайной природы. Сейчас мы просто должны принять за аксиому тот факт, что лишь немногим дана способность отказаться от всех основных предубеждений. Это люди, не порабощенные догматизмом, которых не поколеблют ни групповые интересы, ни расовый, религиозный или партийный фанатизм и которые в случае необходимости могут идти и идут в одиночку на любые проблемы жизни, именно они - врожденные морфологи".

Нельзя не проникнуться уважением к личности, которую Цвикки называет "морфологом от рождения", и нельзя не соблазниться поближе ознакомиться с тем арсеналом из семи методов, который присущ "морфологу от рождения", на предмет попробовать этим арсеналом воспользоваться. И надо сказать, что после этого ознакомления то, что именуют современные обществоведы системным подходом, представляется всего лишь обрывками действительно мощного, всеобъемлющего и разнообразного в своих проявлениях подхода, который мы будем называть системно-морфологическим подходом.

И системный подход обществоведов, и морфологический подход Цвикки в руках методологов изобретательства претерпели существенные изменения, причем в разных руках - разные изменения, вплоть до того, что в изобретательском искусстве на этой базе сформировалось несколько практически самостоятельных методов решения технических проблем: комплексный метод горьковской школы [3,4], метод морфологического анализа и синтеза Одрина [5-7], метод Коллера [8] и развивающий его метод Зарипова [9], и другие, часто безымянные методы. Богатство исходного арсенала Цвикки в совокупности с богатством приемов, заимствованных у других авторов, позволяет для конкретного класса задач сформировать, сконструировать метод, наиболее эффективный именно для этого класса задач. К сожалению, почти все авторы таких методов умалчивают об ограниченности возможностей своего метода и о специфичности задач, к которым он приложим; чаще всего наоборот, авторы без достаточных оснований декларируют универсальность своего метода, тем самым, кстати, подкладывая себе же мину замедленного действия, так как читатели, поверившие такому автору и попытавшиеся применить рекомендуемый метод совсем не там, где следовало бы, после неизбежной неудачи превращаются из сторонников в активных противников метода.

Все сказанное относится и к системно-морфологическому подходу в той форме, в которой он представлен в настоящей работе. Тем более что автор, будучи убежден в универсальности системно-морфологического подхода как такового, не менее убежден и в том, что для разных объектов, для систем разной природы реализуется он очень по-разному, причем иногда эти различия столь велики, что может показаться, что речь идет вообще о принципиально разных методах. Но в действительности базовые принципы системно-морфологического подхода остаются неизменными, а различие состоит в типе обрабатываемых объектов и лингвистическом оформлении процессов. И здесь мы вынуждены будем вторгнуться в область знаний, которую из общеобразовательной системы давным-давно выкинули, - в область логики.

Эта главка называется "Немного истории", и ради исторической справедливости автор считает необходимым привести в неизменном, исходном виде описание методов Цвикки. Правда, здесь мы ограничимся только тремя из семи методов Цвикки, поскольку именно они составляют целостное, непересекающееся множество приемов и процедур, применимых для самых разных задач и ситуаций. Остальные четыре метода в известной степени являются зависимыми от этой основной тройки.

1.1. Метод отрицания и конструирования.

В основу метода положен принцип: любое утверждение, сформулированное в конечных и полностью определенных терминах, не может быть абсолютно верным. Иными словами, любое правило, любой закон, любое условие можно и должно подвергать сомнению, поскольку они имеют ограниченную область действия. Названный принцип подтверждается всем ходом истории науки: даже основополагающие ее постулаты, в момент становления претендующие на абсолютную всеобщность, в конце концов переходят в ранг частного утверждения, справедливого в определенной области, уступая место очередному "всеобщему" закону.

Наиболее яркий пример проявления этого принципа - неэвклидовы геометрии. Две тысячи лет геометрия на плоскости зиждилась на пяти постулатах Эвклида. Но если первые четыре постулата действительно воспринимались как аксиомы, то пятый - постулат о параллельных прямых - вызывал у математиков всех времен чувство неудовлетворения, дискомфорта: уж очень он был похож на теорему, которую так и хотелось доказать. Пытались доказать многие, одним из них был ректор Казанского университета Н.И.Лобачевский. Он выбрал метод доказательства "от противного", т.е. предположил, что утверждение "Через точку, не лежащую на данной прямой, проходит не более чем одна прямая, лежащая с данной прямой в одной плоскости и не пересекающая ее" неверно и решил строить все следствия и выводы на основе нового комплекта постулатов - четыре старых и пятый - новый, измененный таким образом: вместо "не более чем одна прямая" он поставил "по крайней мере две прямые". Очевидно, что, если исходное утверждение неверно, то, строя на его основе новые и новые теоремы, следствия и выводы, можно на каком-то этапе прийти к бессмыслице, абсурду, что и должно свидетельствовать о неверности исходной предпосылки.

Работа началась. Лобачевский формулировал поочередно все теоремы, по аналогии с теоремами эвклидовой геометрии, но абсурда все не было и не было... На каком-то этапе он понял, что создал новую, внутренне непротиворечивую геометрию, и опубликовал свой труд. Это было и его трагедией, и его триумфом. Обыватели (в первую очередь обыватели от науки) до конца жизни считали его несколько "не в себе", и он не мог этого не видеть. А триумф наступил значительно позже, после того как была создана теория относительности (тоже, кстати, теория, полученная отрицанием одного из основных положений ньютоновской механики и заменой его на принципиально иной постулат) и выяснилось, что мы живем в мире, где плоскость - в действительности не плоскость, а поверхность с отрицательной кривизной.

Интересно, что отрицание пятого постулата Эвклида можно провести единственным образом, а вот конструирование нового постулата взамен отброшенного - двумя способами, и это соответствует двум принципиально различным неэвклидовым геометриям: 1) геометрия на сфере, где эквивалентом прямым линиям служат дуги большого диаметра и где через точку, расположенную на сфере вне такой окружности, нельзя провести ни одной "прямой", которая бы не пересекала данную, любая окружность большого диаметра пересечет данную, причем в двух точках; 2) геометрия на поверхности отрицательной кривизны (например, на седловидной поверхности), где эквивалентом прямых служат гиперболы и где через каждую точку вне заданной гиперболы можно провести сколько угодно гипербол, не пересекающих заданную.

Практически в любой другой науке солидного возраста можно найти такую страницу ее истории (а может быть, и не одну), когда происходила смена парадигм, т.е. комплекса аксиом, принципов, на которых она строится. Это нормальный ход познания, проявление диалектического закона отрицания отрицания.

Не менее впечатляющим примером реализации метода отрицания и конструирования является установка наших великих педагогов, работавших с беспризорниками послевоенных времен. Вместо того, чтобы искоренять в них отрицательные, плохие качества и наклонности, ставилась совершенно иная задача: убедить каждого из них, что в нем хорошего гораздо больше, чем плохого, и взрастить это хорошее. Результат вы могли увидеть, читая книги Макаренко. Кстати, ничуть не менее показательно этот метод показан в рассказе К. Паустовского "Кот-ворюга".

В творческой деятельности метод отрицания и конструирования очень плодотворен, причем наибольшей эвристической силой он обладает на стадии постановки задачи, целеполагания. Процедурно он сводится к трем последовательным этапам:

1. В исследуемом объекте (это может быть реальная природная, техническая или социальная система, но может быть и процедура, и любой другой объект любой природы и элементного состава, реальный или мыслимый) выявляют и перечисляют его признаки, характеристики, свойства или иные атрибуты, существенные для выполнения его главной полезной функции. В некоторых случаях достаточно назвать всего один такой признак.

2. Отрицают один из выявленных признаков, отказываются от него и заменяют его принципиально иным признаком, не обязательно противоположным отброшенному. Например, при разработке нового объекта на основе настенных часов можно отрицать их свойство "показывать местное время" и заменить его, в зависимости от назначения, такими: 1) показывать время, оставшееся до конца заданного интервала (например, до конца выступления в парламенте); 2) показывать время с момента восхода солнца; 3) показывать температуру, давление или еще какую погодную характеристику или их комбинацию; 4) показывать фазу Луны, уровень солнечной активности, радиационный фон или иной фактор, влияющий на здоровье и самочувствие.

3. Конструируют (сначала мысленно, а при удачном завершении "мысленного конструирования" - и в натуре) новый объект с этой замененной характеристикой. Остальные характеристики, не связанные с замененной, оставляют теми же, что и в исходном объекте.

Для более глубокого понимания сути и возможностей метода отрицания и конструирования попробуйте выполнить следующие упражнения.

Упражнения.
1. С применением метода отрицания и конструирования предложить идею принципиально нового (не известного в мировой практике) объекта, взяв за основу один из следующих объектов: а) кресло, б) книжный шкаф, в) конфету, г) балкон, д) розничную торговлю, е) железнодорожное расписание.
2. Можно ли модифицировать метод отрицания и конструирования с помощью метода отрицания и конструирования? Если можно, то как?
3. Можно ли считать безусловно справедливым основной принцип метода отрицания и конструирования?

1.2. Метод систематического покрытия поля

Если метод отрицания и конструирования откровеннно ориентирован на конструирование, создание нового объекта, т.е. на изобретательскую (в широком смысле этого слова) деятельность, то метод систематического покрытия поля - это метод науки, метод исследования, ближе всего соответствующий содержанию той цитаты Цвикки, что приведена в начале главы.

Схема метода поясняется рисунком 1, на котором “поле знаний” об объекте исследования условно обозначено в виде некоей замкнутой плоской области. Действительно, начиная изучение любого объекта, исследователь вначале имеет в своем распоряжении лишь очень небольшое количество известных положений, т.е. экспериментальных фактов или теоретических утверждений, которые можно назвать “вехами знаний”. Познание объекта исследования фактически строится как продвижение от каждой из этих “вех” (обозначенных сплошными точками на рис. 1а), причем часть поля знаний (слабо заштрихованная) “покрывается” областями, управляемыми одной-единственной “вехой” (т.е. прямыми следствиями из конкретного исходного положения), какая-то часть покрыта заштрихованными плотнее пересечениями таких областей (т.е. следствиями, использующими два или более исходных положений), а какая-то часть остается “непокрытой” (т.е. относительно объекта имеется группа вопросов или ситуаций, для которых на текущий момент нет ясных и однозначных ответов).

Метод систематического покрытия поля (МСПП) рекомендует последовательно экстраполировать имеющиеся знания в неизученные участки поля, стараясь перекрыть его полностью, т.е. с одной стороны, найти ответы на все вопросы, возникающие по отношению к исследуемому объекту, а с другой стороны, мысленно построить все ситуации и следствия, вытекающие из уже имеющихся знаний (с тем, чтобы затем этим следствиям и ситуациям найти соответствие в реальном мире). Действуя таким образом (и придя в конце концов к ситуации, изображенной на рис. 1б), можно ожидать, что:

а) ничто не будет упущено из поля зрения и
б) существует вероятность сделать открытие.

Рис. 1
а) б)
Рис. 1. К методу систематического покрытия поля.

Первое из утверждений кажется вполне понятным, хотя в действительности оно в принципе не может быть реализовано (в точном соответствии с основополагающим принципом метода отрицания и конструирования). Второе утверждение не так тривиально и оказывается справедливым прежде всего тогда, когда какие-либо участки рассматриваемого “поля знаний” оказываются недоступными (как на рис. 1б), несмотря на все усилия продвинуться в них от наших “вех”. В этом случае есть все основания считать, что отсутствие сведений об этих участках вызвано фундаментальными причинами, т.е. новыми “вехами”, еще не известными науке (на рис. 1б они обозначены вопросительными знаками), и тогда - ищите!

Из необъятного множества известных на сегодня методов поиска новых научно-технических решений МСПП - единственный метод, ориентирующий исследователя не на изобретение, а на открытие. Причем заметим, что открытия бывают трех типов:

а) открытие - прозрение, т.е. открытие нового принципа, нового эффекта или действительно фундаментального положения, дотоле не известного науке;

б) открытие - наблюдение или открытие - обнаружение, когда на основании имеющихся аксиом мысленно конструируется внутренне непротиворечивая ситуация, объект или явление, а затем эта никем не наблюдавшаяся ситуация или “мысленная конструкция” либо обнаруживается в природе, либо создается искусственно,

в) открытие - случайность, когда обнаруженный экспериментально объект (или явление) ни из каких предпосылок не следует и обязан своим обнародованием только наблюдательности и дотошности исследователя.

МСПП выводит на первые два типа открытий, причем на стадии “систематического покрытия поля” (т.е. планомерного продвижения в область неведомого) идут в основном открытия второго типа, а на стадии “тупиковой ситуации” - открытия первого типа (новый принцип). Интересно также, что открытие первого типа, как правило, влечет за собой цепочку открытий второго типа, т.к. сразу же после появления новой “вехи знаний” естественно ожидать (и не только ожидать, но и реализовать ожидаемое) быстрого расширения “покрытой” части поля знаний.

Этот “детективный” способ работы Цвикки использовал в своей "родной" астрофизике в течение нескольких десятилетий для выявления, поиска и предсказания новых космических объектов и явлений. Используя всего пять основных положений астрофизики, он предсказал и обнаружил карликовые галактики, компактные галактики всех типов (от голубых до инфракрасных) и кластеры компактных галактик. По его предсказанию были открыты нейтронные звезды. Из несбывшихся к 1967 году предсказаний Цвикки [2,10] следует отметить компактные галактики, насыщенные нейтронными звездами, чисто световые космические “шары”, а также световые “шары”, напичканные нейтронными звездами. Последние ультракомпактные объекты сильно напоминают “черные дыры”, существование которых сейчас не вызывает сомнения (эти объекты были выдвинуты Цвикки в качестве наиболее вероятных кандидатов на модель квазизвездных радиоисточников, а также обычных радиомолчащих компактных галактик, аномальное красное смещение которых вызвано колоссальным собственным гравитационным полем).

Вообще говоря, ситуация с МСПП несколько перекликается с удивлением г-на Журдена, на склоне лет узнавшего, что он всю жизнь говорил прозой. В действительности большинство деятелей науки пользовалось и пользуется методом систематического покрытия поля в своей обычной научной работе. Конечно, далеко не каждому удается при этом сделать открытие мирового масштаба, но “своих” микрооткрытий - сколько угодно.

В качестве примера рассмотрим ситуацию с периодическим законом химических элементов. Вообще говоря, “зоологическая” стадия развития любой науки (стадия простого накопления фактов) на определенном этапе совершенно прозрачно и откровенно ставит задачу систематизации, в результате чего на горизонте начинает маячить вопрос - неизвестный еще принцип систематизации. Именно такая ситуация сложилась в химии во второй половине XIX века, и поиском принципа систематизации нескольких десятков весьма разнообразных химических элементов занялись многие химики. Однако только одному из них удалось нащупать основополагающий принцип: периодичность изменения химических свойств в ряду, расположенном в порядке возрастания массы атома. Трудность состояла в том, что в момент провозглашения этого правила в нем уже существовал ряд исключений. Однако в том-то и состояла гениальность Д.И. Менделеева, что за этими исключениями он сумел увидеть ситуацию более глубоко, и это позволило ему не только уверенно предсказать существование трех еще не открытых химических элементов (галлия, германия и скандия), но и дать для этих элементов перечень основных их свойств и даже назвать руды, в которых можно искать предсказанные элементы. Последовавшее вскоре реальное обнаружение названных трех элементов именно там, где было предсказано, сняло все сомнения в корректности принципа, положенного в основу Периодического закона Д.И.Менделеева. И одновременно поставило вопрос о том, почему же этот закон нарушается для аргона и калия - единственной пары, у которой масса предшествующего элемента в ряду больше, чем масса последующего. Этот вопрос “висел в воздухе” еще много лет и разрешился только после нового качественного скачка в науке - открытия изотопов.

Единичные “неудобные” факты (исключения) в научной картине мира редко привлекают к себе массовое внимание ученых, поэтому работа по МСПП, как правило, спонтанно реализуется только в тех ситуациях, когда в конкретной области науки или техники накапливается группа родственных (или подозреваемых в родстве) фактов, не объяснимых с помощью имеющегося багажа знаний. Однако, зная о методе, можно сознательно его использовать, не дожидаясь, когда масса необъясненных фактов достигнет критической величины, понятной каждому, и когда десятки ученых начнут ломать голову над этой проблемой.

В этом смысле крайне ценным представляется анализ сегодняшней, сиюминутной ситуации в конкретной области знаний каждого читателя. Поэтому самое время выполнить очередную порцию упражнений.

Упражнения.
1. Назвать два-три открытия первого типа, выполненных по МСПП.
2. Назвать две-три группы открытий второго типа, выполненных по МСПП.
3. Для двух-трех областей знаний назвать группы родственных фактов, не объясненных наукой и предположительно выводящих на открытия нового принципа.

1.3. Метод морфологического ящика

Несмотря на то, что наиболее серьезные достижения Цвикки относятся к двум рассмотренным выше методам, наибольшую известность получил все же метод морфологического ящика (ММЯ), который “узурпировал” и общее название “морфологический анализ” или “морфоанализ”. Причины прозрачны:

а) ММЯ является единственным “алгоритмизированным” методом из набора Цвикки;

б) ММЯ наиболее доступен для понимания обычным инженерам, не “морфологам от рождения”.

Впрочем, последняя особенность (в действительности мнимая) сослужила методу плохую службу: бездумное, догматическое применение ММЯ в той сжатой, “телеграфной” форме, которая дана автором метода, почти неизбежно ведет к отрицательному результату.

В чем же дело? Давайте рассмотрим, как сам Цвикки формулирует этапы ММЯ [2,11]:

1. Точно сформулировать проблему, подлежащую решению.
2. Выявить и охарактеризовать все параметры, которые могли бы войти в решение заданной проблемы.
3. Сконструировать морфологический ящик или многомерную матрицу, содержащую все решения заданной проблемы.
4. Все решения, содержащиеся в морфологическом ящике, внимательно проанализировать и оценить с точки зрения целей, которые должны быть достигнуты.
5. Выбрать и реализовать наилучшие решения (при условии наличия необходимых средств). Этот этап практической реализации требует дополнительного морфологического исследования.

Простейший пример морфологического ящика показан на рисунке 2.

 | Параметры | Варианты
А | Материал корпуса | 1. Сталь | 2. Чугун |  |  |  |  |  | 3. Кирпич |  |  |  | 4. Другое
Б | Материал дымовой трубы | 1. Сталь | 2. Асбоцемент |  |  |  |  |  | 3. Кирпич |  |  |  | 4. Другое
В | Вид топлива | 1. Дрова |  | 2. Солома |  |  |  | 3. Хворост |  | 4. Уголь |  |  |  | 5. Другое
Г | Форма топливника | 1. Вертикальный |  |  |  |  | 2. Горизонтальный
Д | Средства аккумулирования тепла | 1. Водяной бачок |  | 2. Засыпка песком или золой |  |  |  |  |  |  | 3. Обкладка кирпичом
 |  | 4. Тепловая камера, заполненная камнем |  |  |  |  |  |  |  |  |  |  | 5. Другое
Е | Вывод трубы | 1. Через окно |  |  | 2. Через потолок
Ж | Средства пожарной безопасности | 1. Металлический поддон |  |  |  | 2. Асбестовая подкладка |  |  |  |  |  | 3. Ножки |  |  | 4. Нет
И | Устройства для приготовления пищи | 1. Одна конфорка | 2. Две конфорки |  |  |  |  | 3. Нет

Рис.2. Морфологическая матрица для объекта “Печь для дачного домика”

В матрице Рис.2 содержится ни много, ни мало - 4*4*5*2*5*2*3*3=14400 вариантов печурок. Каждый вариант можно обозначить формулой АiБjВkГl... Например, вариант А2Б2В1Г1Д2Е2Ж3И3 означает следующее: чугунная печь (А2) с асбоцементной трубой (Б2), выведенной через потолок (Е2), топится дровами (В1), топливник вертикальный (Г1), теплоаккумулирующая емкость засыпана песком или золой (Д2), печь на ножках (Ж3), никаких приспособлений для приготовления пищи нет (И3).

Универсальность ММЯ успешно продемонстрирована самим Цвикки на целом ряде примеров, а тот факт, что кабинетный ученый - астрофизик в течение нескольких лет получил 16 патентов (из них только три - с соавторами) на новые конструкции ракетных двигателей на химическом топливе и выдвинулся в ряд ведущих специалистов ракетостроения, в архиделовой Америке вызвал первый бум морфоанализа, в результате которого тысячи инженеров кинулись строить морфологические матрицы и... убедились, что все это не так просто. Немыслимое количество вариантов, которое требовалось проанализировать прежде, чем выбрать окончательный, довольно быстро охлаждало энтузиазм.

Интерпретаторы и последователи Цвикки не всегда адекватно понимали и передавали его идеи, даже формулировки этапов ММЯ в разных пособиях скорректированы и еще более сокращены по сравнению с исходным текстом, приведенным выше. В результате метод морфологического ящика, оторванный от общих принципов морфологического подхода, стал достаточно уязвимым для критики [5]. В немалой степени помог этому и сам Цвикки, точнее, его работы [2,10-11]: обозначив цель каждого этапа словесными формулировками, он для описания средств достижения цели этапа воспользовался совсем иным методом, не оговорив это для читателя,- методом “делай, как я”. Основной объем книги [2] - основного труда Цвикки - занят описанием и подробным разбором хода решения нескольких разнородных примеров, взятых из различных областей человеческой деятельности (от способов превращения энергии до систем стенографии, от видов телескопов до юриспруденции в космическом пространстве), при неявном предположении, что читатель на этих примерах сам поймет, как реализуется тот или иной этап. Однако темп жизни и нетерпение читателей и “писателей” привели к тому, что эта важная методическая часть была просто опущена, в результате чего алгоритм ММЯ превратился в лозунг - загадку.

Истекшие десятилетия существенно продвинули науку о методах исследования, поэтому сейчас работы Цвикки кто-то может воспринять и как непоследовательные, и как примитивные. Однако даже не делая скидки на время, следует признать морфологический подход прежде всего весьма плодотворным способом мышления (именно так его представлял сам Цвикки), который в своих конкретных реализациях может служить также и плодотворным методом обработки проблемы, т.е. подготовки, переформулировки, изменения взгляда на проблему. При этом не забудем оговориться, что, как и любой другой, морфологический метод - это метод для мышления, а не вместо мышления; оценки и выбор решения остаются прерогативой человека, а не алгоритма.

Упражнения.
1. Методом морфологического ящика проанализировать устройства для удаления волос на теле человека. Посмотрите, не найдется ли в полученном множестве что-нибудь необычное, еще не опробованное нашими салонами красоты.
2. Составьте морфологическую матрицу печатных изданий. Выявите такие типы изданий, которые пока никем не выпускались.
3. Сколько типов винтовых крепежных соединений (типа “винт-шайба-гайка”) используется во всевозможных конструкциях? (Размерные различия не учитывать)
4. Предложите способ наиболее экономичного выбора оптимального решения из морфологической матрицы, имеющей 10 строк по 5 альтернатив в каждой строке.

1.4. Морфологический подход в науке (история сверхпроводимости)

В 1908 году голландский физик Хейке Каммерлинг-Оннес в Лейденском университете перевел в жидкое состояние последний из инертных газов - гелий и тем самым открыл для физиков область температур от 1 до 10К, весьма близкую к абсолютному нулю. Выражаясь языком морфологического подхода, поле, доступное для увеличения объема наших знаний, расширилось в область дотоле неизведанных температур (расширение поля в действительности громадное, т.к. расстояние до абсолютного нуля температур сократилось сразу в десять раз!). Руководствуясь принципом метода систематического поля и получив уникальную возможность исследований в недоступной (пока) другим исследователям области температур, Каммерлинг-Оннес, изучавший электропроводность металлов, решил прямым экспериментом разрешить многолетний спор ученых о предполагаемом ходе температурной зависимости электропроводности металлов при Т® 0. А ученые эти разделились на три группы, каждая из которых убедительно доказывала справедливость своей гипотезы, но ни одна не имела прямых экспериментальных свидетельств своей правоты. Вот в чем была суть этих гипотез:

1) Проводимость обусловлена движением свободных электронов, а при Т® 0 энергия (и скорость) электронов также стремятся к нулю, электроны окажутся “привязанными” к своим атомам и сопротивление, соответственно, возрастет до бесконечности (кривая 1 на рис. 3).

Рис.3. Гипотетический ход кривых R(T) (по состоянию на 1909 год).

2) Согласно квантовой теории электроны при понижении температуры стремятся занять нижний энергетический уровень в потенциальном поле кристаллической решетки металла, но это не нулевой уровень, так что проводимость при Т® 0 будет стремиться к конечной величине (кривая 2 на том же рисунке).

3. Электросопротивление в металлах обусловлено рассеянием электронов на колеблющихся атомах, а при Т® 0 амплитуда колебаний атомов также стремится к нулю, вклад рассеяния уменьшится до нуля, кривая r(T) будет плавным продолжением уже измеренного участка (до Т» 10К), асимптотически приближающимся к нулю.

Итак, ситуация была близка к тому, чтобы одна из трех гипотез стала теорией, а остальные две - увы………... Довольно быстро Каммерлинг-Оннес установил, что для платины и золота (эти металлы имелись у него в сравнительно чистом виде) ход кривых r(T) ближе всего описывается кривой 2, когда сопротивление при Т®0 выходит на некое постоянное значение - “остаточное сопротивление”. Смущало, правда, то, что величина этого остаточного сопротивления сильно менялась от образца к образцу в зависимости от чистоты металла. Будучи по-прежнему одиноким исследователем в этой части “поля знаний”, Каммерлинг-Оннес предположил, что остаточное сопротивление обусловлено примесями, и в чистых металлах кривая r(T) будет ближе всего к кривой 3, т.е. сопротивление чистого металла будет монотонно уменьшаться до нуля с понижением температуры.

Вопрос оставался открытым, более чистой платины или золота в то время получать не умели. Но был другой металл - ртуть, которую многократной перегонкой можно было очистить гораздо лучше, чем тугоплавкие платину и золото. Сказано - сделано, продвижение по полю знаний продолжалось, и первые же эксперименты на максимально чистой ртути показали, что сопротивление ее при 4,2К (температура кипения гелия) становится столь малым, что его не удавалось даже измерить имеющимися приборами. В 1913 году Каммерлинг-Оннес так описал этот период своих исследований: “Будущее казалось мне прекрасным. Я не видел перед собой трудностей. Они были преодолены, и убедительность эксперимента не вызывала сомнений”.

Однако не измеренное сопротивление - это досадный недочет эксперимента. Подготовлено более совершенное оборудование, более чувствительные приборы, эксперимент в 1911 году повторяется Каммерлинг-Оннесом, и... оказывается (см. Рис. 3а), что кривая r(T) вовсе не похожа на такую хорошую, плавную и спокойную теоретическую кривую 3. И вообще ни на что не похожа. И вообще это не кривая, а какой-то обрывок, за которым... нет ничего. Никакого сопротивления, нуль!

Вот так в ходе рутинной работы по методу систематического покрытия поля (МСПП) было совершено одно из величайших открытий ХХ века - открытие сверхпроводимости. Типичное открытие III типа, открытие-случайность, непонятный и необъяснимый факт. Но факт настолько важный и фундаментальный, что уже в 1913 году Каммерлинг-Оннесу была присуждена Нобелевская премия по физике.

Впрочем, вернемся к сути дела. Установив столь необычный факт для одного из металлов (ртути) и убедившись довольно быстро, что примеси здесь ни при чем, ученые срочно принялись “распахивать” поле знаний о сверхпроводимости, причем основным методом оставался МСПП. Факты накапливались, но чем больше их было, тем туманнее становилась ситуация. Сверхпроводниками оказались почти все металлы, но при разных температурах сверхпроводящего перехода, причем никакой видимой связи этой критической температуры Тс с остальными физическими свойствами элемента не просматривалось. Шла “зоологическая” стадия накопления фактического материала, объяснений же не было. Назревала ситуация для открытия первого типа...

Покончив с металлами, экспериментаторы взялись за сплавы и интерметаллические проводники. Появились признаки работы по тактике метода морфологического ящика (ММЯ), поскольку появилась состязательная цель: найти вещество с максимально высокой температурой сверхпроводящего перехода. Цель отнюдь не платоническая, умозрительная, а вполне реальная, технически значимая, так как к этому времени уже родилась идея сверхпроводящего электромагнита (не потребляющего энергии) и другие заманчивые идеи технического применения сверхпроводимости. Как известно, сплав и интерметаллическое соединение - это комплекс из двух или более химических элементов. А это - уже база для ММЯ, когда для каждого из двух (или трех) элементов, входящих в соединение или сплав, испытывают всю гамму уже “зарекомендовавших себя” сверхпроводников, надеясь хоть на полградуса продвинуться в область более высоких Тс. Движение - практически вслепую, почти каждый новый факт дает неожиданные результаты и только усложняет картину. Но - это и очередная стадия накопления фактов, в частности, и очень странных. Например, обнаружение сверхпроводимости сульфида меди при Тс=1,6К, и это при том, что сера - никакой не сверхпроводник, а медь удается перевести в сверхпроводящее состояние лишь при Т<0,1К!

Теоретики, имея такой “букет” фактов, пытаются объяснить если не все, то хотя бы часть их, возникает множество частных гипотез, сменяющих одна другую и на какое-то время становящихся доминирующими, но целых полвека эта чехарда гипотез так и не могла дать хотя бы одну, достаточно убедительно объясняющую все уже установленные факты и обладающую предсказательной способностью (как, например, было с Периодическим законом Менделеева). И только в 1972 году мировое научное сообщество признало в качестве теории сверхпроводимости теорию, построенную Бардиным, Купером и Шриффером, присудив им Нобелевскую премию (но теория эта пробивалась в жизнь целых 15 лет). Состоялось, наконец, открытие первого типа - открытие нового принципа.

Впрочем, и это открытие по-прежнему оставило за пределами понимания и объяснения достаточно много фактов. И, к сожалению, теория БКШ (так ее стали называть по первым буквам фамилий авторов) в первоначальном виде не обладала основным свойством теории - предсказательной способностью, так что даже после ее официальной “инаугурации” нобелевским комитетом теория продолжала уточняться, модифицироваться и... размножаться.

Экспериментаторы, однако, были в большинстве своем далеки от баталий теоретиков (тем более что теория БКШ совсем не легка для понимания). Шла игра с большими ставками: каждый градус повышения рабочей температуры сверхпроводника означал заметное расширение перспектив практического применения в технике. “Гонка за градусами” после тривиальной стадии чистых веществ, давшей Тс=7,26К для свинца и Тс=9,22К для ниобия, перешла к почти необозримому морфологическому множеству бинарных соединений, позволившему вначале выйти во второй десяток градусов (NbN - 15K, NbH - 13K, NbC - 10K), а затем “разменять” и третий десяток (Nb3Al0,75Ge0,25 - 20,3K, Nb3Ge - 23K), заглянув попутно уже и в семейство тройных соединений. Хотя поддержка теоретиков при блуждании в бесчисленном множестве тройных соединений была крайне необходимой, теория БКШ ее гарантировала лишь в минимальной степени. А морфологическое множество соединений, потенциально перспективных для поставленной цели, обзавелось еще двумя строками, т.к. выяснилось, что кроме состава важна и кристаллографическая модификация вещества, а еще раньше было выяснено, что даже некоторые из простых металлов, не желавших проявлять сверхпроводящие свойства при обычных условиях, тем не менее “сдавались” при повышенном давлении (в пределах 50-100 кбар). Ситуация для поиска почти безнадежная: “поле знаний” для бессистемного поиска было невообразимо большим, а подсказок, где искать, не было.

Впрочем, в теории БКШ можно было найти и “утешение”: она утверждала, что наибольшая возможная температура сверхпроводимости не может превышать 30К, а до этого предела оставалось не так далеко.

Страсти затихли, время от времени в печати публиковались сообщения об “успехе” размером »0,1К, но физики все более уходили в технические приложения сверхпроводимости, тем более что в этой области появилось совершенно новое и перспективное для микроэлектроники направление - сверхпроводниковые электронные приборы со слабой связью (сквиды).

Бомба взорвалась в 1986 году. Редакция престижного журнала Physical Review Letters до сих пор кусает локти, сожалея о том, что она отвергла как несусветную чушь статью мало кому известных сотрудников швейцарского отделения фирмы IBM И.Г.Беднорца и К.А.Мюллера, которые утверждали, что керамический диэлектрик LaBaCuO является сверхпроводником, и не просто сверхпроводником, а еще и с температурой перехода Тс=35К - выше теоретической! Статью авторы переадресовали в менее престижный Zeitschrift fur Physik и она вышла в свет в октябре 1986 года. Нобелевская премия за открытие высокотемпературной сверхпроводимости была присуждена Беднорцу и Мюллеру уже в 1987 году - это самый короткий срок от открытия до его нобелевского увенчания!

Но вернемся к сути: что же произошло и как было сделано это открытие? К 1983 году, когда Беднорц и Мюллер только начинали работу по поиску высокотемпературных сверхпроводников, “поле знаний” о предмете выглядело следующим образом. “Зоологический” набор одноатомных сверхпроводников, явления в которых теория БКШ худо-бедно, но объясняла. Группа сверхпроводящих соединений типа Nb3Ge, характеризующихся своеобразной кристаллической решеткой. Установлено заметное влияние дополнительных легирующих элементов, занимающих вполне определенные места в кристаллической решетке основного соединения. “Странные” сверхпроводящие соединения, состоящие из элементов, не являющихся сверхпроводниками. Наконец, еще более странные органические сверхпроводники с температурой сверхпроводящего перехода вплоть до 10К. Ясно было, что явление сверхпроводимости - гораздо более общее, чем трактуется теорией БКШ.

Творческое решение всегда связано с преодолением психологического барьера. Метод отрицания и конструирования в этом смысле является классическим примером “принудительного” преодоления психологического барьера. Беднорц и Мюллер в точном соответствии с основным принципом этого метода (автору неизвестно, были ли они знакомы с работами своего соотечественника Цвикки) предположили, что сверхпроводник не обязательно должен быть проводником при обычных условиях. Но если мысленный переход от металлов к интерметаллическим соединениям и сплавам представлял собой психологический барьер микроскопической высоты, то здесь (переход от проводника к диэлектрику, т.е. к своей противоположности) психологический барьер оказался непреодолимым для всей армады исследователей. Но не для Беднорца и Мюллера.

Поставив целью изучение окисных соединений, Беднорц и Мюллер “прошли” никельсодержащие оксиды (безрезультатно), затем медьсодержащие соединения типа LaCuO3 (тоже безрезультатно), и только после того, как в керамику был введен третий металл - барий, швейцарские физики обнаружили сверхпроводящие свойства и, варьируя содержание Ва, достигли Тс=35К.

Не имея никакой теоретической поддержки (теория БКШ в одночасье лишилась статуса общей теории сверхпроводимости, т.к. не смогла сказать ничего для этого сверхпроводника), ученые начали почти вслепую разбираться, в чем же дело. Из всех физико-химических свойств сверхпроводящей керамики удалось установить зыбкую связь сверхпроводимости с тем, что атомы меди в керамике имели два состояния окисления - CuII и CuIII. И еще тот факт, что лишь одна из кристаллографических модификаций этой керамики переходила в сверхпроводящее состояние.

Итак, ученый мир к концу 1986 года оказался перед морфологической матрицей керамических сверхпроводников, которая изображена на рисунке 4. Были все основания считать, что LaBaCuO4 - не единственный сверхпроводник такого типа и его температура сверхпроводящего перехода - не максимально возможная (поскольку “теоретический” предел , провозглашенный БКШ, уже преодолен, а нового предела пока никто не поставил).

А. Элемент редкоземельный | La | ... | ...
Б. Элемент II группы | Ba | ... | ...
В. Элемент IБ группы | Cu | ... | ...
Г. Элемент VI группы | O | ... | ...
Д. Кристаллографический тип | перовскит | ... | ...
Е. Давление | норм. | ... | ...

Рис.4. Морфологическое множество высокотемпературных сверхпроводников (заполнены только клетки, соответствующие “нобелевскому” сверхпроводнику)

Все, кто имел доступ к жидкому гелию, ринулись на поиски новых сверхпроводников. Впереди маячил “азотный барьер”: все понимали, что сверхпроводимость при температуре жидкого азота (77К), а не гелия (4К) может вызвать настоящий бум в электротехнике, и тот, кто первым достигнет этого барьера, станет не менее знаменит, чем швейцарский нобелевский тандем. Беспрецедентным стал и обмен научной информацией: каждые две недели в том или ином научном центре собирался международный семинар, где прямо “из научной кухни” горячие, еще нигде не опубликованные и не всегда даже проверенные сведения оглашались и время от времени разворачивали весь научный “пелетон” в новом направлении. Число публикаций в научных журналах было очень большим, например, в США число статей на эту тему в 1987 году менялось так:

март-апрель | май-июнь | июль-август | сентябрь-октябрь
22 | 105 | 69 | 38

Клеточки морфологической матрицы заполнялись медленно, подавляющее большинство комбинаций на базе других элементов не обладали сверхпроводимостью, но и для тех керамик, где сверхпроводимость (или даже просто резкое уменьшение сопротивления) регистрировалась, эффект так сильно зависел от способа получения материала и был так нестабилен, что мираж новой нобелевской премии становился все более призрачным.

И все же общими усилиями Тс медленно (хотя по сравнению с предыдущими десятилетиями это “медленно” было просто космической скоростью!) продвигалась к заветным 77К. Декабрь 1986 года - 39К, январь 87 г. - 48К (замена бария стронцием), а затем и 57К (если образец подвергнуть давлению). К концу января из Китая поступили сведения, что достигнута Тс=70К, но образцы быстро теряют свойство сверхпроводимости. В феврале 1987 года азотный барьер пал. Сначала сообщение о Тс=80К, а через несколько дней - 94К и раскрыт состав первого “азотного” сверхпроводника - YBaCuOx. Перейден и еще один малозаметный барьер: иттрий не относится к редкоземельным лантанидам, так что этот сверхпроводник находится вне морфологического множества рис.3.

В течение недели со дня обнародования исходного состава образца YBaCuOx сразу четыре группы исследователей сообщили о точном составе и структуре сверхпроводящей кристаллографической фазы - YBa2Сu3Ox (другая кристаллографическая фаза этого состава Y2BaCuOx оставалась диэлектриком при любых температурах). Опыты с этим сверхпроводинком были на удивление хорошо воспроизводимы и он вскоре получил собственное имя - 1-2-3-сверхпроводник. Его структура показана на рис. 5.

Рис. 5. Структура 1-2-3 сверхпроводника.

Попытки двинуться в область более высоких температур были стабильно безуспешными и предпринимались все реже и реже, ученые переключились на “удобный” 1-2-3-сверхпроводник, разбираясь в деталях его строения и свойств. Время от времени в печати появлялись будоражащие сообщения: март 1987 - Тс=240К (Калифорнийский университет) и Тс=170-250К (Институт физических проблем АН СССР), июнь 1987 - 155К и 225К на том же 1-2-3-сверхпроводнике; уже в апреле на этом сверхпроводнике был создан СКВИД- основа свехбыстрой электроники будущего; японские газеты даже сообщили, что вскоре каждая японская домохозяйка на кухне сможет испечь сверхпроводник с Тс» 500К, т.е. на 200 градусов выше комнатной. Ни одно из таких сообщений не подтвердилось, и стали поговаривать, что выше 100К, пожалуй, не подняться.

В начале 1988 года надежды ученых возродились с новой силой. А произошло это благодаря тому, что еще раз сработал метод отрицания и конструирования: заменив редкоземельный элемент или таллием (тоже элемент III группы, как и иттрий, и лантаниды) или висмутом (элемент V группы, впервые появившийся в семействе керамических сверхпроводников; впрочем, и таллий, и висмут сами по себе проявляли сверхпроводящие свойства, но только при Тс» 2К), критическую температуру удалось надежно зафиксировать при 125К. К этому времени ученый мир наработал так много, что морфологическая матрица, начинавшаяся со скромной таблички, показанной на рис. 4, разрослась до весьма солидных размеров; она показана на рис. 6.

А | Первый элемент (редкоземельный?) |  | La | Tl | Y | Pb | Er | Nd | Bi | Al
 |  |  | Ho | Sm | Ce | Pr | Eu | Dy | Tu |
Б | Второй элемент (II группы) |  |  | Ba | Sr |  | Ca |  |
В | Третий элемент (IВ группы?) |  |  |  | Cu | Ni(?) |  | K | нет
Г | Четвертый элемент (VI группы) |  |  |  | О |  |  |
Д | Кристаллический тип |  |  | перовскит |  |  | кубическая |  |  |
Е | Дополнительный (стабилизирующий) элемент |  |  |  |  |  |  |  | F |  | Ag
Ж | Вид |  |  | монолит |  |  | пленка |  |
З | Давление | нормальное |  |  | до 10 Кбар |  |  | до 50 Кбар
И | Технология получения | окисление многослойной пленки |  |  |  | магнетронное распыление комплексной мишени |  |  |  | пиролиз
 |  | лазерное напыление со спеченной керамики |  |  |  |  |  | напыление электронным лучом
Рис. 6. Морфологическая матрица сверхпроводящих керамик по состоянию на 1988 год. Жирным курсивом выделены элементы, “инородные” по отношению к наименованию группы.

Уверенность в том, что наступает революция во всей технике, была столь велика, что в начале 1988 года рядом японских ученых был сделан прогноз о том, когда то или иное практическое применение ВТСП “перевернет” целую отрасль техники.
СП-индустрия
Энергетика | Генераторы, линии передач, управляемый термоядерный синтез, накопители
Исследования и разработки | Сверхпроводящий суперколлайдер, ядерный магнитный резонанс, электронная микроскопия
Перспективные технологии | Синхротронное кольцо, магнитное разделение, ионная инжекция, магнитные подушки
Космос и океан | Инфракрасные датчики, СКВИДы, подводные кабели
Медицина | ЯМР-изображение, СКВИДы, ядерный магнитный резонанс
Информатика и связь | Высокоскоростные компьютеры, СКВИДы, подводные кабели
Транспорт | Аэропоезда, флот, СП-вентили, автотранспорт

Рис. 7. Перспективные направления внедрения ВТСП (в соответствии с японской государственной программой на июль 1987 г.).

Красивая таблица перспективных направлений внедрения высокотемпературных сверхпроводников, показанная на рис. 7, перекрывает чуть ли не половину всего технического арсенала человечества, а сроки, когда все это сбудется, виделись совсем короткими. Судите сами, насколько оправдался этот прогноз, представленный в таблице рис. 8.

Область применения | Эксперт
 | К.Ташикава | С.Танака | Н.Макино
 | (Токийский университет) |  | (Мицубиси)
Суда со сверхпроводящим приводом Поезда на СП-магнитном подвесе Силовые линии электропередачи СП-генераторы Аккумуляторы электроэнергии Интегральные схемы на переходах Джозефсона СП-элементы интегральных схем Датчики магнитной напряженности Датчики излучения инфракрасного диапазона Системы исследования ядерного магн. резонанса Магнитные экраны СП-магниты в ускорителях элементарных частиц СП-комплектующие | 2000 2000 1995-2000 2000 2000 1990 1990 1990 1990 1990-1995 1990 2000 1990-1995 | 1997 1995-2000 2000 2000 2000 1990-1995 1990-1995 1995-2000 1990-1995 1990-1995 - 1995 1990 | 1990-1995 1995-2000 2000 1995-2000 1990-1995 1990 1990-1995 1990 1990 1990 1990-1995 1990-1995 1990-1995

Рис. 8. Прогноз внедрения ВТСП в различные отрасли.

Вот и вся (пока) история открытий в области физики сверхпроводимости. За рамками нашего рассказа остались разбитые надежды тех, кто не получил нобелевской премии, упущенные возможности тех, кто держал в руках ту самую керамику LaBaCuOx, но по бедности оборудования не смог померить ее проводимость (а это было, было у нас в стране, в Институте физхимии АН СССР, и не в 1986 году, а на несколько лет раньше), отрицательные результаты тех, кто “перепахивал” морфологическое множество керамик, но так и не нашел нужной. В науке так всегда: жемчужное зерно открытия предваряется громадным количеством труда и отрицательных результатов. Но отрицательный результат - это лучше, чем никакого результата, это тоже знание. Как получают это знание, автор попытался показать на примере вот этой узкой области физики.

В качестве эпилога этой истории (не исключено, что временного эпилога) сообщим, что сейчас темпы исследования ВТСП (ВысокоТемпературных СверхПроводников) приблизились к тем, что характерны для устоявшихся научных направлений, а поле основной работы сместилось к вопросам скорее техническим, чем научным: основные перспективы практического применения ВТСП связаны с электротехникой, а значит, с проводами; керамика же крайне хрупка, и сделать из нее провод для обмотки трансформатора, например, проблема не из простых. Другая трудность связана со стабильностью структуры ВТСП: большинство ВТСП-керамик обладают неприятным свойством старения и перехода в обычную (непроводящую) фазу; для практики это недопустимо.

А теории сверхпроводимости - нет как нет. Намек поняли? Нобелевский комитет ждет.

Ну а теперь, закончив исторический экскурс, вернемся к загадочной науке - логике.


Немного логики

Системно-морфологический подход
в технике, науке, социальной сфере.
Титов В.В.

2. Немного логики

Нелогичность высказываний не всегда является следствием нечестности или желания обмануть; чаще всего это просто проявление недостатка культуры и образования. Последствия такой нелогичности могут быть разной степени плачевности, но общим является одно: говорящий и слушающий могут понимать одно и то же высказывание по-разному, т.е. взаимопонимание будет отсутствовать. Хуже всего, когда говорящий (пишущий, набирающий на компьютере, и т.д.) и слушающий (читающий) - это одно и то же лицо. Хотя такая ситуация может показаться парадоксальной и даже патологической, в действительности она сплошь и рядом реализуется с каждым, и вот как.

Все слова в любом языке неоднозначны. Даже не говоря об омонимах (для забывших, что это такое, пример: “поля” бывают у шляпы, у тетради, у шахматной доски и у колхоза, но это абсолютно разные объекты), почти любое слово в разном контексте может иметь разное смысловое наполнение. А поскольку написание и прочтение частенько бывают разделены во времени солидным промежутком, то человек написавший и человек читающий - разные люди, даже если это один и тот же человек. (А вам разве не приходилось по прочтении какого-нибудь своего давнишнего текста с досадой восклицать: “Ну какую же чушь я написал!”)

И поскольку понимание какого-либо утверждения является основанием, базой для определенных действий, предпринимаемых, в свою очередь, для достижения определенной цели, то совершенно необходимо, чтобы это понимание было однозначным, единственным. Для этого все термины и понятия в данном утверждении должны иметь однозначные определения. И это - самый первый, ключевой элемент логики, смысл и особенности которого мы и напомним тем, кому не довелось ознакомиться с ними в школе или вузе.

2.1. Определение.

Нельзя внести ясность в рассуждения, если она сначала не введена в определения.
В.Гершель

Пренебрежение или даже просто недостаточное внимание к истине, выраженной в эпиграфе, чревато серьезными недоразумениями, которые народная мудрость запечатлела меткой пословицей: “В огороде - бузина, а в Киеве - дядько”. При решении творческих задач, единоличном или коллективном, неоднократно возникает ситуация диалога, рассуждения, и нужно очень точно отслеживать, чтобы в течение этого процесса случайно не был подменен объект рассуждения. Для того, чтобы это не случилось, наиболее надежным способом является логический прием, называемый определение.

Основная цель определения - раскрыть или уточнить содержание понятия. Впрочем, не менее важная его цель - отличить и отграничить определяемый объект от всех иных (это ведь заложено в самом названии - оПРЕДЕЛение). Из сказанного ясно, что определение - фундаментальный оператор логического мышления. И, как это ни странно, из всех проблем познания именно проблема определения изучена хуже всего. Да и сами посудите, может ли быть иначе, когда основной задачей определения считается раскрытие сущности определяемого объекта, а ведь хорошо известно, что за первой, поверхностной сущностью каждого объекта просматривается и вторая, более глубокая сущность, за ней - третья, и этот процесс углубления и все более полного познания - бесконечен, как бесконечен путь к абсолютной истине. А это значит, что, какое бы определение объекта мы ни давали, оно неизбежно будет неполным (т.е. всегда его можно уточнить или углубить). Более того, определение одного и того же объекта меняется и во времени, и в отношениях. Отсюда понятны трудности, с которыми приходится сталкиваться при определении, понятна и изменчивость определений во времени и в отношениях. Два красноречивых примера: 1) определение синхротрона для школьника (см. детскую энциклопедию), для медика (см. учебник по медицинской радиологии) и для физика (см. физический энциклопедический словарь) - это совершенно разные определения; 2) определение социалистической партии в философских словарях, изданных на русском языке в разные годы, меняется почище, чем окраска у хамелеона.

Упражнения:
1. Просмотрите во всех доступных для Вас энциклопедических словарях разных лет выпуска и выпишите определения понятий “телефон”, “система”, “диагноз”, “техника”. Изложите Ваши соображения о причинах трансформации определения каждого из этих понятий.
2. Дайте четыре определения понятия “радиоактивность”: для десятиклассника, для медика, для физика-теоретика и для крестьянина, не желающего отселяться из-под Чернобыля.

Таким образом, фундамент логики - определение - необычайно зыбок, динамичен и непостоянен. И в этом - величайший подарок человечеству, ибо с самого детства, с начала знакомства с родным языком маленький человечек вынужден балансировать среди множества объектов и понятий, каждый день и час достраивая и перестраивая систему определений и сущностей и тем самым проявляя максимум творческой активности. Жаль только, что уже школьная зубрежка у большинства наглухо умерщвляет всю эту активность (не говоря уж о более поздних годах взросления).

Динамичность определений усугубляется еще и чрезвычайным их разнообразием. Прежде всего можно разделить все типы определений на явные и неявные.

Явные определения - это синонимичные определения типа “А=В”, где замена в любом тексте выражения “А” на выражение “В” не меняет смысла текста (хотя может изменить его “грамотность”). Примеры: “Молекула - это мельчайшая частица вещества, сохраняющая все его химические свойства”, “Абракадабра - это бессмысленное выражение”.

Неявное определение - это определение понятия из контекста, когда его сущность, смысл проявляются по всему многообразию его связей с другими, знакомыми понятиями в рассматриваемом тексте. Хотя в принципе неявное определение почти всегда неполно и неустойчиво (каждая новая фраза текста меняет это определение), но в жизни нам большей частью приходится опираться именно на этот вид определения. Показательный пример: ребенок только о 10% встретившихся объектов или услышанных понятий пристает к родителям с вопросами типа “Что это?”, а в 90% случаев сам решает (на основе того, что видит и слышит), с каким объектом он имеет дело, а в результате мы иногда удивляемся их тонкой наблюдательности, а иногда встречаемся с милыми ошибками, которые потом собираются в книги “От двух до пяти”. Впрочем, и взрослых этот тип определений иногда ставит в интересное положение (вспомните, как дед Щукарь в “Поднятой целине” читал энциклопедию, где ему по зрению доступны были только крупные буквы).

Частный вид неявного определения - определение через набор функций, которые объект выполняет, или через набор свойств. Блестящие примеры таких определений - народные загадки (“Не лает, не кусает, а в дом не пускает”, “Зимой и летом - одним цветом”, и т.д.). Но для нас наиболее интересно то, что именно этот тип определений явно или неявно фигурирует в изобретательском творчестве, причем, как в загадках, изобретателю изначально дан набор функций или свойств объекта, а самого объекта (а иногда - даже и его названия!) еще нет в природе.

Еще один вид неявного определения - остенсивное определение или определение путем показа. Можно долго объяснять туземцу, что такое радиоприемник, а можно просто показать его. В качестве контекста этого вида определения здесь выступает не устная или письменная речь, а ситуация, в которой встречается или функционирует определяемый объект. Остенсивные определения - пожалуй, наименее полные из всех возможных, потому что в этом случае функции “контекста” исчерпываются, как правило, единственной “фразой”. Но, с другой стороны, остенсивное определение - единственное, которое связывает слово непосредственно с материальным объектом, предметом или “живым” действием. И тысячу раз верна пословица: “Лучше один раз увидеть, чем сто раз услышать”. Поэтому, кстати, опытный ученый, консультант или новатор обязательно стремится прежде всего посмотреть своими глазами ситуацию, которую требуется объяснить, изменить или разрешить, и только после этого переходит к активным творческим действиям.

С явными определениями дело обстоит проще. Но не потому, что они проще, а потому, что такое определение очень похоже на столь милую советскому человеку инструкцию или директиву. Как у Юлия Кима в песне про школьного учителя обществоведения:
Я им говорю, что, мол, так-то и так-то,
А если не так, значит - ложь!”
А они кричат: “А где факты, где факты?
Аргументы вынь да положь!...”

Наиболее частым видом явного определения является определение через род и видовое отличие, которое описывается формулой “А=В и С”, где “А” - определяемое понятие, “В” - понятие, более общее по отношению к “А” (родовое понятие), “С” - такие признаки, которые выделяют объекты, обозначаемые “А”, среди всех объектов, обозначаемых “В” (видовое отличие). Подавляющее большинство словарных определений относятся именно к этому типу. Например, в “Школьном толковом словаре русского языка” [12] даны следующие определения:

1. Мнение (А) - суждение (В), выражающее оценку чего-либо, отношение к чему-либо (С).
2. Публицистика (А) - вид литературы (В), посвященный злободневным общественно-политическим вопросам современности (С).
3. Рупор (А) - труба с расширяющимся концом (В), служащая для усиления звука (С).
4. Труба (А) - длинный пустотелый предмет (В) обычно круглого сечения, служащий для проведения чего-либо (С).

Нетрудно видеть, что в этих конкретных примерах для более полного разъяснения некоторых понятий используются приемы нескольких типов определения.

Правила явного определения (в частности, родо-видового определения):

1. Правило соразмерности определяющего и определяемого понятий: совокупности объектов, охватываемых ими, должны быть одними и теми же. Надо сказать, что соблюсти это правило вовсе не так легко. Но, с другой стороны, оно позволяет довольно просто отграничить рассматриваемый объект (или группу объектов) от всех остальных, определив его волевым образом. Об этом будет сказано чуть позже, а сейчас обратим внимание на то, что нарушение этого правила возможно двоякое: A>B - ошибка слишком широкого определения, и A<B -ошибка слишком узкого определения.

Примеры ошибок, нарушений правила соразмерности:
а) ошибка слишком широкого определения: “Карандаш - это предмет для нанесения изображений” - но тогда сюда войдут и ручки, и мел, и кисть, и все, что пачкает и чем человек пользуется для нанесения изображений;
б) ошибка слишком узкого определения: “Карандаш - это предмет для нанесения изображений, состоящий из тонкого цилиндрического графитового грифеля и деревянного корпуса, облегающего этот грифель” - но отсюда выпали все автоматические карандаши, а также карандаши с пишущим стержнем не из графита (например, свинцовый и восковой).

Умельцы могут сочинить иногда и такие определения, что появятся сразу обе названные ошибки. Однако прежде чем над ними потешаться, попробуйте выполнить следующие упражнения.

Упражнения:
 1. Сформулируйте точное определение карандаша.
2. Дайте определение объекту под названием “книга”, чтобы под это определение не попали ни тетради, ни блокноты, ни журналы (в том числе и очень толстые).
3. Дайте определение понятию “рынок”. Учтите при этом, что термином “рынок” называют два совершенно разных объекта.

2. Правило запрета порочного круга, когда понятие определяется либо через само себя, либо через другое понятие, которое, в свою очередь, определяется через исходное понятие. Смысл этого правила вполне прозрачен: ведь определение понятия из неизвестного (или недостаточно известного) делает его известным, а значит, само определение должно быть выражено словами, означающими уже известные объекты (к числу которых определяемый объект пока не принадлежит). Но - интересная особенность: возьмите любой словарь (толковый, специальный, энциклопедический или любой другой, кроме двуязычного), и Вы сплошь и рядом можете уличать его составителей в нарушении правила запрета порочного круга.

Упражнения:
 1. Трудно предположить, что синклит ученых мужей - составителей и редакторов словаря сплошь неграмотен и не знает правила запрета порочного круга. Так в чем же тут дело?
2. Как объясниться с человеком, который не знает ни слова по-русски, а Вы не знаете его языка?
3. На каком языке объясняться при первом контакте с внеземной цивилизацией, возникшей не на базе углеродной органики?

3. Правило ясности всех понятий определяющей части. Это означает, что в определяющей части можно использовать только те понятия, которые известны тем, для кого дается определение. Вообще говоря, это правило существует в нескольких ипостасях. Во-первых, в определяющей части нельзя использовать термины, заведомо непонятные для адресата, которому предназначено определение. Во-вторых, нельзя использовать слова, допускающие многозначное толкование. В-третьих, нельзя использовать метафоры, сравнения и другие образные средства языка. Попробуйте, например, решить проблему детского дошкольного воспитания, ориентируясь на определение: “Дети - цветы жизни”. Или решить проблему теплоснабжения на базе определения: “Нефть - это черное золото”.

И, как и в предыдущих случаях, это правило также нарушается довольно часто, причем сознательно. Действительно, прочтите инструкцию к любому (особенно импортному) лекарству. Абракадабра, вгоняющая в дрожь и благоговение неискушенного пациента. И в то же время точное и полное определение для врача, назначающего это лекарство. Разумно? Цель этого определения - антиопределения совершенно прозрачна - исключить самолечение.

Другой пример. Попробуйте в техническом разговоре обойтись без слова “машина”. Или “автомат”, “автоматический”. Да и вообще большая часть специальных терминов техники употребляется в нескольких отраслях, часто весьма отдаленных, причем в разных ситуациях смысл и значение термина совершенно непохожи. Имплантация в медицине - это вживление участка ткани или органа, но имплантация в полупроводниковой технике - это вбивание ионов легирующего вещества в поверхностные слои мишени-полупроводника. Сепарация в изотопной технологии, в вычислительной технике, в хирургической клинике и на молочном заводе - совершенно различные понятия.

Третий пример - любые неявные определения, где всякое лыко - в строку, где идут в ход все самые отдаленные и тонкие сравнения, метафоры, эпитеты и прочее литературное обрамление, так как именно оно и является, собственно, источником информации об объекте.

Итак, правила определения существуют, но - ни одно из них безусловно не выполняется (или выполняется, но с колоссальным трудом). Хорошенькое дело, не правда ли? Ведь речь идет о фундаментальном логическом приеме, на котором строится все дальнейшее здание рассуждений. Как же быть?

Есть один простой и универсальный выход. Дело в том, что различают определение - описание (или реальное определение) и определение - предписание (или номинальное определение). Первое относится к тому понятию, которое уже есть и уже используется в обиходе, имеет вполне определенное смысловое наполнение и некое общепринятое понимание. Поэтому Ваше определение-описание этого объекта может быть либо истинным, либо ложным в зависимости от того, насколько оно совпадает с общепринятым. Что касается определения-предписания, то оно формируется для узкой, конкретной ситуации или обсуждения и относится к тому, как участники обсуждения и совместных действий договорятся называть то или иное явление или предмет (независимо от того, как это определение соотносится с общепринятыми понятиями, если они существуют); значит, о его истинности или ложности говорить нет смысла. Определение - предписание имеет узкую область применения, согласованную участниками. Характерный пример - любой закон, который начинается с раздела определений - предписаний для всех ключевых понятий, используемых в данном законе; определения, введенные в этом первом разделе закона, действуют только в пределах данного закона. Обязательно такие определения-предписания встречаются в юридических документах договорного характера, где точное недвусмысленное определение наиболее важных понятий (и прежде всего самого предмета договора и его участников) является одним из основных условий исключения двойственного толкования договора. И тогда в тексте договора о каком-либо объекте, наименование которого допускает неоднозначное толкование, появляется фраза типа: ”<Объектом>, в смысле настоящего договора, называется...” и далее идет перечень тех характеристик и свойств, которые в настоящем договоре (и только в нем!) определяют смысловые контуры того, что названо <объектом>. Впрочем, это помогает не всегда, и недобросовестные партнеры договоров частенько находят даже в самом скрупулезном определении-предписании белые пятнышки, раскрашивая их в суде в выгодные для себя цвета.

Казалось бы, из такого сравнения реального и номинального определений напрямую следует, что о правильности номинального определения (определения-предписания) сказать ничего нельзя. Однако это не так. Неудачное определение-предписание, сформулированное с нарушением третьего правила (двусмысленность понятий определяющей части), иногда оказывается “миной замедленного действия”: ведь в подсознании у каждого эти правила в той или иной мере зафиксированы и рано или поздно может случиться, что номинальное определение будет непроизвольно воспринято в ином (по сравнению с первоначальным) смысле (особенно если к обсуждению подключаются новые участники, не присутствовавшие при создании этого номинального определения). Поэтому рекомендуется даже в номинальном определении избегать двусмысленности, чаще всего проявляющейся в использовании понятий, закрепленных за другими, широко известными объектами.

Определение - мощное средство против неясности наших понятий и рассуждений. Однако при его использовании нужно, как и везде, чувствовать и соблюдать меру. Дело в том, что нельзя в принципе дать определение всем понятиям без исключения. Ведь для того, чтобы дать определение какому-либо объекту, Вы должны в определяющей его части использовать уже известные понятия, а это значит только одно: Вы уже изначально должны обладать неким набором первичных понятий и терминов, известных безо всякого определения. Попытка определить то, что понятно и очевидно, только затемнит его.

“Неясное” и “неопределимое” - вот две границы, задающие тот довольно узкий интервал, внутри которого механизм определения может проявить свою действенность. Если “неопределимое” - это само собой разумеющееся, то с “неясным” дело обстоит иначе. Когда сведений об исследуемом объекте слишком мало или когда они достаточно противоречивы, попытка определить этот объект способна создать только обманчивую видимость ясности, и тогда может возникнуть ситуация “диалога глухих” про бузину в огороде. Попробуйте определить НЛО, или экстрасенсорику, или биополе, или закон, управляющий формированием погоды на завтра, и Вы рискуете скорее всего вместо реального определения дать определение-предписание, не имеющее отношения к действительному объекту (именно так, кстати, и создавались все “опровержения” перечисленных выше реальных явлений).

В свое время автора очень удивляла философская сентенция “восхождение от абстрактного к конкретному”: уж больно она противоречила укоренившейся привычке построения пирамидальных структур, где внизу - все разнообразие частных объектов, а вверху - некие обобщающие (управленческие) этажи, чем выше, тем важнее и абстрактнее. Однако именно абстрактные объекты легче всего поддаются определению. Вся геометрия строится на пяти аксиомах, и все ее объекты определяются просто, немногословно и однозначно. А попробуйте определить геометрию, скажем колхозного поля конкретного колхоза имени ХХХVII партсъезда, расположенного в предгорьях Кавказа. Чем конкретнее определяемый объект, тем больше индивидуальных свойств, присущих только ему, приходится учитывать в определении, тем многословнее и подробнее становится определение, и уж тут всякие сомнения в том, где “восхождение”, а где - “нисхождение”, рассеиваются окончательно.

Итак, подводя итоги разделу об определении, еще раз подчеркнем, что определение - мощный способ снятия неясности наших понятий. Но применять его следует тогда и только тогда, когда эта неясность или уже существует, или может появиться. При этом следует обращаться именно к тем формам определений, которые наиболее эффективны и уместны в конкретной ситуации. Кстати, владение искусством определения очень важно и в такой проблемной ситуации, как налаживание и обеспечение корректной и эффективной работы творческой группы. Мы слишком суровы и изначально настроены на борьбу даже тогда, когда компромисс, диалог гораздо быстрее и надежнее приведут к цели. И слишком часто эта ситуация борьбы, борьбы мнений возникает не из-за различия целевых установок, а просто по причине того, что один и тот же термин или понятие, употребляемое спорящими сторонами, понимается ими совершенно по-разному. И если Вы это увидели, то первейшая Ваша задача - призвать стороны к тому, чтобы сначала дать определение понятию, вокруг которого идет спор, и только после этого продолжить дискуссию. При этом у Вас есть шанс получить несказанное удовольствие от зрелища недавних противников, в недоумении и смущении скребущих собственные затылки после выяснения, что спорить было... не о чем.

Вопросы для самопроверки:
 1. Что такое “определение”?
2. Какие существуют виды определений?
3. В чем достоинства и недостатки явного и неявного определений?
4. Какие правила надо соблюдать при использовании родо-видового определения?
5. Когда можно и когда нельзя применять номинальное определение?
6. Каким объектам невозможно дать определение? А каким - можно, но не нужно?
7. Можно ли дать объекту единственно правильное определение? Существуют ли такие объекты?
8. Сформулируйте Ваше отношение к определению: “Сосуд, имеющий форму ведра с надписью “пож.вед.” и предназначенный для тушения пожаров, называется пожарным ведром”.

2.2. Классификация

“Должен быть почитаем как Бог тот, кто хорошо может определять и делить.”
Платон.

В большинстве реальных задач, которые приходится решать человеку или коллективу, перед ним то и дело возникают ситуации многовариантности действий или объектов, ситуации необходимости выбора единственного пути среди множества возможных (“налево пойдешь - коня потеряешь, направо пойдешь -...”, и т.д.). Чтобы оценить всесторонне эти варианты и принять обоснованное решение, приходится использовать еще один логический оператор - классификацию.

В книге [13] приведена цитата из “некоей китайской энциклопедии”, в которой говорится, что “животные подразделяются на: а) принадлежащих императору, б) бальзамированных, в) прирученных, г) молочных поросят, д) сирен, е) сказочных, ж) бродячих собак, з) включенных в настоящую классификацию, и) буйствующих как в безумии, к) неисчислимых, л) нарисованных очень тонкой кисточкой из верблюжьей шерсти, м) и прочих, н) только что разбивших кувшин, о) издалека кажущихся мухами”. Веселье, которое имеет место при зачтении этой классификации в любой аудитории, вполне понятно: уж слишком неправильна эта “классификация”. А собственно, что в ней неправильно? Все перечисленные виды животных бывают (какие-то - в жизни, другие - в сказках, но ведь бывают же!). Вот только в один ряд сводить такие группы недопустимо, получается невообразимая путаница.

Упражнения:
 1. Ну а все-таки: как же можно расклассифицировать животных? Это задание рекомендуется сначала попробовать выполнить без использования шпаргалок и справочников, а затем уже посмотреть (где?), какова действительная научная классификация животных. И сравните, в чем ее отличие от Вашей классификации.
2. Провести классификацию машин (или приборов, или инструментов), с которыми Вам приходится иметь дело на основной работе. Эту классификацию следует составить по всем правилам. А поскольку об этих правилах здесь пока ничего не говорилось, то реально это задание придется выполнить попозже.

Для грамотного проведения классификации нужно в совершенстве знать и уметь различать четыре логических оператора: деление, расчленение, обобщение и соединение. Ключевым в этой четверке является логическое деление.

Деление - это распределение на группы всех тех объектов, которые мыслятся в исходном или делимом понятии. Эти группы называются членами деления. Признак, по которому производится логическое деление, называют основанием деления. В каждом делении, таким образом, имеются делимое понятие, основание деления и члены деления. Делимое понятие является родом, а члены деления - видами по отношению к данному роду. Каждое из видовых понятий может в свою очередь стать объектом деления, и т.д. Такое многоступенчатое разветвленное деление и принято называть классификацией.

Логическое деление не следует смешивать с другой, похожей операцией - расчленением (мысленным) объекта на составные части. Формально эти две операции можно проводить, используя вспомогательные тесты. На этапе проведения операции тест-вопросы таковы:

Какие известны варианты данного объекта (различающиеся по данному признаку)?
Из каких частей состоит данный объект?

Читатель сам может догадаться, какой из тест-вопросов соответствует операции деления, а какой - расчленению.

Для проверки правильности проведенной операции (после ее завершения) можно воспользоваться следующими утвердительными тестами:

Любой из членов деления в то же время является делимым понятием.
Любой из продуктов расчленения уже не является расчленяемым понятием.

Рассмотрим два примера.

Проведем операцию деления относительно понятия “металлорежущий станок”. Можно утверждать, что все металлорежущие станки делятся на токарные, фрезерные и строгальные. Основанием деления здесь является характер перемещения режущего инструмента и обрабатываемой детали. Теперь проведем по отношению к тому же исходному понятию операцию расчленения: “металлорежущий станок состоит из мотора, трансмиссии (передающей или преобразующей вращение вала в движение рабочего органа), режущего инструмента, системы охлаждения рабочей зоны, системы управления и станины”. Проверяем правильность обеих операций: 1) и токарный, и фрезерный, и строгальный станок являются металлорежущими станками каждый в отдельности, 2) ни мотор, ни трансмиссия, ни резец, ни станина не являются металлорежущим станком каждый в отдельности.

Другой пример - дерево. Проводим операцию деления, используя тест-вопрос: “Какие известны разновидности дерева (различающиеся по виду органов, в которых проходит фотосинтез)?” Ответ: хвойные, лиственные и безлиственные (фотосинтез идет в тонких ветках или стеблях). А теперь - расчленение: “Из каких частей состоит дерево?” Ответ: из корневой системы, ствола и кроны. Проверка правильности обеих операций утвердительными тестами предоставляется читателю.

Чтобы проводить деление корректно, нужно знать четыре правила деления.

Правило 1. Деление должно проводиться только по одному основанию. Это - главное, основное правило. Пример из “китайской энциклопедии” потому и неверен, что там можно насчитать не менее десятка оснований деления (попробуйте сравнить попарно члены “китайской классификации”, и Вы легко в этом убедитесь). Однако “неча на зеркало пенять...”, зайдите в любой крупный обувной магазин и прочтите названия отделов: “мужская обувь”, “женская обувь”, “детская обувь” и ...”резиновая обувь”. Сколько здесь, по-Вашему, оснований деления намешано? Странно, что, несмотря на это вопиющее нарушение логики, мы ни минуты не колеблемся между отделами, когда надо купить галошки нашей прелестной даме трех лет отроду. Но в более серьезных случаях подмена основания деления может привести (и приводит!) к путанице вместо того, чтобы, как это и требуется от классификации, навести порядок в множестве рассматриваемых объектов.

Правило 2. Деление должно быть соразмерным или исчерпывающим, т.е. сумма объемов членов деления должна быть в точности равна объему делимого понятия. Здесь также возможны два типа ошибок: неисчерпывающее деление (например, при делении всех людей по уровню образования на имеющих начальное, среднее и высшее образование в этой классификации нет места ни неграмотной бабушке, ни ясельному малышу) и деление с излишним членом (как в обувном магазине), но в последнем случае нарушается не только второе, но и первое правило.

Ситуация со вторым правилом частенько ставит подножку исследователю какого-либо класса объектов. Дело в том, что реально очень редко имеет место ситуация, когда нам известны все разновидности входящих в данный класс объектов. Например, если бы Вас попросили ответить на вопрос, какие бывают деревья, вспомнили бы Вы о безлиственных? Ну ладно, Вы, допустим, не специалист по флоре, но уж ученым-то биологам все, казалось бы, должно быть известно, и классификация объектов животного мира, например, уж точно полна и все разложено по полочкам. Память школьных времен подсказывает, что начиная с К. Линнея эта классификация существует и “работает” на науку, находя для каждого животного свою нишу, ячейку, клеточку в многоярусной структуре. Царство животных делится на типы (членистоногие, позвоночные, и т.д.), типы - на классы (тип позвоночных - на классы млекопитающих, птиц, рыб, и т.д.), классы - на отряды, далее идут семейства, роды и, наконец, виды (а иногда еще и подвиды). И эта классификация до сих пор все пополняется и пополняется, открываются новые виды (сотнями), семейства, классы и даже типы (в ХХ веке открыто три новых типа животных). Но ведь это означает, что классификация животных перманентно неполна, т.е. выполнена с ошибкой неисчерпывающего деления. Правда, ученых это не очень смущает, т.к. настоящий ученый знает, что он знает не все (до Сократа с его :”Я знаю, что я ничего не знаю” нам, конечно, далековато), и готов всегда дорисовать лишнюю клеточку в классификацию (и тем увековечить свое имя).

Иначе выглядит ситуация в более “приземленных” науках и в технике. Стоит забыть один из принципов действия какого-либо устройства, и Ваша стройная классификация таких устройств увлечет Вас в исследование упомянутых в ней типов и напрочь закроет путь к забытому или упущенному варианту. А кроме того, остается ведь и вероятность изобретения принципиально нового устройства, для которого в классификации места вообще нет. Чтобы как-то отследить эти варианты, часто используют прием, мелькнувший и в “китайской” классификации, заведя в ней специальную клетку “прочие”. Тогда что бы новое ни появилось, для него ячейка уготована.

Правило 3. Члены деления должны быть альтернативными или взаимно исключать друг друга. Каждый отдельный объект может находиться в объеме только одного видового понятия. Нарушение этого правила также неизбежно связано с нарушением первого правила, что хорошо просматривается с галошками для девочки, которые можно было бы поместить в любое из трех отделений вышеупомянутого обувного магазина.

Правило 4. Деление должно быть непрерывным, однопорядковым. Это означает, что нельзя часть родового понятия делить на виды, а другую часть - на подвиды таких видов (например, делить население на женщин, белых мужчин и цветных мужчин - некорректно).

Из рассуждений о правиле 2 уже ясно, что нарушать четвертое правило нас заставляет жизнь. Нас - это тех, кто творит новое, а значит, вынужден в своей классификации оставлять для этого еще не созданного нового на каждом этапе клетку “прочие” (которая может иметь непредсказуемый уровень общности с остальными клетками этого ряда).

Надо сказать, что есть и еще один достаточно распространенный случай сознательного нарушения четвертого правила. Настолько распространенный, что он получил даже собственное имя - дихотомия (от греческого - разделение надвое).

Дихотомия - это деление объектов на две группы, в одну из которых входят разновидности, обладающие некоторым конкретным свойством, а в другую - все остальные, этим свойством не обладающие. Например, деление двигателей на электрические и неэлектрические, при котором во второй член войдут и лошадь, и реактивный двигатель, и двигатель внутреннего сгорания, и все остальные двигатели, не использующие электроэнергию.

Ну а теперь, когда все правила логического деления названы, самое время потренироваться в исполнении этой ответственной операции.

Упражнения:
1. Выполните второе задание предыдущей группы упражнений.
2. По какому признаку (основанию) и на какие группы Вы разделите кофемолки? блокноты? подшипники? республики?
3. Какие правила были автором нарушены при делении понятия “металлорежущий станок”?

Выполняя второе задание этой группы упражнений, Вы, наверное, почувствовали, что оснований деления для каждого объекта существует несколько, и какое из них выбрать, вопрос непростой. Если речь идет не об учебном упражнении, а о реальной ситуации, то выбор основания подсказывает жизнь: основание должно быть наиболее существенным в данной ситуации. При этом генерируется так называемая “естественная” классификация. Однако кроме естественной нам часто приходится пользоваться и искусственной классификацией. Простейший ее пример - алфавитный каталог библиотеки (но не забудьте, что там есть и систематический каталог, соответствующий естественной классификации изданий). А в некоторых частных библиотеках (и не только у “новых русских”) основанием для классификации (т.е. размещения на полках) книг могут служить и такие “существенные” основания, как формат книги, а иногда и цвет корешка.

Понятие “существенности” основания деления тоже отнюдь не просто и отнюдь не стабильно. Существенность признака зависит и от уровня знаний, и от конкретной ситуации, и от точки зрения, так что нельзя забывать, что классификация любых объектов может быть проведена не единственным образом.

Достаточно часто встречаются ситуации, когда объекты, подлежащие классификации, имеют сразу несколько “равносущественных” признаков, каждый из которых имеет одинаковое право быть основанием деления данного уровня. В этом случае обычная, иерархическая классификация уступает место комбинативной или фасетной классификации, когда деление одного и того же уровня проводится сразу по двум или большему числу оснований, и одномерные линейки вариантов по каждому из равнозначимых оснований пересекаются, образуя многомерную матрицу, каждый элемент которой является видовым понятием или членом фасетной классификации. Именно такая классификация лежит в основе наиболее известного из методов Ф. Цвикки - метода морфологического ящика [2].

Пример фасетной классификации приведен на рис. 9 для объекта “Наземное транспортное средство”. Заметим, что хотя в этой классификации некоторые из сочетаний двигателя и движителя представляются нереальными или даже бессмысленными, наличие их в матрице обязательно (иначе будет нарушено второе правило деления) и полезно с эвристической точки зрения. Тем не менее, в классификации рис. 9 допущен целый ряд ошибок.

Делимое - наземное транспортное средство

Основание деления - двигатель | Основание деления - движитель
 | колеса | ноги | гусеницы | винт | воздушная подушка
электрический |  |  |  |  |
внутреннего сгорания |  |  |  |  |
реактивный |  |  |  |  |
химический |  |  |  |  |
мускульный |  |  |  |  |
ядерный |  |  |  |  |

Рис. 9. Пример фасетной классификации

Упражнения:
 1. Найти ошибки в классификации рис. 9, объяснить и исправить их, составив корректную классификационную матрицу наземных транспортных средств по тем же двум основаниям.
2. Провести классификацию мужских рубашек. Сколько равносущественных оснований деления можно предложить для данной классификации?

Разобравшись с операцией деления, займемся теперь противоположной операцией - обобщением.

Обобщение - это логическая операция, заключающаяся в том, что для рассматриваемого понятия (или группы понятий) находят более широкое по объему понятие, в объем которого входит и объем обобщаемого исходного понятия (или объемы исходных понятий).

Итак, обобщать можно либо группу объектов, либо один-единственный. Что касается обобщения группы объектов, то здесь не обойтись без пары вспомогательных логических операторов: сравнения и различения. С их помощью удается выявить и то общее, что есть у всех объектов данной группы, и те различия, которыми можно охарактеризовать либо все элементы данной группы, либо индивидуальные пары (попарное сходство и различие). В таком случае мы получаем тот же комплект понятий, что и при операции деления: обобщенное понятий или родовое (аналог делимого понятия), основание обобщения (аналог основания деления) и исходные члены - видовые понятия (аналог членов деления). Правда, при задании исходной группы объектов редко заботятся о соблюдении всех правил деления, в результате часто оказывается, что члены заданной группы находятся на разных уровнях общности, что они различаются не по единственному признаку, а по нескольким, и в итоге вместо простенькой одноступенчатой операции обобщения приходится выстраивать сложную многоступенчатую (а иногда и многомерную) классификацию, дополняя ее сверх исходной группы еще большим количеством элементов. Это, кстати, имеет очень существенное эвристическое значение, т.к. позволяет заметно расширить область анализа, введя в нее и те объекты, которые по забывчивости или по недостатку знаний не попали в исходную группу.

Рассмотрим такой пример. Дачный участок москвича в 100 км от города, дощатая избушка “на курьих ножках”, летний отпуск и плохая погода. Холодно, особенно ночью. Надо обогреть избушку. На ум приходят следующие варианты обогревателей: печка, примус, электрокамин. Попробуем, отталкиваясь от этих трех объектов, построить классификацию обогревательных устройств и посмотреть, не найдется ли в ней чего подходящего.

Что общего у этих объектов?
1. Все они дают тепло.
2. Все они используют нетепловую энергию.
3. Все они находятся внутри отапливаемого помещения.

Что различного у этих объектов?
1. Источники энергии.
2. Вид отходов (нежелательного побочного продукта).
3. Занимаемый в помещении объем.
4. Необходимость дополнительных условий (или мероприятий) в помещении.

Итак, обобщающее понятие можно сформулировать, базируясь на всем общем: “Обогревательные устройства, использующие нетепловую энергию и находящиеся внутри отапливаемого помещения”. И для этого обобщающего понятия построим матрицу вариантов его реализации:

 |  | Печка | Примус | Электрокамин
А. | Источники энергии | 1. Дрова | 2. Керосин | 3. Электроэнергия
Б. | Вид отходов | 1. Дым, зола | 2. Запах, копоть | 3. Нет
В. | Объем (форма) | 1. Массивная конструкция >0,5*0,5*1 м3 | 2. Небольшая конструкция Æ20*15 см3 | 3. Плоский экран 50*30*5 см3
Г. | Дополнительные условия | 1. Вывод трубы | 2. Нет | 3. Электропроводка

Получилась небольшая (неполная) морфологическая матрица, составленная пока исключительно из характеристик пришедших на память существующих объектов. Однако в матрице-классификации появились и загадочные новые объекты, например, А3Б3В3Г2 - электрокамин, питающийся не от сети (электропроводка отсутствует), а от какого-то иного источника электроэнегрии (солнечная батарея, что ли?); А2Б3В3Г2 - каталитический окислитель керосина (ага, а ведь бензиновые грелки такие уже есть); А2Б3В1Г1 - жидкотопливная печка. Но кроме того, напрашивается и пополнение матрицы: например, в первую строку можно бы добавить и тепло, и свет. Во вторую строку добавлять что-либо не нужно (отходов человек и так производит сверх головы), в третью строку можно добавить интересный вариант - ноль, т.е. отопительное устройство места внутри помещения не занимает (оно - в стене или в полу, например). В соответствии с этим четвертая строка пополнится встроенным в стену (или в пол) тепловыделяющим элементом. Кстати, некоторые из этих предложений выводят нас за пределы матрицы, т.к. в ней изначально мы предполагали только устройства, использующие нетепловую энергию и находящиеся внутри помещения (а так ли это важно для замерзшего дачника?). А ведь можно греть помещение и направленным излучателем энергии через окно, например. Или использовать аккумулятор тепла (хотя бы резервуар воды, нагретой днем солнечным излучением).

Как видно из этого примера, применение логического оператора классификации дало достаточно пищи для размышления мерзнущего дачника. Вплоть до альтернативных источников автономного теплоснабжения, не использующих никаких платных энергоносителей.

Упражнения.
 1. Найти, что общего и что различного в следующих объектах: мотоцикл, весельная лодка, воздушный шар. Построить классификацию, в которой нашли бы место все три объекта.
2. То же самое задание для объектов: армия, путешественник, фермерское хозяйство.
3. То же самое задание для объектов: триптих, сериал, рассказ.

Особый случай представляет обобщение одного-единственного понятия или объекта. Из всего необъятного набора свойств заданного объекта надо выбрать одно - то самое, которое и даст возможность найти основание обобщения. Какое из этих свойств является наиболее существенным (а именно этим определяется качество или естественность обобщения) - зависит от ситуации, применительно к которой рассматривается объект. Обычно главное свойство или главная функция объекта просматриваются хорошо, так что проблема выбора признака обобщения решается без особого труда. С другой стороны, каждый из более или менее существенных признаков можно взять за основу для выбора основания обобщения, и такая многовариантность обобщения может оказаться очень полезной, опять же вовлекая в поле зрения варианты или объекты, на которые иным путем просто не выйти.

Очень тонким и очень важным фактором является шаг деления или шаг обобщения. Изучаемые логические операторы эффективны в творческой деятельности только тогда, когда шаг минимален, но существенен. Действительно, что толку для изобретателя, исследующего способы повышения надежности микросхем, если в результате одного шага обобщения этих объектов он получит “устройство для удовлетворения человеческих потребностей”, в множество которых войдут и ночной горшок, и самолет. Ненамного больше толку получится, если при одноступенчатом делении этого же исходного понятия придется иметь дело сразу со всеми 8000 типов микросхем самого разного назначения и исполнения. Поэтому шаг обобщения или шаг деления должны выбираться так, чтобы видовые понятия различались по возможности минимальным количеством свойств или признаков (в идеале - одним). Однако практически добиться этого не так просто, и только с опытом приходит умение находить (чаще всего методом последовательных приближений) то самое основание обобщения или деления, используя которое, Вы действительно упорядочите свое понимание предмета, а не заведете себя в тупик.

Возвращаясь теперь к оператору расчленения, стоит вспомнить, что этот логический (т.е. мысленный) оператор сродни физическому (т.е. исполняемому руками) оператору, которым пользуется всякий мало-мальски любопытный мальчуган, дорвавшись до незнакомого устройства, будь то заводная игрушка или папины часы. Различие, пожалуй, в том, что элементы, полученные мальчуганом после применения этого физического оператора, уже никак и никогда не назовешь исходным объектом, как их ни соединяй.

И наконец, последний из четверки операторов - соединение. Это - антипод расчленению, и после реализации этого логического оператора Вы выходите на объект, выполняющий совершенно иную функцию, чем исходный, а исходный объект является лишь составной частью надсистемы, полученной в результате соединения. И еще одно полезное правило: в процессе соединения Вы вводите исходный объект во взаимодействие с другими, принципиально иными по своему функциональному назначению.

Более подробное знакомство с операторами расчленения и соединения состоится позже, а сейчас, в заключение этого краткого экскурса в область логики рассмотрим на примерах, как реализуются все четыре оператора применительно к одному и тому же исходному объекту и как различаются результаты этих действий.

Пример 1. Исходный объект - гвоздь.

Начнем с деления. Основание деления можно выбрать, например, из такого комплекта свойств: форма, материал, назначение (область применения). Остановимся на последнем, тогда получаем следующие разновидности гвоздей по назначению: сапожные, кровельные, мебельные, плотницкие, корабельные, декоративные и прочие.

Обобщение. Этот оператор реализовать значительно проще, если удастся сформулировать удачное явное определение исходного объекта через род и видовое отличие. Попробуем использовать такое определение: “Гвоздь - это крепежный элемент для соединения деревянных конструкций, представляющий собой цилиндрический стержень с заостренным концом и шляпкой на другом конце”. Родовое понятие “крепежный элемент” - именно то, что нам сейчас и нужно, т.е. результат обобщения. Полезно себя проверить, задав вопрос: “А какие еще известны крепежные элементы?”, т.е. просмотрев возможности деления полученного обобщенного понятия. В данном случае все в порядке: есть еще и шурупы, и винты с гайками, и скобы, и другие элементы. (А иногда бывает так, что полученное обобщенное понятие не делится; тогда это означает, что Вы вместо обобщенного понятия получили синоним исходного, и надо работать внимательнее)

Расчленение гвоздя провести не составляет труда, т.к. в нашем родо-видовом определении видовое отличие сформулировано именно в виде набора конструктивных элементов. Результат расчленения: шляпка, цилиндрический стержень, острие.

Соединение. В учебном варианте можно вспомнить любую конструкцию, скрепленную гвоздями, например, посылочный ящик. Реально же в практике творческой деятельности надсистема определяется однозначно той реальной системой или устройством, в котором работает исходный объект (но плохо работает, иначе бы и задачи не было). Требование минимизации шага соединения заставляет назвать конкретный конструкционный узел, элементы которого скреплены нашим гвоздем (ведь в разных узлах качество “работы” гвоздя может оказаться совершенно различным). В посылочном ящике все элементы (фанерные стенки, дно, крышка, деревянные рейки) имеют прямое отношение к нашему исходному элементу.

Рис. 10. Четырехзвенник объекта "гвоздь".

Результат наших действий удобно представить в виде наглядного четырехзвенника рис. 10. На рисунке легко просматривается принцип расширения поля зрения на этапах обобщения и соединения (привлекаются иные объекты) и даже частично на этапе деления. С другой стороны, оператор расчленения позволяет “спуститься вниз”, к деталировке исходного объекта. В изобретательской практике это позволяет спроектировать, спустить проблемную ситуацию с объекта в целом на какую-либо его структурную часть.

В качестве второго примера взят исходный объект из иной сферы человеческой деятельности, результирующий четырехзвенник приведен на рисунке 11 без комментариев.

Рис. 11. Четырехзвенник объекта "магазин".

Упражнения:
 1. Составить четырехзвенник, подобный изображенному на рисунках 10-11, для одного из следующих объектов: “резистор”, “швейная игла”, “аспирин”.
2. То же задание для одного из следующих объектов: “горение”, “грипп”, “град”.
3. То же задание для одного из следующих объектов: “парламент”, “премия”, “путешествие”.

При выполнении упражнений обратите внимание на особенности применения логических операторов к объектам типа “предмет” и к объектам типа “процесс”.


Основные положения системного подхода

Системно-морфологический подход
в технике, науке, социальной сфере.
Титов В.В.

3. Системный подход: основные положения

3.1. Основные определения

Слово "система" стало излюбленным (и вследствие этого избитым) в речах всех любителей трибун и совещаний, поэтому точный смысл его давно расплылся (в чем легко убедиться, попросив любого краснобая сказать, что он под этим термином разумеет). В литературе существует более сорока определений этого термина, каждое из которых ориентировано на ту или иную область знаний. Один из основателей общей теории систем Л.Берталанфи [1] дал весьма краткое определение: "Система есть комплекс взаимодействующих элементов", из которого следуют два главных признака системы:

1) система состоит из дробных частей (элементов);

2) эти элементы представляют собой не случайную совокупность, соседство, а каким-то образом между собой взаимодействуют, т.е. между ними существуют определенные связи.

Если это краткое определение слегка развернуть с учетом названных признаков, то получится довольно работоспособная формула: "Система - это упорядоченное определенным образом множество элементов, взаимосвязанных между собой и образующих некоторое целостное единство" [3]. Важным дополнением к этому определению является замечание, что любая система представляет собой элемент системы более высокого порядка (надсистемы), а ее элементы, в свою очередь, обычно выступают в роли систем более низкого порядка (подсистем) [3].

Система характеризуется составом элементов, структурой и выполняет определенную функцию.

Элементы - это относительно неделимые части целого, объекты или операции, которые в совокупности образуют систему. Элемент считается неделимым в пределах сохранения определенного качества системы. Например, в микрокалькуляторе блок питания является элементом, который можно рассматривать как неделимое целое, поскольку тот факт, что блок питания имеет сложное устройство и сам состоит из многих деталей, имеет для системы "микрокалькулятор" весьма несущественное значение. Другой пример - бухгалтерия предприятия. Если предприятие рассматривать как систему, то бухгалтерия - это элемент данной системы, который в известной степени можно представить как неделимое целое, обеспечивающее определенную часть жизнедеятельности предприятия. Пример из другой области - интегрирование. В рамках учебного курса “математический анализ” этот раздел представляет собой замкнутую часть целого, которую изучают именно как элемент курса, но вместе с тем это - разветвленная самостоятельная дисциплина, включающая в себя множество подразделов, правил и процедур.

Структура - это закономерные устойчивые связи между элементами системы, отражающие пространственное и временное расположение элементов и характер их взаимодействия. Именно структура делает систему некоторым качественно определенным целым, так как структура предполагает взаимодействие элементов друг с другом по-разному, выдвигая на первый план те или иные стороны, свойства элементов. Структура является важнейшей характеристикой системы, так как при одном и том же составе элементов, но при различном взаимодействии между ними меняется и назначение системы, и ее возможности. В подтверждение этого на рис. 12 приведен пример пары различных систем, построенных из одних и тех же элементов.

Рис. 12

Другой характерный пример - в стихотворении С.Я.Маршака "Мельник, мальчик и осел", где упомянутая троица по пути домой из одних и тех же элементов, перечисленных в названии, создавала разные системы, но никак не могла угодить общественности, и закончилось все это, если помните, так:

Тьфу ты ! - хохочет народ у ворот:
- Старый осел молодого везет !

Функция - это внешнее проявление свойств объекта (системы или ее элемента) в данной системе отношений, определенный способ взаимодействия объекта с окружающей средой. Чаще всего функции проявляются в форме действий и отражают возможности системы.

Например, функцией товарной биржи как системы является предоставление возможности купить или продать товар клиентам без лишних затрат личного времени на поиск контрагента. Функция брокера как элемента этой системы - это поиск контрагента в соответствии с заявкой клиента. Другой пример: функции турникета в проходной предприятия - исключить возможность неконтролируемого прохода на территорию и обеспечить возможность поочередного контроля проходящих. Еще пример: функция витрины магазина - показать товары потенциальному покупателю.

Надо заметить, что большинство систем или их элементов выполняют не одну, а несколько функций. При этом из всего перечня функций объекта всегда можно выделить одну (реже - две) наиболее важную его функцию в данной системе отношений. Эта функция называется главной полезной функцией (ГПФ) объекта и, как правило, соответствует первоначальной цели создания или использования объекта. Действительно, если я взял в руку палку при появлении поблизости злой собаки, то ГПФ палки - защитить мои брюки и ноги от повреждения ее зубами, но если я взял ту же палку, чтобы заделать дыру в заборе, то ГПФ этой палки уже совсем другая - перекрыть доступ через дырку для незваных двуногих и четвероногих посетителей. Конструктивные элементы системы следует отличать от подсистем, являющихся частями системы. В качестве подсистемы обычно выступает выделенная по функциональному признаку группа элементов. Иногда подсистема содержит всего один элемент; с другой стороны, один и тот же элемент может входить сразу в несколько подсистем. В таблице Рис. 13 приведены примеры такой "многоликости".

Система | Элементы | Подсистемы и их состав
Авторучка перьевая | Перо Баллон для чернил Корпус Поршень Колпачок Держатель | Подсистема письма (перо, баллон) Подсистема набора и хранения чернил (баллон, корпус, поршень) Подсистема защиты пишущего узла от повреждения(корпус, колпачок) Подсистема защиты костюма от загрязнения чернилами (колпачок) Подсистема крепления, фиксации авторучки (колпачок, держатель)
Вексель | Бумажный носитель Физические и полиграфические элементы защиты Реквизиты векселя Управляющие надписи на векселе | Подсистема идентификации векселя (бумажный носитель, реквизиты) Подсистема актуализации векселя (реквизиты, управляющие надписи) Подсистема защиты от подделки (физические и полиграфические элементы защиты, бумажный носитель)
Завод | Дирекция Бухгалтерия Планово-экономический отдел Отдел сбыта Отдел снабжения Отдел основного производства Отдел рекламы Отдел кадров И т.д. | Административно- управленческая подсистема (дирекция, бухгалтерия, планово-экономический отдел, отдел кадров) Подсистема производства (отдел основного производства, вспомогательные производственные группы, отдел снабжения) Подсистема внешних сношений (дирекция, отдел снабжения, отдел сбыта) Подсистема перспективного планирования и маркетинга (дирекция, планово-экономический отдел, отдел кадров, отдел рекламы, отдел сбыта)

Рис. 13. Примеры систем и их состава.

Возможно, деталировка второго и третьего столбцов этой таблицы покажутся читателю сомнительными или неполными. В таком случае попробуйте сами для сомнительных случаев определить и перечень элементов, и перечень подсистем. Позже мы вернемся к этому вопросу и поясним причины этих сомнений, а пока продолжим знакомство с основными определениями.

Все системы, независимо от их природы, обладают рядом общих свойств.

Целостность системы означает, что комплекс объектов, рассматриваемый в качестве системы, обладает общими свойствами, функцией и поведением, причем свойства системы не сводимы к сумме свойств входящих в нее элементов.

Делимость системы отражает тот факт, что любой объект можно представить состоящим из элементов. В соответствии с этим любой объект нужно рассматривать в трех аспектах: как нечто целое (систему), как часть более общей системы (надсистемы) и как совокупность более мелких частей (подсистем). Способность всегда представить себе эти три (как минимум!) этажа является краеугольным камнем, основной характеристикой системного подхода.

Любую составную часть системы можно выделить и рассматривать отдельно, изолированно. Однако эта изолированность относительна, так как всегда необходимо помнить, что взаимодействие между выделенной частью и ее окружением в системе в той или иной мере влияет на поведение и свойства этой выделенной части.

Именно это свойство - делимость - позволяет упростить изучение и преобразование даже очень сложных систем, не упустив при этом ничего существенного.

Чтобы представить степень общности системного подхода, ниже приведены примеры систем и некоторые элементы этих систем.

Система | Примеры элементов системы
Государственная система | Парламент, министерство, ...
Экологическая система | Симбиотическое сообщество растений, животных, ...
Автомобиль | Мотор, кузов, ...
Наука | Раздел, ...
Нервная система | Спинной мозг, нервное волокно, ...
Ландшафт | Долина, роща, озеро, ...
Мировоззрение | Принцип, этическое правило, ...
Законодательство | Таможенный кодекс, Закон “О ветеранах”, ...
Товарная биржа | Расчетная палата, брокер, ...
Таракан | Голова, ноги, ...
Библиотека | Стеллаж, картотека, ...
Токарный станок | Станина, суппорт, резец, ...

Ясно, что при таком разнообразии систем не обойтись без их классификации. И действительно, существует множество классификаций систем [16]. Например, системы можно классифицировать по таким признакам:
1) по происхождению (естественные, искусственные),
2) по типу элементов (абстрактные, конкретные),
3) по виду элементов (материальный предмет, процесс, информационный блок),
4) по состоянию (статические, динамические),
5) по связям с окружением (открытые, закрытые).

Сейчас для нас наиболее важным является разделение систем на естественные (возникающие и существующие независимо от человека и его воли) и искусственные (созданные человеком сознательно для прямого или косвенного удовлетворения какой-либо своей потребности). Мы сосредоточим внимание на искусственных системах, поскольку и разнообразие их, и актуальность для человека, и, как это ни странно, недостаточная степень познания (а ведь они - дело рук самого человека!), и, наконец, важность их для преуспеяния человека, - все это дает достаточно оснований для нашего выбора.

Искусственные системы, в свою очередь, можно разделить на несколько классов, каждый из которых по-своему касается человека. Вот эти классы:

  1. Технические системы (машины, приборы, аппараты, технологии, и т.п.),
  2. Социальные системы (государство, город, профсоюз, выборы, и т.п.),
  3. Информационные системы (наука, связь, пресса, обучение, и т.п.),
  4. Культурологические системы (философия, театр, этика, живопись, и т.п.)

Уже эта классификация дает ответ на вопрос о причинах сомнений читателя в корректности содержания таблицы Рис. 13. Дело в том, что творения рук человеческих неизбежно встраиваются не в одну, а в несколько надсистем, и в каждой из них и окружение нашей системы, и принципы ее "деталировки" различны. Например, телевизор - это техническая система? Да, конечно. Это информационная система? Пожалуй, в чистом виде нет, но он входит в информационную надсистему связи. Это социальная система? Нет, но в социальной надсистеме "город" ему отведено определенное место. Впрочем, телевизор можно рассматривать и как самостоятельную информационную систему (это мы сделаем ниже), и как элемент культурологической надсистемы "телевидение" (заметим, что надсистема "телевидение" существует и в социальной сфере, но это совсем другая надсистема!). И разумеется, в каждой из названных надсистем основными, наиболее существенными с точки зрения роли телевизора в надсистеме будут совершенно разные его свойства, элементы.

Другой пример - валютная биржа. Это техническая система? Нет, конечно, но в самой валютной бирже работает множество технических систем (строительные конструкции, технические средства жизнеобеспечения: освещение, отопление, вентиляция, и т.п.). Это социальная система? Безусловно, слишком сильно она связана с социальными процессами в обществе, так же как и с другими социальными структурами. Это информационная система? Конечно, и сама она напичкана информационными подсистемами, и внешние ее связи - почти исключительно информационные. Это культурологическая система? В целом, наверное, нет, но влияние ее наличия и функционирования на мировоззрение, этические принципы и нормы достаточно значительно, т.е. она в той или иной мере связана с культурологическими системами.

Упражнения:
 1. Охарактеризовать перечисленные ниже объекты как системы с точки зрения их происхождения, типа, вида, состояния, связей с окружением и класса (последнее - только для искусственных систем):
а) перчатка, б) садовая земляника, в) ветер, г) лимфа, д) стая, е) митинг, ж) закон, з) совесть, и) книга, к) пруд, л) булыжник, м) праздник, н) воспитание, о) гавань.
2. Определить элементный состав следующих систем: а) облако, б) задача, в) собрание акционеров, г) виноградник, д) рабочий день, е) ложь, ж) муравейник, з) гайка, и) стол письменный, к) ботинки.
3. Какие функции выполняют следующие системы: а) деревенская улица, б) кассовый аппарат, в) семья, г) русло реки, д) верблюд, е) парус, ж) грядка, з) нора?. Какие из этих функций наиболее важны, какие - второстепенные?

3.2. Системное представление объекта

Первый шаг системного анализа - представление изучаемого объекта в виде системы. Для искусственной системы этот шаг сводится к выявлению и словесному определению следующих понятий:
а) надсистема, в которую входит объект,
б) главная полезная функция объекта,
в) перечень подсистем объекта,
г) структура системы.

Простота формулировок этого первого шага отнюдь не означает простоты его исполнения. Коварный ложный след ожидает неопытного аналитика уже на первом этапе - этапе определения надсистемы. Слишком часто вместо надсистемы хочется назвать всего лишь обобщенное определение исходного объекта, а эта ошибка заводит в тупик, который ощущается неопытным аналитиком только на следующих шагах системного анализа. Проверьте себя и попробуйте в качестве упражнения для приведенных в таблице примеров выбрать надсистему из нескольких предложенных (а может быть, и не только из предложенных). В этом поможет Вам материал раздела 2.2, где для различения “неразлучной” четверки логических операторов используются вспомогательные тест-вопросы.

№ | Исходный объект | Варианты надсистемы
1 | Электромотор | Двигатель Электродрель Зубоврачебный кабинет Изделие электротехнической промышленности
2 | Немецкая овчарка | Порода собак Население моей квартиры Питомник Теплокровное животное
3 | Закон "О предприятиях и предпринимательской деятельности" | Предпринимательство Гражданское законодательство Документ, регламентирующий конкретный вид человеческой деятельности Книга "Как зарегистрировать предприятие"
4 | Токарный станок | Устройство для обработки металла Цех металлообработки Завод металлоконструкций Машиностроение Магазин “Домашний мастер”
5 | Деньги | Платежное средство Рынок Валюта Товарообмен Семейный бюджет

В данном случае этот способ реализуется так. Чтобы проверить корректность определения надсистемы, можно воспользоваться двумя правилами:

1) Задайте себе вопрос: "Является ли <исходный объект> <надсистемой>?". Правильный ответ - "Нет, не является" (в противном случае имеет место не соединение, а обобщение исходного понятия).

2) Проверьте, корректно ли звучит вопрос: "Какую функцию выполняет <исходный объект> в <надсистеме>?"

Кстати, второй вопрос, если он оказывается корректным, сразу же выводит на ответ о главной полезной функции нашей системы.

Дальнейшее исполнение первого шага системного анализа (определение подсистем и структуры), как правило, затруднений не вызывает, но часто оказывается неполным. Впрочем, эта неполнота не смертельна и не должна особенно беспокоить аналитика, т.к. на следующем шаге она неизбежно выявится и будет скорректирована.

После этих первоначальных понятий о системном анализе полезно потренироваться и закрепить прочитанное не только знанием, но и умением это знание применить.

Упражнения:
1. Представить в виде системы 2-3 объекта из числа следующих: карандаш, плафон, касса, амперметр, литейный участок, город, изгородь, река, стая, справочник химика, хранение картофеля, IBM PC, платежное поручение, фьючерсный контракт, подъезд, ухо, отвертка, вирус, техника игры на гитаре.
2. Из одного и того же набора из 3-4 элементов сконструировать не менее двух различных систем. Изобразить графически структуру каждой системы (если возможно, наподобие рис.12)
3. Определите, какие из предложенных систем естественные, а какие - искусственные: государство, нация, магазин, рынок, капитализм, семья, инфляция, девальвация, шайка, парк, живая изгородь, булыжник, заповедник, эпидемия, мумиё, стадо, буль-терьер, война, нефть, курорт, миграция населения, иностранец, шоссе.
4. Назвать главную полезную функцию (ГПФ) для каждой из следующих систем: электрометр, овчарка, токарный станок, рубль, ракета, метафора, картина, выборы, магазин, блокнот, нотариат.

4. Системное исследование объекта

После этой операции - представления объекта в виде системы - следующим, основным шагом является системное исследование объекта. Полное и правильное представление о системе можно получить, лишь осуществив это исследование в трех аспектах: предметном, функциональном и историческом.

Тип анализа | Направленность анализа
 | Внутрь | Наружу
Предметный | Анализ строения и внутренних связей системы | Анализ строения надсистемы и внешних связей исследуемой системы
Функциональный | Анализ внутреннего функционирования системы, “работы” ее связей | Анализ внешнего функционирования системы, ее входов и выходов
Исторический | Генетический анализ системы | Прогноз развития системы

При этом существенную помощь могут оказать наводящие, тестовые (проверочные) вопросы, перечисленные ниже в таблице Рис. 14.

Тип анализа | Тест-вопросы
 | Внутренний анализ | Внешний анализ
Предметный | Из чего состоит система? Как связаны между собой элементы системы? | Какие еще системы входят в надсистему, кроме нашей? Как в надсистеме наша система связана с другими?
Функциональный | Как работает каждый элемент системы? Какие внутренние функции выполняет каждая из подсистем, входящих в нашу систему ? | Как наша система в целом работает в надсистеме? Какие внешние задачи решает система?
Исторический | Когда и в каком виде возникла система? На каком этапе жизненного цикла находится система? | Как, в каком направлении будет развиваться система? Что будет модифицироваться в системе в первую очередь ?

Рис. 14. Тестовые вопросы системного анализа.

Целью предметного анализа является ответ на два вопроса:
1. Из чего состоит наша система? (элементный анализ)
2. Как связаны между собой элементы системы? (структурный анализ)

Основой предметного исследования являются главные свойства системы - целостность и делимость. При этом элементный состав и набор связей между элементами системы должны быть необходимыми и достаточными для существования самой системы. Очевидно, строгое разделение (и тем более противопоставление) элементного и структурного анализа невозможно ввиду их диалектического единства, поэтому в предметном анализе эти виды исследований проводятся параллельно.

Этим, однако, предметный анализ не исчерпывается. Необходимо еще установить место рассматриваемой системы в надсистеме и выявить все ее связи с другими элементами этой надсистемы. Поэтому, например, системный анализ одной и той же двери может проходить по-разному в зависимости от того, где эта дверь находится (в комедии Фонвизина "Недоросль", если помните, Митрофанушка обосновал по этому принципу даже более суровую классификацию дверей). На этой стадии предметного анализа ищут ответы на другую пару вопросов:
1. Из чего состоит надсистема, в которую входит наша система?
2. Как в надсистеме наша система связана с другими?

Второй аспект системного исследования - функциональный. Фактически это анализ динамики тех связей, которые были выявлены и идентифицированы на этапе предметного анализа. Функциональное исследование отвечает на вопросы:
1. Как работает каждый элемент системы? (для внутреннего функционирования)
2. Как работает наша система в данной надсистеме? (для внешнего функционирования)

Историческое исследование тоже относится к динамике, но уже к другой - к динамике развития системы. Жизненный цикл любой системы разделяют на несколько этапов: возникновение (зарождение), становление, эволюция, разрушение или преобразование. Историческое исследование предполагает проведение генетического анализа, при котором прослеживается история развития системы и определяется текущая стадия ее жизненного цикла, и прогностического анализа, намечающего пути ее дальнейшего развития.

Если в достаточно многочисленной аудитории Вы попросите дать ответ на вопрос, с какого из шести видов анализа следует начинать исследование конкретной системы, то скорее всего ответы распределятся более или менее равномерно между пятью вариантами (прогноз развития системы все безусловно считают заключительной стадией анализа). Действительно, первые шаги анализа могут быть направлены по любому из пяти направлений. Все зависит от вида объекта, от отношения к нему решателя-аналитика и от ситуации, в которой решается задача. Если решатель знает систему так, что сможет разобрать и собрать ее "с закрытыми глазами", то первым будет предметный анализ. Если решатель эксплуатирует систему очень давно и знает все ее капризы, он начнет с функционального анализа (внешнего или внутреннего - это уж зависит от того, приходилось ли ему "чинить" исследуемый объект). Если решатель охотнее всего работает с литературой, ему проще начать с генетического анализа.

Однако с чего бы ни начинался анализ системы, очень скоро все выходит на общий путь. Дело в том, что системный анализ - это познание объекта, развитие нашей системы знаний об исследуемом объекте, а любое развитие, как известно, идет по спирали, возвращаясь к уже пройденным этапам каждый раз на новом, более высоком уровне (вспомните метод систематического покрытия поля Цвикки, о котором говорилось в разделе 1.2). Поэтому на любой стадии системного анализа случается привлекать и аппарат, и результаты остальных. Иными словами, процесс системного анализа объекта меньше всего похож на процесс, скажем, школярского изучения географии: "Америку прошли, забудем, теперь Африку начнем". Нет, здесь перед аналитиком постоянно расширяющийся фронт знаний, тесно связанных между собой, и любое продвижение на любом участке меняет ситуацию в целом, давая информацию для продвижения на других участках. Поэтому после "первого витка" системного исследования начинается "спиральное" движение, поочередный обзор сведений на всех направлениях, их коррекция и дополнение с учетом каждого очередного "шага в незнаемое". И кончается эта спираль тогда, когда при очередном "обходе" всего поля знаний вы уже ничего не можете добавить к тем сведениям об объекте, которые у вас имеются. Это и есть та граница, за которой исследователь должен превратиться в провидца, предсказывающего, как все пойдет дальше.

Прежде чем переходить к деталям системного анализа, рассмотрим подробнее несколько частных классов систем. Из искусственных систем наиболее простыми (для анализа) являются технические системы. При этом следует сразу отметить, что в технике (как, впрочем, и везде) приходится иметь дело как с системами типа "предмет" (машины, аппараты, приборы), так и с системами типа "процесс" (способы, технологии, операционные системы, организационные системы). Терминология и внутреннее содержание анализа для этих двух типов систем часто расходятся, и довольно сильно, причем расхождения начинаются прямо с ключевых определений.

В работе [3] дано достаточно детальное определение технической системы типа "предмет":

"Техническая система (предметная ТС) - это искусственно созданное материальное единство целесообразно организованных в пространстве и времени и находящихся во взаимной связи искусственных или природных элементов, имеющее целью своего функционирования удовлетворение некоторой общественной потребности; ТС и ее элементы являются носителями определенной формы движения материи (т.е. носителями определенного принципа действия)".

Для технической системы типа "процесс" можно предложить такое определение (построенное в рамках той же грамматической и смысловой структуры):

Техническая система (ТС - процесс, технология) - это искусственно выстроенная последовательность целесообразно организованных в пространстве и времени и находящихся во взаимной связи действий и операций, имеющая целью своей реализации удовлетворение некоторой общественной потребности за счет обработки или преобразования материальных объектов; техническая система (технология) и ее элементы всегда соотносятся с определенным классом (или классами) обрабатываемых объектов.

Как видно из сравнения формулировок, общие для обоих текстов смысловые места только подчеркивают искусственность систем, т.е. тот факт, что система создана человеком сознательно, специально для удовлетворения какой-то потребности человека и человеческого общества.

Главная полезная функция (ГПФ) системы соответствует цели ее создания и существования. Отсюда ясно, что в состав ТС входят те элементы, наличие и взаимодействие которых необходимо и достаточно для осуществления ГПФ этой ТС.

Условия приемлемости данной ТС для общества тривиальны:
1. Возможности ТС должны обеспечивать выполнение ГПФ системы.
2. Потребности ТС не должны превышать допустимых затрат на выполнение ее ГПФ.

Под возможностями ТС понимают, что и как делает данная система; под потребностями - что необходимо для ее существования и функционирования. Качество системы выражают обычно через ее эффективность:

Э =(полезный результат)/(затраты),

или, в случае несоизмеримости числителя и знаменателя, через набор физических эффективностей:

S Эф=(полезный выход)/(вход),

где входы и выходы рассматриваются как потоки (энергии, вещества или информации). Поскольку числитель и знаменатель в зависимости от вида и назначения ТС могут иметь наиболее существенное значение в разных плоскостях, то полезно в соответствии с этим выделить и определить пять видов физической эффективности (в правом столбце следующей таблицы приведены понятия, встречающиеся в литературе и непосредственно связанные с данным видом физической эффективности):

Вид физической эффективности | Вариант именования эффективности
Коэффициент использования энергии | КПД
Коэффициент использования времени | Скважность
Коэффициент использования массы (веса) | Полезная нагрузка
Коэффициент использования места (пространства) | Плотность упаковки (монтажа)
Коэффициент использования информации | Избыточность информации

У входов и выходов ТС есть одна особенность, которую тоже можно использовать для характеристики системы. Дело в том, что, кроме полезных входов и выходов, есть еще и бесполезные, и даже вредные. Таким образом, и по входам, и по выходам ТС всегда обладает некоторой избыточностью, которая непосредственно связана с эффективностью.

Внешний элементный и структурный анализ системы фактически имеет целью выявить ГПФ и в нулевом приближении определить полезные входы и выходы исследуемой системы. На этапах внутреннего предметного и функционального анализа выявляются многие побочные входы и выходы и происходит более четкое их разделение на полезные, бесполезные и вредные. При этом проводится и сегрегация свойств элементов системы. Из бесконечного набора свойств, которые характеризуют каждый конкретный объект, в данной системе (куда наш объект входит в качестве элемента) существеными являются лишь некоторые из них. Например, электромотор обладает рядом статических свойств (масса, объем, намагниченность корпуса, цвет окраски корпуса, наличие токоподводов, наличие смазки в подшипниках, расположение крепежных элементов, необходимость муфты для передачи вращения, и т.д.) и рядом динамических свойств (скорость вращения вала, электрическая мощность, механический момент на валу, шум, вибрация, тепловыделение, способность ослаблять винтовые крепления, пожароопасность, газовыделение, и т.д.). Пример из другой области: продавец (как элемент в системе "магазин") имеет рост, вес, цвет глаз, определенную манеру разговора, склонность к определенному стилю одежды, общее образование, специальное образование, и т.д. Что из этих свойств "идет в дело" в данной системе, зависит от ее назначения и от функций, которые данный элемент выполняет в системе. Все остальные свойства элемента либо остаются скрытыми, резервными, либо пополняют список бесполезных и вредных функций. Это очень важный факт, во многом определяющий резервы развития системы. Уметь вскрыть и использовать эти резервы - залог высокой эффективности поиска решения проблемы в целом.

Опыт показывает, что достаточно удобна и эффективна такая последовательность операций внутреннего предметного и функционального исследования ТС (впрочем, эта последовательность не является директивной, иногда полезнее как раз начать с последнего пункта):

1. Составление перечня элементов ТС.
2. Составление перечня попарных взаимодействий элементов и определение результата взаимодействий. Оформление матрицы или графа взаимодействий.
3. Составление списка возможностей ТС, которые обеспечиваются взаимодействием и свойствами элементов.
4. Определение подсистем данной ТС (одновременно с выявлением функций этих подсистем в данной системе).

По мере накопления опыта все эти операции с бумаги постепенно переводятся на уровень выполнения в уме (вплоть до подсознательного), и исследователь, в совершенстве овладевший системным подходом, сразу "видит" систему на всю глубину, все ее возможности и потребности; однако первый опыт набирается тщательным письменным и графическим исполнением этой последовательности. Рассмотрим, как это делается, на конкретных примерах. Однако прежде поясним, как будет строиться дальнейшее изложение материала в книге.

В названии этой работы связаны три довольно далекие друг от друга области человеческой деятельности, и представители их между собой почти не общаются. Свою задачу автор видит и в том, чтобы показать, что аппарат системного анализа одинаково эффективен даже в столь далеких областях. Однако некоторые свойства человеческой натуры заставляют заподозрить, что читатель охотнее будет знакомиться с разделом и примерами, ближе всего соотносящимися с его конкретными занятиями, чем с абстрактными для него "чужими" примерами. Поэтому дальше мы по каждому из основных вопросов будем проводить параллельно разбор нескольких примеров, предоставляя читателю право либо ознакомиться со всеми (и тем в несколько раз успешнее освоить метод), либо ограничиться тем из них, который ближе и понятнее.

Итак, поскольку мы начали с технических систем, то первым будет пример технический.

4.1. Пример 1. ПЫЛЕСОС

Допустим, что перед Вами поставлена задача разработки новой модели бытового пылесоса и Вы решили использовать для ее понимания и решения системный подход. Первый шаг - проверить, является ли пылесос системой. Да, является. Действительно, пылесос - это упорядоченный определенным образом комплекс элементов, взаимосвязанных и образующих некоторое целостное единство. Элементы системы: корпус, мотор, вентилятор, пылесборник, шланг, шнур питания, выключатель, вилка, и т.д.

Определим надсистему, в которую входит пылесос. Очевидно, надсистема - это некая система более высокого ранга. В принципе таких систем, более крупных, несколько, и надо быть очень внимательным, чтобы не ошибиться в выборе. В первую очередь приходят на ум следующие варианты надсистем:

1) средства уборки помещения,
2) бытовая электроаппаратура,
3) продукция конверсионного завода,
4) система жизнеобеспечения жилого помещения,
5) домашнее хозяйство.

Посмотрим, какие из этого "наобумного" комплекта надсистем действительно таковыми являются. На первый тест-вопрос (см. выше) правильный (отрицательный) ответ получается однозначно только для двух последних вариантов. Первый вариант вроде бы сомнителен (обратите внимание, что "средства" - во множественном числе, а "пылесос бытовой" - в единственном, поэтому первый тест-вопрос и звучит неестественно), но сомнения снимаются после формулирования второго тест-вопроса, который получается практически бессмысленным. Четвертый и пятый варианты надсистем проходят благополучно и по второму тест-вопросу, но здесь уже можно почувствовать некоторую разницу в уровне сравниваемых надсистем: последний вариант "домашнее хозяйство" охватывает более обширную сферу деятельности, т.е. более крупную надсистему, в которую входит и "система жизнеобеспечения жилого помещения".

Эта ситуация (о которой уже говорилось при рассмотрении логического оператора обобщения в разделе 2.2) довольно характерна для процедуры системного анализа, так что для максимальной эффективности процедуры нужно выбирать ту из альтернативных формулировок, которая наиболее близко и конкретно относится к исходному объекту исследования. Ведь не следует забывать, что в соответствии с принципом делимости для любой надсистемы есть надсистема следующего уровня, и т.д., вплоть до "человеческого общества", а то и "Метагалактики" или "Вселенной". Представляете себе, сколько всего лишнего придется проанализировать, если "выскочить" сразу от пылесоса на 2-3 этажа обобщения выше, в область городского хозяйства, например?

Кстати, можно рекомендовать еще один путь выявления надсистемы, состоит он в следующем. Если вначале определить ГПФ исходной системы, а затем выяснить, для чего, для какой цели нужна эта ГПФ, то вот эта "надцель" и будет функцией более высокого ранга, т.е. главной полезной функцией искомой надсистемы. После этого назвать собственно надсистему уже не представляет труда. В нашем случае ГПФ пылесоса - убирать пыль, т.е. обеспечивать чистоту в помещении. Для чего? Очевидно, для того, чтобы в этом помещении можно было есть (столовая), читать, писать (кабинет), спать (спальня), и т.д. В общем, для того, чтобы помещение могло эффективно выполнять свою основную функцию, чтобы оно жило.

Итак, в роли надсистемы для пылесоса выбран вариант 4 из нашего списка: это система жизнеобеспечения жилого помещения. С подсистемами проще: это подсистемы электропитания, воздухопровода, корпуса, сбора пыли с обрабатываемой поверхности, транспортировки, сепарации и накопления пыли, перемещения пылесоса. Нет нужды насиловать себя, выдумывая все менее и менее существенные подсистемы. Те из них, которые вы случайно упустите из виду при первом шаге, рано или поздно все равно о себе заявят.

Еще одно правило следует помнить на любой стадии системного анализа: можете быть уверены, что как бы вы ни старались осуществить эту стадию исчерпывающим образом, это так же невозможно, как дойти до горизонта: любая истина относительна и по мере углубления анализа объекта вы будете открывать в анализируемом объекте новые и новые стороны.

Просмотрев список подсистем, можно в принципе перейти к уточнению элементного состава, так как тот беглый перечень, который приведен в начале примера, может оказаться недостаточным для функционирования всех подсистем.

Таким образом, пылесос как техническая система обладает всеми ее атрибутами: целостность, делимость, ГПФ - все есть. В процессе обсуждения мы провели существенную часть внутреннего предметного анализа, осталось, собственно, оформить его в виде матрицы взаимодействия (поэлементного) или графа взаимодействия. Вообще говоря, граф взаимодействия гораздо информативнее (на нем можно выделить не только элементы, но и подсистемы) и нагляднее матрицы, но зато и намного сложнее и капризнее в оформлении, а в монохромном, одноцветном варианте работоспособный граф для более или менее сложных ТС сделать практически невозможно. Поэтому для пылесоса ограничимся матрицей Рис. 15.

 |  | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10
1 | Корпус |  |  |  |  |  |  |  |  |  |
2 | Мотор | + |  |  |  |  |  |  |  |  |
3 | Вентилятор | + | + |  |  |  |  |  |  |  |
4 | Пылесборник | + | - | + |  |  |  |  |  |  |
5 | Шланг | + | - | - | + |  |  |  |  |  |
6 | Насадки | - | - | - | - | + |  |  |  |  |
7 | Шнур питания | + | + | - | - | - | - |  |  |  |
8 | Выключатель | + | + | - | - | - | - | + |  |  |
9 | Вилка | - | - | - | - | - | - | + | - |  |
10 | Колеса | + | - | - | - | - | - | - | - | - |

Рис. 15. Матрица взаимодействия элементов пылесоса.

Обратите внимание на то, что в матрице задействована только половина клеток - пересечений. Наличие второй половины дает возможность сделать матрицу более информативной, если заменить смысловое значение значков "+" и "-" с простого ("есть связь (+)" и "нет связи (-)") на более сложное ("элемент А воздействует на элемент В (+)" и "элемент А не воздействует на элемент В (-)"). Практически это позволяет отразить не только факт наличия связи, но и ее направленность, и наличие (или отсутствие) обратной связи. Разумеется, можно и еще усложнить матрицу, вводя различные значки для обозначения механических (контактных), информационных (причинно-следственных) и иных типов связей, но - во всем нужна мера, перегруженность матрицы сделает очень сложным восприятие заложенной в ней информации и тем сведет на нет достоинства системного анализа.

Теперь попробуем разобраться с внешним предметным анализом пылесоса. Собственно, процедура его проведения аналогична, только, во-первых, на уровне более высокой общности (надсистема), а во-вторых, менее детальна, поскольку нас интересуют не все связи в надсистеме, а только те, которые касаются нашей системы. Поэтому здесь можно матрицу или граф заменить списком (см. Рис. 16).

Надсистема жизнеобеспечения жилого помещения 1. Средства освещения
2. Средства отопления
3. Мебель
4. Средства уборки (пылесос)
5. Вентиляция
6. Специфические для данного помещения предметы (книги - для библиотеки, плита - для кухни, и т.д.)
7. Стены, пол, двери (поверхности, ограничивающие помещение)

Рис. 16. Варианты надсистем для пылесоса.

Взаимодействие пылесоса со всеми этими элементами надсистемы обусловлено тем, что пыль садится везде, и тем, что пылесос в нерабочем состоянии надо где-то хранить. Связи, таким образом, будут влиять на форму насадок пылесоса (удобство очистки именно этого элемента надсистемы) и на форму и упаковку пылесоса (удобство хранения). Кстати, коробка (или ящик) для хранения пылесоса у нас на Рис. 15 отсутствует, надо ее добавить. В результате таблица Рис. 15а становится чуть больше, а выполнение процедуры простановки плюсов и минусов наводит на мысль, что наши разработчики, упаковывая свое детище в обычную коробку (к тому же картонную), ни в коей мере не думают о том, каково будет покупателю пользоваться этим пылесосом и утрамбовывать в недолговечную коробку все его непрочные сменные детали неудобных габаритов... (между прочим, вот Вам уже и изобретательское направление, повышающее конкурентоспособность Вашего товара на рынке).

 |  | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11
1 | Корпус |  |  |  |  |  |  |  |  |  |  |
2 | Мотор | + |  |  |  |  |  |  |  |  |  |
3 | Вентилятор | + | + |  |  |  |  |  |  |  |  |
4 | Пылесборник | + | - | + |  |  |  |  |  |  |  |
5 | Шланг | + | - | - | + |  |  |  |  |  |  |
6 | Насадки | - | - | - | - | + |  |  |  |  |  |
7 | Шнур питания | + | + | - | - | - | - |  |  |  |  |
8 | Выключатель | + | + | - | - | - | - | + |  |  |  |
9 | Вилка | - | - | - | - | - | - | + | - |  |  |
10 | Колеса | + | - | - | - | - | - | - | - | - |  |
11 | Коробка | + | - | - | - | + | + | + | - | + | + |

Рис. 15а.

Теперь можно переходить к функциональному анализу. Из соображений экономии места не будем перечислять тривиальные внутренние функции элементов пылесоса (хотя в общем случае делать это необходимо). Внешние функции пылесоса также известны. Кстати, все они имеют некоторое различие для пылесосов разных марок. В общем случае внешнее функционирование кратко описывается так:

1. Коробку с пылесосом извлекают из места хранения.
2. Производят сборку пылесоса в рабочее состояние (вынимают из коробки, включают вилку в розетку, присоединяют к корпусу шланг воздуховода, к нему присоединяют удлинители и необходимую насадку).
3. Включают пылесос и, меняя насадки, обрабатывают все запыленные поверхности, при этом пылесос перекатывают или переносят по помещению.
4. Закончив работу, пылесос выключают и производят разборку в исходное состояние.
5. (Нерегулярная операция) По заполнении пылесборника снимают крышку корпуса, извлекают (осторожно) пылесборник и вытряхивают пыль в пакет, мусорное ведро или мусоропровод, затем ставят пылесборник на место.
6. Укладывают пылесос и комплектующие детали в коробку и ставят коробку на место.

Уже этот перечень выявляет некоторые операции и узлы, явно требующие усовершенствования. Однако с пылесосом пока на этом остановимся и обратимся к другому примеру, из совершенно другой области.

4.2. Пример 2. РАСПРЕДЕЛЕНИЕ КВАРТАЛЬНОЙ ПРЕМИИ

Поскольку мы уже приняли за аксиому утверждение, что любой объект можно представить в виде системы, то давайте определим, что это за система и к какому типу и классу систем она относится. Очевидно, система - искусственная, т.к. создана она человеком и для его, человека, нужд. Очевидно, система относится к классу социальных систем (хотя и информационный, и технический аспект здесь просматриваются). И, наконец, очевидно, что наша система принадлежит к системам типа "процесс".

Попробуем дать определение социальным системам типа "процесс". На помощь приходит неувядаемый язык словоблудов застойных времен, породивший для систем типа "процесс" суконное название "мероприятие". Итак:

Мероприятие (социальная система типа "процесс") - это искусственно выстроенная последовательность целесообразно организованных в пространстве и времени и находящихся во взаимной связи действий и операций, имеющая целью своей реализации удовлетворение некоторой общественной потребности за счет преобразования (создания, обработки, передачи, и т.д.) социально значимых ценностей; мероприятие всегда осуществляется людьми и цель его соотносится с определенной группой людей.

Следует заметить, что термин "мероприятие" в обиходе имеет сейчас более широкий смысл, поэтому подчеркнем, что в настоящей книге под мероприятием мы будем понимать именно то и только то, что подпадает под определение, приведенное выше (это и "выговор подчиненному", и "выборы в Государственную Думу", и "заселение Севера", и т.п.). Иначе говоря, данное определение является определением-предписанием (см. раздел 1.1).

Проверив исходный объект на соответствие приведенному выше определению и убедившись, что - да, распределение квартальной премии есть не что иное, как мероприятие в настоящем понимании этого слова, перейдем к определению надсистемы. Отметим, что надсистема должна быть тоже социальной, т.е. тоже мероприятием. "С листа" на роль "надмероприятия" можно предложить:

1. Возбуждение чувства материальной заинтересованности сотрудников предприятия.
2. Повышение благосостояния сотрудников предприятия.
3. Материализация справедливого вознаграждения за труд.
4. Реализация регламента оплаты труда на данном предприятии.

Проверяем корректность определения надсистемы теми же вопросами, что и для технической системы.

Является ли распределение квартальной премии возбуждением чувства материальной заинтересованности? Вопрос получился настолько запутанным и двусмысленным, что автор, например, не решается сказать ни да, ни нет. То, что мероприятие это возбуждает в коллективе самые противоречивые чувства, никто спорить не будет. Но вот только ли чувство материальной заинтересованности - это вопрос... Но в такой ситуации есть иной выход, чисто грамматический. Заменим в исходной формулировке отглагольное существительное "распределение" инфинитивом "распределить" и точно так же в формулировках каждого из потенциальных "надмероприятий" заменим первое слово на соответствующий инфинитив. И в этой новой окраске проверочные предложения преобразуются из вопросительной формы в изъявительную. А именно, первое предложение звучит теперь так:

1. Для того, чтобы < надмероприятие> , недостаточно только < мероприятие> . И если "инфинитивные" формулировки, подставленные в это предложение, формируют фразу, соответствующую реальному положению дел, то проверочная фраза наращивается следующим образом:

Для того, чтобы < надмероприятие> , недостаточно только < мероприятие> , нужно еще < S других мероприятий> . Здесь "S других мероприятий"- это все дополнительные мероприятия, которые в совокупности с нашим исходным составляют "надмероприятие" в полном его объеме. Если же инфинитивные формулировки имеют сомнительный или неверный смысл, окончательная проверка проводится по усиленной фразе:

2. Для того, чтобы < надмероприятие> , вполне достаточно < мероприятие> , и если она справедлива, то проверяемое "надмероприятие" не может быть признано таковым.

Итак, возвращаемся к конкретной системе и составляем инфинитивное проверочное предложение: "Для того, чтобы возбудить чувство материальной заинтересованности сотрудников предприятия, недостаточно только распределить квартальную премию". Так ли это? Если нет, то что еще нужно? Вот тут уже заметна неполнота формулировки. Если бы фраза была более развернутой: "Для того, чтобы возбудить чувство материальной заинтересованности сотрудников предприятия, недостаточно только распределить квартальную премию в соответствии с успехами каждого сотрудника", то отрицательный ответ был бы очевиден, так же как очевиден был бы и положительный смысл усиленной проверочной фразы 2. В исходных же формулировках сомнения остаются.

Проверяем второй вариант "надмероприятия": Для того, чтобы повысить благосостояние сотрудников предприятия, недостаточно только распределить квартальную премию. И опять ситуация спорная. А скорее даже бесспорная, т.к. от процесса распределения благосостояние не уменьшится и не увеличится, т.к. общая сумма премии остается той же. Таким образом, ответ отрицательный, и проверочную фразу теперь надо нарастить всем тем, что нужно для достижения "надмероприятия". А это:

1) увеличить суммарный размер премии,
2) повысить зарплату сотрудникам,
3) обеспечить богатые заказы предприятию,
4) обеспечить сотрудников более производительным и совершенным оборудованием,
5) обучить сотрудников приемам более производительного труда,
6) ввести неденежное поощрение сотрудников,
7) обеспечить бытовое обслуживание, льготное снабжение продуктами и предметами быта,

......и еще многое-многое другое.

Становится очевидно, что выбранная надсистема слишком велика, желательно найти поменьше, поконкретнее.

Проверяем третий вариант: Для того, чтобы материализовать справедливое вознаграждение за труд, недостаточно только распределить квартальную премию. Опять недоговоренность. Полезно бы добавить в конце "в соответствии с трудовыми успехами каждого". Впрочем, эта добавка вообще-то подразумевается (хотя некоторые начальники распределяют премию, руководствуясь другими принципами). А фраза звучит корректно, и многим, наверное, известны и другие средства справедливого вознаграждения за труд (в частности, прибавка к зарплате, повышение в должности, и т.п.). Эти "другие мероприятия" не являются обязательно сопутствующими исходному, скорее наоборот, они являются альтернативными (видели вы, чтобы кому-то сразу и зарплату прибавили, и в должности повысили, и увеличенную премию выписали?). Впрочем, если учесть, что речь идет о материализации справедливого вознаграждения за труд не одного сотрудника, а всех сотрудников предприятия, то с этой точки зрения все названные мероприятия в совокупности, распределенные во времени и в пространстве (т.е. в адресации), действительно могут обеспечить справедливое вознаграждение за труд. Только для каждого из добавочных мероприятий надо предусмотреть изменение как в сторону увеличения, так и наоборот (т.е. "изменение в зарплате", "переаттестация по должности"). Таким образом, третий вариант вроде бы проходит на роль надсистемы.

Четвертый вариант. Проверочная фраза: Для того, чтобы реализовать регламент оплаты труда на данном предприятии, недостаточно только распределить квартальную премию. Фраза корректна, но читатель, наверное, чувствует, что она относится совсем к иной области, от конкретного человека более далекой, хотя тоже социальной. Регламент оплаты труда - это элемент финансовой подсистемы предприятия. И здесь приходится выбирать, по какому из двух прошедших проверку направлений двигаться дальше. Как правило, выбор бывает предопределен типом поставленной задачи или ситуацией. Если задача совершенствования процедуры распределения премии поставлена профсоюзом, то в работу пойдет третий ответ; если же планово-экономический отдел хочет навести порядок в финансовых потоках предприятия, то будет принят последний ответ.

Выберем для определенности третий ответ и в качестве надмероприятия будем считать "материализацию справедливого вознаграждения за труд". Теперь необходимо определить ГПФ нашего мероприятия в надсистеме. Сравнивая наше мероприятие (распределение квартальной премии) с остальными двумя мероприятиями этой же надсистемы (изменение в зарплате и переаттестация по должности), нетрудно заметить, что распределение квартальной премии отличается от остальных мероприятий экспрессностью во времени и разовым характером. Иными словами, ГПФ распределения квартальной премии - это разовое экспрессное реагирование на последние трудовые достижения (или проколы) сотрудников предприятия.

Перечень подсистем ("подмероприятий") нашей системы, очевидно, должен грамматически оформляться в том же духе, что и все уже сделанное. Здесь стоит заметить, что хотя инфинитив и отглагольное существительное дают равноценные (с точки зрения смысла) формулировки, но для проверочных целей на отдельных этапах оказывается предпочтительной только одна из форм. Поэтому во избежание тупиковых или двусмысленных ситуаций полезно держать в поле зрения оба варианта формулировок.

Итак, из каких действий, подмероприятий состоит мероприятие, т.е. распределение квартальной премии? Это - наводящий вопрос для определения подсистем. Он может быть сформулирован и иначе, в инфинитивной форме:

1. Что и что нужно сделать, чтобы осуществить мероприятие, т.е. распределить квартальную премию?

Это - эквивалент первого из вопросов предметного анализа системы типа "процесс". Ответы на это вопрос "закрывают" проблему предметного анализа. Для проведения структурного анализа (т.е. второй части предметного анализа) системы типа "процесс" наводящий вопрос также можно представить в двух вариантах:

2. В какой последовательности и в какой причинно-следственной взаимосвязи находятся эти действия (подмероприятия)?

Или: Что за чем следует делать из перечисленного, чтобы осуществить мероприятие (распределить квартальную премию)?

Применительно к нашей задаче перечень подмероприятий можно предложить таким:

1. Получить сведения о суммарной денежной величине премии.
2. Собрать в подразделениях сведения об итогах их деятельности за квартал и свести эти сведения в единый список.
3. Раздать руководителям подразделений список итогов с предложением проранжировать (расставить места) все подразделения, кроме своего.
4. Собрать обработанные списки и, определив сумму мест для каждого из подразделений, в соответствии с этим вычислить объективный балл каждого подразделения.
5. Рассчитать сумму, выделяемую каждому подразделению в соответствии с его баллом и фондом зарплаты (согласно ранее принятому алгоритму расчета).
6. Сообщить руководителям подразделений результаты расчета и предложить им провести распределение премии между сотрудниками своих подразделений.
7. Собрать из подразделений сведения о распределении квартальной премии среди сотрудников и составить итоговый список распределения.
8. Вывесить итоговый список для ознакомления (конечно, в тех случаях, когда зарплата выдается не в конвертах, а по ведомости).
9. Назначить время приема сотрудников по вопросу премирования; принять и выслушать всех недовольных, решить возникшие вопросы с руководителями подразделений.

Естественно, предложенный список - не единственно возможный вариант (более того, автору не известно ни одного предприятия, где был бы реализован именно этот вариант). Кстати, можно этот список сократить, объединив, например, действия 2-4 в одно действие "Провести экспертную оценку сравнительных успехов подразделений", а действия 6-7 - в одно действие "Провести распределение сумм внутри подразделений".

Внешний предметный анализ нашей системы был походя проведен на этапе поиска надмероприятия (кстати, так чаще всего и бывает), останавливаться на нем не будем (тем более, что в свое время читателю было предложено самому кое-что уточнить, а как читатель это сделал, автору не известно).

Функциональный анализ социальной системы типа "процесс" почти ничего общего не имеет с функциональным анализом предметных систем. Дело в том, что для социальной системы чтобы ответить на вопрос "как осуществляется мероприятие (или подмероприятие, что не принципиально)?", надо ответить на целый букет из семи вопросов:

1. Кто осуществляет мероприятие? (Исполнитель - человек!)

2. Что является объектом мероприятия? (Какой предмет или объект иного вида обрабатывается при реализации мероприятия?)

3. Где осуществляется мероприятие?

4. Когда осуществляется мероприятие? (Сколько времени оно занимает?)

5. Какими средствами (инструментами, приборами) осуществляется мероприятие?

6. Сколько стоит мероприятие? (денег, энергии, и т.п.)

7. Для чего осуществляется мероприятие? (какому объекту или другому мероприятию предназначен результат данного мероприятия?)

И очень похоже, что комплекс ответов на эти вопросы практически соответствует почти полному системному анализу иследуемого "подмероприятия". Для начала, впрочем, вполне достаточно ограничиться всего тремя вопросами 1, 2 и 7, т.к. любой из остальных четырех вопросов имеет существенное значение лишь в конкретной ситуации, которая автоматически приведет решателя к необходимости заняться именно этими аспектами проблемы (т.е. место, время, цена, оборудование - что из этого окажется критичным, выясняется, как правило, не сразу).

Однако прервем пока дальнейший анализ животрепещущего премиального вопроса и попробуем разобрать систему иного класса.

4.3. Пример 3. ЗАКОН “О ПОДОХОДНОМ НАЛОГЕ С ФИЗИЧЕСКИХ ЛИЦ”

Нет сомнений, что этот объект к техническим системам отношения не имеет и является информационной системой. А вот как он соотносится с социальной сферой, определить не так просто. Очевидно, что воздействие его на жизнь и деятельность граждан чрезвычайно велико. Но это воздействие направлено исключительно на способ, характер деятельности человека, т.е. на функционирование социальных систем, на связи в социальных системах. В то же время подумав о ГПФ этого закона, нетрудно прийти к выводу, что основная его цель - обеспечить порядок и правильное функционирование социальной, финансовой системы страны, т.е. по своей ГПФ Закон безусловно сильно связан с социальной, финансовой надсистемой. С другой стороны, можно рассматриваемый Закон анализировать, не выходя за пределы чисто информационной надсистемы под названием "Гражданское законодательство" или "Свод законов", поскольку, как уже известно некоторым из законодателей, все законы должны быть строго увязаны между собой, чтобы их действие было согласованным (к сожалению, в российских законотворческих органах столь осведомленных законодателей пока - меньшинство).

В добавление к сказанному напомним, что Закон является системой предметного типа, и примерим к нему стандартное определение системы: Закон - это упорядоченное определенным образом множество норм или правил, взаимосвязанных между собой и образующих некоторое целостное единство. Все правильно, определение системы корректно. Проверку формулировок целостности и делимости Закона "О подоходном налоге" предоставляем читателю провести самому, это заодно будет напоминанием о цели системного анализа, про которую мы пока здесь не вспоминали. А цель поставлена жизнью, Закон этот, принятый в 1991 году, несовершенен (как, впрочем, и последующие его модификации), о чем в газетах писали и правые, и неправые (т.е. левые). Так давайте попробуем с ним разобраться и понять, как можно его сделать более совершенным (а вдруг удастся найти способ, который и фискальным службам потрафит, и налогоплательщика не обременит?!). Но - для того, чтобы систему изменять, нужно сначала понять, как она устроена и как функционирует, т.е. провести нормальный полный ее системный анализ.

Итак, идем по проторенному пути, т.е. начинаем с первого шага - определения надсистемы.

Что можно предложить в качестве надсистемы для нашего Закона? Опять составляем список "с листа":

1. Финансовое законодательство.
2. Гражданское законодательство.
3. Законодательство о налоговой системе.
4. Регламент отношений граждан с государством.
5. Фискальная система.

Первый тест-вопрос, если его "примерить" к этому списку, дает правильный (отрицательный) ответ для всех пяти вариантов. Какую же из надсистем выбрать?

Ситуация посложнее, чем у буриданова осла. Что делать? Попробуем определить ГПФ нашего Закона в каждом из пяти случаев. И сразу же выясняется, что названные пять надсистем прежде всего отличаются уровнем общности. Очевидно, что финансовое законодательство является частью гражданского законодательства (поэтому ответ 2 отпадает из соображений иерархии надсистем). Сравнивая варианты 1 и 3, видим, что и здесь уровень общности различен: в финансовое законодательство входит и ряд законов, не относящихся к налоговой системе (т.е. системе только сбора средств в казну). Итак, из первых трех вариантов ответа остается один только третий. И в нем ГПФ нашего Закона - определение размеров и правил сборов в казну с граждан, физических лиц (а не с предприятий и других юридических лиц). В варианте 4 ГПФ звучит несколько иначе - узаконивание регламента оплаты гражданами услуг государства (хотя в нашем "государстве наоборот" такая формулировка и звучит несколько непривычно). Наконец, пятый вариант также представляется слишком общим, т.к. наш Закон является элементом Законодательства о налоговой системе, которое, в свою очередь, является только частью фискальной системы (причем частью, определяющей регламент действий предметных служб фискальной системы, т.е. налоговой инспекции и налоговой полиции).

Итак, осталось только два варианта надсистем. Читатель, попробуйте ответить на вопрос, за какую из надсистем проголосует правительство, а за какую - партия любителей пива?...Pause... Вы правильно подумали. Высвечивать в надсистеме вопрос "А за какие, собственно, услуги государства мы, граждане, платим?" кое-кому совсем не хочется.

Коли так, то давайте мы с вами, читатель, станем на позицию налогоплательщика, честного трудящегося, в поте лица зарабатывающего на трех работах и согласного по справедливости платить за услуги государства, которые ему, налогоплательщику, необходимы и достаточны. Это значит, что выбираем вариант 4 - надсистему "Регламент отношений граждан с государством". ГПФ в этой надсистеме уже записана выше.

Переходим к перечню подсистем Закона. Есть "соблазн троечника" просто перечислить все формальные разделы Закона и на этом успокоиться. И это стало бы первой ошибкой, совершив которую (т.е. перепутав элементы и подсистемы), мы сильно усложнили бы себе работу, пока не пришлось бы в конце концов вернуться к этому шагу и выполнить его уже по другому. Подсистемы предметной системы (в системах любого класса: технических, социальных, и т.д.) определяются по той внутренней функции, которую они в системе выполняют (вот вам и пример пересечения предметного и функционального анализа, которое в данном случае облегчает выбор правильного, наиболее короткого пути).

Какие задачи, собственно, решает Закон о подоходном налоге? Ответ на этот вопрос попытаемся “обходным путем” найти в перечне из семи вопросов функционального анализа социальной системы типа "процесс". Действительно, Закон описывает и регламентирует функционирование социальной системы типа процесс - системы "Налогообложение граждан". Итак, попробуем записать подсистемы Закона о подоходном налоге таким образом:

1. Подсистема определения налогоплательщика. (Кто платит подоходный налог)
2. Подсистема определения, чем платится. (Вид валюты, вексели или иные ценности)
3. Подсистема места, адресации оплаты. (Кому, какому государственному органу платится)
4. Подсистема временного регламента оплаты. (Когда, в какие сроки)
5. Подсистема определения способов уплаты налога. (Наличными, безналичными рублями, валютой, лично, по доверенности, и т.д.)
6. Подсистема определения размера налога. (Сколько платится)
7. Подсистема определения целей, на которые расходуются налоговые средства. (Зачем платится)

Взяв в руки текст Закона, нетрудно убедиться, что ситуация довольно плачевная. Некоторые подсистемы Закона отсутствуют и в явном, и в неявном виде, другие подсистемы раздуты до фантастических размеров, третьи рассыпаны по десятку статей во всех главах Закона. Кроме того, есть некоторые статьи, которые нельзя отнести ни к одной из названных подсистем. В общем, система довольно неорганизованная.

Но попробуем все же построить структуру нашей системы, приняв в качестве ее элементов статьи Закона. Этих статей - 24, но перечислены они отнюдь не в соответствии с нашей градацией на подсистемы. А поскольку имеются серьезные основания считать, что естественная классификация статей Закона по их функциональной принадлежности более понятна и логична, то мы сгруппируем статьи по их принадлежности подсистемам. Чтобы не отсылать читателя к оригиналу Закона, приведем здесь полный перечень названий его статей:

Закон РФ "О подоходном налоге с физических лиц"
Гл. 1. Общие положения.
Ст.1. Плательщики подоходного налога.
Ст.2. Объект налогообложения.
Ст.3. Доходы, не подлежащие налогообложению.
Ст.4. Устранение двойного налогообложения.
Ст.5. Международные договоры.
Ст.6. Ставки налога.
Гл. 2. Налогообложение доходов, полученных физическими лицами за выполнение ими трудовых и иных приравненных к ним обязанностей по месту основной работы (службы, учебы).
Ст.7. Объекты налогообложения.
Ст.8. Порядок исчисления налога.
Ст.9. Порядок перечисления налога в бюджет.
Гл.3. Налогообложение доходов, получаемых не по месту основной работы (службы, учебы).
Ст.10. Объекты налогообложения.
Ст.11. Порядок исчисления и уплаты налога.
Гл.4. Налогообложение доходов от предпринимательской деятельности и других доходов.
Ст.12. Объекты налогообложения.
Ст.13. Порядок исчисления и уплаты налога.
Гл.5. Особенности налогообложения иностранных граждан и лиц без гражданства, имеющих постоянное местожительство в РСФСР.
Ст.14. Определение облагаемого дохода.
Ст.15. Размеры налогообложения.
Ст.16. Порядок исчисления и уплаты налога.
Гл.6. Особенности налогообложения доходов, получаемых лицами,не имеющими постоянного местожительства в РСФСР.
Ст.17. Порядок налогообложения.
Гл.7. Декларирование физическими лицами совокупного годового дохода и порядок исчисления налога по совокупному годовому доходу.
Ст.18. Порядок представления декларации о доходах.
Ст.19. Порядок перерасчета налога.
Гл.8. Обеспечение соблюдения настоящего Закона.
Ст.20. Обязанности физических лиц, уплачивающих налог.
Ст.21. Порядок удержания и возврата неправильно удержанных налогов.
Ст.22. Меры ответственности юридических и физических лиц за нарушение настоящего Закона.
Ст.23. Обжалование действий налоговых органов и их должностных лиц.
Ст.24. Инструкции по применению настоящего Закона.

Теперь те же статьи сгруппируем по нашим подсистемам (статьи обозначены их номерами, в некоторых случаях в скобках упомянуты подпункты статей):

1. Подсистема определения налогоплательщика (1, 16(4)).
2. Подсистема определения, чем платится (молчаливо предполагается, что рублями, но в явном виде ни в одной статье не сказано; в ст.2 есть фразы о пересчете натуральных и валютных доходов в денежную форму).
3. Подсистема места, адресации оплаты (специальной статьи нет, упоминается понятие "налоговые органы" в ст.ст. 9, 11, 13, 16-21, 23).
4. Подсистема временного регламента оплаты (9, 11, 13, 16).
5. Подсистема определения способов уплаты налога (9).
6. Подсистема определения размера налога (2-4, 6-8, 10-19).
7. Подсистема определения целей, на которые расходуются налоговые средства (отсутствует вообще).

Вне наших подсистем остались статьи 5, 22 и 24. Впрочем, статьи 22-24 - это чистой воды пустышки, первые две из них - отсылки к безымянным "законодательным актам", последняя - уведомление о том, что Закон не имеет прямого действия и исполнители его со стороны государства будут руководствоваться собственным истолкованием Закона. Но помимо этих замечаний, работа с текстом Закона наводит на мысль, что разумнее для данного Закона несколько изменить наименование и состав подсистем. Прежде всего для упрощения анализа исключим подсистемы 2, 3 и 5, полагая "по умолчанию", что налоги в России платятся только наличными или безналичными рублями и только на расчетные счета налоговых инспекций (хотя, наверное, лучше было бы эти положения в одной из статей Закона назвать в явной форме).

Далее. Больше половины текста Закона посвящено перечню видов дохода как объекта налогообложения (а если точнее, то видов дохода, не входящих в базу налогообложения). Собственно ставки налога определены в маленькой статье 6 конкретно и почти корректно. Имеет смысл рассмотреть подсистему определения базы налогообложения самостоятельно, т.к. в ней выделяется ряд подсистем подчиненного уровня (облагаемый доход, необлагаемые виды дохода, необлагаемые уменьшения дохода).

Следующее. Анализ Закона показывает, что государство не доверяет самому налогоплательщику расчеты и платежи подоходного налога. Это резко усложняет структуру системы уплаты подоходного налога, и ее регламент прорисован в Законе совсем не полно. Следует заняться этим подробнее и выделить подсистему "Определение исполнителя налоговых выплат".

Таким образом, выстраивается иная коллекция подсистем (с несколько вольным комментарием в скобках), обозначенных в таблице Рис. 17 через функции, которые каждая из них в Законе выполняет.

I | Определение налогоплательщика | (кого стригут)
II | Определение объекта налогообложения | (что стригут)
III | Определение и расчет величины налога | (сколько стригут)
IV | Определение временного регламента платежей | (когда стригут)
V | Определение исполнителя налоговых платежей | (кто стригаль)
VI | Определение назначения налога | (кому стригут)

Рис. 17.

Многие функции в этом списке начинаются с термина "определение", который (напомним) обозначает не что иное, как логический оператор, решающий одновременно две задачи: 1) обозначить все, что входит в круг определяемого понятия и 2) отграничить этот круг от всего, что в него не входит. Это значит, что некоторые из подсистем списка в свою очередь состоят, как минимум, из двух подсистем более низкого уровня. Учитывая это, распишем подсистемы в виде списка:

I. Определение налогоплательщика.
1.1. Поименование, кто обязан платить подоходный налог.
1.2. Поименование, кто не обязан платить подоходный налог.
II. Определение объекта налогообложения.
2.1. Виды дохода, не облагаемые налогом.
2.2. Виды дохода, облагаемые налогом.
2.3. Виды уменьшений облагаемого дохода.
III. Вычисление величины налога.
3.1. Вычисление итоговой величины облагаемого дохода.
3.2. Определение процентной ставки налога.
IV. Временной регламент налоговых платежей.
4.1. Временной регламент платежей получателем дохода.
4.2. Временной регламент платежей источником дохода.
4.3. Определение платежей, не связанных сроком исполнения.
V. Определение исполнителя налоговых платежей.
5.1. Виды доходов, по которым платит получатель дохода.
5.2. Виды доходов, по которым платит источник дохода.
5.3. Кто не может быть исполнителем налоговых платежей.
5.4. Виды платежей, исполняемых государством (и в чьем лице).
VI. Определение назначения подоходного налога.
6.1. Перечень целей, на которые государство имеет право тратить собранные средства.
6.2. Перечень целей, на которые государство не имеет права тратить собранные средства.

Как видите, изменение точки зрения позволило сконструировать более четкую и логичную схему Закона. Однако в нашей схеме осталась большая дыра, связанная с тем, что законы в нашей стране исполняются из рук вон плохо, и необходим подробный регламент санкций за нарушение Закона. Нарушить же в нашем Законе можно со стороны налогоплательщика, неправильно определив: а) налогоплательщика, б) объект налогообложения, в) величину налога, г) время уплаты налога, д) исполнителя налогового платежа. Со стороны государства в лице его налоговых органов нарушение Закона также возможно, если они (органы) неправильно определят: а) нарушение налогоплательщиком (или исполнителем налогового платежа) какого-либо положения Закона или б) отсутствие такого нарушения, или в) размер и порядок исполнения санкций, наложенных на нарушителя Закона.

Вообще говоря, во всяком регламентном юридическом документе (а в Законе - особенно!), характеризующем взаимоотношение двух субъектов права (А и В), обязана быть четко и однозначно прописана триада основных характеристик каждого регламентного положения:

1) право субъекта А,
2) обязанность субъекта В, связанная с реализацией субъектом А своего права, и
3) санкции, налагаемые на субъекта В в случае неисполнения им своих обязанностей, названных в п.2.

Это касается как договорных отношений, так и особенно - законов. Большинство наших законов не исполняются, в частности, по той причине, что, с одной стороны, отсутствует баланс прав и обязанностей субъектов (стимулирующий субъекта, обиженного в правах, искать пути обхода несправедливого закона), а с другой стороны, отсутствует один, а то и два элемента названной триады, в результате чего нарушается (или вообще отсутствует) механизм исполнения закона.

В связи с этим мы просто обязаны включить в число подсистем Закона подсистему "Определение санкций за нарушение Закона" с подсистемами подчиненного уровня: "Вид нарушения", "Род и размер санкции" и "Исполнитель санкции". После этого можно уже приступить к построению структурной схемы Закона и выявить внутренние связи его подсистем. Начало этой операции представлено в виде Таблицы 10 - пустографки. Девятнадцать подсистем второго уровня, показанные в этой таблице, наводят на мысль, что анализ взаимодействия, взаимосвязи этих подсистем и заполнение таблицы - дело длительное, кропотливое, требующее серьезных обоснований каждого действия и, в общем-то, едва ли уместное в основном тексте книги. Автор - не юрист и не депутат Думы, большинство читателей, думается, тоже не страдают этими излишествами. Но, тем не менее, невооруженным глазом видно, что даже такой кавалерийский дилетантский наскок, который мы с вами совершили на объект, являющийся прерогативой юристов и нардепов всяческих дум, показал, сколько зияющих упущений имеется в конкретном рассмотренном Законе. И это вовсе не свидетельство семи пядей в наших лбах, это всего лишь демонстрация того, что может дать системный подход в сфере законотворчества.

А пока по итогам трех приведенных примеров и соответствующих правил - задания на самостоятельную работу:

Вопросы и упражнения:
 1. В таблице Рис. 14 представлены наводящие вопросы, грамматическая форма и смысл которых больше всего подходят к анализу предметных систем. Составьте аналогичную таблицу вопросов, ориентированных на работу с функциональными, операционными системами.
2. Чем отличается ГПФ функциональной системы от надсистемы этой же функциональной системы?
3. Чем можно измерить эффективность системы "Дошкольное воспитание"? Какие виды физической эффективности применимы к данной системе?
4. Тот же вопрос упражнения 3, но применительно к системе "Закон о подоходном налоге с физических лиц".
5. Что можно считать входами, а что - выходами в следующих системах: пылесос, распределение квартальной премии, Закон о подоходном налоге?
6. Что бы Вы предложили усовершенствовать в пылесосе (причем такое усовершенствование, которого нет пока ни в одной известной модели)?
7. Какие мероприятия следовало бы включить в состав надсистемы "Материализация справедливого вознаграждения за труд" сверх тех, что перечислены в основном тексте?
8. Справедливо ли утверждение, что исполнителем в социальной системе функционального типа всегда является человек?
9. Всегда ли система, созданная человеком и для нужд человека, является искусственной системой?
10. Что является ГПФ естественной системы? И вообще, есть ли ГПФ у естественной системы, а если нет, то что ее заменяет?
11. Сформулируйте общее определение для информационной системы предметного типа. А потом - та же задача для информационной системы функционального типа (только чтобы ваше определение подходило не только к программным продуктам и их прохождению в ЭВМ).
12. Как Вы понимаете функцию элемента системы функционального типа? Можно ли утверждать, что в предметной системе элемент является предметом, а функция является действием, а в функциональной системе элемент является действием, а функция - обрабатываемым предметом?
13. Заполните приведенную ниже таблицу взаимодействия элементов для системы "Закон о подоходном налоге", руководствуясь принципами справедливости и баланса прав и обязанностей. Затем просмотрите текст последней редакции Закона (а точнее, соответствующих глав Налогового кодекса), перечислите, чего нехватает в нем из вашего списка, отыщите путь к какому-либо депутату Думы (или прямо в комитет по законодательству) и предложите ему в порядке законодательной инициативы от его имени выдвинуть вашу разработку (лучше это делать перед очередными выборами).

Примечание: некоторые из заданий этого блока вопросов и упражнений лучше всего выполнять как минимум вдвоем, в режиме дискуссии. Самое интересное, что такая дискуссия выведет вас на куда более интересные вопросы и неоднозначные ответы.

Основная подсистема | Подсистема подчиненного уровня | 1.1 | 1.2 | 2.1 | 2.2 | 2.3 | 3.1 | 3.2 | 4.1 | 4.2 | 4.3 | 5.1 | 5.2 | 5.3 | 5.4 | 6.1 | 6.2 | 7.1 | 7.2 | 7.3
1. Определение налогоплательщика | 1.1.Кто обязан платить налог |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
 | 1.2. Кто не обязан платить налог |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
2. Определение объекта налогообложения | 2.1. Виды дохода, не облагаемые налогом |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
 | 2.2. Виды дохода, облагаемые налогом |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
 | 2.3.Виды уменьшения облагаемого дохода |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
3. Определение величины налога | 3.1.Определение величины облагаемого дохода |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
 | 3.2. Определение процентной ставки |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
4. Определение временного регламента платежей | 4.1. Регламент платежей получателем дохода |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
 | 4.2. Регламент платежей источником дохода |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
 | 4.3. Определение платежей без срока |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
5. Определение исполнителя налогового платежа | 5.1. Платы получателя дохода |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
 | 5.2. Платы источника дохода |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
 | 5.3. Платы налоговых органов |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
 | 5.4. Кто не может быть исполнителем налог. платежа |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
6. Определение назначения подоходного налога | 6.1. Допустимые цели использования налоговых средств |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
 | 6.2. Недопустимые цели использования налоговых средств |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
7. Определение санкций за нарушение | 7.1. Вид нарушения |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
 | 7.2. Род и размер санкции |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
 | 7.3. Исполнитель санкции |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |


Законы построения систем

Системно-морфологический подход
в технике, науке, социальной сфере.
Титов В.В.

5. Законы построения систем

Существование любого объекта обязательно подчиняется определенному, характерному для данного вида объектов комплекту правил, законов, традиций, в общем, каких-то рамок ограничивающего характера. Универсальное правило, действующее, по-видимому, для всех систем (напомним, что любой объект можно представить как систему), состоит в том, что любая система имеет конечный срок своего существования, т.е. когда-то рождается (возникает), сколько-то существует и когда-то исчезает (умирает). Таким образом, наиболее общим атрибутом систем является жизненный цикл. Этот цикл может измеряться и микросекундами (ядерные частицы, например), и миллиардами лет (например, планеты, галактики).

Человек (как “по умолчанию” подразумевается каждым из нас) ставит именно себя в центр мироздания и сортирует все окружающие его системы прежде всего по отношению к своим пространственным и временным масштабам (т.е. по отношению к своим “системным” геометрическим размерам и к своему личному жизненному циклу). Поэтому, собственно, и введено (человеком!) понятие “статической” системы как системы, сохраняющей неизменными все свои характеристики в течение всего времени, пока рассматривается взаимодействие других систем (находящихся в поле внимания человека) с этой системой. Как правило, статические системы предметного типа - это либо неподвижные неизменные материальные объекты (стул, авторучка, дом), либо жестко регламентированные социальные системы (парламент, суд присяжных), либо неизменяемые информационные блоки (пьеса, CD-ROM, книга), хотя здесь о статичности еще можно поспорить.

Искусственные системы сами не рождаются, их создает человек. И если он делает это сознательно (в противном случае, кстати, самозародившуюся систему разумнее считать не искусственной, а естественной), то, во-первых, перед созданием системы человек ставит определенную цель, для которой он хочет эту систему создать (эта цель затем, будучи реализованной, станет главной полезной функцией (ГПФ) системы), а во-вторых, прежде чем создаваемая система будет материализована в натуре, она, как правило, возникает сначала в мозгу ее изобретателя в виде смутного мысленного образа. Затем в течение какого-то времени этот мысленный образ системы уточняется, совершенствуется, преобразуется, на определенной стадии образ системы переносится на другой носитель информации (чертеж, нотные линейки, набросок, “коллективный мозг” рабочей группы, и т.д.). И только когда информационный образ системы становится столь детальным и проработанным, что создатель его (или создатели) могут убедиться, что все законы построения систем надежно выполняются, можно приступать к материализации системы (впрочем, человеку свойственно сомневаться, поэтому первым образцом создаваемой системы почти всегда является ее модель, единичный опытный образец, на котором проводится всесторонняя проверка теоретических выкладок авторов системы).

Итак, что же представляют собой законы построения искусственных систем?

5.1. Закон функциональной полноты

Система должна быть функционально полной, т.е. перечень возможностей системы (в первую очередь перечень ее подсистем) должен включать в себя все минимально необходимое и достаточное для выполнения ГПФ.

На примере этого закона хорошо просматривается и подтверждается последовательность процедур создания системы. Очевидно, что необходимость (общественная потребность) создания новой системы возникает в недрах некоей надсистемы, когда там формируется какое-то неудобство, связанное с тем, что не реализована (или плохо реализована) одна из ее внутренних функций, и надсистема от этого страдает. Эта вот нереализованная внутренняя функция надсистемы и становится ГПФ создаваемой внутри нее новой системы. Поняв и сформулировав эту ГПФ, изобретатель обязан теперь понять, как эту ГПФ можно обеспечить и что для этого нужно, т.е. какие подсистемы должны входить в создаваемую систему и как они должны быть друг с другом связаны. После того, как в этом вопросе появляется полная (а точнее, достаточная) ясность и все подсистемы - в наличии и в нужной взаимосвязи, настоящий закон можно считать выполненным.

А теперь загляните, пожалуйста, в начало предыдущего раздела этой работы, и вы убедитесь, что начальные стадии для анализа уже существующей системы (системное представление) и для создания новой системы проводятся практически в одной и той же последовательности, только в первом случае речь идет о реальной, функционирующей системе , а во втором - о мысленном образе системы, которой еще нет.

Что означает этот закон применительно к различным видам систем? Приведем бегло несколько примеров.

1. Пассажирский железнодорожный вагон поезда дальнего сообщения. Главная полезная функция этой предметной технической системы - обеспечить (комфортное) пребывание пассажиров в течение нескольких дней путешествия при любой погоде и в любое время года.

Подсистемы:
а) подсистема жизнеобеспечения пассажиров (размещение, воздух, температура, питание, сон, и т.д.);
б) подсистема размещения багажа;
в) ходовая часть;
г) подсистема энергообеспечения всех подсистем вагона.

Этот перечень можно детализировать дальше, уходя во все более конкретные детали, службы и процессы, однако, не будем травмировать психику российского пассажира перечнем не знакомых ему удобств. В общем случае ясно, что даже при минимальном воплощении каждой из названных подсистем такой вагон можно назвать тем именем, что стоит в начале этого примера. Отсутствие же хотя бы одной из подсистем превращает объект либо в теплушку военных лет, либо в местную электричку, либо в жилой вагончик без колес, либо вообще в хлам.

Упражнение
Определить минимальный состав следующих предметных технических систем: а) книжный шкаф; б) газовая кухонная плита; в) паяльник; г) многоквартирный жилой дом.

2. Технология плазменного напыления нитрида титана на столовые приборы (“золочение” ложек и вилок). Главная полезная функция этой операционной (функциональной) технической системы: создать однородное прочное покрытие на всей сложной поверхности изделий.

Подсистемы (функциональные!):
а) обеспечение вакуума (откачка воздуха);
б) обеспечение (подача) расходуемых материалов (азота, титана);
в) обеспечение физических условий образования плазмы:
г) электропитание;
д) перемещение (экспонирование) обрабатываемых деталей в плазме;
е) загрузка и выгрузка обрабатываемых деталей.

Каждая из подсистем достаточно сложна, и ни одну из них нельзя игнорировать. Если не будет хотя бы одной из подсистем, технология выродится в лучшем случае в эксперимент по обработке единичных объектов (да и то только частичной), а в худшем - просто в способ превращения ценных ресурсов в металлолом.

Упражнение:
Определить минимальный состав следующих операционных технических систем: а) обеспечение питания авиапассажиров в самолете; б) регулирование уличного движения; в) технический контроль изделий на производстве; г) курс лечения поясничного остеохондроза.

3. Партия (политическая). Главная полезная функция этой предметной социальной системы: объединение усилий граждан- единомышленников для достижения определенной общественно значимой цели или группы целей (мы не считаем те “партии”, которые создаются только ради амбиций вождей; впрочем. они-то как раз громче всех кричат о своей бескорыстности и преданности идее). Подсистемы:
а) регламент (устав, программа);
б) подсистема финансирования деятельности;
в) подсистема public relation (создания позитивного общественного мнения и поддержки);
г) подсистема организационного обеспечения (управление и координация).

Нетрудно видеть, что и здесь, в социальной системе предметного типа исключение любой из названных подсистем превращает политическую партию в:
а) конформистское “болото”,
б) нищую компанию “хиппи” (или что-то вроде),
в) масонскую полузакрытую ложу,
г) анархическое стадо. Варианты перечислены в том же порядке, что и подсистемы, которые поочередно предполагаются отсутствующими.

Сравнив, например, качество названных подсистем у ВКП(б)-КПСС-КПРФ и у современных демократических российских партий, нетрудно понять, почему столь различны эффективности их работы (под эффективностью здесь, естественно, понимается успех в достижении поставленных целей, т.е. качество, степень реализации главной полезной функции партии).

Упражнение:
Определить минимальный состав следующих предметных социальных систем: а) ЖСК; б) батальон; в) нотариат; г) холдинг.

4. Заключение контракта. Главная полезная функция этой операционной социальной системы: создание юридической базы для получения прибыли от реализации контракта. Подсистемы:
а) выбор потенциального контрагента и сбор информации о нем;
б) стимулирование заинтересованности выбранного контрагента в будущем контракте;
в) переговорный процесс и согласование баланса интересов договаривающихся сторон;
г) юридическая экспертиза проекта договорных документов;
д) подписание договорных документов.

Этот перечень подсистем включает минимум, необходимый для заключения контракта. Перечислим те нежелательные варианты финала наших попыток заключить требуемый контракт, если не будет учтена хотя бы одна из названных подсистем:
а) партнер может оказаться жуликом или блефующей пустышкой,
б) партнер безусловно откажется от заключения контракта, если не увидит для себя в нем достаточной выгоды,
в) или если увидит, что вы получаете добавочную выгоду за его счет,
г) контракт может быть оспорен в удобный для контрагента момент, если нарушены правила составления договорных документов; другой вариант неприятности, если неточности и упущения в формулировках могут дать одной из сторон неоправданные преимущества при возникновении, например, спорных ситуаций,
д) без подписания уполномоченными лицами любой контракт недействителен, так что это формальное действие обязательно; существенный момент состоит в том, кто имеет право подписывать контрактные документы и на каком основании.

Упражнение:
Определить минимальный состав следующих операционных социальных систем: а) вакцинация населения региона; б) предвыборная кампания; в) подача судебного иска о выплате задержанной зарплаты.

5. Текстовый редактор - программа для персонального компьютера. Главная полезная функция предметной информационной системы -“минимального” текстового редактора - обеспечить возможность редактору - человеку делать с текстовым файлом все то, что он может делать авторучкой с тем же текстом на бумаге. Основные подсистемы:
а) подпрограмма набора текста (эквивалент обычного письма или набора на машинке);
б) подпрограмма удаления фрагмента текста (эквивалент зачеркивания или стирания);
в) подпрограмма смены шрифта (эквивалент перехода на иностранный язык);
г) подпрограмма выделения фрагмента текста другим типом или размером шрифта (эквивалент подчеркивания);
д) подпрограмма перемещения фрагментов текста (эквивалент работы ножницами и клеем).

Пожалуй, перечисленных подсистем достаточно, и отсутствие любой из них связывает редактору - человеку руки настолько сильно, что едва ли он станет держать такой текстовый редактор у себя на рабочем компьютере.

Упражнение:
Определить минимальный состав следующих предметных информационных систем: а) справочник по математике для поступающих в технические вузы; б) телепрограмма (например, “Время” или “Что, где, когда”); в) алгоритм численного интегрирования; г) письменность.

6. Проведение научного эксперимента. Эта информационная система операционного типа имеет главной полезной функцией получение новых знаний об исследуемом объекте. Основные подсистемы:
а) выдвижение всех мыслимых гипотез о ходе и возможном результате эксперимента;
б) обеспечение необходимых условий для осуществления эксперимента;
в) контроль всех значимых параметров в ходе эксперимента;
г) обеспечение возможности корректировки эксперимента в зависимости от промежуточных его результатов;
д) обеспечение безопасности экспериментаторов при нештатном развитии эксперимента.

Как известно, чернобыльская катастрофа по одной из версий произошла именно во время эксперимента. Эксперимента, всех последствий которого экспериментаторы не предвидели (игнорирована подсистема “а”), а поэтому и не озаботились проверкой достаточности имеющихся средств для планового осуществления эксперимента (неправильно построена подсистема “б”). Эксперимента, на определенном этапе которого была потеряна возможность управления реактором (разрушена подсистема “г”, частично - сознательно, частично - самопроизвольно). Наконец, эксперимента, где подсистема безопасности “д” также не выдержала нагрузки.

Конечно, эксперименты, затрагивающие судьбы многих тысяч людей, должны многократно страховаться, а все названные подсистемы - дублироваться и проверяться на макетах. Но и скромный эксперимент младенца, впервые чиркнувшего спичкой, не менее значим для него, чем для ученого мужа - синтез нового полимера или открытие нового принципа действия электронного прибора. И там, и там - шаг в неведомое, познание нового. А поэтому и правила в обоих случаях - одни и те же.

В информационных системах операционного типа довольно трудно бывает отделить чисто информационные подсистемы от систем технических средств, без которых никакой эксперимент просто невозможен. Поэтому имеет смысл для названной выше системы рассмотреть иной набор подсистем:
а) выявление группы существенных с научной точки зрения вопросов, формирующих целевое назначение научного эксперимента;
б) оформление схемы или модели научного эксперимента с мысленным просматриванием всех вариантов хода (развития) эксперимента;
в) формирование запросов на материальное, временное и кадровое обеспечение научного эксперимента;
г) обеспечение всех контрольно-измерительных систем, необходимых в ходе проведения эксперимента (одновременно идет подготовка всех остальных подсистем собственно эксперимента, но - это уже другая система);
д) обработка результатов научного эксперимента и формирование выводов и следствий из полученных данных;
е) формирование (на базе полученных выводов) вопросов и рекомендаций о направлениях дальнейших исследований.

Чем грозит науке несоблюдение закона функциональной полноты? Отвлекаясь от чернобыльского синдрома, рассмотренного выше (там последствия сильнее всего били и бьют отнюдь не по науке и ее проблемам), перечислим эти неприятности в том же порядке, в каком будут отвергаться положения предыдущего списка подсистем:
а) праздное любопытство за государственный счет;
б) эксперимент может потребовать от исполнителя неожиданных действий и решений, к которым он не готов;
в) никакой эксперимент не может быть организован без необходимых для него ресурсов, о которых, разумеется, надо позаботиться заранее;
г) очень обидно бывает, когда уникальный, неповторимый (или повторимый, но очень дорогостоящий) эксперимент дает неожиданные или странные результаты, зафиксировать или измерить которые экспериментатор не в состоянии из-за отсутствия соответствующих приборов. Яркий пример этому - отечественная вулканология, когда уникальные природные явления типа извержения Толбачика в 1975-76 годах или извержение Карымского вулкана в 1996 году прошли для нашей науки с колоссальными упущенными возможностями именно из-за крайней бедности двух вулканологических институтов, находящихся “под боком” этих вулканов;
д) эксперимент без подведения его итогов - это бесполезная трата средств (так же, как в пункте “а”). Даже отрицательный результат эксперимента должен хоть на малую толику, но увеличить наш объем знаний о предмете исследований;
е) крайне редко эксперимент ставит точку в какой-то научной проблеме; чаще всего это - точка с запятой, и новые результаты и выводы обязательно дают пищу для новых вопросов. Пожалуй, только эксперименты, поставленные для убедительного и однозначного подтверждения какого-либо закона природы, могут не иметь продолжения, но это слишком редкий случай.

Для научных работников - два вопроса: 1) все ли информационные подсистемы учтены в последнем перечне? 2) всегда ли Вы следуете этим системным положениям в своей научной работе?

Упражнение:
Определить минимальный состав следующих операционных информационных систем: а) создание литературного произведения; б) обучение игре на гитаре; в) приобретение редкой марки, недостающей в моей филателистической коллекции; г) игра на фондовой бирже.

Обилие примеров и упражнений в настоящем разделе для торопливого читателя не даст почти ничего, кроме осознания всеобщности системного подхода. Неторопливый, вдумчивый читатель попытается понять каждый из шести примеров и тем самым научится “разговаривать” на шести “системных языках”, что, в свою очередь, облегчит чтение (впрочем, это уже не чтение, а изучение) последующих разделов и позволит элементарно разделываться с любыми встречающимися системами в реальном масштабе времени (т.е. сразу, на ходу).

5.2. Закон проводимости

Всякая искусственная система создается человеком либо для обработки каких-либо объектов (материальных, энергетических или информационных), либо для обслуживания объектов, остающихся в процессе функционирования системы внешними по отношению к ней. Однако в любом случае в процессе функционирования в системе имеют место потоки: либо потоки вещества (материальных тел), либо потоки энергии, либо потоки информации. И настоящий закон гласит, что

Система должна быть проводимой по всем имеющимся в ней потокам: вещественным, энергетическим (силовым) и информационным.

Полная цепь, по которой идет поток в системе, состоит из следующих качественно различных элементов, каждый из которых обеспечивает определенную функцию по отношению к потоку (см. Рис. 18).

Элемент | Функция | Примечание
Источник | Создание (генерация) переносимого агента | Может находиться вне системы, тогда для нее источником является соответствующий вход
Транспортное устройство | Перенос агента в другое место, или другое время, или другое окружение | Переносимый агент при этом остается качественно неизменным
Преобразователь | Изменение вида переносимого агента (без порождения принципиально иного продукта) | Например, преобразование электрической энергии в механическую или преобразование аналоговой информации в цифровую
Рабочая зона | Преобразование агента с порождением принципиально нового продукта | Происходит, как правило, не полностью (КПД<100%) и часто - во взаимодействии с другими агентами
Сток | Удаление неиспользованных остатков агента из системы | Как правило, находится вне системы, т.е. стоком является один из выходов системы.

Рис. 18.

Названные элементы могут иметься в системе не в единственном экземпляре, т.е. какая-либо из функций может быть реализована неоднократно. Кроме того, потоки в системе, как правило, часто ветвятся (разделяются), в то время как обратный процесс (слияние однородных потоков) встречается гораздо реже. Особенно это относится к энергетическим потокам, где закон возрастания энтропии (т.е. диссипация, рассеяние энергии) превалирует над кумулятивным ее сосредоточением.

Исследование потоков в реальной системе дает настолько глубокую и всестороннюю информацию, что после зарисовки схемы каждого из потоков практически высвечивается полный облик системы, ее элементный состав, структура и функционирование становятся совершенно прозрачными. Но этот факт имеет и оборотную сторону. А именно: все потоки в системе так или иначе связаны друг с другом, имеют точки соприкосновения и взаимодействия. В одних случаях это взаимодействие решающим образом влияет на функциональный облик системы, в других оно совершенно несущественно; конечно, есть и промежуточные ситуации, когда с ходу трудно определить степень важности данного взаимодействия потоков.

Задача “отделить суп от мух” вовсе не так проста, как кажется, и даже при максимуме внимания и осторожности не исключена вероятность, что ради упрощения схемы (ведь в этом суть системного подхода!) окажется устраненным из рассмотрения узел взаимодействия потоков, заметно влияющий на параметры всей системы. Поэтому в ответственных случаях для систем с большим разнообразием потоков часто формируют иерархию узлов взаимодействия, а затем анализируют вначале только узлы первого порядка; убедившись в работоспособности системы, начинают по очереди добавлять узлы взаимодействия второго порядка (в математике такой метод получил название “метод малых возмущений”), и т.д. Разумеется, все это проверяется либо теоретическими расчетами, либо машинным моделированием, либо моделированием реальным. Долго? Да, но поспешность хороша лишь там, где принципу “Время - деньги” не противоречит другая народная мудрость: “Поспешишь - людей насмешишь”, которая иногда трансформируется, например, в потерю внезапно “замолчавшего” космического аппарата и даже в такие чудовищные происшествия, как чернобыльская катастрофа.

Теперь обратимся к примерам, только на этот раз из-за громоздкости анализа потоков ограничимся не шестью, а двумя системами.

5.2.1. Пример 1. Пылесос.

Выше мы прервали анализ этого агрегата, теперь настала пора продолжить, но уже с иной точки зрения. Напомним, что пылесос - это техническая система предметного типа. Прежде всего перечислим, какие могут быть потоки в этом объекте. Очевидные три: 1) электроэнергия, 2) воздух, 3) пыль. Но есть еще и неочевидные. В данном случае это силовые цепи, локализующие элементы пылесоса относительно друг друга в пространстве, а также цепь, обеспечивающая перемещение пылесоса в пространстве обрабатываемого помещения. Кроме того, в любой системе есть информационные потоки. Наконец, в любой системе, потребляющей внешнюю энергию, выделяется тепло, так что есть и тепловые потоки.

Для каждого потока удобно нарисовать цепочку элементов (возможно, ветвящуюся), по которой и течет данный поток. На рис. 19 эта цепочка изображена для потока электрической энергии.

Если поток изображать не в виде электрической цепи (двухпроводной, а иногда и трехпроводной), а в виде однонаправленного потока именно энергии, то схема будет выглядеть, как показано на Рис. 19а.

Кстати, упомянув выше об информационных потоках, можно здесь уже учесть, что энергия для передачи информации на индикаторы, очевидно, берется из этого же источника. И наконец, еще одно соображение. Источник электроэнергии может иметь различные параметры (например, сеть 110-220V или автомобильный аккумулятор 12V), и в пылесосе может появиться коммутатор входов и преобразователи напряжения. А в еще более “продвинутой” модели все это еще и сопровождается маленьким информационным блоком, распознающим вид входного напряжения и соответственно коммутирующим схему электропитания (рис. 19б):

Нетрудно в данной схеме потоков идентифицировать и источник (сеть), и транспортные цепи (вилка, шнур, другие не указанные на схеме проводники), и преобразователи (трансформатор, преобразователь), и рабочий орган (мотор вентилятора), и сток (преобразование в тепло; кстати, поток тепла для точности надо бы зафиксировать от каждого из элементов схемы). Кроме того, в схеме есть два элемента, не включенные в перечень Рис. 15: выключатель и анализатор напряжения с коммутатором. Нетрудно догадаться, что эти элементы по отношению к потоку энергии являются управляющими и формально хотя и могут быть отнесены к элементам переноса, но в действительности их функция более значительна: не только пассивная передача, перенос из одной области в другую, но и решение, нужно ли этот перенос осуществлять. В дальнейшем мы еще встретимся с такими элементами и поговорим о них более подробно.

Теперь посмотрим, как в пылесосе формализуется воздушный поток (см. Рис. 20).

Цепь воздушного потока получилась у нас одномерная, ни разветвлений. ни потерь воздуха нет. А ведь в принципе воздушный поток можно “нагрузить” дополнительной задачей, например, охлаждения мотора вентилятора. Обычно вентиляторы так и проектируются, чтобы воздушный поток обтекал мотор и отводил от него тепло. Другая функция, также часто встречающаяся в пылесосах,- использование выходящей струи чистого воздуха для пульверизации. А если не только для пульверизатора? Например, для увлажнения воздуха барботированием через простейший барботер. Или для ароматизации воздуха в помещении. Или для отпугивания и удаления из помещения комаров или моли. Таким образом, вырисовывается комплект насадок уже не на входном отверстии пылесоса, а на выходе его. Схема потока преобразуется следующим образом:

На этой схеме изображены два варианта работы устройства: красные линии показывают, как элементы работают в режиме пылесоса, в соответствии с зелеными линиями элементы подключены в режиме использования выходной струи чистого воздуха (иногда для повышения производительности в последнем случае из пылесоса удаляют и фильтр пылесборника).

Теперь переходим к пылевому потоку:

Пыль движется вместе с воздушным потоком, поэтому все элементы этой цепи обслуживают одновременно и воздушный поток. Схема здесь тоже одномерна и скучна (рис. 21). И явно недостаточна, и вот почему. Всякий поток имеет источник (здесь он тоже есть) и сток, которым всегда является последний элемент цепи. Но в данном случае последний элемент служит не абсолютным стоком, а всего лишь промежуточным, действующим только до заполнения емкости камеры (отнюдь не бездонной), а дальнейшая судьба собранной пыли у нас в схеме никак не прорисована. В некоторых моделях пылесосов пылесборники сделаны одноразовыми, фильтр выбрасывается в мусоропровод вместе с накопленной на нем пылью. Но есть и другие возможности: например, к пылесосу можно приложить простейшее устройство типа пяльцев для опорожнения наполненного пылесборника в любой полиэтиленовый пакет, которыми торговля снабжает нас в избытке. Тогда и пылесборник будет работать лучше (во-первых, один многоразовый пылесборник дешевле десятков одноразовых и его можно оборудовать более эффективным фильтром, а во-вторых, известно, что пыль, проникшая в тело фильтра, повышает его фильтрующую способность, т.е. качество пылесбора еще улучшится).

Раздумья над этой скучной схемой потока пыли подсказали еще одну идею. Дело в том, что часто пылесос засасывает не только пыль, но и листья, и конфетные обертки, брошенные за диван нерадивым членом семьи, клочки бумаги и другой подобный мусор. Эти клочки и листки, попадая на поверхность фильтра пылесборника, распластываются по ней и перекрывают значительную часть рабочей поверхности фильтра, что приводит к ухудшению работы пылесоса (мотор перегревается, а скорость всасывания уменьшается). Поэтому в разрыв входного шланга полезно на этот случай встроить некий ресивер - емкость сравнительно большого поперечного сечения, в которой эти плоские листки и другой крупный мусор падали бы на дно ресивера, а воздух с мелкой пылью шел бы дальше, к фильтру пылесборника. Этот ресивер можно пристыковать прямо к входному отверстию пылесоса, причем он может быть съемным, т.е. подключаться только в тех случаях, когда предстоит убирать захламленное помещение с теми самыми конфетными обертками и т.п.

Учитывая все сказанное, схему пылевого потока можно перерисовать так (см. рис. 21а):

Переходим к неочевидным потокам. Их неочевидность сказывается прежде всего в том, что и анализ их совсем непохож на то, что мы проделали выше. Например, силовые цепи, которые почти на 100% формируются крепежными элементами и конструктивными особенностями формы отдельных элементов. Анализ здесь - это практически анализ эскизов и чертежей сборки отдельных узлов и отдельных элементов, т.е. чисто конструкторская задача, которой мы здесь заниматься не будем (такие задачи отлично решаются в рамках ФСА для каждого узла).

Проблема перемещения пылесоса по очищаемым помещениям еще более неординарна. Для большинства моделей пылесосов она вообще решается не в системе, а в надсистеме, где человек - уборщик является и тягловой силой пылесоса. В фантастических романах уже давно живут и работают роботы-уборщики, но реально для сегодняшнего уровня техники эта задача если и посильна, то очень недешева, и пока такие модели на нашем рынке отсутствуют. Хотя в принципе прорисовать схему “умного и самостоятельного” пылесоса не составило бы труда. И тогда потоки, связанные с этими перемещениями пылесоса (или, возможно, только его части), вполне понятны и доступны для анализа.

Информационные потоки. Эти потоки в технических системах обычно проявляются либо как обратные связи (с выходом на исполнительный орган), либо как индикация (с выходом на индикатор состояния). Но внутренняя организация этих потоков во многих случаях для потребителя не видна, а разработчику может доставить неприятности, если он недостаточно тщательно организует эти потоки.

Начнем с вопроса, какая информация от пылесоса нужна потребителю. Очевидно, это информация о включении (подаче напряжения на вход), информация об исправности пылесоса, информация о наполнении пылесборника. Информацией о включении, если пылесос исправен, мог бы быть и шум мотора и вентилятора. Однако если мотор почему-либо застопорен, то подача напряжения при отсутствии шумовой “индикации” может привести к серьезным неисправностям (мотор просто сгорит). Поэтому лучше все же иметь альтернативный индикатор подачи напряжения (хотя бы лампочку).

Информация об исправности пылесоса. Рассмотрим типичные неисправности этого агрегата. Их три: 1) мотор сгорел, 2) вентилятор заклинил, 3) скорость прокачки воздуха уменьшилась ниже допустимого предела (причины могут быть разными).

Две первых неисправности связаны с вращением вала мотора (точнее, с отсутствием вращения) и, стало быть, могут регистрироваться любым центробежным датчиком, связанным с валом. Третья неисправность требует измерения объемного расхода воздуха после вентилятора (например, с помощью крыльчатки и счетчика оборотов или по перепаду давления на измерительной диафрагме).

Информация о наполнении пылесборника. Проще всего эту информацию получить, измеряя перепад давления на фильтре пылесборника. Это, кстати, даст информацию не только о количестве накопленной пыли, но и о тех самых конфетных обертках, если они попали в пылесборник и мешают нормальной работе пылесоса. Иначе говоря, эта информация сводится к тому, что пылесос должен сообщить человеку, что пора опорожнить пылесборник.

Таким образом, информационная сеть пылесоса оказывается довольно сложной и содержит много изолированных потоков. Разумно всю индикацию сосредоточить в одном месте (на пульте управления), а это означает, что всю ее имеет смысл перевести в световую сигнализацию (а особо важную информацию задублировать и звуком).

Вообще говоря, на рис. 22 нехватает одного очень важного информационного элемента. Этот элемент должен не допустить аварийной ситуации, которая могла бы возникнуть в случае либо короткого замыкания электрической цепи, либо длительной подачи напряжения на застопоренный мотор.

Короткое замыкание может возникнуть везде, начиная от сетевой вилки. Это значит, что абсолютно надежный предохранитель может быть установлен только на источнике напряжения вне пылесоса, т.е. на квартирном счетчике или где-то до розетки. Что касается короткого замыкания внутри пылесоса, то оно при нормальном монтаже должно быть исключено, а такие ситуации, как проплавление утюгом изоляции сетевого шнура пылесоса или переруб этого шнура упавшим топором, можно не учитывать. Но близкий к короткому замыканию режим возникает, когда напряжение подается на обмотку застопоренного мотора, и квартирный предохранитель здесь может не сработать. Таким образом, задача состоит в том, чтобы при длительном превышении тока обмотки (на уровне пускового тока) пылесос сам отключал подачу электроэнергии на обмотку. Иначе говоря, нужно ввести еще цепь обратной связи и управления подачей напряжения на мотор.

Схема информационных потоков пополнилась еще одной цепью. Вообще говоря, в нашем агрегате почти вся информация передается по электрическим цепям, т.е. после преобразования первичных сигналов от разнообразных датчиков носитель информации становится одинаковым для всех информационных потоков. Финишное преобразование электрического сигнала в свет (и в особенно важном случае - еще и в звук) также единообразно. Это заставляет подумать об оптимизации параметров носителя информации. В данном случае каждый из потоков несет только один бит информации (сигнал “да - нет”), так что вопросы скорости передачи, отсутствия искажений и т.п. вопросы телекоммуникационного плана здесь излишни, остается лишь вопрос удобства и надежности.

Использовать в этих сетях 220V неудобно прежде всего из-за требований безопасности. Поэтому для питания информационных цепей целесообразно поставить понижающий трансформатор и работать при 6 или 12 вольтах. Это потребует соответствующих изменений в схеме потоков электрической энергии рис. 19б.

Подводя итоги этого анализа, можно заметить, что, изменив “точку зрения” на анализируемый объект, удается увидеть массу возможностей для его модификации.

И еще одно замечание. По внешнему впечатлению, вся эта “возня” с потоками кажется какой-то мелкой, посторонней деятельностью, бесполезной и неинтересной. Однако уже наш пример достаточно ясно показывает, что эта рутинная работа каким-то малопонятным образом наталкивает на необычные идеи и решения.

5.2.2. Пример 2. Издание бюллетеня.

Издание подписного бюллетеня - дайджеста научных работ по тематике ионной имплантации - это реальная задача. Возникла она в связи с тем, что к 1996 году десятки институтов и научно-производственных комплексов, связанных с ионной имплантацией (внедрением быстрых ионов в твердое тело), оказались в информационном вакууме: средств подписаться на научные журналы практически нет, а информация по данной тематике распылена по полутора сотням научных периодических изданий, каждое из которых к тому же взвинтило подписную цену в соответствии с уровнем инфляции.

Рассматриваемая система может быть отнесена к информационным системам операционного вида, хотя она теснейшим образом связана с информационной системой предметного типа (система "бюллетень-дайджест"). Основные объекты, формирующие соответствующие потоки в этой двойственной системе, таковы:

1. Информация по тематике ионной имплантации.
2. Информация о подписчиках.
3. Информация о бюллетене.
4. Бумага.
5. Тираж бюллетеня.
6. Деньги.
плюс еще некоторые менее значимые или промежуточные объекты.

Заметим, что любое новое издание обычно начинается с выпуска нулевого номера и бесплатной рассылки его тиража потенциальным подписчикам. Не исключение и данный бюллетень. Поскольку потоки, обозначенные выше, очень тесно друг с другом взаимодействуют, то мы для упрощения поступим так: рассмотрим состав и структуру системы операционного вида и проследим на этой структуре прохождение каждого из потоков. При этом будем рассматривать именно выпуск нулевого номера (а не устоявшееся издание бюллетеня).

Информация по тематике. Суть всего замысла состоит в том, чтобы эту информацию сжать, сконцентрировать в одной брошюре и предоставить эту брошюру подписчику. Для нулевого номера есть дополнительная задача: показать будущему подписчику, что ему это совершенно необходимо. Поток информации по теме имеет два источника: общедоступные библиотеки (2) и малодоступные препринты и отчеты коллег (1). Информация из обоих источников переносится на бумагу ксерокопированием (6) и поступает на комплектование (11), которое в некоторых случаях требует составления аннотаций (12) (большинство статей уже имеет аннотации, поэтому их просто копируют из журнала).

Для удобства работы с бюллетенем составляется также авторский указатель (13). Вся эта информация в нормализованном виде поступает на изготовление оригинал-макета (14), с которого уже производится тиражирование (15). И, наконец, тираж рассылается потенциальным подписчикам (17) - это и есть полезный результат, замыкающий элемент данного потока. Впрочем, рассылается не весь тираж, его остаток составляет резерв (23), который впоследствии будет либо разослан по запросам, либо списан, уничтожен.

Заметим, что, назвав источники (1 и 2), полезный результат (17) и элемент, утилизирующий остаток (23), можно к ним добавить и преобразователь потока (11+12+13), переводящий информацию в иной, более сжатый вид, и транспортные элементы (6 и 15), переносящие информацию с одного носителя на другой (или другие).

Информация о подписчиках. Для нулевого номера исходная ситуация - отсутствие подписчиков. Собственно, рассылка извещений и нулевого номера преследует как раз цель - генерировать, создать список абонентов, подписчиков, т.е. вся данная система в целом является источником информации о подписчиках. Поэтому данный поток здесь только зарождается и формируется в элементе (22).

Информация о бюллетене. Источником ее являются инициаторы издания - Научный Совет РАН и один из институтов Российского научного центра “Курчатовский институт” - оба они обязались финансировать издание нулевого номера. В схеме рис. 12 источником информации для потенциальных подписчиков являются элементы (5) и (15). Информация из источника (5) распределяется на 2 потока: один идет в прессу (19), которую предположительно читает научный мир, другой - в рассылку на предприятия (20), которые тематикой занимаются, но прессу читать не склонны, да и нет ее на предприятии. По пути оба потока проходят этап передачи, переноса на другой носитель: в одном случае - в научный журнал (19), в другом - на тираж информационного листка (21).

Бумага. Источник бумаги находится вне системы, появляется она на этапе (9), поток разветвляется на два, обслуживающие тиражирование бюллетеня (15) и извещения (21), там и прекращает свое существование (как чистая бумага), отходы при тиражировании утилизируются вне системы (в типографии).

Тираж бюллетеня. С ним все коротко и ясно: источник (15), полезный результат (17), резерв или остаток (23).

Деньги. С них начинается все: если источник (3) отсутствует, то ни одна из операций (кроме тех, которые выполняют бессребреники - энтузиасты) не будет выполнена. Поэтому поток денег должен из источника (3) разветвиться на элементы (4, 7, 8, 9, 10, 16, 18, 19 и 20) и замкнуться на соответствующих оплачиваемых операциях. Никаких преобразований (бухгалтерские операции мы здесь не рассматриваем), никаких остатков в схеме не просматривается. Хотя если подходить строже, то финансовый поток окажется совсем не прост: налоги (разные для разных частей потока), отчисления во всякие фонды, амортизационные расходы, и т.п. Но - это совсем другая система.

Мы не разрисовываем здесь каждый из названных потоков, поскольку проследить их можно по стрелкам на рис. 23 (кстати, посмотрите на схему внимательно: все ли там указаны стрелки и нет ли лишних?). Но, поверьте на слово, автору пришлось не один раз перекраивать и доделывать эту схему, прежде чем она приняла такой сравнительно внятный вид. Раскраска схемы несколько отличается от обычной: зеленым обозначены ячейки, соответствующие истокам того или иного потока, морковным - сток (остаток) или полезный результат.

(В заключение этого примера стоит сказать, что идея издания этого конкретного бюллетеня так и не была реализована. Почему? Надеюсь, читатель сам догадался).

Упражнения:
 1. Определить основные потоки в системе “пассажирский вагон дальнего сообщения”.
2. Рассмотреть систему “продовольственный магазин” и проследить в ней потоки следующих объектов: а) деньги, б) покупатели, в) молоко, г) живая рыба, д) вода, е) электричество. Какие еще потоки существуют в этом магазине, который имеет статус АОЗТ?
3. Определить в системе “электродрель ручная” все энергетические и информационные потоки.

5.3. Закон динамичности

Система должна обладать хотя бы минимальной степенью динамичности и управляемости, обеспечивающей ее функционирование в некотором диапазоне изменения внешних условий, характеристик внутренних связей, свойств элементов системы.

При беглом чтении этого текста часто происходит путаница в понимании термина “динамичность”, поэтому подчеркнем, что речь идет не о шустрости или быстроте реакции системы, а о способности адаптироваться, приспосабливаться к меняющимся условиям и свойствам объектов, не теряя при этом своей работоспособности.

Посмотрим, как проявляется этот закон в тех системах, которые анализировались в разделе 5.1.

1. Пассажирский железнодорожный вагон поезда дальнего сообщения. Внешними условиями для этой системы являются, например: железнодорожная колея, климатическая среда, источник энергии. Очевидно, что не любой вариант каждого из перечисленных объектов позволит системе выполнить свои функции с приемлемым качеством; в то же время очевидно, что имеется допустимый диапазон вариации параметров названных внешних условий, когда система еще работоспособна. Например, колея в соответствии с российским стандартом имеет определенный допуск по ширине (измеряемый долями миллиметра), и в пределах этого допуска тележки вагона функционируют нормально; в то же время перейти на более узкую европейскую колею отечественный вагон не может без замены тележек. Аналогичная ситуация и с климатической средой, и с источником энергии: везде есть ГОСТ и ТУ, определяющие диапазон рабочих температур, влажности, предельную нагрузку (грузоподъемность, пассажировместимость, скорость движения, и т.п.) и массу других эксплуатационных характеристик; для источника электропитания всегда регламентируются допустимые колебания и по амплитуде, и по частоте и форме синусоиды (если речь идет о переменном напряжении). В общем, для технических систем предметного типа закон динамичности выливается в перечень ТУ на данный объект. Но этим не ограничивается проявление закона динамичности. Ведь для каждой из подсистем другие подсистемы являются в известной мере внешним окружением, и нормальное функционирование подсистем в силу того же закона возможно лишь при наличии некоего диапазона изменения связей, взаимодействия между подсистемами и свойств этих подсистем.

2. Технология плазменного напыления нитрида титана на столовые приборы. Это - техническая система операционного типа, здесь понятие динамичности и управляемости относится как к элементам системы (поскольку элементами в данном случае являются операции, функции), так и к связям системы (внутренним и внешним).

Для каждой операции должен быть определен минимальный диапазон по каждому из условий ее осуществления. А эти условия легко усмотреть из таблицы Рис. 24:

Вопрос | Вид связи
1) кто (что) выполняет данную операцию? | субъект операции
2) что является объектом операции? | объект операции
3) где выполняется операция? | место операции
4) когда выполняется операция (по отношению к другим операциям) и сколько она длится? | время операции
5) как, каким способом выполняется операция? | способ осуществления операции
6) кому предназначен результат операции? | адресат операции

Рис. 24.

В данной конкретной системе эта таблица конкретизируется следующим образом:

1) Субъект операции - это конкретное устройство (аппарат, установка), выполняющее нанесение покрытия. Очевидно, что технология может быть реализована на установках различных марок и типов, иначе (как и в притче с писцом, письма которого мог прочесть только он сам) такая технология для общества не представляла бы практически никакой ценности.

2) Объект операции - столовые приборы. Тоже очевидно, что технология должна быть применима к множеству различных типов столовых приборов, только тогда она найдет массовое применение.

3) Место операции. Разумеется, здесь условия приемлемости технологии для общества требуют совершенно не такой динамичности в отношении места, как, например, при выращивании винограда сорта Хванчкара.

4) Способ осуществления операции, как правило, является стержневым элементом технологии, и здесь допустимый диапазон вариаций очень часто – нулевой, в данном случае этот способ именуется способом реактивного распыления (возможны и другие способы, дающие сходный результат; но в этих случаях и технология именуется по-другому).

5) Адресат операции. Что касается столовых приборов, то адресат, в общем-то, однозначен: это торговля предметами бытового обихода. Однако, не далее как в 1996 году адресатом данной технологии оказалась православная церковь: купол храма Христа Спасителя “позолочен” с помощью именно этой технологии.

В заключение анализа этого примера отметим, что нулевой диапазон динамичности может встречаться в системах операционного типа почти для любого вида связей; при этом можно говорить, что мы имеем дело с уникальной системой, единственной в своем роде. Например, к такому типу систем можно отнести методику работы любого из великих мастеров искусства. Именно из-за уникальности их методик экспертам удается даже по прошествии многих лет и веков авторизовать их труды.

3. Партия (политическая). Как известно, законами любой страны налагаются определенные регламентные ограничения на организации, именуемые партиями. Диапазон условий существования (легального) партий в демократическом обществе достаточно широк, но все же ограничен (недопустимость разжигания розни, и т.п.). В тоталитарном обществе диапазон “внешних” условий существования партий крайне узок (как по Форду: “Я сделаю Вам машину любого цвета при одном условии: она должна быть черной”), при диктатуре этот диапазон сужается до нуля. Но не только внешние условия определяют жизнеспособность партии. Партия функциональна в известном диапазоне различия точек зрения ее членов (вспомните, как появилась буква “(б)” в названии РКП), в известном диапазоне уровня ее финансирования (при меньшем финансировании она бессильна, при слишком большом - развращена и вследствие этого в глазах общества опорочена), в известном диапазоне централизации управления (не анархия, но и не “Бесы” Достоевского), и т.д. Наконец, партия - это объединение различных людей, различных не только по образу мыслей (это уже отмечено выше), но и по возрасту, и по образованию, и по роду деятельности; по всем этим параметрам должен быть определен допустимый диапазон их изменения. Смешно, например, создавать партию двадцатидвухлетних девиц, или партию инженеров-механиков. Но естественной будет и партия молодежи, и партия инженерно-технической интеллигенции, где можно задать и диапазон возраста (в первом случае), и диапазон специальностей и выпускающих вузов (во втором случае).

4. Заключение контракта. В этой социальной системе операционного типа также имеются и внешние условия (законодательство, состояние рынка товаров и услуг, степень экономической стабильности), и условия внутренние, связанные с подсистемами этой системы. Рассмотрим на примерах, как влияет динамичность этой системы на ее жизнеспособность.

Газеты жалуются, что плохо притекает иностранный капитал в Россию, и это несмотря на громадный спрос и блестящие перспективы по возможной прибыльности контрактов. А дело просто в том, что щель среди законодательных рогаток для инвесторов столь узка, уверенность в неизменности экономического курса и экономического законодательства столь мала, т.е. стоимость риска (включаемая в цену контракта) столь велика, что при этих условиях только в очень редких системах подобного рода диапазон допустимости этих условий включает в себя область реально имеющихся условий, так что системы оказываются жизнеспособными и “доживают” до рождения конкретного контракта.

Точно так же жизнеспособность системы зависит и от внутренних ее условий. Можно оценить диапазон допустимости условий функционирования каждой из внутренних подсистем (см. их перечень в п.4 раздела 5.1). Если контрагентом договора может быть только торговец колготками и только с фамилией Стеклобоев, то вероятность того, что контракт состоится, практически равна нулю, т.к. диапазон условий реализации подсистемы выбора контрагента сужен до точки, до нуля. Если расширить диапазон и отбросить условие о фамилии торговца, то появляется надежда заключения контракта. Наконец, совсем другое дело, если убрать из условия и “колготки”, оставив только то, что контракт будет заключаться с физическим лицом, занимающимся торговлей.

Аналогично обстоит дело и с заинтересованностью контрагента. Если, желая продать дом, вы имеете только один “заинтересовывающий” аргумент, что в доме очень светло, так как много окон, то вам трудно будет найти покупателя, для которого этого аргумента будет достаточно. Другое дело, если вы запасетесь диапазоном, комплектом аргументов, комбинируя которые в соответствии с вашими сведениями о нуждах контрагента, вы сможете с большей вероятностью добиться успеха, т.е. заключить нужный контракт.

Переговорный процесс, как известно, требует от участников высокого искусства, умения уговорить, умения понять контрагента, умения строить свои действия в зависимости от поведения партнера и его доводов. Жесткая, несгибаемая позиция и фиксированные условия (нулевой диапазон) - надежный путь сорвать любые переговоры и распроститься с контрагентом навсегда (лучше всего об этом написано у Дейла Карнеги).

5. Текстовый редактор - программа для РС. На рынке software сейчас присутствует множество текстовых редакторов самых разных фирм и стран. Первые версии этих программ, как правило, включали минимум операций, которые выполнял редактор в “докомпьютерную” эру (вспомните хотя бы наш отечественный Лексикон первоначальных модификаций, первую ласточку отечественных продуктов подобного рода). Однако сейчас разработчикам текстовых редакторов приходится оглядываться не столько на пользователя, сколько на конкурентов: планка минимально допустимого диапазона возможностей редактора поднята уже достаточно высоко, и каждый новый продукт должен хоть немного расширять возможности пользователя, быть хоть немного динамичнее предшественников.

По мере роста числа текстовых редакторов важным фактором стала их взаимная совместимость. Пользователь столкнулся с барьером: да, новый редактор значительно лучше, чем тот, которым я пользуюсь уже несколько лет, но он не может прочесть то, что я за эти годы набрал старым редактором. Как быть? И мощным шагом вперед стали редакторы, имеющие специальные программы – конверторы, позволяющие понять и “перевести” текстовый файл, обработанный другим редактором. Это резко увеличило динамичность новых версий текстовых редакторов и привлекло к ним массу пользователей.

6. Проведение научного эксперимента. Пожалуй, нигде закон динамичности не проявляется столь полно и выпукло, как в этой системе. Действительно, научный эксперимент ставится с целью проникнуть в область, где наших знаний либо вовсе нет, либо слишком мало, чтобы с уверенностью предсказать ход и результат эксперимента. Конечно, эксперимент эксперименту рознь, например, запуск ракеты к Юпитеру и изучение мутаций у дрозофилы несравнимы по управляемости. Но в общем случае большинство подсистем этой системы (их перечень приведен выше, в начале пункта 6 раздела 4.1) должно быть сформировано с максимальным запасом по динамичности. Это отнюдь не легко, т.к. создателям системы в общем случае неизвестно, что их может ожидать в ходе эксперимента, насколько фактический ход будет отличаться от предполагаемого и хватит ли реально тех возможностей по динамичности, которые заложены экспериментатором в схему и обеспечение эксперимента.

Вопросы и упражнения:
 1. Как проявляется закон динамичности при создании такой системы, как электробритва?
2. В чем выражается динамичность учебника истории для 7 класса?
3. Работает ли закон динамичности в естественных системах? Рассмотрите этот вопрос применительно к таким системам, как река, популяция кроликов, сосна, народность.
4. Как проявляется закон динамичности в системах: “железнодорожное полотно”? “обед в ресторане”? “кинотеатр”? “велосипед”? “контрольная работа по математике”? “волчья стая”?

5.4. Закон параметрического порога.

Количественные показатели работоспособной системы должны превосходить характерный для данной системы параметрический порог. При этом порог может быть не единственным, а “превосходить” не обязательно означает “быть больше”.

Собственно говоря, этот закон является конкретизацией первого из условий приемлемости, сформулированных для технических систем раньше, но одинаково справедливых для любых искусственных систем. И вместе со вторым из этих условий приемлемости является “воротами”, обеспечивающими системе путевку в жизнь.

Посмотрим, как этот закон реализуется в той же шестерке систем различного типа и в некоторых других системах.

1. Технические системы предметного типа

Пассажирский вагон дальнего сообщения. Любая количественная характеристика данной системы имеет допустимый диапазон изменения, но в одних случаях выход за пределы этого диапазона делает систему неработоспособной в принципе, а в других случаях он просто ухудшает эффективность работы системы. Например, расстояние между колесами в ходовой тележке вагона регламентируется допусками, выход за пределы которых неизбежно чреват аварией, т.е. делает систему неработоспособной как при уменьшении расстояния между колесами, так и при увеличении: в обоих случаях вагон сойдет с рельсов в первом же рейсе. Так что по этому параметру существуют два порога: верхний и нижний. А вот по поперечным габаритам вагона порог только один - верхний, т.к. уменьшение габаритов не лишает вагон работоспособности.

И, наконец, в параметре “пассажировместимость” отклонение от нормы всего лишь ухудшает эффективность использования, но не меняет функции системы. Вагон на одного пассажира (президента государства, например) - это полноценный вагон (даже более чем полноценный), но с резко ухудшенной эффективностью по расходу средств на перевозку одного пассажира. Купейный вагон курортного направления, набитый “левыми” пассажирами - все-таки тоже вагон, но с резко ухудшенными характеристиками по удобствам для пассажиров. В обоих случаях параметрического порога нет.

Рассмотрим систему, которая называется “самолет”. Самолет только тогда сможет выполнить свою ГПФ (летать), когда подъемная сила его крыльев станет больше его собственного веса. В противном случае это - что угодно (аэросани, например), но никак не самолет. Это условие (вместе со вторым условием приемлемости технической системы для общества) во многом определяет выбор физического принципа действия, закладываемого в основу работы вновь создаваемой системы. Вертолетный принцип для летательных аппаратов тяжелее воздуха (вращающееся крыло - винт) был предложен Леонардо да Винчи на несколько столетий раньше самолетного (неподвижное обдуваемое крыло), но первым поднялся в воздух именно самолет, так как параметрический порог (подъемная сила) у него достигается при значительно меньших удельных энергозатратах.

Сверхпроводник только тогда становится сверхпроводником (т.е. имеет нулевое электрическое сопротивление), когда его температура станет ниже определенной критической величины Тс. В соответствии с этим любая техническая система, использующая сверхпроводимость (например, электромагнит со сверхпроводящими обмотками), будет работоспособна только при названном выше условии.

2. Технические системы операционного типа.

Технология плазменного напыления нитрида титана на столовые приборы. Один из параметрических порогов этой системы - величина адгезии (сцепления) покрытия к подложке. Если усилие отрыва (отслоения) покрытия меньше определенной величины, то технология не будет принята в производство, т.е. система, не преодолевшая этот параметрический порог, может иметь статус интересного фокуса, но никак не технологии.

У этой технологии есть и другие количественные параметры, но не по всем из них можно назвать точное число, определяющее порог жизнеспособности. Например, ясно, что чем ниже скорость напыления, т.е. чем меньше производительность технологии, тем хуже ее экономическая эффективность; но нельзя назвать точное число (например, в квадратных сантиметрах, обрабатываемых в минуту), ниже которого технология безусловно отвергается, а выше которого - безусловно принимается. То-есть здесь параметрический порог отсутствует.

Иногда преодоление параметрического порога осуществляется оригинальными способами, вплоть до анекдотического. Например, в Германии практиковалась “общественная приемка” технологии варки пива, когда контрольная порция готового продукта выливалась на деревянную скамью определенной формы и веса, автор технологии в кожаных штанах усаживался на эту лужицу пива, сидел неподвижно определенное (строго регламентированное) время, после чего вставал, и если скамья отлеплялась от штанов и грохалась об пол (или вообще не прилипала к штанам), технолога с позором прогоняли; если же скамья прочно прилипала к штанам вставшего технолога, то его с почетом принимали в гильдию пивоваров, технология “преодолела параметрический порог”.

Осуществление цепной ядерной реакции деления. Из школьного курса помнится, что цепная реакция начинается только если масса делящегося элемента (урана или плутония) выше строго определенной величины, называемой критической массой. Этот параметрический порог определяет работоспособность и ядерного реактора, и атомной бомбы. Но выражение “критическая масса” из ядерной физики перекочевало и в другие области человеческой деятельности, вплоть до экономики, политики и семейных отношений, и везде оно трактуется именно в точном смысле параметрического порога.

3. Социальные системы предметного типа.

Политическая партия. По российскому законодательству регистрация партии возможна только в том случае, если численность ее членов - не менее 100 человек. Это и есть явно выраженный параметрический порог. Аналогичные параметрические пороги есть и в схожем случае организации избирательного объединения, где юридическая регистрация (дающая объединению определенные права и прежде всего “право на жизнь”) производится также при условии преодоления параметрического порога “минимальной численности”.

Национальная автономия. В Советском Союзе статус полноправной национальной республики могли иметь только регионы, где процент основной нации был не меньше 50, иначе республика понижалась в статусе до автономной (именно так это произошло с Карелией и чуть-чуть не произошло с Эстонией). Этот параметрический порог сопровождался и другим: суммарное население республики должно было быть не меньше одного миллиона человек. При меньшей численности регион получал статус национального округа, независимо от площади региона (и микроскопический Бурятский Усть-Ордынский национальный округ, и громадный Ненецкий национальный округ размером с Францию). Параметрические пороги при административном делении являлись необходимым атрибутом, “объективизирующим” наличие тех или иных прав и ограничений для конкретных регионов. После развала Союза и утраты компартией своей монополии на “кислородный вентиль” для всех и вся началась борьба областей, республик, краев и округов за свои права в новом государстве - России. Тенденции последнего времени таковы, что вскоре названный параметрический порог, по-видимому, исчезнет или превратится в чисто декоративный фактор, предназначенный для удовлетворения самолюбия нацменьшинств.

4. Социальные системы операционного типа.

Заключение контракта. Для этого процесса есть нижний параметрический порог и по числу участников (не менее двух), и по сумме контракта (не менее стоимости самого процесса заключения), хотя в последнем случае реальная ценность контракта может включать не только денежную компоненту, так что выявление данного параметрического порога может потребовать довольно сложной оценки всех неденежных факторов.

Выдвижение кандидата в президенты РФ (выборы 1996 года) требовало сбора подписей в поддержку данного кандидата в количестве не менее миллиона, причем этот параметрический порог сопровождался и другим: эти подписи должны быть собраны не менее чем в пяти регионах. Вообще говоря, любая выборная кампания всегда обставляется массой условий, во многих случаях сформулированных в точном соответствии с определением параметрического порога, приведенным выше.

5. Информационные системы предметного типа.

Текстовый редактор - программа для РС. В доисторическую эпоху персоналок типа ХТ или отечественной ДВК одним из важнейших параметрических порогов для данного программного продукта был размер редактора: если он превышал емкость постоянной памяти компьютера, то нечего было и говорить о применимости этого текстового редактора на данном конкретном компьютере. Другой параметрический порог из тех же времен - скорость работы редактора. Прекрасный редактор WORD6 для Windows, однако, совершенно непригоден для работы на компьютере с размером оперативной памяти £ 1 Мб: Вы успеете напиться чаю и полчасика вздремнуть, пока он обработает и распечатает табличку в полстраницы величиной. Заметим, однако, что между программой (software) и компьютером (hardware) есть динамическое равновесие, соответствие параметрических порогов, и изготовители программного продукта в своих информационных текстах почти всегда указывают все параметрические пороги hardware, которые должны учитываться для того, чтобы данная software проявила себя наилучшим образом. Например, тот же WORD6 для Windows требует RAM не меньше 2 Мб и свободной памяти на жестком диске не меньше 6 Мб (и указывается, что лучше бы RAM=4 Мб, а на жестком диске - 11 Мб, но это уже для расширения возможностей редактора за пределы обязательного минимума).

Другой пример. Один из коварнейших способов рекламы - импульсная реклама (25-й кадр) в телевизионных передачах и кинофильмах. Если рекламный кадр длится менее 1/20 секунды, то сознание зрителя не успевает даже зафиксировать его появление. Но подсознание информацию этого кадра получает и обрабатывает. И ничего не ведающий клиент идет и покупает определенный товар сразу же, как его встретит. Так вот, стоит длительность рекламного кадра увеличить хотя бы вдвое, т.е. до такой величины, что зритель уже сможет его рассмотреть и осознать, как эффект от этой рекламы резко падает и может даже изменить знак, т.к. явная реклама зрителю уже давно навязла в зубах и дает скорее негативный эффект. Так что и здесь имеет место параметрический порог - длительность экспозиции рекламного кадра.

В заключение этого раздела рекомендуется выполнить следующее упражнение для всех приведенных в нем объектов.

Упражнения:
 1. Определить, какие параметрические пороги следует учитывать при создании следующих систем:
1) микроволновая печь,
2) выращивание арбузов,
3) гаражный кооператив,
4) реализация тиража справочника терапевта:
5) реклама рыболовных крючков,
6) конкурс бухгалтерских компьютерных программ.
2. Как связаны между собой законы динамичности и параметрического порога?

Выполняя первое упражнение, Вы неизбежно столкнетесь с ситуацией, когда по отношению к какому-либо из заданных объектов Ваши знания окажутся чисто дилетантскими, т.е. поверхностными. Этот факт для многих является непреодолимым психологическим барьером, не позволяющим вторгаться в область собственной недостаточной компетентности. А зря. Ведь кроме знаний по специальности, для анализа систем нужно владеть методологией системного подхода (чем, собственно, мы и занимаемся), и эти два рода знаний у большинства людей с традиционным образованием не пересекаются.

Опыт автора показывает, что при решении реальной проблемы наиболее эффективна работа тандема: методолога - системщика и традиционного специалиста - предметника. Не сразу этот тандем становится работоспособным, вначале специалист - предметник может весьма критично (и даже пренебрежительно) относиться к “глупым” вопросам и “нелепым” построениям системщика. Но после того, как из этой “мешанины глупостей” вдруг, как чертик из табакерки, появляются совсем не тривиальные идеи и решения, предметник по-иному начинает относиться к действиям системщика и со временем охотно осваивает весь его арсенал.

Для методолога же важным является убеждение, что браться ему можно за задачу из любой области, так как правила построения и развития систем едины для всех без исключения объектов окружающего нас мира. Если же Ваши пробелы в специальных знаниях по исследуемому объекту будут восполняться помощью предметника (или, на худой конец, справочником или учебником по нужному предмету), то результат обязательно будет получен. Поэтому - смелее, не смущайтесь тем, что из шести задач упражнения Вам знакомо, например, меньше половины перечисленных объектов, это не должно мешать найти большую часть решений.


Законы развития систем

Системно-морфологический подход
в технике, науке, социальной сфере.
Титов В.В.

6. Законы развития систем

Четыре рассмотренных в предыдущей главе закономерности обеспечивают минимальную работоспособность системы в том окружении, для которого она создается. Однако по мере развития и распространения системы и по мере развития и изменения ее окружения частенько происходит нарушение какой-либо из этих закономерностей. Это не значит, что система испортилась, нет, она осталась такой же, просто изменилось ее окружение (надсистема) и поставило новые условия для функционирования нашей системы. Так что система тоже должна измениться в соответствии с изменившимися условиями, причем измениться так, чтобы ее ГПФ выполнялась не хуже, чем раньше. До поры до времени необходимое изменение системы не форсируется, поскольку изначальное условие некоторой динамичности системы позволяет ей “со скрипом” функционировать в первоначальной форме. Но - только до поры до времени, пока не исчерпан исходный ресурс динамичности.

Естественно, что развитие, изменение систем также управляется определенным комплексом правил или закономерностей. И для разработчика любой из систем крайне важно знать эти закономерности, чтобы упреждающим образом модифицировать систему, не только не давая ей отстать от изменяющейся надсистемы, но иногда даже более того, подталкивать своим изменением развитие надсистемы в целом.

Если законы построения систем являются серьезным подспорьем при проведении предметного и функционального анализа, то законы развития систем “обслуживают” наиболее богатую событиями и захватывающую часть анализа - исторический анализ, на базе которого и формулируется завершающий аккорд - прогноз, в каком направлении будет развиваться система.

Законы развития систем непосредственно вытекают из трех основных законов диалектики: закона единства и борьбы противоположностей, закона перехода количественных изменений в качественные и закона отрицания отрицания.

Основным и наиболее важным законом развития систем является закон повышения идеальности системы.

6.1. Закон повышения идеальности системы.

Понятие абсолютно идеальной системы в какой-то степени сродни понятию абсолютной истины: и то, и другое одинаково недостижимо. В свое время известный авиаконструктор и ученый Р. Бартини говорил своим сотрудникам: “Самый лучший агрегат самолета - тот, который во время полета остается на земле”. Иными словами, идеальная система - это такая, когда ГПФ системы выполняется … без самой системы. Степень приближения к идеальности может быть различной. Соответственно, различными являются и целевые установки, направленные на повышение идеальности. В работе [3] для технических систем предложен такой ряд целевых установок:

1. Получить заданный полезный результат от действия или средства без самого этого действия или средства (”Получить - даром!”).

2. Ввести требуемые средства или взаимодействия только там, где это нужно, и только на то время, пока это нужно (“Ничего лишнего!”).

3. Максимально использовать внутренние резервы системы (т.е. вещества, поля, свойства, бесполезные (и особенно вредные) входы и выходы, и т.д.), устранять потери и отходы (“Из лишнего - максимальную пользу!”).

4. Максимизировать скорости и интенсивности всех процессов, обеспечивающих достижение полезного результата (“Получить - сразу!”).

Этот ряд расположен в порядке убывания эвристической силы установок, поэтому порядок опробования их для каждой конкретной системы желательно начинать с первой позиции. Кстати, очень неплохо придуманы авторами [3] сопровождающие лозунги к каждой из установок.

Сформулировав закон и четыре варианта направлений его реализации, следовало бы перейти теперь к примерам, как мы делали и раньше. Но в этой главе примеры будут строиться несколько иначе, поскольку, как уже говорилось, законы развития систем реализуются в истории системы, и большая часть примеров, естественно, будет относиться к прошлому рассматриваемых систем. Но попутно это и приглашение читателя от прошлого (истории) заглянуть в будущее, т.е. попытаться спрогнозировать будущее рассматриваемых систем. Между прочим, здесь дилетантские знания об объекте могут оказаться предпочтительнее глубоких специальных (стоит вспомнить утверждение одного из корифеев науки: “Все знают, что это невозможно, а какой-нибудь чудак не знает и … делает открытие!”)

Итак, вспомним историю. Нефтеналивной флот возник вскоре после того, как человек понял, что нефтью можно не только лечить некоторые кожные заболевания. Первые суда возили нефть в бочках, и отношение массы перевозимого продукта к массе перевозчика составляло менее 1/50. А далее это соотношение постепенно изменялось: относительный вес транспортной системы (по отношению к весу перевозимого продукта) в процессе развития системы все уменьшался и уменьшался. А последние идеи заменить громадный супертанкер с прочным (а значит, и массивным) корпусом небольшими буксируемыми емкостями с тонкими эластичными стенками, повидимому, еще приблизит эту систему к идеальной.

В действительности история развития любого транспортного средства проходит эту стадию повышения идеальности, причем в наиболее выразительной и наглядной реализации по первому варианту.

Рис. 25

Когда первый вариант повышения идеальности исчерпан, человек ищет пути использования второго варианта повышения идеальности. Вот как интересно был реализован этот принцип на том же водном транспорте. При строительстве Асуанской плотины требовалось отсыпать многие миллионы кубометров скального грунта в тело будущей плотины. Дробленый камень доставляли по Нилу в баржах. Если погрузка баржи с помощью самосвалов и экскаваторов была отработана нормально, то с разгрузкой дело обстояло сложнее, т.к. постоянного места разгрузки не было (Нил широк). Решение пришло такое: баржа понтонного типа (боковые стенки баржи изготовлены из пустотелых понтонов). Подведя баржу, заполненную доверху камнем, к месту разгрузки в русле реки, капитан открывал кингстоны одного из бортов, баржа наклонялась, весь груз сваливался в воду сам и … проблема решена! Ни грузчиков, ни экскаваторов, а камень разгружен. Конечно, здесь “даром” - это понятие относительное, необходимая работа в действительности совершена за счет работы при погрузке (потенциальная энергия груза, поднятого на борт баржи). Но - погрузка и так, и так была необходима, а вот разгрузку человек ухитрился осуществить за счет гравитации, не применяя собственных усилий (кроме умственных, конечно). Точно так же разгружают, кстати, и баржи с лесом, сбрасывая его в воду простым наклоном баржи (как показано на рис. 25).

Пример с баржей можно интерпретировать и как результат использования всех четырех приемов увеличения идеальности. Действительно, экскаватор-разгрузчик исчез? - исчез (первый прием). Действительно, процедура подтопления баржи имеет место только там и только тогда, когда надо (второй прием). Действительно, для разгрузки используются резервы системы - потенциальная энергия груза, поднятого на борт (третий прием). И наконец, вместо многочасовой перегрузки ковшом или схватом экскаватора - секундное сползание груза и опорожнение баржи (четвертый прием).

В операционных технических системах повышение идеальности - очевидное и наиболее широко применяемое средство продления жизненного цикла системы. Особенно если учесть, что любой из приемов повышения идеальности связан с увеличением того или иного вида физической эффективности системы (см. выше). Однако сравнивая формулировки приемов повышения идеальности, перечисленные в этом разделе, и формулировки физической эффективности, нетрудно видеть, что акценты в них расставлены несколько по-разному, и в связи с этим имеет смысл одновременно, параллельно использовать оба варианта формулировок.

Интересный пример реализации закона повышения идеальности - технология СВС (Самораспространяющийся Высокотемпературный Синтез). Карбиды тугоплавких металлов - очень перспективные и нужные конструкционные материалы. Нужные из-за одного своего свойства - способности выдерживать крайне высокие температуры (3-4 тысячи градусов) без потери механических свойств. Но чтобы реакция металла с углеродом пошла (а это был единственный способ получения такого материала), их нужно нагреть почти до 3000 градусов, т.е. технология получения продукта оказывается очень энергоемкой и капризной (из-за неполноты реакции и загрязнения материалом тигля, в котором идет реакция). Кроме того, последующее формование и спекание полученного карбидного порошка в деталь нужной формы требовало еще больших энергозатрат. В общем, дорого обходилась эта технология.

В связи с этим открытие принципа СВС было принято мировой научной общественностью "на ура". Причем не только из-за практической значимости, но и из-за красоты решения. Авторы обратили внимание на то, что реакция М+С=МС - экзотермическая, т.е. идет с выделением тепла. В обычном тигле, нагреваемом снаружи, это тепло малозаметно по сравнению с теми колоссальными энергозатратами, которые приходится нести для того, чтобы реакция прошла. Да и тепло это быстро уходит в виде излучения и практически не сказывается на ходе реакции. Тогда авторы открытия спрессовали смесь мелкодисперсных порошков металла и графита в сплошной монолит (прямо в форме готовой детали) и "подожгли" реакцию синтеза в малой области (например, искровым или дуговым разрядом). Получившийся эффект действительно эффектен. От точки реакции (раскаленной до ~2500С) тонкая ярко светящаяся полоска - волна с заметной скоростью пробегает всю поверхность спрессованной детали (разумеется, одновременно она распространяется и внутри детали, т.е. это - объемная волна), и... после остывания деталь из высокотемпературного карбида готова!

Таким образом, здесь "идеализация" технологического процесса реализована сразу в нескольких направлениях, а именно:
1. Исчез внешний источник тепла (его функции переданы внутреннему источнику) (получить - даром!)
2. Исчез тигель (реакционный объем и форма поддерживаются без тигля) (получить-даром!)
3. Тепло для синтеза выделяется только там, где оно нужно, и только тогда, когда оно нужно. (ничего лишнего!)
4. Экзотермический эффект использован как внутренний резерв системы (из лишнего - максимальную пользу!)
5. Процесс синтеза и создания готовой детали идет намного быстрее (секунды вместо часов), чем при традиционном способе. (получить - сразу!)

Итак, с техническими системами примеров достаточно, и читатель может привести их значительно больше, они окружают нас повсеместно. Посмотрим, как обстоит дело с системами социальными. В глобальном масштабе хорошим примером является развитие способа промышленного производства в человеческом обществе. Первобытно-общинный строй и натуральное хозяйство предполагали принцип “Делай все сам”. Первые товарообменные операции (бартер, по-современному) ввели в обиход другой принцип: “Делай сам те товары, что ты делаешь лучше, эффективнее других”. Первые коллективные производственные объединения - мануфактуры перешли к разделению труда даже при производстве отдельных единиц товара: “Делай сам только те операции, что ты делаешь лучше и быстрее, чем другие”. Следующим шагом в развитии производства явилась замена человеческого труда машинным (“Делай только то, что не может сделать машина”), но - это уже другая история, связанная с другим законом развития систем, о котором разговор будет позже.

Еще пример - правоохранительные органы. Как известно, ГПФ этой системы - обеспечить выполнение законов, т.е. правил сосуществования людей в данном конкретном государстве. А как бы хорошо было, если бы выполнение законов осуществлялось без правоохранительных органов (ну это уж чистой воды идеализм!). Первый прием повышения идеальности в данном случае может служить “лакмусовой бумажкой” в определении, каково же состояние общества в этом государстве. Если при гипертрофированной правоохранительной системе (ГУЛАГ, тройки, сексоты) о законности никто и не думает, дело плохо. Если в стране адвокатов больше, чем судей, это уже лучше. И наконец, еще лучше, если профессия судьи является общественной, когда суд идет “по совести”.

Второй прием повышения идеальности правоохранительной системы реализован в изолированных племенах и малых общинах, где суд старейшин собирается только тогда, когда в этом есть необходимость (а она появляется нечасто), в остальное время те же старейшины трудятся по мере сил “на общем поле”. И в России, и в других странах такой принцип реализуется довольно часто, когда мелкие локальные спорные вопросы разрешаются либо авторитетным для обеих сторон арбитром, либо местным представителем далекой центральной власти (фактически осуществляющим на месте функции всех трех ветвей власти).

Использование внутренних резервов при развитии правоохранительной системы - это фактически подключение законов этики, законов совести к формированию правосознания людей. Десять христианских заповедей ни в одном кодексе законов не фигурируют, но ими пронизаны почти все статьи почти любого закона. А в общем-то ведь все десять заповедей сводятся к одной: “Не делай другому того, чего не хочешь себе”. И вот это чисто воспитательное мероприятие, этот принцип, принятый каждым членом общества, может свести функции правоохранительной системы к минимуму.

Четвертый прием повышения идеальности правоохранительной системы также является хорошим тестом на совершенство этой системы. Если преступник совершенно спокоен, потому что уверен, что возмездие маловероятно и необременительно, то система больна, очень больна. Если же потенциальный преступник знает, что возмездие будет быстрым и неизбежным, то преступление не состоится вообще. В этом смысле показательна такая ситуация. В одной из стран, где терроризм “достал” власти вконец, начались некоторые странности. Террористы, добившиеся выполнения всех своих условий, спустя довольно короткое время умирали. Это случалось либо в тюрьме (если они туда попадали, будучи выданными правосудию страны), либо на свободе в результате самых разных причин, причем даже в другой стране. Довольно быстро стало ясно, что слишком уж много совпадений случайными не бывают, и терроризм быстро пошел на убыль и вскоре почти совсем прекратился (впрочем, фундаменталисты нашли способ обойти эту трудность с помощью смертников).

Итак, в технических системах и в юриспруденции примеры реализации закона повышения идеальности достаточно наглядны. Заглянем теперь в медицинский мир и посмотрим, как там обстоит дело с этим законом.

Медицинская диагностика. Больной жалуется на боли в животе. В идеале (для малопросвещенного врача) неплохо было бы, если бы больной сам ставил себе диагноз и сам подсказывал, какое ему назначить лекарство. Но и для опытного, серьезного врача ситуация на современном этапе сложная: фармация располагает десятками тысяч лечебных препаратов, многие из которых нацелены на одну и ту же болезнь, но по-разному воздействуют на остальные (не затронутые болезнью) органы и по-разному воспринимаются пациентами различного склада. Некоторые экстрасенсы практикуют такие действия: пациент приносит те лекарства, что назначили ему в поликлинике, а экстрасенс, анализируя соответствие полей (до сих пор не известных серьезной науке) пациента и лекарства, определяет, какие из них помогут, какие бесполезны, а какие, может быть, и усугубят болезнь или дадут сильный негативный побочный эффект. Не вдаваясь в оценку действий экстрасенса, отметим, что если бы был такой прибор, который без длительных анализов мочи, крови и прочих выделений больного организма находил бы однозначное прицельное соответствие болезни, больного и лекарства, то человечеству стало бы намного легче и здоровее.

Второй путь повышения идеальности в медицине можно продемонстрировать на примере радиационного воздействия на раковые клетки. Если опухоль расположена внутри организма, то прямое облучение ионизирующей радиацией разрушит не только раковые клетки, но и все, что на пути луча до и после опухоли. Однако степень разрушения зависит от дозы радиации, причем зависит резко нелинейно, сильно возрастая по мере увеличения дозы. Поэтому выход состоял в том, чтобы облучить опухоль тонкими лучами, с разных сторон сходящимися к требуемой зоне опухоли. Доза, получаемая опухолевыми клетками, при этом в несколько раз превышает дозу, полученную близлежащими тканями.

Этот второй принцип повышения идеальности является основным при разработке любых химиотерапевтических препаратов: лекарство должно концентрироваться только в том органе, для которого оно предназначено, а курс лечения должен определяться только в меру минимальной необходимости (исходя из априорной истины, что абсолютно безвредных для человека химикалиев просто нет).

Третий путь повышения идеальности исповедуется не всеми светилами медицинской науки и сводится к тому, что лечить надо не болезнь, а больного, не симптомы, а причину. И вообще, надо не лечить болезнь, а восстановить или усилить иммунную систему, сопротивляемость организма, мобилизовать его внутренние резервы на борьбу с микробом, вирусом или последствиями травмы, а уж он (организм) сам сообразит, куда и сколько кинуть резервов, чтобы встать на ноги. Простейший случай - аскорбиновая кислота (витамин С) при многих болезнях, как мощный стимулятор резервов сопротивляемости организма.

Наконец, четвертый путь повышения идеальности в медицине можно проиллюстрировать примером, когда врач при назначении медикаментозного лечения рекомендует вначале принять ударную (двойную, тройную) дозу лекарства (чтобы максимально быстро достичь нужной концентрации действующего вещества в больном органе), а затем (при длительном лечении) принимать его в дозировке, в два-три раза меньше первоначальной.

Надо заметить, что этот четвертый путь в медицине - палка о двух концах. Все лекарства в большой дозе становятся ядами, поэтому ударные дозы применяют только в очень острых случаях, когда потери от промедления лечения более опасны, чем побочные явления от передозировки.

Попробуем теперь заглянуть в мир информации: как тут с идеальностью и приближением к ней обстоит дело? Возьмем, к примеру, библиотечное дело.

Первый принцип идеализации: как получить и прочесть книгу без самой книги? Проблема решена сначала микрофильмированием, а в последние годы - записью на магнитных носителях, и Вы можете любой (или почти любой) раритет изучить по его изображению, тем самым исключив возможность случайного повреждения оригинала.

Второй путь в библиотеке реализуется, например, при организации стенда новых поступлений. Любой регулярный посетитель знает, что, следя за этим стендом, он не пропустит ничего нового и интересного (для него), поскольку содержимое стенда обновляется раз в две недели (или раз в месяц в небольших библиотеках).

Третий путь повышения идеальности реализуется в библиотеке исключительно на энтузиазме бессребреников - библиотечных работников. Что только они ни делают, чтобы привлечь читателя к “умному, доброму, вечному”! Книги на выставочных стендах открыты на самых привлекательных или интригующих страницах, фонды перед тематическими выставками перелопачены до самых дальних закоулков, недостающие книги вымениваются у других библиотек за счет своих дублирующих (а иногда и основных) экземпляров. В противоположность этому в некоторых библиотеках из чисто конъюнктурных соображений списывают и сдают в макулатуру сотни и сотни наименований (тоже “лишнее” в понимании заведующего, переброшенного сюда из банно-прачечного комбината), получая “из лишнего - максимальную пользу”.

Четвертый путь повышения идеальности особенно нагляден на этапе создания библиотечного фонда, когда задача состоит в том, чтобы как можно раньше и быстрее сформировать достаточный ассортимент литературы, способный удовлетворить запросы потенциальных читателей.

6.2. А что же дальше?

Различные исследователи называют разное количество законов развития систем, от трех до полутора десятков. Даже беглый анализ списков этих "законов" показывает их постепенное измельчание (по мере роста длины списка), поэтому здесь мы ограничимся пятью, на наш взгляд, достаточно представительными закономерностями, тем более, что каждая из них обладает (как и рассмотренный выше закон повышения идеальности) достаточным разнообразием способов реализации.

Подробный перечень примеров реализации того или иного закона - это предмет особого исследования, и читатель может получить несказанное удовольствие от самостоятельного анализа истории развития какого-нибудь близкого ему предметного или операционного объекта. Здесь же мы ограничимся только конспективным перечислением основных характеристик оставшихся четырех законов развития систем.

Р2. Закон повышения динамичности и управляемости ТС. Это фактически продолжение закона динамичности, сформулированного в "статической" форме. Конкретные реализации данного правила очень многообразны и зависят от вида системы, захватывая практически любые ее компоненты и связи между ними:

Р2а) переход от систем с постоянными параметрами к системам, параметры которых меняются в зависимости от режима работы (например, введение коробки скоростей в автомобиль);

Р2б) переход к широкофункциональным, перестраиваемым системам (например, создание детского универсального станка "Умелые руки");

Р2в) переход к системам с увеличенным числом степеней свободы (история развития манипуляторов).;

Р2г) переход к самоуправлению системы за счет внутренних обратных связей (термостат);

Р2д) переход от статически устойчивых к динамически устойчивым системам (двухколесный велосипед).

РЗ. Закон согласования систем. В процессе развития системы происходит все более полное согласование ее подсистем между собой и с внешней средой. При этом согласовываются материалы, формы и размеры, ритмика действия системы и другие параметры подсистем. Этот закон может реализовываться в трех различных вариантах:

РЗа) согласование параметров подсистем для повышения полезного действия или для исключения вредного;

РЗб) направленное рассогласование параметров подсистем для той же цели;

РЗв) переход к динамическому согласованию-рассогласованию при подготовке к работе или в процессе работы ТС.

Р4. Закон углубления системности или закон усложнения иерархической структуры системы реализуется по двум направлениям: переходом в надсистему (или созданием надсистемы) и развитием в подсистемы (дифференциацией системы). Для каждого из этих направлений свойственны свои правила.

Объединение в надсистему на разных этапах жизненного цикла систем имеет различную эффективность. Запараллеливание (дублирование) одинаковых систем фактически не меняет свойства каждой из них. Объединение взаимно дополняющих (а иногда даже антагонистических) систем ведет уже к уменьшению самостоятельности каждой системы. Оно возможно лишь при известном запасе изменяемости систем, так как в процессе такого симбиоза неизбежен процесс согласования (РЗ). Однако это и наиболее эффективный выход в надсистему. Слишком специализированные, высокоразвитые системы трудно объединять с другими в надсистему из-за наличия множества хорошо согласованных между собой (и, следовательно, достаточно жестких) внутренних связей. В любой надсистеме они, как правило, сохраняют высокую степень автономности и изолированности.

Дифференциацию системы можно осуществить различными путями:

Р4а) разделением системы на несколько одинаковых (дублирующих) подсистем, что повышает надежность системы;

Р4б) разделением системы на разнофункциональные части (блочный принцип), что расширяет функциональные возможности и системы в целом, и каждой из ее подсистем;

Р4в) переходом с макро- на микроуровень (детали обобщенной формы, пористые материалы, фазовые переходы, химические реакции, поле вместо вещества и т.д.).

Р5. Повышение функциональной полноты системы и вытеснение из нее человека. Это динамический вариант закона функциональной полноты, отражающий тот факт, что подавляющее число систем неполно и недостающие их части заменяет человек (безлюдная технология - это чаще всего только лозунг).

Последовательность вытеснения человека из технических систем отражена на рис. 24 начиная с досистемного уровня, когда кроме зубов и ногтей человек ничем не располагал. В зависимости от сложности рассматриваемой системы и от области человеческой деятельности, к которой относится система, смысловое содержание каждого из блоков рис. 24 различно, в соответствии с этим различны и стадии совершенствования системы, и уровень функциональной полноты, и перспективы ее развития.

Рис. 24. Схема взаимодействия подсистем (функциональные связи указаны стрелками) и очередность вытеснения человека из подсистем данной системы (показана цифрами).

Этапы вытеснения;
1 - использование инструментов;
2 - использование посторонних источников энергии (не собственной мускульной силы) и преобразователей энергии;
3 - использование датчиков, отражающих состояние ТС, использование устройств управления,
4 - использование автоматических систем с обратной связью.

Вытеснение человека из ТС происходит постепенно, в порядке нумерации блоков (см. Рис.24). Однако системы с низким уровнем развития хотя и перестают быть ведущими в данной области, но часто продолжают существовать наряду с системами высокого уровня. Как известно, в технике практически рядом сосуществуют и ГАП, и примитивная отвертка в кармане ремонтника, а сотрудники ВЦ продолжают пользоваться карандашом, линейкой, справочниками, несмотря на наличие АЦПУ, графопостроителей и банков данных. Причина такого сосуществования в том, что в процессе развития многие системы становятся все более специализированным, теряя при этом свою универсальность и неприхотливость. Кроме того, каждая система входит обычно в несколько надсистем, и жизненный цикл системы в каждой из надсистем проходит по-своему.

Нетрудно заметить, что закономерности Р2 - Р5 диалектичны и иногда даже противоречат друг другу. Поэтому в строгом смысле их нельзя называть ни законами, ни закономерностями, а только тенденциями. Нельзя забывать и о факторе случайности событий, способствующих развитию системы. Все это приводит к тому, что развитие систем идет скачками или стадиями.

Напомним, что любой объект как система может входить одновременно в несколько разнородных надсистем (технических, научных, социальных, экономических, природных и т.д.). Для каждой из этих надсистем законы построения, функционирования и развития могут звучать и воздействовать по-разному, так что их совокупное воздействие может оказаться довольно неожиданным. Интересный пример можно привести из истории морского флота. После поражения в войне 1855-1856 гг. России было запрещено иметь в Черном море большие корабли. Однако для защиты гаваней нужны были крупнокалиберные тяжелые орудия, которые можно было разместить только на крупных судах с мощной броней. Техническое решение задачи (броненосец прибрежной обороны) было найдено очень оригинальное - судно круглой формы (допустимый, с юридической точки зрения, максимальный размер судна, но очень большое водоизмещение, т.е. грузоподъемность) с мощной броней и мощным дальнобойным вооружением. Это направление никак не соответствовало вектору чисто технического развития военных судов (скорость, дальнобойность, неуязвимость), международно-правовая надсистема существенно "скорректировала" решение.

Чтобы не создавалось впечатления, что системный подход хорош только для технических задач и для технических систем, можно рассмотреть пример системного анализа объекта, весьма далекого от станков и пылесосов. Итак, анализируемый объект - содержание "Справочника по математике для инженеров и учащихся втузов". То, что это система, сомнений не вызывает. Это действительно система сведений, необходимых названным потребителям для всех их математических нужд (в этом, собственно, и состоит ГПФ справочника). Элементами и подсистемами объекта являются разделы, главы, параграфы и более мелкие рубрики, все это - в чисто информационном ключе. На вопрос о надсистеме можно было бы ответить -"справочник", имея в виду его материальное воплощение. Однако попробуем не выходить за пределы информационного мира (неважно, в какой обложке сведения, важно, для чего они), тогда надсистемой будут "математические расчеты" или "решение задач", в любой из этих надсистем ГПФ нашего объекта сохраняется в форме, приведенной выше (интересно, что в надсистему здесь входит человек, решатель).

Переходим к закономерностям строения нашей системы. Здесь придется осуществить "перевод" формулировок, изложенных выше на языке машинной техники, на язык информационный, соответствующий типу рассматриваемой системы. Но страхи читателя напрасны, полиглотом для этого быть не надо.

Закон функциональной полноты. Содержание справочника должно включать сведения из всех разделов математики, с которыми приходится иметь дело инженерам всех специальностей (и не содержать разделов, не имеющих применения в инженерной деятельности). Если ближе к оригиналу, то "справочник должен быть функционально полным",

Закон проводимости. Все сведения справочника должны быть организованы в логически непрерывные и полные информационные цепочки. Это означает, что каждый "блок информации" в справочнике должен быть полностью подкреплен цепочкой предшествующих блоков (определений, теорем и формул), причем каждая информационная цепочка должна начинаться с положения, не требующего доказательства, и заканчиваться примерами практического применения конечной формулы в инженерном расчете.

Очевидно, в данной конкретной системе информационная цепочка будет содержать, как правило, существенно больше элементов, чем перечислено выше. (Впрочем, и для технических истем дело не всегда так просто, ведь одно только преобразование энергии может в системе встретиться 2-3 раза: химическая энергия в газовой турбине переводится сначала в тепловую, а уже она - в механическую и затем в электрическую). Однако общее правило минимизации длины цепочки здесь справедливо: едва ли Вы захотите пользоваться справочником, если для понимания какого-либо соотношения придется проштудировать полсправочника.

Закон динамичности. Сведения справочника должны регулярно обновляться и корректироваться согласно изменяющимся потребностям. Для бумажных справочников (книг) динамичность затруднена (хотя, например, в справочных каталогах электронных компонентов она реализована путем регулярной замены вкладных листов), но математика - не этика, понятия здесь устаревают редко и справочники, как правило, по мере переизданий, только дополняются и увеличиваются в объеме, И тем не менее, все больше и больше поклонников машинных банков данных - справочников, в которых корректировать (аналог "регулирования") можно каждое слово и каждую букву.

Закон параметрического порога. Объем и глубина сведений справочника должны соответствовать минимальному уровню знаний инженера, ведущего самостоятельные расчеты. Интересно, что здесь при "формальном переводе" правила проявляются сразу два порога. А именно: с одной стороны, справочник должен быть подспорьем, помощником инженера, и поэтому для пользователя бесполезен справочник, если в нем ничего, кроме таблицы умножения, нет. С другой стороны, слишком сложный справочник, в котором исходные "аксиомы" для пользователя - совсем не аксиомы, тоже едва ли вызовет интерес, так как пользователь не сумеет им пользоваться.

А теперь давайте посмотрим, каковы тенденции развития справочников.

(Р1). В справочнике есть только те сведения, которые пользователю нужны в данный момент.

(Р2). Справочник сам модифицирует свои формулы и соотношения применительно к задаче пользователя.

(Р4) и (Р5). Справочник предлагает различные пути решения задачи и снабжает решателя для этого нужными справочными данными.

Как видно из этого списка возможных направлений модификации сути и функций справочной системы, картина - нетривиальная, а тенденция – пожалуй, тоже. В несколько ином аспекте она дискутировалась уже не раз, в том числе и на самом высоком, философском уровне.

7. Заключение

Системно-морфологический подход - универсальный инструмент мышления, позволяющий не только грамотно разобраться в самой сложной ситуации, но и найти интересные, нестандартные решения. Универсальность этого подхода вытекает из триады законов диалектики, на которых, собственно, и базируется данный метод. Поэтому остается только пожелать читателю не ограничиваться простым чтением этой работы, и тогда любые Ваши неразрешимые проблемы покажутся Вам школьными задачками. Успехов Вам!


Аннотация

Системно-морфологический подход
в технике, науке, социальной сфере.
Титов В.В.

Аннотация

Настоящая работа является попыткой объединить два направления исследовательской и творческой деятельности, развивавшиеся в известной степени независимо друг от друга, но, по мнению автора, в значительной степени схожих по основному принципу, заложенному в их основу. Системный подход обществоведения и морфологический подход естественнонаучного и изобретательского мышления вместе дают сплав, способный эффективно работать на поиск нестандартных решений практически в любой области человеческой деятельности. Поэтому разнообразие примеров реализации тех или иных аспектов метода в данной работе чрезвычайно велико, и пусть это не пугает читателя, ибо знание метода куда важнее знания предмета.


Введение

Системно-морфологический подход
в технике, науке, социальной сфере.
Титов В.В.

"Не по частям водочерпательницы, но по совокупности ее частей суди об ее достоинствах"
К. Прутков. "Проект о введении единомыслия в России"

Введение

Системный анализ как самостоятельное направление исследований возник в недрах общественных наук и, продемонстрировав свое могущество в столь сложной, многообразной и запутанной системе, как человеческое общество, быстро распространился и в сфере технических наук. Это не случайно, так как системный подход дает метод исследования, представления и преобразования информации и объектов, при котором сложное можно представить через простое, не теряя при этом связи изучаемой части и целого, что очень важно в такой сложной деятельности, как творческий поиск в науке, технике и социальной сфере.

Не менее важным оказалось и то обстоятельство, что технические системы, все без исключения созданные человеком, являются для человека более прозрачными, понятными по причинам чисто генетическим: ведь он сам создавал систему, все ее элементы и связи между ними, растил ее, встраивал в уже существующий мир систем и в силу этого должен был прочувствовать почти все ее многообразные связи с внешним окружением, а о внутреннем строении уж и говорить не приходится. Поэтому технические системы для демонстрации, изучения или освоения системного подхода являются наиболее простыми объектами.

В настоящее время актуальность проблем научно-технического творчества отошла на второй план по сравнению с сиюминутной важностью решения задач бизнеса: экономических, финансовых, организационных. Причем речь идет не только о глобальных масштабах и даже не о масштабах отрасли, области или района. Своя рубашка ближе к телу, и задача обеспечения собственного благосостояния становится первостепенной (пережитки и угрызения социалистического сознания, у кого они остались, можно утишить той истиной, что благосостояние державы все-таки складывается из благосостояний ее граждан). Тем самым оказывается, что, в подтверждение диалектического закона о спиральном развитии, мы вернулись к области общественных и социальных проблем, туда, где впервые заговорили о системном анализе, но уже к другому масштабу задач. Однако, это не означает, что другие области будут обойдены вниманием, нет, это просто невозможно в силу самой сущности системного подхода, когда для любой системы в той или иной мере нужно видеть и учитывать все многообразные ее связи, причинно-следственные, информационные, временные, пространственные, и т.д.