О всеобщности системного подхода

Титов В.В.

Системный подход как самостоятельный способ взаимодействия с информацией об окружающем мире был декларирован прежде всего в области обществоведения, так как именно здесь размер (и размерность) объектов исследования выходила далеко за рамки возможностей целостного охвата исследовательскими инструментами. Гораздо проще и эффективнее системный подход "сработал" в применении к техническим системам, где изобретательская мысль, помноженная на аппарат системного анализа, во много раз усиливала свой потенциал. Однако как обществоведы, так и технари-изобретатели не любят выходить за пределы собственного поля деятельности, поэтому какого-либо взаимодействия между ними до сего времени не было.

Хорошо это или плохо?

На первый взгляд кажется, что ну и пусть они себе копаются каждый в своем огороде, не мешают ведь друг другу – и ладно. Но в действительности картина взаимной изоляции отнюдь не так безобидна. Вот Вам пара примеров:

  1. Изобретатель с предложением, способным уменьшить энергопотребление страны на 30% с одновременным улучшением экологии так и умирает, не сумев пробить многочисленные бюрократические препоны. Умирает вместе с изобретением.
  2. Монетизация льгот, задуманная российским правительством к 2005 году, вызвала такую социальную бурю, что оно заметалось в панике, не зная, то ли отменить непопулярный (но очень необходимый и логически правильный) закон, то ли придумать для стариков какую-нибудь морковку, чтобы заткнуть рты недовольным.

В первом случае изобретатель совершенно не задумывался о строении и внутренних связях той социальной системы, которая должна была принять его изобретение, и погиб, образно говоря, разбив лоб о стену, хотя стена эта имеет множество поворотов и дверей. Во втором случае отсутствие проработки технических вопросов монетизации льгот (а это все же другая система, точнее, система другого типа) привело к отторжению прогрессивного в общем то мероприятия.

Все это приводит к выводу, известному в диалектике как закон всеобщей взаимосвязи. Каждый объект и каждая операция в той или иной степени связаны со множеством других объектов и операций, и чтобы во всем этом разобраться, выявить и расклассифицировать объекты и связи между ними по степени существенности и влияния на данный объект или операцию, иного пути, чем системный подход, никто пока не придумал.

Но для этого прежде всего придется принять, что системный подход и весь его аналитический аппарат применимы абсолютно ко всем типам объектов и операций. Поэтому здесь предпринята попытка изложить основные определения, аксиомы и теоремы системного подхода с учетом специфики систем, которые нас окружают. Возможно, какие-то из приведенных ниже формулировок "царапают слух", а может быть, и совсем покажутся неверными, тогда давайте поспорим и совместными усилиями дошлифуем формулировки до нужной кондиции.

Начнем с определения системы. В таблице 1 приведено "переложение" этого определения в терминах, соответствующих виду объектов, формирующих систему.

Таблица 1. Определение систем различного вида.

Тип элементов |  | Предметы | Операции
Разновидности систем по сфере проявления | Обобщенные формулировки | Предметная система - это упорядоченное в пространстве определенным образом множество элементов, взаимосвязанных между собой и образующих некоторое целостное единство. | Операционная система – это упорядоченная во времени последовательность действий (операций), взаимосвязанных между собой и образующих некоторое целостное единство.
 | Природные системы | Природная предметная система (природный комплекс) – это упорядоченное в пространстве множество природных объектов, взаимосвязанных между собой и образующих некоторое устойчивое единство. | Природная система типа "процесс" (природное явление) – это упорядоченная во времени последовательность событий (природных явлений), взаимосвязанных между собой и образующих некоторое целостное единство.
 | Технические системы | Предметная техническая система - это искусственно созданное материальное единство целесообразно организованных в пространстве и времени и находящихся во взаимной связи искусственных или природных объектов, имеющее целью своего функционирования удовлетворение некоторой общественной потребности. | Техническая система типа "процесс" - это искусственно выстроенная совокупность целесообразно организованных в пространстве и времени и находящихся во взаимной связи действий и операций над материальными объектами, имеющая целью своей реализации удовлетворение некоторой общественной потребности.
 | Социальные системы | Предметная социальная система – это упорядоченное определенным образом множество людей (или групп людей), взаимосвязанных между собой и образующих некоторое целостное единство, имеющее целью удовлетворение некоторой общественной потребности. | Социальная система типа "процесс" (мероприятие) - это совокупность осуществляемых людьми целесообразно организованных в пространстве и времени и находящихся во взаимной связи действий и операций, имеющая целью удовлетворение некоторой общественной потребности за счет преобразования (создания, обработки, передачи, и т.д.) социально значимых ценностей.
 | Информационные системы | Предметная информационная система – это упорядоченные определенным образом блоки информации, взаимосвязанные между собой и образующие некоторое целостное единство. | Информационная система типа "процесс" (акт управления информацией) – это упорядоченная определенным образом последовательность целесообразно организованных правил взаимодействия между предметными информационными системами.

Четыре конкретных вида систем в свою очередь разделены на две неравноценные группы: естественные системы (т.е. системы, созданные и существующие независимо от воли и желания человека) и искусственные системы (сознательно созданные человеком или обществом с определенной целью удовлетворения некоей общественной потребности). Граница между этими системами в известной степени условна, но большая часть естественных систем относится к природным объектам и процессам, в то время как к искусственным системам относятся целиком информационные системы и все (за редкими исключениями) социальные и технические системы. Последнее (про исключения) может показаться сомнительным, но объяснение таково: некоторые социальные и технические системы возникают спонтанно, иногда даже без созидательного участия человека.

В следующей таблице приведены примеры конкретных систем различного типа. Это сделано, с одной стороны, для демонстрации разнообразия и всеохватности системного подхода, а с другой стороны, для того, чтобы показать, что и в одной группе могут оказаться системы очень и очень непохожие друг на друга (а это означает, что и в каждой ячейке таблицы 2 множество входящих в нее систем можно расклассифицировать по тем или иным признакам).

Таблица 2. Примеры конкретных систем

Тип элементов

Предметы

Операции

Разновидности систем по сфере проявления Природные системы
  • Галактика
  • Планета
  • Вулкан
  • Озеро
  • Стая
  • Роща
  • Воробей
  • Бактерия
  • Кристалл
  • Атом водорода
  • Извержение вулкана
  • Солнечное затмение
  • Формирование русла реки
  • Эпизоотия (эпидемия)
  • Круговорот воды в природе
  • Формирование погоды
  • Жизненный цикл дерева
  • Суточный ритм человека
  • Мутация
  • Паника
Технические системы
  • Автозавод
  • Сборочный цех автозавода
  • Конвейер сборочного цеха
  • Электромотор
  • Статор электромотора
  • Ручная отвертка
  • Шуруп (или болт, или гайка)
  • Телевизор
  • Тетрадь
  • Букет цветов
  • Технология производства труб
  • Штамповка
  • Икэбана
  • Удаление больного зуба
  • Коллекционирование марок
  • Фотографирование
  • Оформление презентации
  • Изучение иностранного языка
  • Сборка компьютера
  • Приготовление яичницы
Социальные системы
  • Министерство
  • Город
  • Автозавод
  • Футбольная команда
  • Библиотека
  • Студенческий строительный отряд
  • Дачный кооператив
  • Семья
  • Нация
  • Театр
  • Технология успеха
  • Воспитание ребенка
  • Оформление дворовой территории
  • Презентация товара
  • Празднование Дня города
  • Уимблдонский турнир
  • Предвыборная кампания
  • Война
  • Сватовство
  • Санаторное обслуживание
Информационные системы
  • Рассказ
  • Компьютерный файл
  • Телевизор
  • Наука (как комплекс знаний)
  • Лекция
  • Библиотека
  • Справочник по математике
  • Система пожарной сигнализации
  • Учебник английского языка
  • Кинофильм
  • Дипломатия
  • Законотворчество
  • Компьютерная поисковая система
  • Функционирование ЦУП (центра управления полетами)
  • Диспетчерская служба в аэропорту
  • Наука (как процесс исследования)
  • Отладка компьютерной программы
  • Методология изобретательского творчества
  • Социологическое исследование
  • Создание кинофильма

Технические системы можно также разделить на три основные группы в соответствии с градацией объектов промышленной собственности, защищаемой патентами. Кроме названных в таблице 3 трех основных "ипостасей" технической системы (вещество, устройство и способ) среди объектов правовой защиты есть еще "штамм микроорганизмов", "новое применение" и "топология интегральных схем". Однако штамм микроорганизмов по системной сути своей близок к веществу (неорганическому), новое применение известной системы - к способу, а топология интегральных схем - к устройству, поэтому выделять их в самостоятельные системообразования едва ли есть смысл.

Понятие "удовлетворение некоторой общественной потребности" довольно расплывчато и многозначно, так же как многообразны и сами потребности. Среди технических систем - устройств просматриваются как устройства, созданные для конечного потребителя - человека (мебель, одежда, бытовые мелочи личного использования), так и устройства - средства производства других устройств (или средства обработки объектов природного или искусственного происхождения). В свою очередь, последние можно также разделить на аппараты (устройства обработки неисчисляемых объектов, т.е. вещества), инструменты (устройства обработки исчисляемых объектов - предметов или деталей), машины (устройства преобразования и использования энергии) и приборы (устройства обработки информации). Нетрудно сформулировать и на этих уровнях классификации свои, более конкретные определения. Здесь мы этого делать не будем, но при работе с конкретным типом технических систем такая работа представляется очень полезной, т.к. позволяет глубже понять суть системы.

Обратите внимание, что определения в таблице 3 даны именно с акцентом на системный подход к определяемым объектам, поэтому они могут отличаться от нормативных определений, введенных законотворцами.

Таблица 3. Определение технических систем различного вида

Тип элементов

Предметы

Операции

Примеры

Обобщенные формулировки Предметная система - это упорядоченное в пространстве определенным образом множество элементов (предметов), взаимосвязанных между собой и образующих некоторое целостное единство. Операционная система – это упорядоченная последовательность действий (операций), взаимосвязанных между собой и образующих некоторое целостное единство.
Технические системы Вещество Вещество - это естественная или искусственно созданная совокупность целесообразно организованных в пространстве и находящихся во взаимной связи (неисчисляемых) компонентов, имеющая целью своего существования обеспечение некоторого (общественно полезного) внешнего свойства.
  • Композит
  • Полимер
  • Химическое соединение
  • Удобрение
  • Краска гуашевая
  • Кормовая смесь
  • Шерстяная ткань
  • ВТСП (высокотемператур-ный сверхпроводник)
  • Цементный раствор
  • 10. Омлет
Устройство Устройство - это искусственно созданное материальное единство целесообразно организованных в пространстве и времени и находящихся во взаимной связи искусственных или природных объектов, имеющее целью своего функционирования удовлетворение некоторой общественной потребности.
  • Плотина ГЭС
  • Автомобиль
  • Утюг
  • Стол письменный
  • Газонокосилка
  • Громкоговоритель
  • Клетка для попугая
  • Уличный фонарь
  • Болт
  • Кроссовки
Способ Способ - это искусственно выстроенная совокупность целесообразно организованных в пространстве и времени и находящихся во взаимной связи действий и операций над объектами любого типа, имеющая целью своей реализации удовлетворение некоторой общественной потребности.
  • Технология производства труб
  • Заточка инструмента
  • Переплет книги
  • Удаление больного зуба
  • Перевод текста с английского
  • Проявление фотопленки
  • Перевод денег за границу
  • СВС (самораспространяющийся высокотемпературный синтез)
  • Сборка микросхемы
  • Приготовление яичницы

Следующее определение системного подхода относится к определению основных характеристик системы.

Таблица 4. Определение основных характеристик систем различного вида.

Тип элементов |  | Предметы | Операции
Разновидности систем по сфере проявления | Обобщенные формулировки | Система характеризуется составом элементов, структурой и выполняет определенную функцию. | Операционная система характеризуется составом входящих в нее операций, их временной и причинно-следственной связью и выполняет определенную функцию
 | Природные системы | Природная предметная система (природный комплекс) характеризуется составом природных объектов, структурой и обладает набором свойств (или функций, если система создана искусственно) | Природная система типа "процесс" (природное явление) характеризуется составом входящих в нее явлений или процессов, их пространственной, временной и причинно-следственной связью.
 | Технические системы | Предметная техническая система характеризуется составом естественных или искусственных элементов, структурой и выполняет определенную функцию | Техническая система типа "процесс" (технология, способ) характеризуется составом входящих в нее операций, их пространственной, временной и причинно-следственной связью и выполняет определенную функцию
 | Социальные системы | Предметная социальная система (организация) характеризуется составом входящих в нее людей или организаций. структурой и выполняет определенную функцию | Социальная система типа "процесс" (мероприятие) характеризуется составом входящих в нее действий (актов, мероприятий), их пространственной, временной и причинно-следственной связью и выполняет определенную функцию
 | Информационные системы | Предметная информационная система характеризуется составом входящих в нее информационных блоков, структурой и выполняет определенную функцию по отношению к системам иной сферы проявления. | Информационная система типа "процесс" (акт управления информацией) характеризуется составом входящих в нее операций управления информационными блоками и их взаимосвязью и выполняет определенную функцию по отношению к иным информационным системам.

Применительно к градации технических систем, приведенной в таблице 3 конкретизация определения основных характеристик системы почти не дает новой информации (это простая замена терминов), поэтому здесь мы ее не приводим, предоставляя читателю самому проверить правильность настоящего утверждения.

Следующее определение относится к структуре систем различного типа. В таблице 5 проведена общая градация систем, а в таблице 6 дано определение структуры технических систем. Кстати, нетрудно заметить, что некоторые из наших "системных" определений почти дословно совпадают с обычными определениями, введенными безо всякой оглядки на системный подход.

Таблица 5. Определение структуры систем различного типа

Тип элементов |  | Предметы | Операции
Разновидности систем по сфере проявления | Обобщенные формулировки | Структура системы - это закономерные устойчивые связи между элементами системы, отражающие пространственное и временное расположение элементов и характер их взаимодействия | Структура операционной системы - это закономерная устойчивая последовательность входящих в нее операций, отражающая их пространственную и причинно-следственную связь
 | Природные системы | Структура природного комплекса - это закономерные устойчивые связи между природными объектами, отражающие их взаимное расположение и характер взаимодействия | Структура природного явления - это закономерная устойчивая последовательность природных явлений (событий), отражающая их причинно-следственную связь
 | Технические системы | Структура предметной технической системы - это закономерные устойчивые связи между ее элементами, отражающие пространственное и временное расположение элементов и характер их взаимодействия | Структура операционной технической системы - это закономерная устойчивая последовательность операций (действий), отражающая их пространственную, временную и причинно-следственную связь
 | Социальные системы | Структура организации - это закономерные устойчивые связи между входящими в нее людьми (или организациями), отражающие характер их взаимодействия | Структура мероприятия - это закономерные устойчивые связи между входящими в него актами (действиями), отражающие их временные и причинно-следственные отношения
 | Информационные системы | Структура предметной информационной системы - это закономерные устойчивые связи между ее элементами (информационными блоками), отражающие временные и причинно-следственные отношения между ними. | Структура операционной информационной системы (системы управления информацией) - это закономерные устойчивые связи между ее действиями, отражающие временные и/или причинно-следственные отношения между информационными блоками.

Таблица 6. Определение структуры технических систем различного вида

Тип элементов |  | Предметы | Операции (действия)
Обобщенные формулировки |  | Структура системы - это закономерные устойчивые связи между элементами системы, отражающие пространственное и временное расположение элементов и характер их взаимодействия | Структура операционной системы - это закономерная устойчивая последовательность входящих в нее операций, отражающая их пространственную и причинно-следственную связь
Технические системы | Вещество | Структура вещества - это закономерное устойчивое (регулярное) взаимное расположение компонентов вещества, отражающее характер их взаимодействия |
 | Устройство | Структура устройства - это закономерные устойчивые связи между элементами устройства, отражающие пространственное и временное расположение элементов и характер их взаимодействия |
 | Способ |  | Структура способа – это закономерные устойчивые временные и причинно-следственные связи между входящими в него операциями.

Следующим шагом является определение функции системы. По поводу этого определения (даже в обобщенной его форме) до сих пор ломаются копья, поскольку житейское понимание этого термина не охватывает всех аспектов этого понятия в системном подходе. Тем не менее, важность этого понятия и важность точного понимания смыслового объема этого понятия весьма высоки, поскольку оно формирует множество практически значимых следствий.

Таблица 7. Определение функции систем различного типа

Тип элементов |  | Предметы | Операции
Разновидности систем по сфере проявления | Обобщенные формулировки | Функция предметной системы - это внешнее проявление свойств объекта в данной системе отношений, определенный способ взаимодействия объекта с окружающими объектами. Функция часто проявляется в определенном действии или возможности (способности) совершить такое действие. | Функция операционной системы - это внешнее проявление результата действия данной операционной системы в данном ее окружении, определенное изменение состояния объектов, затрагиваемых данной системой.
 | Природные системы | Функция природного комплекса - это внешнее проявление свойств комплекса, определенный способ взаимодействия объекта с окружающей средой или отдельными ее элементами. | Функция природного явления - это внешнее проявление результата действия данного явления в данном его окружении, определенное изменение состояния природных объектов или явлений, затрагиваемых данным явлением.
 | Технические системы | Функция предметной технической системы - это внешнее проявление ее свойств в данной системе отношений, определенный способ взаимодействия системы с окружающими объектами. Функция часто проявляется в определенном действии или возможности (способности) совершить такое действие. | Функция технологии (способа) - это внешнее проявление результата действия данной технологии в данном ее окружении, определенное изменение состояния объектов, обрабатываемых с помощью данной технологии.
 | Социальные системы | Функция организации - это внешнее проявление ее свойств в данной системе отношений, определенный способ взаимодействия организации с людьми или другими организациями. Функция часто проявляется в определенном действии или возможности (праве, способности) совершить такое действие. | Функция мероприятия - это внешнее проявление результата данного мероприятия в данном его социальном окружении, определенное изменение состояния людей или организаций, затрагиваемых данным мероприятием.
 | Информационные системы | Функция предметной информационной системы - это внешнее проявление ее свойств в данной системе отношений, определенный способ взаимодействия информации с окружающими объектами любого типа. Функция проявляется в определенном управляющем воздействии (стимулировании) или способности совершить такое воздействие. | Функция операционной информационной системы - это внешнее проявление результата действия данной операционной системы в данном ее окружении, определенное изменение состояния иных информационных систем любого типа, затрагиваемых данной системой.

Любая система имеет много функций. Среди этого множества в каждом конкретном случае можно выделить одну функцию, наиболее важную в данной конкретной ситуации. В системах, созданных человеком для удовлетворения общественной (или личной) потребности (такие системы здесь названы искусственными), эта особая, наиболее важная в данной системе отношений функция называется Главной Полезной Функцией (ГПФ). Понятие полезности не абсолютно, а соотносится с участником (создателем или пользователем) данной системы. Особенно четко это проявляется во взаимодействии антагонистических участников или систем, где объект или система, полезные для одного участника, отнюдь не полезны для другого (типичное противостояние щита и меча). ГПФ системы на этапе ее создания обычно в точности соответствует цели ее создания, но на протяжении жизненного цикла системы ГПФ может меняться, во-первых, по мере изменения самой системы, а во-вторых, в связи с изменением надсистемы или окружения данной системы (например, на заре компьютерной эры в России компьютеры у многих выполняли отнюдь не главную свою функцию).

Функции предметных систем часто "запрятаны" в связях между элементами системы. Связи эти бывают множественными и несут самую разную информацию о взаимодействии элементов (это может быть и простой механический контакт, и проведение какого-либо потока энергии, силового воздействия, вещества или информации, и т.д.).

В системах операционного типа связи являются еще более содержательными, поскольку в них заложена информация обо всех предметных объектах, с которыми взаимодействует данная операционная система (операция). В случае социальных систем связь между элементами операционного типа (мероприятиями, акциями, и т.д.) характеризуется семеркой вопросов: "Кто? Что делает? Что? Кому? Где? Когда? Сколько стоит?", а восьмой вопрос "Зачем?" определяет ГПФ элемента мероприятия. Интересно, что те же самые семь вопросов отнюдь не бессмысленны и в операционных системах иного вида, нужно только правильно понимать их с учетом специфики объектов, относительно которых действует данная система.

Следующим шагом является определение двух основных свойств системы.

Таблица 8. Основное свойство системы - целостность

Тип элементов |  | Предметы | Операции
Разновидности систем по сфере проявления | Обобщенные формулировки | Комплекс объектов, рассматриваемый в качестве системы, обладает общими свойствами, функцией и поведением, причем свойства системы не сводимы к сумме свойств входящих в нее элементов. | Функция операционной системы - это внешнее проявление результата действия данной операционной системы в данном ее окружении, определенное изменение состояния объектов, затрагиваемых данной системой.
 | Природные системы | Любой природный комплекс обладает общими свойствами, функцией и поведением, причем свойства природного комплекса не сводимы к сумме свойств входящих в него элементов (природных объектов или комплексов) | Любое природное явление обладает общими свойствами, функцией и проявлением, причем характеристики природного явления не сводимы к простой сумме проявлений входящих в него событий.
 | Технические системы | Любая предметная техническая система обладает общими свойствами, функцией и поведением, причем свойства системы в целом не сводимы к сумме свойств входящих в нее элементов. | Любая технология обладает общими свойствами, функцией и поведением, причем свойства и результат применения технологии не сводимы к сумме результатов входящих в нее действий или операций.
 | Социальные системы | Любая организация обладает общими, присущими ей свойствами, функцией и поведением, причем свойства и поведение организации не сводимы к сумме свойств и поведения входящих в нее персон или организаций. | Любое мероприятие обладает общими свойствами, функцией и поведением, причем свойства и результат мероприятия не сводимы к сумме свойств и результатов входящих в него действий или мероприятий.
 | Информационные системы | Любая предметная информационная система обладает общими, присущими ей свойствами, функцией и поведением, причем свойства системы в целом не сводимы к сумме свойств входящих в нее информационных блоков | Любая система управления информацией обладает общими свойствами, функцией и поведением, причем свойства и результат действия системы не сводимы к сумме результатов действия входящих в нее процедур управления информационными блоками.

Тут полезно вспомнить один из критериев изобретения, существовавших в союзном патентном законодательстве: изобретение признавалось таковым тогда и только тогда, когда имел место так называемый сверхсуммарный эффект, т.е. свойства (или действия) защищаемого устройства или способа включали в себя не только свойства (или действия) всех входящих в него элементов, но обязательно имели еще специфическое свойство, присущее только системе в целом. В переводе на "системный" язык это означает, что изобретением признавалось только создание новой системы.

Таблица 9. Основное свойство системы – делимость. Следствие – многоуровневость представления системы.

Тип элементов |  | Предметы | Операции
Разновидности систем по сфере проявления | Обобщенные формулировки | Любой объект можно представить состоящим из элементов. Следствие: любой объект нужно рассматривать в трех аспектах: как нечто целое (систему), как часть более общей системы (надсистемы) и как совокупность более мелких частей (элементов или подсистем) | Любую операцию можно представить состоящей из ряда действий. Следствие: любую операцию нужно рассматривать в трех аспектах: как нечто целое (операцию), как часть более общей системы (надоперации, "технологии") и как совокупность более мелких частей (подопераций, действий, и т.п.).
 | Природные системы | Любой природный комплекс можно представить состоящим из элементов. Следствие: любой природный объект нужно рассматривать в трех аспектах: как нечто целое (природный комплекс), как часть системы более высокого уровня (надсистемы) и как совокупность более мелких частей (природных объектов) | Любое природное явление можно представить состоящим из ряда событий (явлений). Следствие: любое природное явление нужно рассматривать в трех аспектах: как нечто целое (явление), как часть более глобального явления и как совокупность более мелких частей (событий, физико-химических процессов, и т.д.).
 | Технические системы | Любую предметную техническую систему можно представить состоящей из элементов. Следствие: любое устройство или вещество нужно рассматривать в трех аспектах: как нечто целое (систему), как часть более общей системы (надсистемы) и как совокупность более мелких частей (элементов или подсистем) | Любую технологию можно представить состоящей из ряда операций. Следствие: любую технологию нужно рассматривать в трех аспектах: как нечто целое (операцию), как часть более общей технологии (надоперации) и как совокупность более мелких частей (подопераций, процедур, действий).
 | Социальные системы | Любую организацию можно представить состоящей из отделов (подразделений, и т.п.). Следствие: любую организацию нужно рассматривать в трех аспектах: как нечто целое (систему), как часть более общей организации (надсистемы) и как совокупность более мелких частей (отделов или, в наименьшем дроблении, персон) | Любое мероприятие можно представить состоящим из ряда акций (мероприятий). Следствие: любое мероприятие нужно рассматривать в трех аспектах: как нечто целое (мероприятие), как часть более крупного (или во времени, или в содержании) мероприятия и как совокупность более мелких мероприятий (действий, акций, и т.д.).
 | Информационные системы | Любую предметную информационную систему можно представить состоящей из отдельных информационных блоков. Следствие: любую информационную систему нужно рассматривать в трех аспектах: как нечто целое (систему), как часть более общей предметной информационной системы (надсистемы) и как совокупность более мелких частей (разделов, глав, серий, и т.п.). | Любую информационную систему операционного типа (систему управления информацией) можно представить состоящей из ряда операций. Следствие: любую систему управления информацией нужно рассматривать в трех аспектах: как нечто целое (систему), как часть более общей системы управления информацией (надсистемы) и как совокупность более мелких частей (подсистем, операций, и т.п.).

Свойство делимости не является абсолютно идентичным для предметных и для операционных систем. Это связано прежде всего со спецификой составляющих систему элементов. А именно: предметные системы могут быть зафиксированы во времени, т.е. их можно "сфотографировать", в то время как для операционных систем только "киносъемка", только динамика изменения несут информацию о системе. Другое отличие состоит в том, что детализация операционной системы довольно быстро приводит к "элементарным" операциям, дробить которые практически не имеет смысла. Третье отличие состоит в том, что объектом воздействия операционных систем являются, как правило, объекты и системы предметного типа, как целое; так что переход к анализу подчиненных операций (подсистем) часто заставляет одновременно заменить и объект воздействия, спустившись и в объектном поле на уровень подсистем. Особенно заметно это проявляется в социальных и информационных системах операционного типа, где один-два системных шага дробления систем выводят из области операционных систем в область систем предметного типа. Наконец, четвертое отличие состоит в том, что для большинства предметных систем функция сводится к воздействию на другую предметную систему, т.е. объект функции, как правило, единичен. Для операционных систем функция определяется семеркой вопросов ("Кто? Что делает? Что? Кому? Где? Когда? Сколько стоит?), и при каждом переходе к подсистемам это семикратное дробление или изменение участников анализа резко увеличивает объем аналитической работы. Именно поэтому в подавляющем большинстве публикаций с привлечением понятий "система" или "системный анализ" "по умолчанию" рассматриваются исключительно предметные системы.

Вот на этом пока и закончим апологию глобализации системного подхода. Впереди – гораздо более спорный анализ законов строения и развития систем, статус, специфика и общность этих законов, закономерностей и тенденций.

Автор готов к обсуждению поднятой здесь темы и если у Вас появилось такое же желание, то - вперед!

Ваше имя:

Ваш E-mail:

О чем спорим?: