МОРФОЛОГИЧЕСКИЙ ПОДХОД

Титов В.В.

Аннотация

В работе рассмотрены три метода поиска новых решений проблем, предложенные Ф.Цвикки: метод систематического покрытия поля, метод отрицания и конструирования и метод морфологического ящика. Анализируются основные особенности этих методов и их возможности на разных стадиях поиска и исследования в науке и технике. Подробно рассмотрен так называемый "короткий" метод морфологического ящика, основанный на многоступенчатой реализации метода, но каждый раз со сравнительно небольшим объемом морфологического множества.
Приведена аннотированная библиография основных работ по морфологическим методам.

ВВЕДЕНИЕ

В 1942 г. швейцарский астрофизик Ф.Цвикки обнародовал ряд методов, которыми рекомендовалось пользоваться при решении научных и технических задач. Сначала этих методов было семь, впоследствии Цвикки остановился на трех основных, сочтя остальные либо недостаточно эффективными, либо недостаточно самостоятельными. В их числе:

1) метод отрицания и конструирования (МОК);
2) метод систематического покрытия поля (МСПП);
3) метод морфологического ящика (ММЯ).

Совокупность методов Цвикки получила название "морфологический подход". Вообще говоря, по мнению Цвикки, морфологический подход - это вовсе не метод и не совокупность методов, а своеобразное мировоззрение, миропонимание. Вот как он сам писал в предисловии к одной из своих книг [l] :

"Цель морфологического исследования - увидеть перспективу полного "поля знаний" о предмете. Это может быть поле материальных объектов, поле явлений или поле отношений, концепций, идей или теорий. Чтобы получить желаемую общую перспективу такого поля, морфолог ("morphologist - термин Ф.Цвикки) должен иметь внутреннюю мотивацию к исследованию без предубеждений. Одни обладают такими способностями, другие - нет, и почему это так, до сих пор остается тайной природы. Сейчас мы просто должны принять за аксиому тот факт, что лишь немногим дана способность отказаться, от всех основных предубеждений. Это люди, не порабощенные догматизмом, которых не поколеблют ни групповые интересы, ни расовый, религиозный или партийный фанатизм и которые в случае необходимости могут идти и идут в одиночку на любые проблемы жизни, именно они - врожденные морфологи".

Можно не соглашаться со столь категоричным утверждением, что если уж не дано владеть этим подходом, то не дано, однако опыт подсказывает, что действительно, наиболее эффективен морфологический подход в руках тех, кто склонен к систематическому, последовательному и разностороннему, широкому исследованию проблем и кто неуютно себя чувствует в плохо определенных ситуациях. Тем не менее, знание арсенала Цвикки полезно любому ученому, инженеру, исследователю, конструктору.

Полвека - большой срок для любого алгоритма творчества, так что методы Цвикки сейчас усовершенствованы и в некоторых вариантах изменены весьма существенно. И все же начать нужно с базовых трех методов, названных выше.

МЕТОД ОТРИЦАНИЯ И КОНСТРУИРОВАНИЯ

Основой метода служит принцип: любое утверждение, сформулированное в конечных и полностью определенных терминах, не может быть абсолютно верным. Иными словами, любое правило, любой закон, любое условие можно и должно подвергать сомнению, поскольку они имеют ограниченную область действия. Названный принцип подтверждается всем ходом истории науки: даже основополагающие ее постулаты, в момент становления претендующие на абсолютную всеобщность, в конце концов переходят в ранг частного утверждения, справедливого в определенной области, уступая место очередному "всеобщему" закону.

Наиболее яркий пример проявления этого принципа - неэвклидовы геометрии. Две тысячи лет геометрия на плоскости зиждилась на пяти постулатах Эвклида. Но если первые четыре постулата воспринимались действительно как аксиомы, то пятый - постулат о параллельных прямых - вызывал у математиков всех времен чувство неудовлетворения, дискомфорта: уж очень он был похож на теорему, которую так и хотелось доказать. Пытались доказать многие, одним из них был ректор Казанского университета Н.И.Лобачевский. Он выбрал метод доказательства "от противного", т.е. предположил, что утверждение "через точку, не лежащую на данной прямой, проходит не более чем одна прямая, лежащая с данной прямой в одной плоскости и не пересекающая ее", неверно и решил строить все следствия и выводы на основе нового комплекта постулатов - четыре старых и пятый - новый, измененный таким образом: вместо "не более чем одна прямая" он поставил "по крайней мере две прямые". Очевидно, если исходное утверждение неверно, то, строя на его основе новые и новые теоремы, следствия и выводы, можно на каком-то этапе прийти к бессмыслице, что и должно свидетельствовать о неверности исходной предпосылки.

Работа началась. Лобачевский формулировал поочередно все теоремы, по аналогии с теоремами эвклидовой геометрии, но абсурда нигде не просматривалось... На каком-то этапе он понял, что создал новую, внутренне непротиворечивую геометрию, и опубликовал свой труд. Это было и его трагедией, и его триумфом. Обыватели (в первую очередь обыватели от науки) до конца жизни считали его несколько "не в себе", и он не мог этого не видеть. А триумф наступил значительно позже, после того как была создана теория относительности (тоже, кстати, теория, полученная отрицанием одного из основных положений ньютоновской механики и заменой его на принципиально иной постулат) и выяснилось, что мы живем в мире, где плоскость - в действительности не плоскость, а поверхность с отрицательной кривизной. Кстати, отрицание пятого постулата можно провести единственным образом, а вот конструирование нового постулата взамен отброшенного - двумя способами, и это соответствует двум принципиально различным неэвклидовым геометриям: 1) геометрия на сфере, где эквивалентом прямым линиям служат окружности большого диаметра и где через точку, расположенную на сфере вне такой окружности, нельзя провести ни одной "прямой", которая бы не пересекала данную, любая окружность большого диаметра пересечет заданную в двух точках; 2) геометрия на поверхности отрицательной кривизны, например на однополостном гиперболоиде (седловидная поверхность), где эквивалентом прямых служат гиперболы и где через каждую точку вне заданной гиперболы можно провести сколько угодно гипербол, не пересекающих заданную.

Практически в любой другой науке солидного возраста можно найти такую страницу ее истории (а может быть, и не одну), когда происходила смена парадигм, т.е. комплекса аксиом, принципов, на которых она строится. Это нормальный ход познания, революционный, качественный скачок, проявление диалектического закона отрицания отрицания.

Не менее впечатляющим примером реализации метода отрицания и конструирования является установка наших великих педагогов, работавших с беспризорниками послевоенных времен. Вместо того чтобы искоренять в них отрицательные, плохие качества и наклонности, ставилась совершенно иная задача: убедить каждого из них, что в нем хорошего гораздо больше, чем плохого, и взрастить это хорошее. Аналогичную картину мы наблюдаем сейчас в масштабе страны: запретительный стиль административной системы ("запрещено все, что не разрешено"), душивший не только нарушения инструкций, но и любую инициативу и творчество, меняется на демократический стиль руководства, поощряющий самодеятельность ("разрешено все, что не запрещено") и дающий возможность каждому самоутвердиться, почувствовать себя, наконец, личностью, нужной и полезной обществу, и результаты (там, где их удается довести до стадии "конструирования", т.е. создания новых работоспособных структур) не заставляют себя ждать.

В технике метод отрицания и конструирования очень плодотворен, причем наибольшей эвристической силой он обладает на стадии постановки задачи, целеполагания. Процедурно он сводится к трем последовательным этапам:

1. Выявляют в исследуемом объекте (это может быть реальная, действующая техническая система, но может быть и технология, и любой другой объект любой природы и элементного состава, реальный или мыслимый) его признаки, характеристики, свойства или иные атрибуты, существенные для выполнения его главной полезной функции. В некоторых случаях достаточно определить всего один такой признак.

2. Отрицают один из выявленных признаков, отказываются от него и заменяют его принципиально иным признаком, не обязательно противоположным.отброшенному. Например, при разработке нового объекта на основе настенных часов можно отрицать их свойство "показывать местное время" и заменить его, в зависимости от назначения, такими: а) показывать время, оставшееся до конца заданного интервала (например, до конца рабочей смены); б) показывать время с момента восхода солнца; в) показывать температуру, давление или еще какую-нибудь погодную характеристику или их комбинацию; г) показывать фазу луны, уровень солнечной активности или иной космический фактор, влияющий на здоровье и самочувствие.

3. Конструируют (сначала мысленно, а при удачном завершении "мысленного конструирования" - и в натуре) новый объект с этой замененной характеристикой. Остальные характеристики, не связанные с замененной, оставляют теми же, что и в исходном объекте.

Метод отрицания и конструирования по своей сути перекликается с очень многими приемами, применяемыми в других методах. Для ознакомившихся с арсеналом методов поиска новых технических решений полезно в качестве упражнения сравнить указанные ниже группы методов и приемов и обрисовать признаки их общности и различия, а также совместимость этих методов:

1. Метод отрицания и конструирования (МОК) и списки контрольных вопросов.
2. МОК и метод систематического покрытия поля.
3. МОК и метод морфологического ящика.
4. МОК и метод фокальных объектов, метод гирлянд ассоциаций и аппарат аналогий в синектике.
5. МОК и аппарат технического противоречия в АРИЗ.
6. МОК и принцип идеальности в АРИЗ.
7. МОК и оператор РТВ в АРИЗ.

Для наиболее глубокого понимания сути и возможностей метода отрицания и конструирования можно попробовать решить задачи такого типа:
с применением МОК предложить идею принципиально нового (не известного в мировой практике) объекта бытового назначения, взяв за основу один из следующих объектов: а) самовар; б) кресло; в) любую единицу верхней одежды; г) домашние тапки; д) хозяйственную сумку; е) книжный шкаф, ж) конфету, з) балкон.

МЕТОД СИСТЕМАТИЧЕСКОГО ПОКРЫТИЯ ПОЛЯ

Рис.1.

Схема метода поясняется рис.1, на котором "поле знаний" об объекте исследования условно обозначено в виде некой замкнутой плоской области. В действительности, начиная изучение любого объекта, исследователь вначале имеет в своем распоряжении лишь очень небольшое количество известных положений, т.е. экспериментальных фактов или теоретических утверждений, которые можно назвать "вехами знаний". Познание объекта исследования фактически строится как продвижение от каждой из этих "вех" (обозначенных кружочками на рис.1), причем часть поля знаний "покрывается" областями, управляемыми одной-единственной "вехой" (т.е. прямыми следствиями из конкретного исходного положения), какая-то часть покрыта заштрихованными на рис.1 пересечениями таких областей (т.е. следствиями, использующими два или более исходных положений), а какая-то часть остается "непокрытой" (т.е. относительно объекта исследования существует группа вопросов или ситуаций, для которых на текущий момент нет ясных и однозначных ответов).

Метод систематического покрытия поля (МСПП) рекомендует последовательно экстраполировать имеющиеся знания в неизученные участки поля, стараясь перекрыть его полностью, т.е., с одной стороны, найти ответы на все вопросы, имеющие отношение к объекту исследования, а с другой стороны, мысленно построить все ситуации и следствия, вытекающие из уже имеющихся знаний (с тем, чтобы затем этим следствиям и ситуациям найти соответствие в реальном мире). Действуя таким образом, можно ожидать, что:

а) ничто не будет упущено из поля зрения; и
б) существует вероятность сделать открытие.

Последнее утверждение оказывается действительным прежде всего тогда, когда какие-либо участки рассматриваемого "поля знаний" оказываются недоступными, несмотря на все усилия продвинуться в них от наших "вех"; в этом случае есть все основания ожидать, что отсутствие сведений об этих участках вызвано фундаментальными причинами, т.е. новыми "вехами", еще не известными науке (на рис.1 справа они обозначены полыми кружочками с вопросительным знаком), и тогда - ищите!

Из необъятного множества известных на сегодня методов поиска новых научно-технических решений МСПП - единственный метод, ориентирующий исследователя не на изобретение, а на открытие. Причем заметим, что открытия бывают трех типов: 1) открытие-прозрение, т.е. открытие нового принципа, нового эффекта или действительно фундаментального положения, дотоле не известного науке; 2) открытие-наблюдение или открытие-обнаружение, когда на основании имеющихся аксиом мысленно конструируется внутренне непротиворечивая ситуация, объект или явление, а затем эта никем не наблюдавшаяся ситуация или "мысленная конструкция" либо обнаруживается в природе, либо создается искусственно; 3) открытие-случайность, когда обнаруженный экспериментально объект (или явление) ни из каких предпосылок не следует и обязан своим обнародованием только наблюдательности исследователя.

МСПП выводит на первые два типа открытий, причем на стадии "систематического покрытия поля" (т.е. планомерного продвижения в область неведомого) идут в основном открытия второго типа, а на стадии "тупиковой ситуации" - открытия первого типа (новый принцип). Интересно также, что открытие первого типа, как правило, влечет за собой цепочку открытий второго типа, т.к. сразу же после появления новой "вехи знаний" естественно ожидать (и не только ожидать, но и реализовать ожидаемое) быстрого расширения "покрытой" части поля знаний.

Этот "детективный" способ работы Цвикки использовал в астрофизике в течение нескольких десятилетий для выявления, поиска и предсказания новых космических объектов и явлений. Используя всего пять основных положений астрофизики, он предсказал и обнаружил карликовые галактики, компактные галактики всех типов (от голубых до инфракрасных) и кластеры компактных галактик. По его предсказанию были открыты нейтронные звезды. Из несбывшихся к 1967 г. предсказаний Цвикки [2, 3] следует отметить компактные галактики, насыщенные нейтронными звездами, чисто световые космические "шары", а также световые "шары", напичканные нейтронными звездами. Последние ультракомпактные объекты сильно напоминают "черные дыры", существование которых сейчас не вызывает сомнения (эти объекты были выдвинуты Цвикки в качестве наиболее вероятных кандидатов на модель квазизвездных радиоисточников, а также обычных радиомолчащих компактных галактик, аномальное красное смещение которых вызвано колоссальным собственным гравитационным полем).

Вообще говоря, ситуация с МСПП несколько перекликается с удивлением г-на Журдена, на склоне лет узнавшего, что он всю жизнь говорил прозой. В действительности большинство деятелей науки пользовалось и пользуется методом систематического покрытия поля в своей обычной научной работе. Конечно, далеко не каждому удается при этом сделать открытие мирового масштаба, но "своих" микрооткрытий - сколько угодно.

В качестве примера рассмотрим ситуацию с периодическим законом химических элементов. Вообще говоря, "зоологическая стадия" развития любой науки на определенном этапе совершенно прозрачно и откровенно ставит задачу систематизации, в результате чего на горизонте начинает маячить "кружочек с вопросом" - неизвестный еще принцип систематизации. Именно такая ситуация сложилась в химии во второй половине XIX века, и поиском принципа систематизации нескольких десятков весьма разнообразных химических элементов занялись многие химики. Однако только одному из них удалось нащупать основополагающий принцип: периодичность изменения химических свойств в ряду, расположенным в порядке возрастания массы атома. Трудность состояла.в том, что в момент провозглашения этого правила в нем уже существовал ряд исключений. Однако в том-то и состояла гениальность Д.И.Менделеева, что за этими исключениями он сумел увидеть ситуацию более глубоко, и это позволило ему не только уверенно предсказать существование трех еще не открытых химических элементов (галлия, германия и скандия), но и дать для этих элементов перечень их основных свойств и даже наз-ватьГруды,в которых можно искать предсказанные элементы.

Последовавшее вскоре реальное обнаружение названных элементов сняло все сомнения в корректности принципа, положенного в основу Периодического закона Л.И.Менделеева. И одновременно поставило вопрос о том, почему же этот закон нарушается для аргона и калия - единственной пары, у которой масса предшествующего элемента в ряду больше, чем масса последующего. (Для разрешения этого_ вопроса потребовался новый качественный скачок физики -открытие изотопов).

Единичные "неудачные" факты исключения в "научной картине мира" редко привлекают к себе массовое внимание ученых, поэтому работа по МСПП, как правило, спонтанно реализуется только в тех ситуациях, когда в конкретной области науки или техники накапливается группа родственных (или подозреваемых в родстве) фактов, не объяснимых с помощью имеющегося багажа знаний. Однако, зная о методе, можно сознательно его использовать, не дожидаясь, когда масса необъясненных фактов достигнет величины, понятной каждому. В этом смысле крайне ценным представляется анализ сегодняшней сиюминутной ситуации в конкретной области знаний каждого слушателя (или читателя). Поэтому самое время выполнить упражнения:

1. Назвать два-три открытия первого типа, выполненных по МСПП.
2. Назвать две-три группы открытий второго типа, выполненных по МСПП.
3. Для 2-3 областей знаний назвать группы родственных фактов, не объясненных наукой и предположительно выводящих на открытия нового принципа.

МЕТОД МОРФОЛОГИЧЕСКОГО ЯЩИКА

Несмотря на то, что наиболее серьезные достижения Цвикки относятся к двум рассмотренным выше методам, наибольшую известность получил все же метод морфологического ящика (ММЯ), который "узурпировал" общее название • "морфологический анализ", или "морфоанализ". Причины ясны:

а) ММЯ является единственным "алгоритмизированным" методом из набора Цвикки;
б) ММЯ наиболее доступен для понимания обычным инженерам, не "морфологам от рождения".

Впрочем, последняя особенность (в действительности мнимая) сослужила методу плохую службу: бездумное, догмагическое применение ММЯ в той же сжатой, "телеграфной" форме, которая дана автором метода, почти неизбежно ведет к отрицательному результату.

В чем же дело? Давайте рассмотрим, как сам Цвикки формулирует этапы ММЯ [1, 2] :

1.Точно сформулировать проблему, подлежащую решению.
2.Выявить и охарактеризовать все параметры, которые могли бы войти в решение заданной проблемы.
3.Сконструировать морфологический ящик или многомерную матрицу, содержащую все решения заданной проблемы.
4.Все решения, содержащиеся в морфологическом ящике, внимательно проанализировать и оценить с точки зрения целей, которые должны быть достигнуты.
5.Выбрать и реализовать наилучшие решения (при условии наличия необходимых средств). Этот этап практической реализации требует дополнительного морфологического изучения.

Универсальность ММЯ успешно продемонстрирована самим Цвикки на целом ряде примеров, а тот факт, что кабинетный ученый-астрофизик в течение нескольких лет получил 16 патентов (из них только три с соавторами) на новые конструкции ракетных двигателей на химическом топливе и выдвинулся в ряд ведущих специалистов ракетостроения, в архиделовой Америке вызвал первый бум морфоанализа, в результате которого тысячи инженеров кинулись строить морфологические ящики и ... убедились, что все это не так просто.

Интерпретаторы и последователи Цвикки не всегда адекватно понимали и передавали его идеи, даже формулировки этапов ММЯ в разных пособиях скорректированы и еще более сокращены по сравнению с исходным текстом, приведенным выше. В результате метод морфологического ящика, оторванный от общих принципов морфологического подхода, стал достаточно уязвимым для критики [4]. В немалой степени помог этому и сам Цвикки, точнее, его работы [1-3]: обозначив цель каждого этапа словесными формулировками, он для описания средств достижения цели этапа воспользовался совсем иным методом, не оговорив это для читателя, - методом "делай, как я". Основной объем книги [2] - основного труда Цвикки - занято описанием и подробным разбором хода решения нескольких разнородных примеров, взятых из различных областей человеческой деятельности (от способов превращения энергии до систем стенографии, от видов телескопов до юриспруденции в космическом пространстве), при неявном предположении, что читатель на этих примерах сам поймет, как реализуется тот или иной этап. Однако темп жизни и нетерпение читателей и "писателей" привели к тому, что эта важная методическая часть была просто опущена, в результате чего алгоритм ММЯ превратился в лозунг-загадку.

Истекшие десятилетия существенно продвинули науку о методах исследования, поэтому сейчас работы Цвикки кто-то может воспринять и как непоследовательные, и как примитивные. Однако, даже не делая скидки на время, следует признать морфологический подход прежде всего весьма плодотворным способом мышления (именно так его представлял сам Цвикки), который в своих конкретных реализациях может служить также и плодотворным методом обработки проблемы, т.е. подготовки, переформулировки, изменения взгляда на проблему. При этом не забудем оговориться, что, как и любой другой, морфологический метод - это метод для мышления, а не вместо мышления; оценки и выбор решения остаются прерогативой человека, а не алгоритма.

МОРФОЛОГИЧЕСКИЙ ПОДХОД В НАУКЕ.

События последних лет в физике продемонстрировали яркий пример действенности морфологического подхода. Однако начало этих событий относится к началу XX века.

Рис.2 В 1908 г. голландский физик Г.Каммерлинг-Оннес в Лейденском университете перевел в жидкое состояние последний из инертных газов - гелий и тем самым открыл для физиков область температур от 1 до 10 К, весьма близкую к абсолютному нулю. Первые эксперименты были направлены на ликвидацию "белых пятен" в области электросопротивления металлов при этих температурах (рутинная работа по МСПП). Теория электросопротивления предполагала три возможных хода кривой r (Т) при низких температурах (рис.2): 1) плавное стремление r к нулю; 2) плавный выход "на полку"; 3) бесконечный рост-вымораживание электронов. Первый эксперимент для Pt и Аu (достаточно чистых в то время металлов) показал, что реальный ход кривых ближе к кривой 1, но зависит от степени чистоты металла. Однако переход к экспериментам на ртути (ее очистка многократной дистилляцией позволяла получить наиболее чистый металл) дал в 1911 г. неожиданный и совершенно непонятный результат (рис.3). Многократная проверка подтвердила открытие сверхпроводимости, не объяснимое никакой из имевшихся теорий.

Вскоре тот же эффект был обнаружен и на многих других металлах, но объяснения ему не было.... Типичная для МСПП ситуация: яркая группа фактов, дразнящих своей необъяснимостью. И хотя Нобелевская премия за экспериментальное открытие сверхпроводимости (открытие 3-й группы) была присуждена Каммерлинг- Оннесу всего через два года - в 1913 г., для объяснения эффекта (открытия 1-й группы) потребовалось около полувека. Многие теоретики пытались раскусить твердый орешек сверхпроводимости, но только в 1972г. очередная Нобелевская премия по физике была присуждена трио: Бардину, Куперу и Шрифферу, создателям "теории БКШ", описывавшей все известные к тому времени эффекты сверхпроводимости.

Экспериментаторы отнюдь не спали эти полвека. Фантастические перспективы практического использования сверхпроводимости тормозились только одним фактором: эффект наблюдался лишь при очень низких температурах, получение которых стоило слишком дорого. Началась "гонка за градусами" - поиск веществ, которые могли бы переходить в сверхпроводящее состояние при более высоких температурах. Элементарные вещества были исследованы очень быстро, в промышленность пошли только свинец (критическая температура сверхпроводимости Тк = 7,26 К) и ниобий (Тк = 9,22 К).

Бинарные соединения, поиск которых (МСПП + ММЯ) проводился уже не наобум и не "поголовно", а с учетом теоретических подсказок, позволил выйти вначале во второй десяток градусов (NbN - 15 К, NbH -13 К, NbC - 10 К), а затем "разменять" и третий десяток ((Nb3Al)4Nb3Ge - 20,3 К, Nb3Ge - 23 К) . Последние градусы давались с колоссальным трудом, а впереди маячил печальный финал: теория БКШ поставила верхний предел Тк в районе 30 К, в крайнем случае 40 К. Это означало, что "голубая мечта" техники - сверхпроводимость при комнатной температуре (300 К) или хотя бы при температуре жидкого азота (77 К) - всего лишь мечта...

27 января 1986 г. два сотрудника швейцарского отделения фирмы IBM Беднорц и Мюллер сдали в редакцию журнала Phys. Rev. Lett. статью, в которой утверждали, что керамический (это же диэлектрик!!!) образец сложного окисла LaBaCu04 переходит в сверхпроводящее состояние при 33 К. Статья была отвергнута редакцией (чушь ведь, диэлектрик вообще не проводник, а тут - сверхпроводимость, да еще и температура чуть ли не выше теоретической!), поэтому мир узнал об этих результатах лишь в октябре, когда менее престижный Zeitschrift fur Physik опубликовал эту статью. Психологический барьер был прорван (МОК), и последующие два года вызвали беспрецедентный в XX веке вал публикаций по керамическим сверхпроводникам.

События развивались, как на фронте: каждые две недели ведущие научные учреждения собирали семинары, керамику "пекли" везде, Тк росла невиданными темпами: декабрь 1986 г. -39 К, январь 1987 г.- 70 К, февраль 1987 г.- 80 К (ура, азотный предел пройден!), март 1987 г.- 240 К (Калифорния) и 170-250 К (ИФП АН СССР), в середине 1987 г. появилось даже сообщение о Тк = 500 К! Незаметно "пал" и психологический барьер, поставленный теорией БКШ: реальная, твердо установленная температура полной сверхпроводимости (со всеми сопутствующими ей эффектами) Тк = 90 К втрое превысила теоретическую и ситуация явно требовала новой теории, новой "вехи знаний". Японцы, наиболее поднаторевшие в пользовании методами поиска новых научно-технических решений, развернулись шире всех: более 5 тысяч публикаций за 2 года, сотни патентов на будущее практическое использование сверхпроводящих керамик. При этом четко прослеживается именно морфологический подход к проблеме во всех ее аспектах: систематическое исследование вариаций состава керамик (МСПП), систематическая замена отдельных компонент на родственные (ММЯ), пробная частичная замена кислорода на иные атомы (МОК) - все это относится к физике высокотемпературной сверхпроводимости. Параллельно в технологии систематически просматриваются все мыслимые области перехода на сверхпроводящие керамики вместо металла (МСПП + ММЯ), а дешевизна жидкого азота позволяет использовать сверхпроводимость керамик даже там, где обычную проводимость применять слишком дорого (МОК).

Итак, за последние два года в физике прошла волна открытий 2-го типа (упрежденная открытием 3-го типа, авторы которого уже через год были удостоены Нобелевской премии), сделанных по МСПП, и сейчас теоретики в спорах и муках рождают открытие 1-го типа (на базе ситуации, созданной МСПП).

МОРФОЛОГИЧЕСКИЙ ПОДХОД В ТЕХНИКЕ.

Если в науке из трех "китов" морфологического подхода основным, как правило, является МСПП (хотя и остальные два метода привлекаются в качестве подспорья на некоторых этапах), то в технике базовым чаще всего оказывается ММЯ (хотя Цвикки и в технике прекрасно решал задачи при том же соотношении методов).

Переработка и "перетолкование" ММЯ последователями Цвикки шло разными путями, но в конце концов сформировалось два существенно различных направления работы по ММЯ:

1) многоступенчатый ММЯ при малых объемах морфологических множеств на каждой ступени и полном их анализе;
2) одноступенчатый ММЯ при очень большом объеме морфологического множества и тактике последовательного улучшения объекта без полного перебора вариантов.

Второй путь часто связывают с солидной математической и машинной поддержкой, в то время как первый доступен для реализации "вручную", причем в сравнительно ограниченные сроки. Учитывая современное состояние машинного парка в стране и настоятельную необходимость вооружить массу решателей "подручным" методом, способным работать в любых условиях, мы считаем необходимым в первую очередь предложить вниманию читателя один из простейших и наиболее быстрых вариантов реализации морфологического подхода на базе ММЯ.

За основу взят тот же комплект из пяти этапов ММЯ, перечисленных выше. Однако сразу же отметим то, что Цвикки не счел нужным акцентировать в описании алгоритма:
а) на этапе IV при анализе вариантов полезно использовать механизм МСПП, выводящий иногда далеко за пределы альтернатив, содержащихся в морфологическом множестве;
б) на этапе V "дополнительное морфологическое изучение", рекомендованное Цвикки, целесообразно осуществлять, используя весь доступный решателю арсенал методов (а не только ММЯ, МОК и МСПП).

А теперь попробуем описать предлагаемый метод по этапам, демонстрируя особенности их реализации на конкретной задаче.

I этап.

Знаете ли Вы, почему шахматисты терпеть не могут, когда зрители начинают им подсказывать? В частности, и потому, что "сбоку виднее": зрителю, стороннему наблюдателю, спокойно относящемуся к происходящему на шахматной доске, часто легче обнаружить наилучший ход, чем сидящему за доской (при равной с играющим квалификации, разумеется). Именно эту особенность человеческой психики имел в виду Цвикки, когда формулировал указание к алгоритму ММЯ: никаких ограничений и оценок до тех пор, пока морфологический ящик не будет полностью составлен.

Чтобы включить мысленное "боковое зрение" уже на первом этапе, имеет смысл прежде всего вместо задачи типа "разработать объект заданного назначения" рассмотреть задачу другого типа - "посмотреть, какие известны объекты подобного назначения и какими могут быть такие объекты". Иными словами, задачу конструирования, синтеза заменить задачей исследования, анализа в надежде, что при таком "ненаправленном" анализе полезные варианты выявятся сами, без дополнительных усилий и "охоты" за ними.

Итак, формулировка задачи: разработать осветительный прибор для выездного мастера телеателье.

Как переформулировать задачу, сделав ее более "нейтральной", достаточно общей, чтобы можно было использовать несколько известных вариантов, и в то же время достаточно близкой к исходной, чтобы поле вариантов решения нашему выездному мастеру было все же интересным (иначе есть риск утонуть в изучении, например, театральных люстр). Попробуем разные варианты:

исследовать осветительные приборы (пожалуй, слишком общая);
осветительные приборы для освещения труднодоступных мест;
переносной малогабаритный осветительный прибор;
осветительный прибор для стационарного рабочего места радиомастера.

Фактически каждая из трех последних формулировок акцентирует внимание на какой-либо одной особенности объекта исходной задачи (труднодоступность внутренностей телевизора; транспортабельность устройства; специфика радиомастерской). Комплект этих "побочных" исследовательских задач будет очень полезен при составлении морфологического ящика, а сейчас попробуем точно выполнить первый этап ММЯ - точно сформулировать проблему:

сконструировать переносной малогабаритный осветительный прибор для освещения труднодоступных внутренностей телевизора при условиях работы в произвольном жилом помещении.

Многословие формулировки не должно пугать решателя: чем детальнее сформулирована задача, тем легче будет в дальнейшем отсеивать ненужные варианты и отбирать полезные.

II этап.

Приступаем ко второму этапу. Формулировка Цвикки этого этапа в погоне за общностью потеряла ясность и конкретность, поэтому уточним, что при анализе задач "на устройство" под параметром следует понимать функциональный узел этого устройства, при анализе задач "на способ" - операцию, осуществляющую достижение той или иной целевой функции. В нашем случае речь идет об устройстве, так что следует просто разобраться в том, какие внутренние функции (обеспечивающие реализацию основной внешней функции, сформулированной на этапе I) реализуются в осветительном устройстве и какие функциональные узлы выполняют эти функции.

Осветительное устройство использует какую-то энергию, преобразует ее в световую и организует поток света в нужное место. Кроме того, оно на чем-то крепится или устанавливается, возможно, имеет какие-то элементы, обеспечивающие перевод из транспортного в рабочее положение, а также элементы, обеспечивающие безопасность работающего. Пока достаточно, но может случиться, что память потом подскажет еще какую-нибудь функцию, тогда мы ее добавим. Составляем простенькую табл. 1, где слева будет наименование функции, а справа - наименование узла, участвующего в ее реализации.

Таблица 1.
Функция | Узлы
Энергопитание | Источник энергии, коммутатор (регулятор потока энергии), коммуникации (проведение энергии от источника к преобразователю)
Преобразование энергии источника-" в световую | Источник света, регулятор интенсивности светового потока
Организация светового потока | Рефлектор, светопровод, линзовое устройство и т.п.
Крепление устройства | Элемент крепления (основание, стойка, зажим, струбцина и т.п.)
Перевод из транспортного состояния в рабочее | Элементы, обеспечивающие изменение габаритов устройства (шарниры, телескопические устройства, гибкие элементы и т.п.)
Обеспечение безопасности | Элементы защиты (изоляции) от напряжения, ожога, ослепления и т.д.

Обратите внимание: в правой части таблицы опять некоторое многословие. Оно и здесь нелишне: во-первых, это исходный материал для формулировки наиболее точного наименования будущего параметра морфологического ящика, а во-вторых, этот же материал будет полезной подсказкой на третьем этапе ММЯ. Еще одна особенность: одной функции может соответствовать не один элемент, а цепочка связанных между собой элементов, причем в некоторых случаях состав этой цепочки может меняться (например, регулировка величины светового потока может осуществляться или в цепи энергопитания, или в световой цепи, а может и вообще отсутствовать). Таким образом, выявляется очень важный и часто встречающийся вариант реализации объекта, когда данный элемент в нем отсутствует. На третьем этапе с этим придется столкнуться вплотную и не раз.

Извлекаем из правого столбца таблицы наименования параметров:

1. Источник энергии.
2. Проводник энергии.
3. Выключатель.
4. Регулятор потока энергии.
5. Источник света.
6. Регулятор светового потока.
7. Светонаправляющие элементы.
8. Устройство крепления осветителя.
9. Устройство развертывания-свертывания осветителя.
10. Элементы защиты работающего. Список получился достаточно длинным. Это чревато крупными неприятностями, и вот какими. Если каждый параметр можно реализовать всего лишь тремя способами, то каждый в итоге морфологический ящик будет содержать 310 = 59049 вариантов светильника, а такую массу вариантов очень трудно проанализировать (в обозримое время). Поэтому при работе по "короткому" алгоритму ММЯ стараются число параметров и число вариантов их реализации свести к минимуму. При этом очень важным представляется напоминание Цвикки, что все параметры должны быть примерно равнозначимы с точки зрения поставленной цели.

Рассмотрим вновь наш список из десяти параметров на предмет сравнения важности параметров и возможного сокращения списка.

Прежде всего, ясно, что телевизионный мастер будет работать в помещении, где есть сеть переменного тока (едва ли даже владелец автомобильного телевизора пригласит мастера для ремонта в туристическую палатку на лоне природы), стало быть, источник энергии можно однозначно определить так же, как и проводник энергии, и выключатель (его, правда, может и не быть, если это будет иметь смысл с точки зрения компактности). Одновременно традиционными способами решаются и вопросы электроизоляции. Следующий шаг: регулировку светового потока целесообразно делать (если делать вообще) только в одном месте. И, наконец, защита работающего от электрического напряжения решена, защита от света решается одновременно с задачей организации светового потока, а от ожогов - едва ли кому нужен осветитель с КПД < 1%, а поскольку освещение рабочей зоны требует не более 10 — 100 мВт световой мощности, то обжечься, собственно, и нечем. Таким образом, параметры 1 и 2 исключаются из-зa тривиальности их выбора, параметр 3 оставим, но лишь затем, чтобы выбрать, где разместить выключатель и вообще нужен ли он. Параметр 5 остается, 4 и 6 объединяются в один. Параметры 7, 8 и 9 остаются, 10 исключается. Итого: в списке осталось 6 параметров, при этом изменилась и формулировка задачи, поскольку в нее следует добавить слова "с питанием от электросети ~220 В".

III этап.

Приступаем к третьему этапу. Прежде, однако, заметим, что оформление морфологического множества можно проводить в нескольких модификациях:

1. Морфологическая таблица строится так: левый столбец заполняется наименованиями параметров, а затем к каждой клетке этого столбца справа пристраивается столько клеток, сколько нужно для размещения всех вариантов реализации данного параметра (по одному в каждой клетке).

Очевидно, получившиеся строки будут в общем случае иметь разную длину. Пример такой таблицы приведен ниже (табл. 2), причем наименования условно обозначены буквами.

Таблица 2

Параметр | Альтернативы
А | А1 | А2 | А3
Б | Б1 | Б2 |
В | В1 | В2 | В3
Г | Г1 | Г2 | Г3

2. Морфологический список строится аналогично многозвенному оглавлению: вслед за пронумерованным (или обозначенным буквой) параметром выписываются по порядку с красной строки все варианты или альтернативы его реализации с соответствующими двухзвенными номерами (аналогичными обозначениям в табл. 2).

3.Морфологическая матрица представляет собой прямоугольную матрицу, каждая клетка которой соответствует конкретному варианту реализации исследуемого объекта (рис.4).

 |  | А1 |  | А2 |  | А3
 |  | Б1 | Б2 | Б1 | Б2 | Б1 | Б2
Г1 | В1 |  |  |  |  |  |
 | В2 |  |  |  |  |  |
 | В3 |  |  |  |  |  |
Г2 | В1 |  |  |  |  |  |
 | В2 |  |  |  |  |  |
 | В3 |  |  |  |  |  |
Г3 | В1 |  |  |  |  |  |
 | В2 |  |  |  |  |  |
 | В3 |  |  |  |  |  |

Рис.4. Морфологическая матрица

4.Морфологическая диаграмма строится так: выписывают в столбик все альтернативы всех параметров по порядку, затем против каждой из них проводят горизонтальную черту необходимой длины. Каждый конкретный вариант реализации объекта формируют с помощью вертикальной черты, пересекающей все горизонтальные линии, с отметкой всех реализуемых в данном варианте альтернатив (например, укрупненной точкой, как показано на рис.5).

Рис.5
Рис. 5. Морфологическая диаграмма

Из перечисленных форм первые две удобнее использовать на стадии заполнения морфологического множества, последние две - на стадии его анализа (третью - при исключении заведомо непригодных вариантов, четвертую - при словесной оценке варианта, для которой можно оставить необходимый участок под соответствующей чертой).

Заметим еще следующее. ММЯ - метод, требующий в оформлении крайней тщательности, и одновременно метод, неизбежно связанный с многократными исправлениями, дополнениями и вычеркиваниями. Поэтому, если Вы хотите, чтобы ММЯ в ваших руках заработал во всей своей мощности, возьмите за правило переписывать каждый лист записи полностью, как только 15-20% его рабочей площади будет покрыто исправлениями всех видов, иначе большую часть умственных усилий Вам придется тратить не на анализ материала, а на разбирание мазни и каракуль, что не способствует ни успеху, ни оптимизму. Но в то же время нельзя выбрасывать ни один листик черновика или переделанный лист: в отброшенных или исправленных формулировках, как правило, остаются ценные идеи, которые могут пригодиться на любой стадии работы.

Ну а теперь строим морфологическую таблицу или, выражаясь языком Цвикки, заполняем морфологический ящик ("morphological box"). Без всяких вспомогательных материалов, ориентируясь только на свой жизненный опыт и табл. 1, автор построил матрицу, представленную в виде табл. 3, затратив на это ровно столько времени, сколько необходимо было для ее написания. После этого следует пополнить эту таблицу тем, что удастся "выудить" из известных вариантов устройств, решающих задачи, переформулированные нами в самом начале первого этапа.

Таблица 3

Морфологическая таблица для задачи конструирования переносного малогабаритного электроосветительного прибора для освещения труднодоступных внутренностей телевизора при условиях ремонта его в произвольном жилом помещении, с питанием от электросети 220 В

А. Выключатель | А1. В основании |  |  | А2. В вилке. |  |  |  | А3. В патроне |  |  |  | А4. Отсутствует |  |  | А5*. На проводе
Б. Источник света | Б1. Лампа накаливания |  |  |  |  |  | Б2. Светодиод |  |  |  | Б3. Люминесцентная лампа
В. Регулятор светового потока |  |  | В1. Автотрансформатор |  |  | В2. Реостат |  |  | В3. Диафрагма |  |  |  | В4. Шторка |  | В5. Отсутствует
Г. Светонаправляющий элемент |  |  | Г1. Рефлектор | Г2. Линзовый конденсор |  |  |  | Г3. Световод |  |  |  | Г4. Плоское зеркало |  |  | Г5. Отсутствует
Д. Устройство крепления | Д1. Массивное основание |  |  |  | Д2. Струбцина |  |  | Д3. Зажим типа "крокодил" |  |  |  |  | Д4. Магнит |  | Д5*. Наголовник
Е. Устройство развертывания |  | Е1. Телескопическое устройство |  |  |  | Е2. Жесткий металлорукав |  |  |  | Е3. Шарнирное устройство |  |  |  | Е4. Отсутствует

*Альтернативы, появившиеся при просмотре аналогов из других областей, согласно измененным формулировкам цели

"Осветительные приборы для освещения труднодоступных мест" - что бы это могло дать?

1. Энтероскопия в медицине, где речь идет о рабочем поле площадью от квадратных миллиметров до квадратных сантиметров. Через гибкий световод решается задача как освещения, так и лазерной хирургии лучом, проводимым по параллельному каналу того же световода. Идея световода в таблице 3 уже есть, лазер для радиомастера - дороговато и громоздко.

2. Прожектора освещают далекие, т.е. труднодоступные места. Рефлектор, дуговая лампа. Идея рефлектора в таблице 3 есть, дуговая лампа слишком мощна, остальное прожекторное оборудование интереса вроде бы не представляет.

"Переносной малогабаритный осветительный прибор" - где еще они встречаются?

1. Карманный фонарик. Рефлектор - уже есть; автономное питание - для него в таблице строки нет, так как мы условились питаться от электросети. В некоторых фонариках есть регулировка фокуса. Нужно ли это нам? Кажется, нет. Но вообще система с батарейкой не неприемлема, надо ее иметь в виду.

2. Переноска электромонтажника - электролампа в металлическом обрешеченном корпусе с крючком для подвешивания. Крючок для подвешивания отсутствует в табл. 3, его надо внести. Защитная решетка тоже отсутствует, но для нее и места нет, т.к. параметр безопасности мы исключили. Может быть, и зря, защитить ведь нужно не только работающего, но и лампу, ведь рядом или паяльник, или отвертка, или пассатижи, для обычной стеклянной лампы это не лучшее соседство. Но пока список параметров увеличивать не будем, просто отметим этот факт.

3. Лампа горняка-шахтера и лампа врача-окулиста. Крепится на шлеме или на лобном хомутике-наголовнике. Расположена довольно удобно, т.к. луч зрения почти совпадает с лучом осветителя. Добавим в пятую строку таблицы 3 наголовник. Остальные элементы этого осветителя в таблице есть.

"Осветительный прибор для стационарного рабочего места радиомастера" - обычно это коленчатый (в жестком металлорукаве или на штанге с шаровыми шарнирами) светильник с рефлектором, прикрепляемый к полке рабочего стола. Все его элементы в таблице 3 есть, кроме того, что выключатель в некоторых конструкциях закреплен непосредственно на питающем проводе (как у торшера). Внесем этот вариант в строку 1.

Вот и все, морфологическое множество построено, оно содержит 5x3x5x5x6x4=900 вариантов светильника. Многовато вариантов, начинаем "выжимать" из матрицы все лишнее. Подходить к этой операции следует с крайней осторожностью, так как некоторые, на первый взгляд, сами по себе неприемлемые альтернативы могут оказаться очень перспективными в совокупности с какими-либо альтернативами из другой строки. Поэтому, прежде чем выкинуть какой-либо вариант, следует просмотреть, нет ли для него в остальных клетках "палочки-выручалочки".

Итак, начинаем процедуру отбрасывания.

Выключатель. Нужен ли он в вилке? Ведь выдернуть вилку из розетки или щелкнуть тумблером в том же месте - почти одно и то же. Да и вообще нужен ли он, если есть вилка и розетка? Микроскопическое дополнительное удобство не оправдывается, наверное, введением этого (не самого надежного) элемента. Выбрасываем всю первую строку (или, иными словами, останавливаемся на варианте А4).

Источник света. Компактных люминесцентных ламп наша промышленность не выпускает, так что БЗ тоже можно исключить. Светодиод Б2 компактен, экономичен, но есть у него два серьезных недостатка: 1) монохроматический (окрашенный) свет; 2) отсутствие промышленных светодиодов осветительного назначения (есть только индикаторные со световой мощностью в милливатты). Наконец, светодиоды дороги. Все это вынуждает оставить единственный вариант источника света - лампу накаливания Б1, а значит, исключить всю строку, а в формулировку задачи добавить "с лампой накаливания".

Регулятор светового потока. По весу и габаритам автотрансформатор едва ли обрадует телемастера. С другой стороны, напрашивается еще один вариант регулировки освещенности - изменением фокуса светонаправляющего элемента. Освещенность рабочего поля у радиомастера должна быть, видимо, стандартной, так что прежде чем говорить о том, чем ее регулировать, следует решить вопрос, нужно ли это делать вообще. Поэтому строка В на первой стадии анализа будет иметь лишь два варианта реализации: В1. Отсутствует, В2. Имеется.

.Светонаправляющий элемент. Заметим, что эта строка составлена с нарушением основного закона морфоанализа: в ней не все варианты являются альтернативами. Действительно, разве нельзя сконструировать осветитель, где свет лампы с рефлектором и конденсором направлялся бы на вход волоконного световода, с выхода которого поток уже освещал бы рабочее поле? В такой ситуации (а ее следует сначала распознать!) правильно было бы изменить структуру строки Г, как показано в таблице 4. При этом вместо одной строки появляется несколько, но зато в каждой из этих строчек только по две тривиальные альтернативы.

Устройство крепления. Здесь, пожалуй, из-за веса следует убрать вариант Д1 (избыточный вес ничем не скомпенсируешь) . Большие сомнения из-за плохой надежности вызывают варианты Д5 (электрики все же вешают переноску подальше от того места, где приходится орудовать инструментом) и Д4 (во-первых, шасси может оказаться и не железным, а во-вторых, не дай бог влезть с магнитом в цветной телевизор, месяц потом размагничивать его придется), так что и их стоит, наверное, исключить.

Таблица 4

Г. Светонаправляющая система | Г1. Рефлектор | Г1.1. Есть | Г1.2. Нет
 | Г2. Конденсор | Г2.1. Есть | Г2.2. Нет
 | Г3. Световод | Г3.1. Есть | Г3.2. Нет
 | Г4. Зеркало | Г4.1. Есть | Г4.2. Нет

После всех этих преобразований матрица принимает следующий вид (табл.5) .В ней содержится 2х2х2х2х х2х2хЗх4 = 768 вариантов. Казалось бы, немного меньше, чек в исходной, однако это не совсем так. Дело в том, что светонаправляющая система до сокращения имела в действительности не 5 вариантов, а 24 = 16 вариантов, так что реально наша работа уменьшила число вариантов в 4 раза.

Таблица 5

А. Регулятор |  | А1. Есть |  |  | А2. Нет
Б. Светонаправляющие элементы | Б1. Рефлектор | Б1.1. Есть |  |  | Б1.2. Нет
 | Б2. Конденсор | Б2.1. Есть |  |  | Б2.2. Нет
 | Б3. Световод | Б3.1. Есть |  |  | Б3.2. Нет
 | Б4. Зеркало | Б4.1. Есть |  |  | Б4.2. Нет
В. Устройство крепления |  | В1. Струбцина | В2. Зажим |  | В3. Наголовник
Г. Устройство развертывания |  | Г1. Телескопическое | Г2. Металлорукав | Г3. Шарнир |  | Г4. Нет

Сделаем еще один (очень сильный) шаг, отложив детальный анализ светонаправляющей системы и системы развертывания до следующей стадии и ограничившись сейчас анализом совсем небольшой морфологической таблицы, изображенной в табл. 6. Тут всего лишь 24=16 вариантов осветителей, но зато эти варианты обозначены лишь в самых общих чертах.

Это, кстати, общая закономерность и наиболее быстрый способ проведения морфоанализа, при котором полнота анализа сочетается с требуемой детальностью и допустимым временем исследования. Решив вопросы, заложенные в табл. 6, т.е. выбрав принципиальную блок-схему осветителя, на следующей стадии можно по тем узлам, где выбор пал на клетку "Есть", провести анализ маленьких таблиц по этим подсистемам. В результате вместо 768 вариантов таблицы 5 придется в худшем случае исследовать всего 16 + 15 + 4 = 35 вариантов.

Таблица 6

А. Регулятор | А1.Естъ | А2.Нет
Б. Светонаправляющие элементы | Б1.Есть | Б2.Нет
В. Устройство крепления | В1. Струбцина (зажим) | В2 . Наголовник
Г. Элементы развертывания | Г1 .Есть | Г2.Нет

IV этап.

Переходим к четвертому этапу. Но прежде заметим, что в процессе работы на предыдущих этапах могут начаться помехи такого сорта. Вы обнаружили неожиданный вариант реализации объекта, и этот вариант Вам нравится. Если не принять специальных мер, то вся дальнейшая работа может оказаться бесполезной, так как мысленно Вы уже остановились на этом варианте и дальнейшие Ваши действия (неосознанно!) будут направлены на то, чтобы доказать "объективно", что именно этот вариант - наилучший. На этот случай психологи дают очень ценный совет: запишите мысль, которая Вас тревожит (в данном случае понравившийся вариант), в любом месте и в любой форме, и она Вас оставит (во всяком случае, на какое-то время). В нашем случае такая запись "на полях" вдвойне ценна: с одной стороны, она Вам не будет мешать, а с другой стороны, исключается и опасность забыть или потерять ценную идею.

Если говорить конкретно о нашей задаче, то автору уже давно мешают две идеи: 1) светильник - гибкий световод, один конец которого укреплен в рабочей зоне, а другой - просто на баллоне обычной настольной лампы; 2) светильник врача-окулиста или горняка с небольшими изменениями. Записав их в сторонке, можно теперь анализировать содержимое морфологического множества. Однако очередной взгляд на таблицу 6 выявляет, что в строке В отражено не столько устройство крепления, сколько место крепления: телевизор или голова мастера. Действительно, это более общий параметр, так как способов крепления - к голове ли, к телевизору или еще куда-то - известно очень много, а в строке В их практически нет. Поэтому еще раз наведем порядок в задании, представив его в виде диаграммы (рис.6), немного видоизменив ее оформление по сравнению с рис.5 и заодно собрав все коррективы в формулировке задачи. Кстати, проверим, есть ли на диаграмме то, чем обходится сейчас выездной мастер. Настольная лампа или верхний свет "заказчика" - это вариант А2Б2(Б1)Г2, а вот в строке В соответствующей альтернативы нет (во всяком случае, для верхнего света). Как быть? Добавить "на потолке"? Не стоит, ведь верхний свет - это осветитель не телемастера, а заказчика. Карманный фонарик у мастера встречается редко, но этот вариант возможен, в диаграмме он отражен.

А1. С регулятором света А2. Без регулятора света Б1. Со светонап-
равляющими элементами 		Б2. Без светонап-
равляющих элементов 		В1. Крепление на голове В2. Крепление на телевизоре Г1. С элементами разверты-
вания 		Г2. Без элементов разверты-
вания

Рис.6. Морфологическая диаграмма переносного малогабаритного' осветителя с лампой накаливания и питанием от сети ~220 В для освещения труднодоступных внутренностей телевизора при условии работы в произвольном жилом помещении

При анализе диаграммы довольно легко прийти к выводу, что регулятор света - излишняя роскошь, поэтому все нечетные варианты светильника сразу отбрасываем (обозначение "X" на диаграмме). Из оставшихся восьми вариантов нетрудно выделить два приемлемых: один - из-за простоты, другой - из-за многофункциональности. При окончательном выборе варианта определяющим фактором является позиция решателя по отношению к объекту: телемастер, желающий сам сделать для себя осветитель при наименьших затратах труда и средств, выберет скорее вариант 10; производственник, озабоченный выпуском новой продукции и расширением спроса на эту продукцию, выберет вариант 6, поскольку потенциально такой светильник полезен не только телемастеру, но и специалистам многих других профессий (да и для дома такое устройство при соответствующей цене небесполезно).

Остановимся здесь для конкретности именно на варианте 6 - осветителе со светонаправляющими элементами и элементами развертывания, устанавливаемом на телевизоре и предназначенном для выездного телемастера. Требуют уточнения конструктивные вопросы выбора светонаправляющих, установочных устройств и устройств развертывания. Начнем со светотехнической схемы (раздел Б табл. 5), как наиболее принципиальной, и возвратимся к морфологической табл. 4.

Тем самым мы начинаем рекомендованное Цвикки "дополнительное морфологическое исследование" (этап V).

V этап.

Вообще говоря, табл. 4 не отражает реального положения дел. Формально оптическая система может содержать отнюдь не в единственном числе любой из перечисленных в таблице элементов (вспомните, например, оптическую схему микроскопа). Мoжнo было бы облегчить себе жизнь требованием минимизации числа элементов (все-таки это и сложность, и стоимость, и надежность системы), но гораздо эффективнее вернуться чуть назад и попытаться сформулировать, какие, собственно, операции или внутренние функции должны быть реализованы в нашей оптической системе. Ведь исходной ее точкой является электролампочка, светящая во все стороны, а в конечном итоге должен быть узкий (но не очень!) пучок света, освещающий заданную небольшую площадь "в стесненных условиях". Итак, составим морфологическую таблицу функций оптической системы '(табл. 7).

Таблица 7

А. Отразить "тыльный" световой поток | А1. Нужно | А2. Не нужно
Б. Изменить угловую расходимость | Б1. Нужно | Б2. Не нужно
В. Провести световой пучок к нужному месту в телевизоре | В1. Нужно | В2. Не нужно
Г, Направить световой пучок на рабочую поверхность | Г1. Нужно | Г2. Не нужно

В принципе все эти функции нужны, хотя первые две направлены только на более эффективное использование света, т.е. менее важные цели, чем последние две. Теперь можно строить таблицу элементов (табл. 8), реализующих эти функции (кстати, функции в табл. 7 расположены в той же последовательности, в какой их нужно реализовать по ходу светового пучка).

Таблица 8

А. | Рефлектор | А1 .Сферическое зеркало |  |  | А2. Плоское зеркало |  |  |  | A3. Нет
Б. | Фокусирукщее устройство | Б1 .Конденсорная линза | Б2 . Фокусирующая линза |  |  | БЗ. Сферическое зеркало |  | Б4.Нет
В. | Светопровод | В1 .Труба |  | В2. Световод (воздух) |  |  | ВЗ.Нет
Г. | Оконечный светонаправляющий элемент |  | Г1 .Зеркало |  | Г2 . Матовый рассеиватель |  |  | ГЗ.Нет

108 вариантов табл. 8 - слишком много, начинаем "выжимать" лишние альтернативы. В строке А целесообразно оставить А1, причем лампу следует поместить в центре сферы, тогда ее изображение совпадет с самой лампой, что облегчит дальнейшие манипуляции со световым потоком. Что касается строки В, то световод имеет здесь несомненные преимущества перед остальными двумя вариантами. Выбрав световод, мы тем самым конкретизируем и условия для параметров Б и Г: весь световой пучок нужно "загнать" во входной зрачок световода, т.е. пригодны только варианты Б2 и БЗ; на выходе из световода пучок имеет угловую расходимость ~25°, и если выходной зрачок его правильно сориентировать относительно рабочей площадки, то никаких оконечных светонаправляющих элементов уже не потребуется. Таким образом, осталось в этой таблице выбрать только линзу или сферическое зеркало. С точки зрения компактности и эффективности использования света последний вариант предпочтительнее (рис.7).

Теперь можно заняться выбором крепления. Особенность выбранной конструкции в том, что осветитель фактически состоит из жестко зафиксированных друг относительно друга рефлекторов, лампы и входного зрачка световода (но положение этой группы никак не привязано к рабочей зоне телемастера) и жестко зафиксированного относительно рабочей зоны выходного зрачка световода. Это значит, что жесткое крепление требуется для входного зрачка световода, причем крепление компактное, надежное и "за что угодно" (т.е. за шасси, за стенку телевизора, за монтажную стойку в схеме и т.д.).

а)

б)
Рис.7. Линзовый (а) и рефлекторный (б) варианты реализации входного участка осветителя

Очевидно, лучше, чём зажим, едва ли удастся найти средство крепления. Но одним зажимом не обойтись, нужно еще ориентировать выходной зрачок (напомним, что из световода выходит узкий световой конус с углом расходимости ~ 25°), так что обойма световода должна быть соединена с зажимом крепления, например, через шаровой шарнир (как у фотоштатива). Блок же лампы можно класть куда угодно, а при малых его габаритах можно вообще допустить, чтобы он свободно висел на световоде. Кстати, гибкость световода позволяет
снять вопрос об устройствах развертывания, осветитель можно просто смотать в моток. Однако у нас появилось условие малогабаритности блока лампы, которое выполнимо только для точечных ламп, а подобные лампы малой мощности выпускаются только на низкое напряжение. Значит, придется добавить трансформатор питания 220/8 В; для 8-ваттной лампочки трансформатор получается и компактным, и достаточно легким. .

Если теперь вернуться к тем двум вариантам, что у нас остались "на полях", то в матрице один из них так и не появился. Это, кстати, не случайно, слишком часто содержимое матрицы наводит на варианты, не содержащиеся в ней.

На этом решение задачи закончено, дальше уже идет рутинное конструирование и расчет всех характеристик осветителя (впрочем, не исключена возможность, что и на этой стадии возникнет необходимость применения аппарата морфологического подхода).

НЕКОТОРЫЕ РЕКОМЕНДАЦИИ

В заключение еще раз напомним основные ноу-хау, обеспечивающие эффективность работы ММЯ:

1) максимально точная формулировка цели морфологического исследования, снятие акцента директивности, возможная переформулировка или уточнение цели;
2) все параметры должны быть примерно равноэначимы с точки зрения поставленной цели;
3) никаких оценок вариантов не следует проводить до полного оформления морфологического множества;
4) для каждой строки морфологической таблицы проверить, являются ли частные варианты реализации параметра альтернативными и является ли осмысленным вариант "отсутствует";
5) после определения полного объема морфологического множества проверить, нельзя ли морфологическую таблицу разделить на 2-3 блока, которые можно было бы анализировать не сразу, а последовательно, друг за другом.

И, наконец, еще одна рекомендация для ММЯ. Если ситуация позволяет организовать представленную ниже последовательность действий, это оказывается наиболее кратким, понятным и действенным способом решения задачи. Вначале для исследуемого объекта составляют перечень всех возможных внешних функций, которые он мог бы исполнять. Этот перечень организуют в виде левого столбца морфологической таблицы I ступени, альтернативами по каждой строке будут только "нужно" и "не нужно". Решив эту "функциональную" задачу, получают тем самым левый столбец морфологической таблицы II ступени, где для каждой из "нужных" функций в качестве альтернатив записывают возможные способы ее реализации. И, наконец, после того, как N функций конкретизировались в N способов, составляют морфологическую таблицу III ступени, где для каждого способа (левый столбец) выбирают вид устройства для его реализации. Условно этот путь можно назвать трехступенчатым морфоанализом, хотя число ступеней может меняться в ту или другую сторону.

Теперь, ориентируясь на пример задачи с лампой и на все высказанные выше рекомендации, можно попробовать самостоятельно решить методом ММЯ одну из следующих задач:

1. Как найти девушку "глаза голубые и брови вразлет, и носик курносый при этом", если Вы видели ее всего один раз на встречном эскалаторе в метро в часы пик?
2. Решить проблему наиболее эффективного использования отходов фабрики головных уборов из искусственного меха. То же - для телевизионного завода, для хладокомбината, для РСУ, для Вашего предприятия.
3. Какие виды индивидуальной трудовой деятельности предпочтительны для инженера по ТБ крупного НИИ химического профиля, если ему 35 лет, у него двухкомнатная квартира, двое детей, жена - бухгалтер и хобби - рыбалка?
4. Предложить способ и устройство двусторонней связи с автономной глубоководной обитаемой капсулой, предназначенной для работы на глубинах до 5 км.
5. Предложить способы выявления "белых пятен" МСПП в области: а) нейрохирургии б) метеорологии; в) определения общественного мнения, г) металлообработки.

О БИБЛИОГРАФИИ ПО МОРФОЛОГИЧЕСКОМУ АНАЛИЗУ

Большинство руководств по методам технического творчества в той или иной степени упоминает морфологические методы. Однако, как уже упоминалось выше, основное внимание уделяется методу морфологического ящика (иногда складывается впечатление, что авторы соответствующих руководств просто не знают о существовании триады методов Цвикки), зато модификаций и усовершенствований этого метода можно найти довольно много. В этом разделе предпринята попытка составить нечто вроде аннотированной библиографии тех публикаций по морфоанализу, где есть более или менее самостоятельное осмысление или оригинальная трактовка метода.

В работе [1], цитировавшейся выше, кроме основного астрофизического содержания, Цвикки освещает, в частности, процедуру морфологического исследования одной из наиболее серьезных своих задач: исследование толкающих силовых двигателей на химическом топливе. Подробно описан анализ разработки больших телескопов. Особый интерес представляет восьмая глава, где наряду с общефилософскими вопросами познания автор обсуждает и странности "магических" чисел i, e и p , и природу размерностей, и природу физических законов. В заключении Цвикки формулирует три аспекта морфологического подхода:

"1. Морфологический подход включает некие общие принципы, которые составляют в сумме определенный общефилософский взгляд на вещи.
2. Базовая философия морфолога подкреплена общими методологическими положениями.
3. Философия и методология морфолога автоматически приводят к ясности мысли и эффективности действия, которые можно назвать морфологическим образом жизни".

Наконец, в последнем разделе заключения сформулированы пять принципов морфологического исследования, о которых в настоящей работе сказано достаточно. В книге имеется обширная библиография (~200 наименований), в основном фактического, экспериментального плана.

Работа [2] - основной труд Цвикки, чрезвычайно широкий по содержанию и интересный по изложению и оформлению. Подробно изложена процедура морфологического исследования целого ряда конкретных задач из различных областей науки и техники. По мнению автора настоящей работы, эта книга в наибольшей степени отражает общую концепцию морфологического подхода.

Сборник докладов, в который входит работа [3], относится в основном к познавательному аспекту морфологического подхода и наиболее интересен для представителей гуманитарного направления.

В работе [5], являющейся развитием предшествующей работы [4], дана упрощенная трактовка работ Цвикки, после чего анализируется процедура постановки задачи. Рассмотрены различные приемы выбора вариантов решения: полный перебор, последовательный перебор ограниченного количества вариантов, зондирование морфологического множества (ненаправленное и направленное). Перечислены и кратко охарактеризованы различные методы оценки качества вариантов. Автор строит морфологическую таблицу морфологических методов решения задач и исследования систем; однако из реально существующих методов в этой таблице найдено место только для метода Коллера. Работа [5] ориентирована в основном на теоретиков машинного поиска и не содержит ни одного практического примера.

Работа [6] интересна прежде всего последней частью, где автор предлагает сочетание мозгового штурма с морфологическим анализом, построенное по "морфологическому сценарию". В работе анализируются также методы поиска оптимального решения в морфологических множествах большего объема, предлагавшиеся различными авторами, но в основном рассмотрение ведется применительно к машинному методу, причем на языке, не очень понятном обычному инженеру и конструктору.

Своеобразный, достаточно полный и подробный анализ творческих процессов конструирования дан в работе [7]. По сравнению с примерами, рассмотренными в работах Цвикки, здесь объектом пробного исследования и конструирования является МГД-генератор, сложность и "многоэтажность" анализа которого можно охарактеризовать хотя бы тем, что морфологический список параметров и альтернатив объекта с трудом укладывается в 13 страниц мелкого шрифта. Тем не менее, процедура работы со столь громадными массивами информации, предложенная в [7], понятна инженеру, знакомому с высшей математикой в объеме втузовского курса.

В работе [8] дан достаточно подробный анализ метода морфологического ящика. Отметим детальную проработку дедуктивного и индуктивного методов формирования перечня параметров на втором этапе ММЯ. Интересна также рекомендация автора [8] о применении ММЯ на этапе систематизации, например, патентной информации по конкретному типу объектов (в работе [8] - по компасу). При определенных условиях этот метод позволяет непосредственно выходить на новые изобретения. Кроме того, рекомендовано строить морфологическую таблицу не только на этапе поиска решения, но и тогда, когда решение уже найдено: в этом случае есть шанс расширить сферу применения найденного решения или предложить различные варианты реализации найденной идеи.

Работа [9] практически представляет собой хрестоматию по ММЯ. В ней проведен анализ ряда технических объектов (гидравлические средства механизации и автоматизации технических систем, линейные электрогидравлические следящие приводы, гидромеханизм подъемника, портативные тележки, поршневые гидравлические тандем-цилиндры). Представляет интерес ряд оригинальных способов представления морфологических множеств (часть из них использована в настоящей работе).

В работе [10] морфологическому подходу уделено достаточно много внимания. Основой анализа является по-прежнему ММЯ, но с сильным "акцентом" на системный подход. Очень ценной представляется классификация свойств технической системы (рис.17 в [10]). Представляет интерес также трехмерная универсальная морфологическая матрица (рис.20 в [10]) для поиска решения изобретательских задач и варианты ее реализации, представленные в табл. 3 той же работы и в работе [11] . Матрица в известной степени перекликается с самостоятельным методом, названным его автором "десятичной матрицей поиска" [12].

В работе [13] демонстрируется применение морфологического подхода в сфере отнюдь не технической - в сфере планирования. Интересно, что комплекс ключевых вопросов в этой работе отличается от аналогичного комплекса в [10, 11] как по количеству вопросов (6 и 7), так и по смыслу некоторых из них. По каждой конкретной проблеме планирования предлагается строить шесть ориентированных деревьев - классификационных или причинно-следственных конструкций, соответствующих каждое своему контрольному вопросу. Применение понятия комбинаторного файла, как и в [7], позволяет наглядно представлять и легко контролировать ход планирования даже для весьма сложных и многоплановых ситуаций.

В заключение отметим, что в популярной книге [14], так же, как и в [15-18], изложение морфологического анализа (точнее, ММЯ) довольно поверхностно и односторонне и не дает правильного представления о методе.

ЛИТЕРАТУРА

1. Zwicky F. Morphological astronomy,- Berlin, 1957.
2. Zwicky F. Discovery, invention, research through the morphological approach.- Toronto, 1969.
3. Zwicky F. The morphological approach to discovery, invention, research and construction //New methods of thought and procedure.- Pasadena, 1967.- P.273-297.
4. Одрин В.М., Картавов С.С. Морфологический анализ систем,- Киев: Наукова думка, 1977.
5. Одрин В.М. Морфологический анализ систем: постановка задачи, классификация методов, морфологические методы "конструирования". Препринт ИК АН УССР 86-3, 1986.
6. Одрин В.М. Морфологический синтез систем: морфологические методы поиска. Препринт ИК АН УССР 86-5,1986.
7. Капустян В.М., Махотенко Ю.А. Конструктору о конструировании атомной техники,- М.: Атомиздат, 1981.
8. Попов А.Б. Морфологический анализ технических объектов. Методическая разработка Минживмаш,- Люберцы, 1987.
9. Плужников А.И. Применение морфологического анализа для поиска рациональных структур и компоновок механизмов. Методическая разработка ИПК Минживмаш.- Люберцы, 1987.
10. Буш Г. Основы эвристики для изобретателей.- Рига: Знание, 1977.- ч. II.
11. Буш Г. Рождение изобретательских идей.- Рига: Лиесма, 1976.
12. Повилейко Р.П. Десятичная матрица поиска, - Рига: Знание, 1978.
13. Капустян Б.М., Кузнецов П.Г., Махотенко Ю.А. Системно-морфологический анализ творческих процессов планирования //Обзоры по электронной техник'е. Сер.9, Экономика и сист. управления,- Вып.З (501)-77,- М.: ЦНИИ "Электроника", 1978.
14. Джонс Дж.К. Методы проектирования.- М.: Мир, 1986.
15. Селюцкий А.Б., Слугин Г.И. Вдохновение по заказу.- Петрозаводск: Карелия, 1977.
16. Бородастов Г.В., Альтшуллер Г.С. Теория и практика решения изобретательских задач.- М.: ЦНИИАтоминформ, 1980.
17. Чус А.В., Данченко В.Н. Основы технического творчества.- Киев, 1982.
18. Дерзкие формулы творчества /Под ред. Г.С.Альтшуллера,- Петрозаводск: Карелия, 1987.

Работа опубликована в 1990 году